FAQ  •  Register  •  Login

New LG Profile Requiring Testers. (2012 Models ONLY)

<<

Cerberus

User avatar

DLNA master

Posts: 4116

Joined: Sun Jan 02, 2011 5:20 pm

Location: Reading, UK

Post Fri Mar 02, 2012 11:53 pm

New LG Profile Requiring Testers. (2012 Models ONLY)

Please can users of following devices please test the profile and report if they are able to play all of their files and if not post information on files that wont play so that profile can be updated in serviio.( howto in my signature )

Profile for (2012) models ONLY. (LW980, LW650, LW550, PZ90, PZ570)

  Code:
<Profile id="21" name="LG Smart TV (2012)" extendsProfileId="1">
      <SubtitlesMimeType>text/srt</SubtitlesMimeType>
      <Detection>
           <UPnPSearch>
              <FriendlyName>(.*LW98.*)|(.*LW65.*)|(.*LW55.*)|(.*PZ9.*)|(.*PZ57.*)</FriendlyName>
              <Manufacturer>LG Electronics</Manufacturer>
           </UPnPSearch>
      </Detection>
      <Transcoding>
           <!-- Transcode h264 videos with profile level > 4.1 to mpegts with ac3 audio -->
           <Video targetContainer="mpegts" targetVCodec="mpeg2video" targetACodec="ac3" >
              <Matches container="avi" vCodec="h264" profile="high" levelGreaterThan="4.2" />
              <Matches container="avi" vCodec="h264" profile="main" levelGreaterThan="4.2" />
              <Matches container="mp4" vCodec="h264" profile="high" levelGreaterThan="4.2" />
              <Matches container="mp4" vCodec="h264" profile="main" levelGreaterThan="4.2" />
              <Matches container="matroska" vCodec="h264" profile="high" levelGreaterThan="4.2" />
              <Matches container="matroska" vCodec="h264" profile="main" levelGreaterThan="4.2" />
           </Video>
            <!-- remux unsupported audio codecs in MKV into AC3 -->
           <Video targetContainer="mpegts" targetACodec="ac3" >
              <Matches container="matroska" vCodec="h264" aCodec="dca" />
              <Matches container="matroska" vCodec="h264" aCodec="flac" />
              <Matches container="matroska" vCodec="h264" aCodec="vorbis" />
              <Matches container="matroska" vCodec="h264" aCodec="truehd" />
           </Video>
           <!-- Remux WTV files to MPEG-PS with no transcoding-->
           <Video targetContainer="mpeg">
              <Matches container="wtv" />
           </Video>
           <!-- transcode unsupported video codecs into mpeg-ts, mpeg2video and ac3 audio -->
           <Video targetContainer="mpegts" targetVCodec="mpeg2video" targetACodec="ac3">           
              <Matches container="avi" vCodec="mjpeg" />
              <Matches container="avi" vCodec="dvvideo" />
              <Matches container="mp4" vCodec="mjpeg" />
              <Matches container="asf" />
              <Matches container="flv" />
              <Matches container="ogg" />
           </Video>
           <!-- unsupported audio will be transcoded into lpcm audio -->
           <Audio targetContainer="lpcm">
              <Matches container="flac" />
              <Matches container="ogg" />
              <Matches container="asf" />
              <Matches container="adts" />
           </Audio>
        </Transcoding>     
    </Profile>
Phil Bennett
Beta Tester Group
Wiki | FAQ

Samsung LE40C750 LCD | Samsung BD-C5900 | Sony PS3 | Windows 7 |
HowTo: Provide supported formats of a device HowTo: Record a new ticket on Bitbucket
HowTo: Provide details of a video file that doesn't play HowTo: Turn on detailed logging
<<

811mark

Serviio newbie

Posts: 11

Joined: Wed Sep 28, 2011 4:14 pm

Post Sun Mar 04, 2012 3:06 pm

Re: New LG Profile Requiring Testers. (2012 Models ONLY)

Should this be for the 2011 models ????, the LG 2012 range are due out April.

Will test it out with my LW650 and let you know how it goes.

Thanks for trying for us, we all know how you love the LG's. lol
Mark
<<

Rufal

Serviio newbie

Posts: 1

Joined: Thu Mar 08, 2012 1:50 pm

Post Fri Mar 09, 2012 11:34 pm

Re: New LG Profile Requiring Testers. (2012 Models ONLY)

Hi,

Thank you for the profile, works great for lots of files that did not play before. Also I now experience full Digital audio (no forced downsampling that was needed before due to dts problems).

TV is LG 47LW650W (Nordic version of the LG 650 )

This file does not play, neither video or sound. Handbrake was able to make the sound play but not the movie.

General
Unique ID : 197419820422558953769701253471967386803 (0x9485ACA3F42909CA90319EF331241CB3)
Complete name :
Format : Matroska
Format version : Version 2
File size : 6.34 GiB
Duration : 1h 30mn
Overall bit rate mode : Variable
Overall bit rate : 10.1 Mbps
Encoded date : UTC 2012-02-26 04:05:32
Writing application : mkvmerge v4.0.0 ('The Stars were mine') built on Jun 6 2010 16:18:42
Writing library : libebml v1.0.0 + libmatroska v1.0.0

Video
ID : 1
Format : AVC
Format/Info : Advanced Video Codec
Format profile : High@L4.1
Format settings, CABAC : Yes
Format settings, ReFrames : 6 frames
Codec ID : V_MPEG4/ISO/AVC
Duration : 1h 30mn
Width : 2 560 pixels
Height : 544 pixels
Display aspect ratio : 4.706
Frame rate : 23.976 fps
Color space : YUV
Chroma subsampling : 4:2:0
Bit depth : 8 bits
Scan type : Progressive
Writing library : x264 core 120 r2164 da19765
Encoding settings : cabac=1 / ref=6 / deblock=1:-2:-2 / analyse=0x3:0x133 / me=umh / subme=10 / psy=1 / psy_rd=0.30:0.00 / mixed_ref=1 / me_range=36 / chroma_me=1 / trellis=2 / 8x8dct=1 / cqm=0 / deadzone=21,11 / fast_pskip=0 / chroma_qp_offset=-2 / threads=6 / sliced_threads=0 / nr=0 / decimate=0 / interlaced=0 / bluray_compat=0 / constrained_intra=0 / bframes=8 / b_pyramid=2 / b_adapt=2 / b_bias=0 / direct=3 / weightb=1 / open_gop=0 / weightp=2 / keyint=360 / keyint_min=6 / scenecut=40 / intra_refresh=0 / rc=crf / mbtree=0 / crf=17.0 / qcomp=0.70 / qpmin=0 / qpmax=69 / qpstep=4 / frame-packing=3 / ip_ratio=1.40 / pb_ratio=1.30 / aq=2:1.00
Default : No
Forced : No

Audio
ID : 2
Format : FLAC
Format/Info : Free Lossless Audio Codec
Codec ID : A_FLAC
Duration : 1h 30mn
Bit rate mode : Variable
Channel(s) : 8 channels
Sampling rate : 48.0 KHz
Bit depth : 24 bits
Writing library : libFLAC 1.2.1 (UTC 2007-09-17)
Language : English
Default : Yes
Forced : No
<<

Illico

User avatar

DLNA master

Posts: 4649

Joined: Fri Jul 23, 2010 8:08 am

Location: France

Post Sat Mar 10, 2012 7:33 pm

Re: New LG Profile Requiring Testers. (2012 Models ONLY)

Probably the video resolution not supported
Width : 2 560 pixels
Height : 544 pixels

max should be 1920x1080
Illico
Sony 2010 KDL-46EX501 | BDP-S373 | SMP-N100 | Windows 8-i7 | Network DD HD-CE1.5TLU2 | Livebox2-UHD86 | ServiiDroid | ServiiGo | BubbleUPnP
Serviio beta tester - Moderator
<<

811mark

Serviio newbie

Posts: 11

Joined: Wed Sep 28, 2011 4:14 pm

Post Sun Mar 11, 2012 10:38 pm

Re: New LG Profile Requiring Testers. (2012 Models ONLY)

Been using the profile for a week now with a variety of files and not had one problem with any file yet.
LW 650 with firmware 5.11.06

Thanks Phil :D
Mark
<<

dongioia

Serviio newbie

Posts: 2

Joined: Sun Mar 18, 2012 2:51 pm

Post Sun Mar 18, 2012 3:00 pm

Re: New LG Profile Requiring Testers. (2012 Models ONLY)

Thanks for the good work. I'm very happy with this profile.
Is there a way to improve the subtitle support?
I try to make my self clear: the tv's internal player can smoothly play mkv files, with embedded subtitles (srt, ass, etc....).
If I want to play the same files with serviio, I must extract the subtitles and convert in an srt file.
Can serviio use the tv's internal player features?
I already tried to disable transcodng, with no results.
<<

Goofball

Serviio newbie

Posts: 1

Joined: Sun Mar 18, 2012 11:55 pm

Post Sun Mar 18, 2012 11:58 pm

Re: New LG Profile Requiring Testers. (2012 Models ONLY)

This profile has so far worked much better than the default LG profile with my 47LW5600 TV. It fixes a bunch of errors with unplayable files containing DTS tracks and/or incompatible x264 video encoding settings.
<<

ybrett23

Serviio newbie

Posts: 3

Joined: Wed Mar 21, 2012 7:47 pm

Post Wed Mar 21, 2012 7:49 pm

Re: New LG Profile Requiring Testers. (2012 Models ONLY)

hi
everytime i add this profile to the xml file the servio service starts then stops? any ideas as to what im doing wrong?
<<

811mark

Serviio newbie

Posts: 11

Joined: Wed Sep 28, 2011 4:14 pm

Post Wed Mar 21, 2012 10:08 pm

Re: New LG Profile Requiring Testers. (2012 Models ONLY)

ybrett23 wrote:hi
everytime i add this profile to the xml file the servio service starts then stops? any ideas as to what im doing wrong?


Have attached my working profile.xml for you
yours could be crashing because there is already a profile id21 for sony and this has id21 as well ?????????
Attachments
profiles.xml
(60.7 KiB) Downloaded 713 times
Mark
<<

ybrett23

Serviio newbie

Posts: 3

Joined: Wed Mar 21, 2012 7:47 pm

Post Wed Mar 21, 2012 10:28 pm

Re: New LG Profile Requiring Testers. (2012 Models ONLY)

thanks for this, it works now , but i cant choose the profile from the list?
for get that, ive done it thank you
<<

demnior

Serviio newbie

Posts: 3

Joined: Sat Mar 24, 2012 7:38 am

Post Sat Mar 24, 2012 7:42 am

Re: New LG Profile Requiring Testers. (2012 Models ONLY)

Hello!

The new profile works perfect on my LW659 S. Now it can play every video file. Unfortunately with a couple of High Res MKVs it won't let me use the fast forward nor the rewind function. Any Chance to fix this?
Do you need the debug.log for that?

brgs
<<

811mark

Serviio newbie

Posts: 11

Joined: Wed Sep 28, 2011 4:14 pm

Post Sat Mar 24, 2012 1:16 pm

Re: New LG Profile Requiring Testers. (2012 Models ONLY)

demnior wrote:Hello!

The new profile works perfect on my LW659 S. Now it can play every video file. Unfortunately with a couple of High Res MKVs it won't let me use the fast forward nor the rewind function. Any Chance to fix this?
Do you need the debug.log for that?

brgs


This will only happen on the files that Serviio is transcoding to make it playable on your TV, mine lets me fast forward at 2x - but no faster and no rewind.
Mark
<<

demnior

Serviio newbie

Posts: 3

Joined: Sat Mar 24, 2012 7:38 am

Post Sat Mar 24, 2012 4:40 pm

Re: New LG Profile Requiring Testers. (2012 Models ONLY)

@811mark

Yeah, that's what I actually meant. I can play it 2xFF but can't rewind nor can I jump to a certain point in the movie. Is there any chance that this might get fixed? Would be awesome!
<<

demnior

Serviio newbie

Posts: 3

Joined: Sat Mar 24, 2012 7:38 am

Post Sun Apr 01, 2012 11:21 am

Re: New LG Profile Requiring Testers. (2012 Models ONLY)

Lately I get the Info from the TV that "This File is not valid" for many movies. Even on a movie that had been working with the new settings quiet well for a while.

Andy idea?
<<

dreamlayers

Serviio newbie

Posts: 15

Joined: Tue Apr 10, 2012 6:12 pm

Location: Ontario, Canada

Post Tue Apr 10, 2012 8:08 pm

Re: New LG Profile Requiring Testers. (2012 Models ONLY)

Thanks! This profile works with LG 47LW5600 TV with 04.03.01 firmware. That's a 2011 model. It allows me to play:
  • FLV with H.264/AAC, sometimes unnecessarily transcoding to MPEG2
  • MKV with H.264/DTS, transcoding only audio to AC3
  • MKV with High@L5.1 H.264 video, transcoding to MPEG2. (Edit: Some High@L5.1 H.264 will play properly without transcoding, but I don't think Serviio can determine which can play.)
  • MOV with MJPEG, transcoding to MPEG2
  • OGM with MPEG4/Vorbis, unnecessarily transcoding video to MPEG2
I think the profile id at the start
  Code:
<Profile id="21" name="LG Smart TV (2012)" extendsProfileId="1">
needs to be changed:
  Code:
<Profile id="22" name="LG Smart TV (2012)" extendsProfileId="1">
When I looked in Serviio v0.6.2 profiles.xml, there already was an id=21 profile.

When playing FLV, according to the TV, some files get transcoded to MPEG2 while others are still H.264/AAC. According to MediaInfo, the ones that didn't get transcoded are "AVC (NTSC) (Main@L2.0)", while the ones that did are "AVC (High@L3.0)" and "AVC (NTSC) (High@L3.0)". It's possible to play H.264/AAC FLV without transcoding by deleting
  Code:
              <Matches container="flv" />
and inserting this before that block:
  Code:
           <Video targetContainer="mpegts">
              <Matches container="flv" />
           </Video>
Of course, this won't let you play FLV with unsupported codecs such as VP8.

It's still not possible to play MPEG4 with QPEL and/or GMC. MediaInfo considers that "Advanced Simple@L5", but adding a levelGreaterThan="4.2" test for vCodec="mpeg4" results in all MPEG4 files being transcoded. Do I need to test for some higher level, or is there another way to detect QPEL and GMC?

Edit: I wonder if it would be a good idea to include aBitrate and maxVBitrate. I see that the default is 192, and that's low for AC3. Many other occurrences of audio transcoding to AC3 use aBitrate="384". As for maxVBitrate, the web page claims you can "omit to keep the same quality". I'm sceptical about that. Should I use the maximum bitrate that the TV can handle, to minimize quality degradation?

Edit: The following can handle OGM with MPEG4/Vorbis, only transcoding the audio. Many things don't like MPEG4 in mpegts but the TV can handle it. I actually put the ogg line into the already existing audio transcoding block.
  Code:
           <Video targetContainer="mpegts" targetACodec="ac3" >
              <Matches container="ogg" vCodec="mpeg4" aCodec="vorbis" />
           </Video>

Edit: It may be a good idea to transcode video from live streams. I found it almost impossible to play the majority of rtmp streams that I could play from my computer. Transcoding the video to MPEG2 helped a lot. Look at my post in another thread.
<<

dsvarc

Serviio newbie

Posts: 3

Joined: Mon Apr 16, 2012 3:44 pm

Post Mon Apr 16, 2012 3:56 pm

Re: New LG Profile Requiring Testers. (2012 Models ONLY)

demnior wrote:Hello!

The new profile works perfect on my LW659 S. Now it can play every video file. Unfortunately with a couple of High Res MKVs it won't let me use the fast forward nor the rewind function. Any Chance to fix this?
Do you need the debug.log for that?

brgs


Well, have the same TV (42LW659S) but, i must say.. no benefits using this profile.
In real life, i have problem only with matroska (mkv) files with DTS audio.. that is what i need this profile for...

The only change is movie icon.. it looks different, but not playable..

Any suggestion? maybe i do not know how to use it.. (it is properly added to xml file, properly numbered, transcoding is turned on.. )

Regards.
<<

hans

Serviio newbie

Posts: 8

Joined: Wed Feb 01, 2012 10:49 am

Post Wed Apr 18, 2012 7:15 am

Re: New LG Profile Requiring Testers. (2012 Models ONLY)

I have same problem with my 37LV5500 (2011) after last firmware update. I'v found out that the problem with icon and not-playble file is when 1. file is transcoded AND 2.subtitle for this file is available. Try delete or rename srt file (update library) and MKV with DTS should play.
I also confirm that some High@L5.1 H.264 will play properly without transcoding.
So main problem is again: transoding with subtitles. Because I play 99% movies with subtitles, transcoding is problem for me and if I remember it is problem of LG from beginning (with older firmware transcoding worked but subtitles were ignored) so transcoding was disabled in LG profile.

After last firmware update also friendly name string was changed.
<<

dsvarc

Serviio newbie

Posts: 3

Joined: Mon Apr 16, 2012 3:44 pm

Post Wed Apr 18, 2012 8:50 am

Re: New LG Profile Requiring Testers. (2012 Models ONLY)

hans wrote:I have same problem with my 37LV5500 (2011) after last firmware update. I'v found out that the problem with icon and not-playble file is when 1. file is transcoded AND 2.subtitle for this file is available. Try delete or rename srt file (update library) and MKV with DTS should play.
I also confirm that some High@L5.1 H.264 will play properly without transcoding.
So main problem is again: transoding with subtitles. Because I play 99% movies with subtitles, transcoding is problem for me and if I remember it is problem of LG from beginning (with older firmware transcoding worked but subtitles were ignored) so transcoding was disabled in LG profile.

After last firmware update also friendly name string was changed.


I will check if anything is playable with subtitles removed from movie's directory.
It would be just a test, i need subtitles.

Will be back with results soon..
<<

hans

Serviio newbie

Posts: 8

Joined: Wed Feb 01, 2012 10:49 am

Post Wed Apr 18, 2012 3:08 pm

Re: New LG Profile Requiring Testers. (2012 Models ONLY)

Sink for TV LG 37LV5500 (firmware 5.11.08)
  Code:
http-get:*:audio/l16;rate=44100;channels=1:DLNA.ORG_PN=LPCM,http-get:*:audio/l16;rate=44100;channels=2:DLNA.ORG_PN=LPCM,http-get:*:audio/mpeg:DLNA.ORG_PN=MP3,http-get:*:image/jpeg:DLNA.ORG_PN=JPEG_SM,http-get:*:image/jpeg:DLNA.ORG_PN=JPEG_MED,http-get:*:image/jpeg:DLNA.ORG_PN=JPEG_LRG,http-get:*:video/mpeg:DLNA.ORG_PN=MPEG_PS_PAL,http-get:*:video/mpeg:DLNA.ORG_PN=MPEG_PS_NTSC,http-get:*:video/vnd.dlna.mpeg-tts:DLNA.ORG_PN=MPEG_TS_SD_NA,http-get:*:video/vnd.dlna.mpeg-tts:DLNA.ORG_PN=MPEG_TS_SD_NA_T,http-get:*:video/mpeg:DLNA.ORG_PN=MPEG_TS_SD_NA_ISO,http-get:*:video/vnd.dlna.mpeg-tts:DLNA.ORG_PN=MPEG_TS_SD_KO,http-get:*:video/vnd.dlna.mpeg-tts:DLNA.ORG_PN=MPEG_TS_SD_KO_T,http-get:*:video/mpeg:DLNA.ORG_PN=MPEG_TS_SD_KO_ISO,http-get:*:video/vnd.dlna.mpeg-tts:DLNA.ORG_PN=MPEG_TS_SD_EU,http-get:*:video/vnd.dlna.mpeg-tts:DLNA.ORG_PN=MPEG_TS_SD_EU_T,http-get:*:video/mpeg:DLNA.ORG_PN=MPEG_TS_SD_EU_ISO,http-get:*:audio/mpegurl:*,http-get:*:audio/mp3:*,http-get:*:audio/mpeg:*,http-get:*:audio/mpeg3:*,http-get:*:video/x-ms-wmv:*,http-get:*:video/x-ms-asf:*,http-get:*:video/x-ms-avi:*,http-get:*:video/mpeg:*,http-get:*:video/avi:*,http-get:*:video/mp4:*,http-get:*:video/x-matroska:*,http-get:*:video/3gpp:*,http-get:*:video/x-msvideo:*
Attachments
MediaRenderer1.xml
(2.2 KiB) Downloaded 469 times
<<

dsvarc

Serviio newbie

Posts: 3

Joined: Mon Apr 16, 2012 3:44 pm

Post Wed Apr 18, 2012 6:26 pm

Re: New LG Profile Requiring Testers. (2012 Models ONLY)

dsvarc wrote:
hans wrote:I have same problem with my 37LV5500 (2011) after last firmware update. I'v found out that the problem with icon and not-playble file is when 1. file is transcoded AND 2.subtitle for this file is available. Try delete or rename srt file (update library) and MKV with DTS should play.
I also confirm that some High@L5.1 H.264 will play properly without transcoding.
So main problem is again: transoding with subtitles. Because I play 99% movies with subtitles, transcoding is problem for me and if I remember it is problem of LG from beginning (with older firmware transcoding worked but subtitles were ignored) so transcoding was disabled in LG profile.

After last firmware update also friendly name string was changed.


I will check if anything is playable with subtitles removed from movie's directory.
It would be just a test, i need subtitles.

Will be back with results soon..


as i can see, subtitle file has no influence on device's behavior. Movie file is unplayable, no matter if there is subtitle file or not.
So far.. problem with DTS is still unresolved, as far as i am concerned..

i will continue to convert audio part of movie file using mkvdts2ac3.sh script while in Linux, and MKV2AC3 tool when in Windoze..
Next

Return to LG

Who is online

Users browsing this forum: No registered users and 1 guest

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.