FAQ  •  Register  •  Login

LG 475500LE + Serviio 1.0.1 + mp4 x264 freezes

<<

|ZUTI|

Serviio newbie

Posts: 14

Joined: Mon Apr 11, 2011 3:45 pm

Post Sun Oct 28, 2012 10:44 am

LG 475500LE + Serviio 1.0.1 + mp4 x264 freezes

Hey.

Strange problem that I have been detecting for a long time now, but was too lazy to report earlier. When it happens I usually just select the film again and continue from where it stopped. Still, perhaps there is a solution to this.

For some films (I have not noticed this for avis, but mainly for mp4 movies compressed with x264) serviio sometimes just freezes playback, then goes black and shows "device disconnected" message. I have noticed this on Windows XP 32bit and also now on W7, 64bit. The same movie plays perfectly fine if played from USB drive. I have also tried to stream it directly to the tv without switch/router in between, same thing.

The serviio log does hold some exceptions, mainly like this one:
  Code:
2012-10-28 08:38:48,595 ERROR [ActionNode] Cannot retrieve results of action command: Cannot execute library command for single item: For input string: "503/movie.1080p.BRay.x264.mp4"
org.serviio.upnp.service.contentdirectory.command.CommandExecutionException: Cannot execute library command for single item: For input string: "503/movie.1080p.BRay.x264.mp4"
   at org.serviio.upnp.service.contentdirectory.command.AbstractCommand.retrieveItem(AbstractCommand.java:153)
   at org.serviio.upnp.service.contentdirectory.definition.ActionNode.executeRetrieveItemAction(ActionNode.java:179)
   at org.serviio.upnp.service.contentdirectory.definition.ActionNode.retrieveDirectoryObject(ActionNode.java:82)
   at org.serviio.upnp.service.contentdirectory.ContentDirectoryEngine.browse(ContentDirectoryEngine.java:105)
   at org.serviio.upnp.service.contentdirectory.ContentDirectory.Browse(ContentDirectory.java:152)
   at sun.reflect.GeneratedMethodAccessor44.invoke(Unknown Source)
   at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
   at java.lang.reflect.Method.invoke(Unknown Source)
   at org.serviio.upnp.protocol.soap.ServiceInvoker.invokeOperation(ServiceInvoker.java:253)
   at org.serviio.upnp.protocol.soap.ServiceInvoker.invokeService(ServiceInvoker.java:93)
   at org.serviio.upnp.webserver.ServiceControlRequestHandler.handleRequest(ServiceControlRequestHandler.java:66)
   at org.serviio.upnp.webserver.AbstractRequestHandler.handle(AbstractRequestHandler.java:61)
   at org.apache.http.protocol.HttpService.doService(HttpService.java:293)
   at org.serviio.upnp.webserver.ServiioHttpService.doService(ServiioHttpService.java:58)
   at org.apache.http.protocol.HttpService.handleRequest(HttpService.java:212)
   at org.serviio.upnp.webserver.WebServer$WorkerThread.run(WebServer.java:191)
Caused by: java.lang.NumberFormatException: For input string: "503/movie.1080p.BRay.x264.mp4"
   at java.lang.NumberFormatException.forInputString(Unknown Source)
   at java.lang.Long.parseLong(Unknown Source)
   at java.lang.Long.parseLong(Unknown Source)
   at org.serviio.upnp.service.contentdirectory.command.AbstractListObjectsByFSHierarchyCommand.getFolderId(AbstractListObjectsByFSHierarchyCommand.java:224)
   at org.serviio.upnp.service.contentdirectory.command.AbstractListObjectsByFSHierarchyCommand.retrieveSingleItem(AbstractListObjectsByFSHierarchyCommand.java:166)
   at org.serviio.upnp.service.contentdirectory.command.AbstractCommand.retrieveItem(AbstractCommand.java:148)
   ... 15 more


This is serviio data from the log:
  Code:
2012-10-27 22:39:59,937 INFO  [MediaServer] Serviio DLNA media streaming server v 1.0.1 (rev. 6dbf7c6e334f+)
2012-10-27 22:39:59,937 INFO  [MediaServer] Petr Nejedly 2009-2012
2012-10-27 22:39:59,937 INFO  [MediaServer] http://www.serviio.org
2012-10-27 22:39:59,937 INFO  [MediaServer]
2012-10-27 22:39:59,937 INFO  [MediaServer] Java 1.7.0_05-Oracle Corporation
2012-10-27 22:39:59,937 INFO  [MediaServer] OS Windows 7 amd64 6.1
2012-10-27 22:39:59,937 INFO  [MediaServer] File encoding: windows-1250
2012-10-27 22:39:59,953 INFO  [MediaServer] Headless mode enabled: true
2012-10-27 22:39:59,953 INFO  [MediaServer] User home dir: C:\
2012-10-27 22:39:59,953 INFO  [MediaServer] Temp dir: C:\Windows\TEMP\
2012-10-27 22:39:59,953 INFO  [MediaServer] ------------------------------------------------------------------------
2012-10-27 22:40:01,000 INFO  [WebServer] Socket buffer set to 65535 bytes
2012-10-27 22:40:01,015 INFO  [RestletServer] Starting Restlet server (/rest) exposed on port 23423
2012-10-27 22:40:01,250 INFO  [RestletServer] Starting Restlet server (/cds) exposed on port 23424
2012-10-27 22:40:01,250 INFO  [RestletServer] Starting Restlet server (/mediabrowser) exposed on port 23424
2012-10-27 22:40:01,390 INFO  [DBSchemaUpdateExecutor] Checking if DB schema needs to be updated
2012-10-27 22:40:11,031 INFO  [MediaServer] ------------------------------------------------------------------------
2012-10-27 22:40:11,031 INFO  [MediaServer] License: PRO (EVALUATION, id: 11111111-1111-1111-1111-111111111113)
2012-10-27 22:40:11,031 INFO  [MediaServer] ------------------------------------------------------------------------


Any idea(s)?

Tx.
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 17037

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Tue Nov 13, 2012 5:27 pm

Re: LG 475500LE + Serviio 1.0.1 + mp4 x264 freezes

the exception is not related, it's due to a crappy DLNA player in the TV. Freezing - not sure ,might be due to network, file....
<<

|ZUTI|

Serviio newbie

Posts: 14

Joined: Mon Apr 11, 2011 3:45 pm

Post Sat Nov 24, 2012 12:25 pm

Re: LG 475500LE + Serviio 1.0.1 + mp4 x264 freezes

Hey.

Could be network related, but at the moment that it freezes, it's basically no action, no bit-rate spike. And the file, this is why I have no clue as it plays it fine from USB. Just don't have any idea. To be fair, all other DLNA servers also fail :D (at least the ones that I tried).
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 17037

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Mon Nov 26, 2012 5:23 pm

Re: LG 475500LE + Serviio 1.0.1 + mp4 x264 freezes

The USB and DLNA player implementations are often differently implemented in the TVs, so it's not a benchmark really.

Return to LG

Who is online

Users browsing this forum: No registered users and 3 guests

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.