Page 1 of 1

Subtitles not displaying on Panasonic TV

PostPosted: Sat Dec 30, 2017 8:41 am
by astratis

Apologies if this has been covered before but I can't get subtitles contained with in am MP4 file to play when streaming from my synology NAS to my Panasonic VT30 (2011). The picture and sound are fine but can't figure out how to get the subtitles to show this is the extract of the text file embedded in the file. I am using the latest version of Serviio, this profile - Panasonic Viera E/S/ST/VT (2011) - and a synology DS415+ NAS. I have tried with both transcoding on and off and all the subtitle check-boxes are ticked, subtitles transcoding is defualt UTF-8, I've tried inputting other settings but keep getting invalid character coding message. Much appreciated if anyone could help shed some light on this.

ID : 6
Format : Timed Text
Muxing mode : sbtl
Codec ID : tx3g
Duration : 1 h 20 min
Bit rate mode : Variable
Bit rate : 5 b/s
Stream size : 3.13 KiB (0%)
Title : Subtitle Track
Language : English
Default : Yes
Forced : No
Alternate group : 3
Encoded date : UTC 2017-05-28 17:47:37
Tagged date : UTC 2017-05-28 17:47:37
Menus : 7

Re: Subtitles not displaying on Panasonic TV

PostPosted: Sat Dec 30, 2017 4:04 pm
by atc98092
Just a guess on my part, but I doubt your TV supports Timed Text captions. When I looked them up, TT seems to be designed for web based streaming. I have an ST30, but it's not very DLNA capable. I don't think I've ever seen subs on my TV from my media. Although the ST30 is so bad at DLNA I generally use my Roku 4 instead.