FAQ  •  Register  •  Login

Serviio docker

<<

ycodryn

Serviio newbie

Posts: 5

Joined: Sun Feb 25, 2018 5:38 pm

Post Fri Jan 25, 2019 9:42 am

Serviio docker

Hello guys.I just bought a DS718+ and I`m trying to use serviio dlna on a docker because for synology we can`t have the latest version. Here is the container > https://hub.docker.com/r/riftbit/serviio . Container is running but I can`t access console page (:23423/console/) I`m new to this docker thing.
Do I have to manually create Volumes ?
/opt/serviio/config
/opt/serviio/library
/opt/serviio/plugins
/opt/serviio/log
/media/serviio

Can anyone help me?

Here is a link to log

https://pastebin.com/fycWXmXU
<<

Meelis

User avatar

Serviio lover

Posts: 91

Joined: Mon Aug 13, 2012 6:00 pm

Location: Estonia

Post Fri Jan 25, 2019 10:42 am

Re: Serviio docker

ycodryn wrote:Hello guys.I just bought a DS718+ and I`m trying to use serviio dlna on a docker because for synology we can`t have the latest version. Here is the container > https://hub.docker.com/r/riftbit/serviio . Container is running but I can`t access console page (:23423/console/) I`m new to this docker thing.
Do I have to manually create Volumes ?
/opt/serviio/config
/opt/serviio/library
/opt/serviio/plugins
/opt/serviio/log
/media/serviio

Can anyone help me?

Here is a link to log

https://pastebin.com/fycWXmXU


Hi,

I have same NAS and I have plan to try it in this weekend. After that i can give feedback here.
<<

ycodryn

Serviio newbie

Posts: 5

Joined: Sun Feb 25, 2018 5:38 pm

Post Fri Jan 25, 2019 2:20 pm

Re: Serviio docker

Ty for answer. I will try to resolve this in the mean time maybe I will have some luck.

Edit: I managed to get it to run. You have to choose "Use the same network as Docker host" in Advanced settings when you are creating the container. Don`t forget to mount your media folders. One question, using older serviio application in transcoding I can see 4 cores but inside docker I can see only one. Can I assign more to it ?
<<

Meelis

User avatar

Serviio lover

Posts: 91

Joined: Mon Aug 13, 2012 6:00 pm

Location: Estonia

Post Wed Jan 30, 2019 8:38 pm

Re: Serviio docker

ycodryn wrote:Ty for answer. I will try to resolve this in the mean time maybe I will have some luck.

Edit: I managed to get it to run. You have to choose "Use the same network as Docker host" in Advanced settings when you are creating the container. Don`t forget to mount your media folders. One question, using older serviio application in transcoding I can see 4 cores but inside docker I can see only one. Can I assign more to it ?


Hi,

Can you make a installation guide? I did a installation try but i didn't got it to work. Also i have installed a NAS version of Serviio and maybe this is my issue.
Why i didn't wanted to continue with docker version install is that media folder must be changed from current one what i have at the moment. Also i am not sure about nas sleeping mode when docker is running. Will NAS still goes to sleep and when from tv i select serviio then it wakes up?
<<

farly

Serviio newbie

Posts: 3

Joined: Fri Feb 01, 2019 7:08 pm

Post Fri Feb 01, 2019 7:25 pm

Re: Serviio docker

Meelis > installed NAS version (1.9.2) of serviio is not problem, but u must stop this package when you want testing docker serviio (1.10.1). And after docker serviio working fine you can uninstall NAS package serviio. On my DS 218+ works docker serviio very nice without any problems, its very easy to make it works. Write where exactly do you have problem.
<<

Meelis

User avatar

Serviio lover

Posts: 91

Joined: Mon Aug 13, 2012 6:00 pm

Location: Estonia

Post Fri Feb 01, 2019 11:01 pm

Re: Serviio docker

Okey, this is what i do.

1. Stopped current NAS serviio 1.9.2 from packages.
2. Installed Docker.
3. In Docker/Registry i search for Serviio and from list i select "riftbit/serviio" and download this image last version.
4. Now under Docker/Images i see "riftbit/serviio:latest" image 243 MB.
5. I select under Docker/Images the downloaded "riftbit/serviio:latest" and clicking "Launch" button.
6. In "Create Container" settings i select Advanced Settings/Network. I mark there "Use the same network as Docker host". (See picture 1)

7. Now i tried to connect to console. "Page not found"
I allmost started to uninstall it but i did last try after 1-2 minutes. Wow i got connection to console. I have no idea why it didn't worked immediately.
http:// your lan ip :23423/console/#/app/welcome

8. So next problem was unable to see my media files. I forgot to setup path. My media folder is called "videos". Its a shared folders. So who have saeme problem please see picture 2.

And now it seems working. I have to test it.
Attachments
2.png
picture 2
2.png (93.28 KiB) Viewed 3888 times
1.png
picture 1
1.png (146 KiB) Viewed 3892 times
<<

Meelis

User avatar

Serviio lover

Posts: 91

Joined: Mon Aug 13, 2012 6:00 pm

Location: Estonia

Post Sat Feb 02, 2019 12:14 am

Re: Serviio docker

I have a question... Where are located that serviio folder in docker. I need it for editing file. "Editing renderer profiles" (profiles.xml) Is it possible to access to it ?
<<

farly

Serviio newbie

Posts: 3

Joined: Fri Feb 01, 2019 7:08 pm

Post Sat Feb 02, 2019 10:26 am

Re: Serviio docker

Meelis > correct settings is: File/Folder = your existing shared folder with your videos (i have there folder with all my files), Mouth path = /media/serviio
see here: https://hub.docker.com/r/riftbit/serviio/ this: [/media/serviio - put media content here and add in serviio gui this path]

where is located servio folder for editing profiles.xml unfortunately don't know
i woud also like to know that
<<

Meelis

User avatar

Serviio lover

Posts: 91

Joined: Mon Aug 13, 2012 6:00 pm

Location: Estonia

Post Sat Feb 02, 2019 11:09 am

Re: Serviio docker

Seems like with Docker system NAS not hibernate (sleep mode) any more. Its all the time on. Do you have the same issue?
<<

farly

Serviio newbie

Posts: 3

Joined: Fri Feb 01, 2019 7:08 pm

Post Sat Feb 02, 2019 11:34 am

Re: Serviio docker

yea its possible, i have sleep mode set for 2 hours and disk never hibernate with or without docker, so I don't care. I rather use week plan for shutting down and turning on NAS, and when NAS is off and I exceptionally need any my files (for example at work) , so I use Wake on LAN.
<<

ErgoZ

Serviio newbie

Posts: 6

Joined: Wed Dec 19, 2018 7:09 pm

Post Mon May 27, 2019 1:29 pm

Re: Serviio docker

Meelis wrote:Okey, this is what i do.

1. Stopped current NAS serviio 1.9.2 from packages.
2. Installed Docker.
3. In Docker/Registry i search for Serviio and from list i select "riftbit/serviio" and download this image last version.
4. Now under Docker/Images i see "riftbit/serviio:latest" image 243 MB.
5. I select under Docker/Images the downloaded "riftbit/serviio:latest" and clicking "Launch" button.
6. In "Create Container" settings i select Advanced Settings/Network. I mark there "Use the same network as Docker host". (See picture 1)

7. Now i tried to connect to console. "Page not found"
I allmost started to uninstall it but i did last try after 1-2 minutes. Wow i got connection to console. I have no idea why it didn't worked immediately.
http:// your lan ip :23423/console/#/app/welcome

8. So next problem was unable to see my media files. I forgot to setup path. My media folder is called "videos". Its a shared folders. So who have saeme problem please see picture 2.

And now it seems working. I have to test it.


HI! I am a maintainer (developer) of this container, and i am glad that someone uses it :) But i never tested it on NASes or something else of bare-metal servers :) And this thread can be a good feedback for me :)

About ur problem in 7. - it is not problem of the container. You cant get access to web console immediately because serviio java service starting not so fast :) If u will check logs of container you will see moment when it ready to accept connections. It need 30-60 seconds to fully start.

About 8. - u need to bind any folder with your media files. I binds:

    host - /media/hdd
    path in container - /media/serviio

And then in serviio gui i navigate path /media/serviio/....<here your content of mounted folder>.....
Like on screenshot:
Image

Folder VIDEO is in host path /media/hdd

If someone have problems with setup feel free to open an issue on github page: https://github.com/riftbit/docker-serviio/issues

P.S. Serviio v 2.0 container will be released today or tomorrow :)

Best regards and sorry for bad English, it is not native for me :)
:D
<<

ErgoZ

Serviio newbie

Posts: 6

Joined: Wed Dec 19, 2018 7:09 pm

Post Mon May 27, 2019 1:38 pm

Re: Serviio docker

Meelis wrote:I have a question... Where are located that serviio folder in docker. I need it for editing file. "Editing renderer profiles" (profiles.xml) Is it possible to access to it ?


I am not sure, but as i remeber this file should be here: /opt/serviio/config
And if you want to edit files in this folder i recommend to bind this volume path because on next update all changes are will be overwritten. But before mounting - copy from this path to another location, because when you mounting volume first time with empty host folder - you will get empty folder in container. (i mean backup configs firstly)
<<

atc98092

User avatar

DLNA master

Posts: 3423

Joined: Fri Aug 17, 2012 10:22 pm

Location: Washington (the state)

Post Mon May 27, 2019 4:03 pm

Re: Serviio docker

ErgoZ wrote:
Meelis wrote:I have a question... Where are located that serviio folder in docker. I need it for editing file. "Editing renderer profiles" (profiles.xml) Is it possible to access to it ?


I am not sure, but as i remeber this file should be here: /opt/serviio/config
And if you want to edit files in this folder i recommend to bind this volume path because on next update all changes are will be overwritten. But before mounting - copy from this path to another location, because when you mounting volume first time with empty host folder - you will get empty folder in container. (i mean backup configs firstly)


Don't forget you can create a user-profiles.xml file for your customized profiles, and it is not replaced when Serviio is updated.
Dan

Panasonic ST30 Plasma, Samsung JU7100 4K TV, Sony BDP-S3500, Sharp 4K Roku TV, Insignia Roku TV, Roku 4, Ultra and Stick, Nvidia Shield, Yamaha RX-V583 AVR.
Primary server: Intel i5-6400, 8 gig ram, Windows 10 Pro, 18 TB hard drive space | Test server Windows 10 Pro, AMD Phenom II X4 965, 8 gig ram

HOWTO: Enable debug logging HOWTO: Identify media file contents
<<

ErgoZ

Serviio newbie

Posts: 6

Joined: Wed Dec 19, 2018 7:09 pm

Post Tue May 28, 2019 11:27 am

Re: Serviio docker

atc98092 wrote:
ErgoZ wrote:
Meelis wrote:I have a question... Where are located that serviio folder in docker. I need it for editing file. "Editing renderer profiles" (profiles.xml) Is it possible to access to it ?


I am not sure, but as i remeber this file should be here: /opt/serviio/config
And if you want to edit files in this folder i recommend to bind this volume path because on next update all changes are will be overwritten. But before mounting - copy from this path to another location, because when you mounting volume first time with empty host folder - you will get empty folder in container. (i mean backup configs firstly)


Don't forget you can create a user-profiles.xml file for your customized profiles, and it is not replaced when Serviio is updated.


Yes you are right. But it can be deleted when container updates if not binded to volume or path bind :)
<<

DVD Listing

Serviio newbie

Posts: 11

Joined: Sat Dec 10, 2016 1:59 pm

Post Sun Jun 02, 2019 6:22 pm

Re: Serviio docker

I am trying to get the Docker version of Serviio working on my Synology NAS.

I seem to be having an error with the profiles.xml file (I created a blank one to let the initialization process to continue)
Where can I get a sample one to modify

ErErgoZ, can you help?

Log extract below
---------------------------------------------------------------------------------------------------------------
INFO CompositeCacheManager - Finished configuration in 152 ms.

DEBUG CompositeCacheManager - attr = [ IS_LATERAL = true, IS_SPOOL = true, IS_REMOTE = true, IS_ETERNAL = true, MaxLifeSeconds = -1, IdleTime = -1, CreateTime = 1559497023783, LastAccessTime = 1559497023635, getTimeToLiveSeconds() = -1, createTime = 1559497023783 ]

DEBUG CompositeCacheManager - attr = [ IS_LATERAL = true, IS_SPOOL = true, IS_REMOTE = true, IS_ETERNAL = true, MaxLifeSeconds = -1, IdleTime = -1, CreateTime = 1559497023786, LastAccessTime = 1559497023635, getTimeToLiveSeconds() = -1, createTime = 1559497023786 ]

INFO ProfileManager - Loading profiles from file /profiles.xml

ERROR XmlUtils - XML Profiles.xsd didn't pass validation, reason: Content is not allowed in prolog.

ERROR MediaServer - An unexpected error occurred. Ending the application. Message: org.serviio.profile.ProfilesDefinitionException: Profiles XML file is not valid (according to the schema). Check the log.

java.lang.RuntimeException: org.serviio.profile.ProfilesDefinitionException: Profiles XML file is not valid (according to the schema). Check the log.

at org.serviio.profile.ProfileManager.parseProfilesFromFile(ProfileManager.java:186)

at org.serviio.profile.ProfileManager.loadProfiles(ProfileManager.java:158)

at org.serviio.MediaServer.main(MediaServer.java:136)

Caused by: org.serviio.profile.ProfilesDefinitionException: Profiles XML file is not valid (according to the schema). Check the log.

at org.serviio.profile.ProfilesDefinitionParser.validateXML(ProfilesDefinitionParser.java:1054)

at org.serviio.profile.ProfilesDefinitionParser.parseDefinition(ProfilesDefinitionParser.java:154)

at org.serviio.profile.ProfileManager.parseProfilesFromFile(ProfileManager.java:184)

... 2 more

An unexpected error occurred. Ending the application. Message: org.serv
<<

ErgoZ

Serviio newbie

Posts: 6

Joined: Wed Dec 19, 2018 7:09 pm

Post Mon Jun 03, 2019 9:20 pm

Re: Serviio docker

DVD Listing wrote:I am trying to get the Docker version of Serviio working on my Synology NAS.

I seem to be having an error with the profiles.xml file (I created a blank one to let the initialization process to continue)
Where can I get a sample one to modify

ErErgoZ, can you help?

Log extract below
---------------------------------------------------------------------------------------------------------------
INFO CompositeCacheManager - Finished configuration in 152 ms.

DEBUG CompositeCacheManager - attr = [ IS_LATERAL = true, IS_SPOOL = true, IS_REMOTE = true, IS_ETERNAL = true, MaxLifeSeconds = -1, IdleTime = -1, CreateTime = 1559497023783, LastAccessTime = 1559497023635, getTimeToLiveSeconds() = -1, createTime = 1559497023783 ]

DEBUG CompositeCacheManager - attr = [ IS_LATERAL = true, IS_SPOOL = true, IS_REMOTE = true, IS_ETERNAL = true, MaxLifeSeconds = -1, IdleTime = -1, CreateTime = 1559497023786, LastAccessTime = 1559497023635, getTimeToLiveSeconds() = -1, createTime = 1559497023786 ]

INFO ProfileManager - Loading profiles from file /profiles.xml

ERROR XmlUtils - XML Profiles.xsd didn't pass validation, reason: Content is not allowed in prolog.

ERROR MediaServer - An unexpected error occurred. Ending the application. Message: org.serviio.profile.ProfilesDefinitionException: Profiles XML file is not valid (according to the schema). Check the log.

java.lang.RuntimeException: org.serviio.profile.ProfilesDefinitionException: Profiles XML file is not valid (according to the schema). Check the log.

at org.serviio.profile.ProfileManager.parseProfilesFromFile(ProfileManager.java:186)

at org.serviio.profile.ProfileManager.loadProfiles(ProfileManager.java:158)

at org.serviio.MediaServer.main(MediaServer.java:136)

Caused by: org.serviio.profile.ProfilesDefinitionException: Profiles XML file is not valid (according to the schema). Check the log.

at org.serviio.profile.ProfilesDefinitionParser.validateXML(ProfilesDefinitionParser.java:1054)

at org.serviio.profile.ProfilesDefinitionParser.parseDefinition(ProfilesDefinitionParser.java:154)

at org.serviio.profile.ProfileManager.parseProfilesFromFile(ProfileManager.java:184)

... 2 more

An unexpected error occurred. Ending the application. Message: org.serv


if i understood cerrectly you need original profiles.xml? I think you can download it with original serviio tar.gz archive from download page, extract this archive and find original files there. Docker container uses original tar.gz archive from download section of this site :)
<<

atc98092

User avatar

DLNA master

Posts: 3423

Joined: Fri Aug 17, 2012 10:22 pm

Location: Washington (the state)

Post Mon Jun 03, 2019 10:08 pm

Re: Serviio docker

Here's a recent version. I can't say for sure it's from 2.0, but I think it is.
Attachments
profiles.xml
(183.6 KiB) Downloaded 168 times
Dan

Panasonic ST30 Plasma, Samsung JU7100 4K TV, Sony BDP-S3500, Sharp 4K Roku TV, Insignia Roku TV, Roku 4, Ultra and Stick, Nvidia Shield, Yamaha RX-V583 AVR.
Primary server: Intel i5-6400, 8 gig ram, Windows 10 Pro, 18 TB hard drive space | Test server Windows 10 Pro, AMD Phenom II X4 965, 8 gig ram

HOWTO: Enable debug logging HOWTO: Identify media file contents
<<

ErgoZ

Serviio newbie

Posts: 6

Joined: Wed Dec 19, 2018 7:09 pm

Post Tue Jun 04, 2019 9:55 am

Re: Serviio docker

DVD Listing wrote:I am trying to get the Docker version of Serviio working on my Synology NAS.

I seem to be having an error with the profiles.xml file (I created a blank one to let the initialization process to continue)
Where can I get a sample one to modify

ErErgoZ, can you help?

Log extract below
---------------------------------------------------------------------------------------------------------------
INFO CompositeCacheManager - Finished configuration in 152 ms.

DEBUG CompositeCacheManager - attr = [ IS_LATERAL = true, IS_SPOOL = true, IS_REMOTE = true, IS_ETERNAL = true, MaxLifeSeconds = -1, IdleTime = -1, CreateTime = 1559497023783, LastAccessTime = 1559497023635, getTimeToLiveSeconds() = -1, createTime = 1559497023783 ]

DEBUG CompositeCacheManager - attr = [ IS_LATERAL = true, IS_SPOOL = true, IS_REMOTE = true, IS_ETERNAL = true, MaxLifeSeconds = -1, IdleTime = -1, CreateTime = 1559497023786, LastAccessTime = 1559497023635, getTimeToLiveSeconds() = -1, createTime = 1559497023786 ]

INFO ProfileManager - Loading profiles from file /profiles.xml

ERROR XmlUtils - XML Profiles.xsd didn't pass validation, reason: Content is not allowed in prolog.

ERROR MediaServer - An unexpected error occurred. Ending the application. Message: org.serviio.profile.ProfilesDefinitionException: Profiles XML file is not valid (according to the schema). Check the log.

java.lang.RuntimeException: org.serviio.profile.ProfilesDefinitionException: Profiles XML file is not valid (according to the schema). Check the log.

at org.serviio.profile.ProfileManager.parseProfilesFromFile(ProfileManager.java:186)

at org.serviio.profile.ProfileManager.loadProfiles(ProfileManager.java:158)

at org.serviio.MediaServer.main(MediaServer.java:136)

Caused by: org.serviio.profile.ProfilesDefinitionException: Profiles XML file is not valid (according to the schema). Check the log.

at org.serviio.profile.ProfilesDefinitionParser.validateXML(ProfilesDefinitionParser.java:1054)

at org.serviio.profile.ProfilesDefinitionParser.parseDefinition(ProfilesDefinitionParser.java:154)

at org.serviio.profile.ProfileManager.parseProfilesFromFile(ProfileManager.java:184)

... 2 more

An unexpected error occurred. Ending the application. Message: org.serv


I posted profiles.xml on Github Gists - https://gist.github.com/ergoz/256c739c4 ... 57adec17a6
It is from Serviio 2.0

Return to NAS installation

Who is online

Users browsing this forum: No registered users and 1 guest

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.