FAQ  •  Register  •  Login

PACKAGE: Serviio 1.9.2 - Synology NAS, with HW transcoding!

<<

Acetone

Serviio newbie

Posts: 4

Joined: Tue May 15, 2018 8:03 am

Post Fri May 18, 2018 8:47 am

Re: PACKAGE: Serviio 1.9.2 - Synology NAS, with HW transcodi

Still suck on this, when I try to open the web UI it goes to http://my_ip:23423/console and then just hangs on an about:blank with the browsers saying "An error occurred trying to load the resource"

Not changed any setting from before the update, just the update to Java 1.8.0_171_0047
<<

Acetone

Serviio newbie

Posts: 4

Joined: Tue May 15, 2018 8:03 am

Post Wed May 23, 2018 11:24 pm

Re: PACKAGE: Serviio 1.9.2 - Synology NAS, with HW transcodi

After updating the synology to DSM 6.2 everything is work fine again.
<<

MrHands

Serviio newbie

Posts: 4

Joined: Thu Feb 25, 2016 3:17 pm

Post Fri Jul 20, 2018 10:23 am

Re: PACKAGE: Serviio 1.9.2 - Synology NAS, with HW transcodi

I don't know if I'm the only one with this problem but a few weeks ago I tried updating my NAS synology serviio package from 1.8.0-0031 to 1.9

the update was successful but my samsung TV (2016) could NOT see anything in my usual shared folder.
I tried to change tv profile, updateed everything, rebooted etc
I couldn't manage to solve the issue, Samsung TV never managed to see serviio files

I solved by reverting my Synology package to 1.8

any ideas?
<<

Airborne1

Serviio newbie

Posts: 10

Joined: Tue Jul 24, 2018 4:13 pm

Post Tue Jul 24, 2018 4:43 pm

Re: PACKAGE: Serviio 1.9.2 - Synology NAS, with HW transcodi

Hi,

Serviio won't start anymore on my DS916+ (1.9.2-0035).
I'm running the latest DSM version (6.2-23739 Update 2). Java SE embedded 8 ist installed and running (1.8.0_171-0047).

serviio.log says:
Starting Serviio
Unrecognized option: --add-modules
Error: Could not create the Java Virtual Machine.
Error: A fatal exception has occurred. Program will exit.

Any recommendations?

Thanks.
<<

nbat42

Serviio newbie

Posts: 2

Joined: Sun Apr 10, 2016 10:12 pm

Post Sun Jul 29, 2018 1:17 pm

Re: PACKAGE: Serviio 1.9.2 - Synology NAS, with HW transcodi

I have the same exact problem as below. Same system. Same set up. Serviio installs but won't run.

Thoughts.



Airborne1 wrote:Hi,

Serviio won't start anymore on my DS916+ (1.9.2-0035).
I'm running the latest DSM version (6.2-23739 Update 2). Java SE embedded 8 ist installed and running (1.8.0_171-0047).

serviio.log says:
Starting Serviio
Unrecognized option: --add-modules
Error: Could not create the Java Virtual Machine.
Error: A fatal exception has occurred. Program will exit.

Any recommendations?

Thanks.
<<

atc98092

User avatar

DLNA master

Posts: 3011

Joined: Fri Aug 17, 2012 10:22 pm

Location: Washington (the state)

Post Sun Jul 29, 2018 4:01 pm

Re: PACKAGE: Serviio 1.9.2 - Synology NAS, with HW transcodi

nbat42 wrote:I have the same exact problem as below. Same system. Same set up. Serviio installs but won't run.

Thoughts.



Airborne1 wrote:Hi,

Serviio won't start anymore on my DS916+ (1.9.2-0035).
I'm running the latest DSM version (6.2-23739 Update 2). Java SE embedded 8 ist installed and running (1.8.0_171-0047).

serviio.log says:
Starting Serviio
Unrecognized option: --add-modules
Error: Could not create the Java Virtual Machine.
Error: A fatal exception has occurred. Program will exit.

Any recommendations?

Thanks.


We need to see your complete log, not just a snippet. It appears that Java isn't being recognized, but the log has more detail than what Airborne1 copied. A detailed log might be necessary.
Dan

Panasonic ST30 Plasma, Samsung JU7100 4K TV, Sony BDP-S3500, Sharp 4K Roku TV, Insignia Roku TV, Roku 4, Ultra and Stick, Yamaha RX-V583 AVR.
Primary server: Intel i5-6400, 8 gig ram, Windows 10 Pro, 18 TB hard drive space | Test server Windows 7 Home Premium, AMD Phenom II X4 965, 8 gig ram

HOWTO: Enable debug logging HOWTO: Identify media file contents
<<

JesseBlue78

Serviio newbie

Posts: 3

Joined: Fri Jul 27, 2018 5:55 pm

Post Sun Jul 29, 2018 9:04 pm

Re: PACKAGE: Serviio 1.9.2 - Synology NAS, with HW transcodi

<<

Airborne1

Serviio newbie

Posts: 10

Joined: Tue Jul 24, 2018 4:13 pm

Post Mon Jul 30, 2018 8:44 am

Re: PACKAGE: Serviio 1.9.2 - Synology NAS, with HW transcodi

atc98092 wrote:
nbat42 wrote:I have the same exact problem as below. Same system. Same set up. Serviio installs but won't run.

Thoughts.



Airborne1 wrote:Hi,

Serviio won't start anymore on my DS916+ (1.9.2-0035).
I'm running the latest DSM version (6.2-23739 Update 2). Java SE embedded 8 ist installed and running (1.8.0_171-0047).

serviio.log says:
Starting Serviio
Unrecognized option: --add-modules
Error: Could not create the Java Virtual Machine.
Error: A fatal exception has occurred. Program will exit.

Any recommendations?

Thanks.


We need to see your complete log, not just a snippet. It appears that Java isn't being recognized, but the log has more detail than what Airborne1 copied. A detailed log might be necessary.


Well, I proceeded as described in the link given in your message regarding the "detailed log".
The so called "snippet" is actually all there is.
No wonder, if the process is stopped almost right after the launch of the program.
If there is a hidden feature to configure different debug levels, then please tell me, and I will gladly provide more info!
<<

Airborne1

Serviio newbie

Posts: 10

Joined: Tue Jul 24, 2018 4:13 pm

Post Mon Jul 30, 2018 8:45 am

Re: PACKAGE: Serviio 1.9.2 - Synology NAS, with HW transcodi

JesseBlue78 wrote:http://forum.serviio.org/viewtopic.php?f=5&t=24649


OK, same problem, still unsolved.
<<

dmsg

Serviio newbie

Posts: 1

Joined: Mon Jul 30, 2018 12:09 pm

Post Mon Jul 30, 2018 12:12 pm

Re: PACKAGE: Serviio 1.9.2 - Synology NAS, with HW transcodi

Airborne1 wrote:
JesseBlue78 wrote:http://forum.serviio.org/viewtopic.php?f=5&t=24649


OK, same problem, still unsolved.


I have the same problem. After a couples of times install/uninstall now I am facing this issue, could anyone help as I am o novice to this. :(
Attachments
serviio.png
serviio.png (77.81 KiB) Viewed 1815 times
<<

patters

User avatar

DLNA master

Posts: 1264

Joined: Sat Oct 09, 2010 3:51 pm

Location: London, UK

Post Mon Sep 10, 2018 12:03 pm

Re: PACKAGE: Serviio 1.9.2 - Synology NAS, with HW transcodi

Have a read here:
viewtopic.php?f=14&t=19275

There's a DSM bug where sometimes during package removal, DSM leaves the firewall rules behind which will then cause the error in your screenshot when you try to re-install.
The only way to delete this file will be to enable SSH and connect in using an SSH client (PuTTY on Windows). You need to log in as the admin user. Once logged in as admin, run
  Code:
sudo -i

Re-enter the admin password a second time. You're now root, be very careful to type things correctly as a mistake here could do damage.
  Code:
rm /usr/local/etc/services.d/Serviio.sc
exit
exit
PS4 | Bravia KDL-32V5500 | Xbox One S | Synology DS214play
Serviio 1.9.2 package for Synology NAS - with hardware transcoding support!
<<

HSH

Serviio newbie

Posts: 7

Joined: Fri Mar 20, 2015 3:08 pm

Post Wed Nov 28, 2018 5:41 pm

Re: PACKAGE: Serviio 1.9.2 - Synology NAS, with HW transcodi

is there any plan to release 1.10 also for SYnology nas'es ?
<<

HostNet

Serviio newbie

Posts: 1

Joined: Tue Jan 22, 2019 5:44 am

Post Tue Jan 22, 2019 5:49 am

Re: PACKAGE: Serviio 1.9.2 - Synology NAS, with HW transcodi

Hello,

This is just FYI. Have anyone tried using Docker. I setup Serviio using riftbit/sorviio script and it is running without any issues.

https://hub.docker.com/r/riftbit/serviio/

Regards,
<<

mimis

Serviio newbie

Posts: 4

Joined: Fri Jan 25, 2019 8:50 pm

Post Fri Jan 25, 2019 9:13 pm

Re: PACKAGE: Serviio 1.9.2 - Synology NAS, with HW transcodi

Hello all,

I've been trying to run Serviio 1.9.2 all day on a synology DS414 with no luck. I've followed relative instructions and installed first Java embedded (both 8 and 7) and also tried official synology Java8, but no luck. Serviio runs for a few seconds and then stops. I've read a lot of posts but could not find a solution.

Is there someone who could provide some suggestions?

Many thanks in advance
<<

atc98092

User avatar

DLNA master

Posts: 3011

Joined: Fri Aug 17, 2012 10:22 pm

Location: Washington (the state)

Post Sat Jan 26, 2019 2:36 am

Re: PACKAGE: Serviio 1.9.2 - Synology NAS, with HW transcodi

mimis wrote:Hello all,

I've been trying to run Serviio 1.9.2 all day on a synology DS414 with no luck. I've followed relative instructions and installed first Java embedded (both 8 and 7) and also tried official synology Java8, but no luck. Serviio runs for a few seconds and then stops. I've read a lot of posts but could not find a solution.

Is there someone who could provide some suggestions?

Many thanks in advance


Please attach your Serviio log here so we can see why it won't start.
Dan

Panasonic ST30 Plasma, Samsung JU7100 4K TV, Sony BDP-S3500, Sharp 4K Roku TV, Insignia Roku TV, Roku 4, Ultra and Stick, Yamaha RX-V583 AVR.
Primary server: Intel i5-6400, 8 gig ram, Windows 10 Pro, 18 TB hard drive space | Test server Windows 7 Home Premium, AMD Phenom II X4 965, 8 gig ram

HOWTO: Enable debug logging HOWTO: Identify media file contents
<<

mimis

Serviio newbie

Posts: 4

Joined: Fri Jan 25, 2019 8:50 pm

Post Sat Jan 26, 2019 4:54 pm

Re: PACKAGE: Serviio 1.9.2 - Synology NAS, with HW transcodi

First of all, many thanks for your quick reply.

I tried once more to run Serviio, it started running for about 20 seconds and then stopped. I then tried to find a log in Log Center but unfortunately nothing was recorded there. I only found logs from the past not concerning this issue.

Is there maybe another way to locate this log you are asking for?

Thank you and I apologize for my ignorance in this.
<<

mimis

Serviio newbie

Posts: 4

Joined: Fri Jan 25, 2019 8:50 pm

Post Sat Jan 26, 2019 4:55 pm

Re: PACKAGE: Serviio 1.9.2 - Synology NAS, with HW transcodi

atc98092 wrote:
mimis wrote:Hello all,

I've been trying to run Serviio 1.9.2 all day on a synology DS414 with no luck. I've followed relative instructions and installed first Java embedded (both 8 and 7) and also tried official synology Java8, but no luck. Serviio runs for a few seconds and then stops. I've read a lot of posts but could not find a solution.

Is there someone who could provide some suggestions?

Many thanks in advance


Please attach your Serviio log here so we can see why it won't start.


First of all, many thanks for your quick reply.

I tried once more to run Serviio, it started running for about 20 seconds and then stopped. I then tried to find a log in Log Center but unfortunately nothing was recorded there. I only found logs from the past not concerning this issue.

Is there maybe another way to locate this log you are asking for?

Thank you and I apologize for my ignorance in this.
<<

atc98092

User avatar

DLNA master

Posts: 3011

Joined: Fri Aug 17, 2012 10:22 pm

Location: Washington (the state)

Post Sat Jan 26, 2019 6:12 pm

Re: PACKAGE: Serviio 1.9.2 - Synology NAS, with HW transcodi

I'm uncertain where the Serviio logs might be on a NAS, but on computer installs it's in the Serviio install path, in the /log folder. You'll need to be able to browse your file structure on your NAS to find it, and I can't tell you how to do that.
Dan

Panasonic ST30 Plasma, Samsung JU7100 4K TV, Sony BDP-S3500, Sharp 4K Roku TV, Insignia Roku TV, Roku 4, Ultra and Stick, Yamaha RX-V583 AVR.
Primary server: Intel i5-6400, 8 gig ram, Windows 10 Pro, 18 TB hard drive space | Test server Windows 7 Home Premium, AMD Phenom II X4 965, 8 gig ram

HOWTO: Enable debug logging HOWTO: Identify media file contents
<<

mimis

Serviio newbie

Posts: 4

Joined: Fri Jan 25, 2019 8:50 pm

Post Sat Jan 26, 2019 7:33 pm

Re: PACKAGE: Serviio 1.9.2 - Synology NAS, with HW transcodi

atc98092 wrote:I'm uncertain where the Serviio logs might be on a NAS, but on computer installs it's in the Serviio install path, in the /log folder. You'll need to be able to browse your file structure on your NAS to find it, and I can't tell you how to do that.

That's really unfortunate. I tried searching for "serviio" but got zero results. This was my last resort, I will not be able to run it after all.

Anyway, thanks a lot for your time.
<<

atc98092

User avatar

DLNA master

Posts: 3011

Joined: Fri Aug 17, 2012 10:22 pm

Location: Washington (the state)

Post Sat Jan 26, 2019 8:04 pm

Re: PACKAGE: Serviio 1.9.2 - Synology NAS, with HW transcodi

If you're just searching via a web interface for the NAS, that may not provide full file structure access. Often times you have to SSH (secure shell) into these boxes to be able to browse the full file structure. Putty is a good program for that. Anyway, best of luck. Perhaps someone with more knowledge about your NAS will pop in here.
Dan

Panasonic ST30 Plasma, Samsung JU7100 4K TV, Sony BDP-S3500, Sharp 4K Roku TV, Insignia Roku TV, Roku 4, Ultra and Stick, Yamaha RX-V583 AVR.
Primary server: Intel i5-6400, 8 gig ram, Windows 10 Pro, 18 TB hard drive space | Test server Windows 7 Home Premium, AMD Phenom II X4 965, 8 gig ram

HOWTO: Enable debug logging HOWTO: Identify media file contents
PreviousNext

Return to NAS installation

Who is online

Users browsing this forum: No registered users and 1 guest

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.