FAQ  •  Register  •  Login

Web UI in Ajax (Mobile & desktop edition)

<<

kairoh

DLNA master

Posts: 180

Joined: Sun Aug 08, 2010 10:41 am

Location: France

Post Sat Aug 27, 2011 9:15 pm

Re: Web UI in Restful Ajax

patters wrote:It was just to change the font and font size really, not the text. Cheers for the other things!
I'm not a web guy so I'm not too good with CSS. How do I make the line spacing a bit more generous? I've tried a few things but got nowhere. The other thing I'd like to do is change the borders of the table items so they're just a single line of pixels (not the raised edges).

It looks really nice! 8-)
Try to add these CSS properties :
  Code:
div.tab { line-height: 2; }
div.tab table { border-collapse:collapse; }
Serviio WebUI console developer : New Homepage | Support | Project | Issues

Samsung UA32C6600 | WinXP / Ubuntu 11.10 | Samsung Galaxy S | Freebox v6
HowTo: Provide supported formats of a device HowTo: Record a new ticket on Bitbucket
HowTo: Provide details of a video file that doesn't play HowTo: Turn on detailed logging
<<

patters

User avatar

DLNA master

Posts: 1273

Joined: Sat Oct 09, 2010 3:51 pm

Location: London, UK

Post Sat Aug 27, 2011 9:40 pm

Re: Web UI in Restful Ajax

I'll carry on with this tomorrow. I've decided that, since changes with the Web UI are likely to be more frequent than with Serviio, I will make it a completely separate package. That way people with the lower spec Synology units with 128MB RAM devices don't have to use it.
LG OLED55B8PLA | PS4 Pro | Xbox One S | Synology DS214play
Serviio 2.0 package for Synology NAS - with limited hardware transcoding support!
<<

meshelton

Serviio newbie

Posts: 7

Joined: Wed Jul 20, 2011 4:16 pm

Post Sun Aug 28, 2011 10:31 am

Re: Web UI in Restful Ajax

I'm having some issues: I've set up serviio 0.5.2, and followed all the instructions on https://bitbucket.org/kairoh/serviio-re ... /wiki/Home, I'm sure serviio is running but when I navigate to the page I get this error

Cannot connect to Serviio server, it does not seem to be running. Exiting...
Rest error to "categoryVisibilityTypes" : Invalid JSON: DISPLAYED Display category CONTENT_DISPLAYED Display content only DISABLED Disabled (200)
Rest error to "profiles" : Invalid JSON: 6 DirecTV HD-DVR 1 Generic DLNA profile 8 LG BD player 12 Panasonic Viera 4 Playstation 3 5 Samsung TV (A-series) 2 Samsung TV (B-series) 7 Samsung TV / player (C/D-series) 10 Sony BD Player 9 Sony Bravia TV 13 Toshiba Rezga 3 XBox 360 (200)
Rest error to "cpu-cores" : Invalid JSON: numberOfCPUCores 4 (200)
Rest error to "descriptiveMetadataExtractors" : Invalid JSON: NONE No descriptive metadata ONLINE_VIDEO_SOURCES Online metadata sources SWISSCENTER Swisscenter XBMC XBMC .nfo files (200)
Rest error to "metadataLanguages" : Invalid JSON: cs Čeština da Dansk de Deutsch el Ελληνικά en English es Español fi Suomeksi fr Français he עברית hr Hrvatski hu Magyar it Italiano ja 日本語 ko 한국어 nl Nederlands no Norsk pl Polski pt Português ru Pусский язык sl Slovenščina sv Svenska tr Türkçe zh 中文 (200)
Rest error to "browsingCategoriesLanguages" : Invalid JSON: bg български език ca Català cs Čeština da Dansk de Deutsch en English es Español fr Français hu Magyar it Italiano nl Nederlands no Norsk pl Polski pt_BR Português (Brazil) ro Română ru Pусский язык sk Slovenčina sv Svenska zh_CN 中文 (Simplified) zh_HK 中文 (Traditional) (200)
Rest error to "status" : Invalid JSON: STARTED b4fc48e0-a880-4ba3-9ee5-55c08ee5241d 192.168.1.10 Windows Media Player 1 ACTIVE aa27a903-9aa0-4c2d-913c-b5566d809a6b 192.168.1.2 Unrecognized device 1 UNKNOWN (200)

I've been trying for quite a while to get this to work. I'm starting serviio using upstart and then starting the webui by cding into the serviio-0.5.2/bin and running "sudo ./serviio-webui.sh". I'm running serviio on ubuntu 11.04 headless server and trying to access it using windows 7 and chrome.
<<

kairoh

DLNA master

Posts: 180

Joined: Sun Aug 08, 2010 10:41 am

Location: France

Post Sun Aug 28, 2011 11:14 am

Re: Web UI in Restful Ajax

It seems you have not patched serviio server 0.5.2 to use json. Download the jars, then patch and run servio.sh (see how to do it).
I don't know what the "upstart" command do, but it needs to call this patched shell.
Serviio WebUI console developer : New Homepage | Support | Project | Issues

Samsung UA32C6600 | WinXP / Ubuntu 11.10 | Samsung Galaxy S | Freebox v6
HowTo: Provide supported formats of a device HowTo: Record a new ticket on Bitbucket
HowTo: Provide details of a video file that doesn't play HowTo: Turn on detailed logging
<<

meshelton

Serviio newbie

Posts: 7

Joined: Wed Jul 20, 2011 4:16 pm

Post Sun Aug 28, 2011 11:36 am

Re: Web UI in Restful Ajax

kairoh wrote:It seems you have not patched serviio server 0.5.2 to use json. Download the jars, then patch and run servio.sh (see how to do it).
I don't know what the "upstart" command do, but it needs to call this patched shell.


I'm pretty sure I have already patched the server, I have downloaded the latest patch and have unzipped the files to my serviio/lib folder, then I deleted the old serviio.sh script and created a new one whose contents were exactly the same as teh one online with the addition of the -Dserviio.remoteHost=192.168.1.15, stoped the server and then restarted and I still get the same errors. Upstart is just the program that manages the boot up of Ubuntu and makes it easier to manage deamon's like serviio.sh . I wasn't able to use wget to download the zip file directly to my server because of an authentication failure so I had to use sftp to move the zip over and then extract. I'm not sure I set up the permissions correctly for the the .jar files. this is what I get when I put in "ls -la" while in the /opt/serviio-0.5.2/lib folder:
  Code:
-rwsrwsrwt 1 root root  189284 2009-07-15 06:03 concurrent.jar
-rwsrwsrwt 1 root root 2628039 2010-11-05 17:33 derby.jar
-rwsrwsrwt 1 root root  879259 2009-07-04 06:28 freemarker.jar
-rwxrwxrwx 1 root root  173590 2011-08-28 04:55 gson-1.7.1.jar
-rwsrwsrwt 1 root root  174611 2009-09-25 09:09 httpcore.jar
-rwsrwsrwt 1 root root  779880 2009-12-24 10:45 jaudiotagger.jar
-rwsrwsrwt 1 root root   17306 2010-05-30 06:31 jcl-over-slf4j.jar
-rwsrwsrwt 1 root root  435347 2010-05-30 06:24 jcs.jar
-rwsrwsrwt 1 root root    4461 2010-05-30 06:18 jul-to-slf4j.jar
-rwsrwsrwt 1 root root  481535 2011-01-16 07:08 log4j.jar
-rwxrwxrwx 1 root root    4363 2011-08-28 04:55 org.restlet.ext.gson-2.1-M2.jar
-rwsrwsrwt 1 root root    6082 2011-01-08 08:07 org.restlet.ext.xstream.jar
-rwsrwsrwt 1 root root  662401 2011-01-08 08:07 org.restlet.jar
-rwsrwsrwt 1 root root  505947 2009-09-12 10:29 sanselan.jar
-rwxrwxrwx 1 root root    7656 2011-08-28 04:56 serviio-addons-gson.jar
-rwsrwsrwt 1 root root  217055 2011-03-27 13:42 serviio-client.jar
-rwsrwsrwt 1 root root  929650 2011-03-27 13:42 serviio.jar
-rwxrwxrwx 1 root root  159829 2011-08-28 04:46 serviio-webclient-0.2.jar
-rwsrwsrwt 1 root root   25496 2010-05-30 06:18 slf4j-api.jar
-rwsrwsrwt 1 root root    9750 2010-05-30 06:18 slf4j-log4j12.jar
-rwsrwsrwt 1 root root  431406 2010-08-08 18:35 xstream.jar
<<

kairoh

DLNA master

Posts: 180

Joined: Sun Aug 08, 2010 10:41 am

Location: France

Post Sun Aug 28, 2011 5:29 pm

Re: Web UI in Restful Ajax

meshelton wrote:I'm not sure I set up the permissions correctly for the the .jar files. this is what I get when I put in "ls -la" while in the /opt/serviio-0.5.2/lib folder:
  Code:
-rwsrwsrwt 1 root root  189284 2009-07-15 06:03 concurrent.jar
-rwxrwxrwx 1 root root    4363 2011-08-28 04:55 org.restlet.ext.gson-2.1-M2.jar

Maybe try to set the same permission (including sudo) to every jars:
  Code:
chown +s *.jar
Serviio WebUI console developer : New Homepage | Support | Project | Issues

Samsung UA32C6600 | WinXP / Ubuntu 11.10 | Samsung Galaxy S | Freebox v6
HowTo: Provide supported formats of a device HowTo: Record a new ticket on Bitbucket
HowTo: Provide details of a video file that doesn't play HowTo: Turn on detailed logging
<<

meshelton

Serviio newbie

Posts: 7

Joined: Wed Jul 20, 2011 4:16 pm

Post Mon Aug 29, 2011 6:21 pm

Re: Web UI in Restful Ajax

still get the same errors
<<

kairoh

DLNA master

Posts: 180

Joined: Sun Aug 08, 2010 10:41 am

Location: France

Post Mon Aug 29, 2011 8:19 pm

Re: Web UI in Restful Ajax

meshelton wrote:still get the same errors

Are you sure you have no other serviio instance running ?
Could you send me by MP your serviio.sh ?
Serviio WebUI console developer : New Homepage | Support | Project | Issues

Samsung UA32C6600 | WinXP / Ubuntu 11.10 | Samsung Galaxy S | Freebox v6
HowTo: Provide supported formats of a device HowTo: Record a new ticket on Bitbucket
HowTo: Provide details of a video file that doesn't play HowTo: Turn on detailed logging
<<

kairoh

DLNA master

Posts: 180

Joined: Sun Aug 08, 2010 10:41 am

Location: France

Post Tue Aug 30, 2011 9:23 am

Re: Web UI in Restful Ajax

kairoh wrote:Could you send me by MP your serviio.sh ?

My mistake! Just another confusion between win and unix :evil:
On Unix, you have to use ":" separator and not ";".
Thanks meshelton for pointing me out the "serviio.sh" on wiki was invalid!
Serviio WebUI console developer : New Homepage | Support | Project | Issues

Samsung UA32C6600 | WinXP / Ubuntu 11.10 | Samsung Galaxy S | Freebox v6
HowTo: Provide supported formats of a device HowTo: Record a new ticket on Bitbucket
HowTo: Provide details of a video file that doesn't play HowTo: Turn on detailed logging
<<

moltra

DLNA master

Posts: 1871

Joined: Thu Mar 24, 2011 11:00 pm

Location: Ohio USA

Post Sun Sep 25, 2011 5:33 pm

Re: Web UI in Restful Ajax

I am trying to run this and keep getting the following error.

  Code:
bash: ./serviio-webui.sh: /bin/sh^M: bad interpreter: No such file or directory
mark@ssmsserver:~/serviio/bin$


The serviio-webui.sh is in the serviio/bin directory.

There is no entries in the serviio.log file.
Mark
Beta Tester Group
http://www.serviidb.com Online media resource repository

Netgear EVA2000 | Samsung BD-D5300 | XBOX 360 | Windows 7 | Mint Debian 12 | Raxz Maxx
HowTo: Provide supported formats of a device HowTo: Record a new ticket on Bitbucket
HowTo: Provide details of a video file that doesn't play HowTo: Turn on detailed logging
<<

kairoh

DLNA master

Posts: 180

Joined: Sun Aug 08, 2010 10:41 am

Location: France

Post Wed Sep 28, 2011 2:50 pm

Re: Web UI in Restful Ajax

moltra wrote:I am trying to run this and keep getting the following error.
  Code:
bash: ./serviio-webui.sh: /bin/sh^M: bad interpreter: No such file or directory

This shell script included bad line feed (from windows to linux...).
Try the unix command :
  Code:
dos2unix serviio-webui.sh serviio-webui.sh

or (where ^M is made by typing CTRL-V then CTRL-M) :
  Code:
sed 's/^M$//' serviio-webui.sh
Serviio WebUI console developer : New Homepage | Support | Project | Issues

Samsung UA32C6600 | WinXP / Ubuntu 11.10 | Samsung Galaxy S | Freebox v6
HowTo: Provide supported formats of a device HowTo: Record a new ticket on Bitbucket
HowTo: Provide details of a video file that doesn't play HowTo: Turn on detailed logging
<<

kairoh

DLNA master

Posts: 180

Joined: Sun Aug 08, 2010 10:41 am

Location: France

Post Wed Sep 28, 2011 2:57 pm

Re: Web UI in Restful Ajax

moltra wrote:I am trying to run this and keep getting the following error.

OR download the new packages for serviio 0.5.2 or 0.6 : here

In 0.6 version, I've change all the scripts to :
- fix every bad line feeds.
- scan every jars in /plugins THEN in /lib (no explicit listing, and allows easy patching of Serviio).
- provide 2 launching modes : either alone (normal) or with Serviio ("wrapping" in only one jvm process - for embeded devices).

Of course this version provides support for online feeds.
Serviio WebUI console developer : New Homepage | Support | Project | Issues

Samsung UA32C6600 | WinXP / Ubuntu 11.10 | Samsung Galaxy S | Freebox v6
HowTo: Provide supported formats of a device HowTo: Record a new ticket on Bitbucket
HowTo: Provide details of a video file that doesn't play HowTo: Turn on detailed logging
<<

moltra

DLNA master

Posts: 1871

Joined: Thu Mar 24, 2011 11:00 pm

Location: Ohio USA

Post Wed Sep 28, 2011 4:02 pm

Re: Web UI in Restful Ajax

I thought I had the version for 0.6 but it looks like you have updated your page and files. I will download the newest version tonight and see if have the same problem.
Mark
Beta Tester Group
http://www.serviidb.com Online media resource repository

Netgear EVA2000 | Samsung BD-D5300 | XBOX 360 | Windows 7 | Mint Debian 12 | Raxz Maxx
HowTo: Provide supported formats of a device HowTo: Record a new ticket on Bitbucket
HowTo: Provide details of a video file that doesn't play HowTo: Turn on detailed logging
<<

patters

User avatar

DLNA master

Posts: 1273

Joined: Sat Oct 09, 2010 3:51 pm

Location: London, UK

Post Thu Sep 29, 2011 11:44 pm

Re: Web UI in Restful Ajax

Tried out the new 0.6 version just now. It works if I launch Serviio, then launch the serviio-webui.sh script separately. But when I used the wrapper script to launch both as one it doesn't work. Serviio starts up and writes to its log, but it's as if the REST stuff isn't bound correctly to the network interface. I am unable to use the Web UI, and unable to connect a normal Serviio Remote Console. The log says Restlet server exposed on port 23423 in both cases. However I only see the message [RestletProxy] Starting Serviio WebUI on port 8123 if I launch the WebUI in a separate JVM.

Could this be similar to the problem you originally had with the serviio-webui.sh script where it was only binding to the loopback interface on 127.0.0.1?
LG OLED55B8PLA | PS4 Pro | Xbox One S | Synology DS214play
Serviio 2.0 package for Synology NAS - with limited hardware transcoding support!
<<

kairoh

DLNA master

Posts: 180

Joined: Sun Aug 08, 2010 10:41 am

Location: France

Post Fri Sep 30, 2011 8:13 am

Re: Web UI in Restful Ajax

patters wrote:Could this be similar to the problem you originally had with the serviio-webui.sh script where it was only binding to the loopback interface on 127.0.0.1?

I've removed from the webui any binding restriction.
Actually the wrapper script launches sequentially Serviio THEN the webui.
Have just tried to wait a little before connecting to the webui?
Serviio WebUI console developer : New Homepage | Support | Project | Issues

Samsung UA32C6600 | WinXP / Ubuntu 11.10 | Samsung Galaxy S | Freebox v6
HowTo: Provide supported formats of a device HowTo: Record a new ticket on Bitbucket
HowTo: Provide details of a video file that doesn't play HowTo: Turn on detailed logging
<<

patters

User avatar

DLNA master

Posts: 1273

Joined: Sat Oct 09, 2010 3:51 pm

Location: London, UK

Post Fri Sep 30, 2011 2:52 pm

Re: Web UI in Restful Ajax

Yeah I gave it a good while. I could see from the logs that Serviio had started (all device profiles and online plugins loaded), but even the normal Serviio Remote Console wouldn't connect to it. Once I stopped and reverted to the normal Serviio launch shell script it's fine.
LG OLED55B8PLA | PS4 Pro | Xbox One S | Synology DS214play
Serviio 2.0 package for Synology NAS - with limited hardware transcoding support!
<<

moltra

DLNA master

Posts: 1871

Joined: Thu Mar 24, 2011 11:00 pm

Location: Ohio USA

Post Fri Sep 30, 2011 3:05 pm

Re: Web UI in Restful Ajax

kairoh wrote:
moltra wrote:I am trying to run this and keep getting the following error.

OR download the new packages for serviio 0.5.2 or 0.6 : here

In 0.6 version, I've change all the scripts to :
- fix every bad line feeds.
- scan every jars in /plugins THEN in /lib (no explicit listing, and allows easy patching of Serviio).
- provide 2 launching modes : either alone (normal) or with Serviio ("wrapping" in only one jvm process - for embeded devices).

Of course this version provides support for online feeds.


Installed new version works on local / remote machine. going to try with droid X.
Mark
Beta Tester Group
http://www.serviidb.com Online media resource repository

Netgear EVA2000 | Samsung BD-D5300 | XBOX 360 | Windows 7 | Mint Debian 12 | Raxz Maxx
HowTo: Provide supported formats of a device HowTo: Record a new ticket on Bitbucket
HowTo: Provide details of a video file that doesn't play HowTo: Turn on detailed logging
<<

kairoh

DLNA master

Posts: 180

Joined: Sun Aug 08, 2010 10:41 am

Location: France

Post Wed Oct 19, 2011 9:14 pm

Re: Web UI in Restful Ajax

patters wrote:Yeah I gave it a good while. I could see from the logs that Serviio had started (all device profiles and online plugins loaded), but even the normal Serviio Remote Console wouldn't connect to it. Once I stopped and reverted to the normal Serviio launch shell script it's fine.

I've finally founded the mistake in the wrap shell script: a stupid windows backslash was still there... (there is no error but the db isn't created/updated!).
I've uploaded a new version (0.6-b) which fix this point.
Serviio WebUI console developer : New Homepage | Support | Project | Issues

Samsung UA32C6600 | WinXP / Ubuntu 11.10 | Samsung Galaxy S | Freebox v6
HowTo: Provide supported formats of a device HowTo: Record a new ticket on Bitbucket
HowTo: Provide details of a video file that doesn't play HowTo: Turn on detailed logging
<<

kairoh

DLNA master

Posts: 180

Joined: Sun Aug 08, 2010 10:41 am

Location: France

Post Mon Oct 31, 2011 10:52 pm

Re: Web UI in Restful Ajax

0.6-c
=====

- updated i18n files (from forum & Patters pack for PHP Web UI).
- added i18n for combo box.
- added automatic disabling of inputs (same as console).
- updated icon alignment in table.
- added a release notes file.

0.6-b
=====

- fixed linux wrap mode script ([back]slash error).
- added a readme file.

0.6-a
=====

- added support of online feeds.
- added wrap starting mode.
- changed packaging : move libs to plugins dir.
- changed scripts to allow easy plugin system : scans jars in /plugins then /libs.
- updated scripts.

Available here.

Don't hesitate to create bitbucket ticket if you find any problem or have any feature request... ;)
Serviio WebUI console developer : New Homepage | Support | Project | Issues

Samsung UA32C6600 | WinXP / Ubuntu 11.10 | Samsung Galaxy S | Freebox v6
HowTo: Provide supported formats of a device HowTo: Record a new ticket on Bitbucket
HowTo: Provide details of a video file that doesn't play HowTo: Turn on detailed logging
<<

qoolbox

Streaming enthusiast

Posts: 45

Joined: Tue Nov 01, 2011 4:35 pm

Location: France

Post Tue Nov 01, 2011 4:41 pm

Re: Web UI in Restful Ajax

Hi Dear,

I made a Serviio Thecus Module with your interface (0.6b)

I got some problems :

[*]interface doesnt refresh, i have to refresh my browser to view the change

[*]in media library : add local (by browsing NAS content) add the path of where serviio is installed + the local path
I have to add the path manually...

[*]files and folder with "éà..." UTF-8 are not display neither indexed...

Have any idea to fix this problems ?
Third Party Thecus NAS Develloper

http://forum.thecus.com
http://www.tsuga.fr
PreviousNext

Return to Third-party tools integration

Who is online

Users browsing this forum: No registered users and 19 guests

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.