FAQ  •  Register  •  Login

ServiiGo (Android 3G/4G/Wifi Playback App)

<<

will

DLNA master

Posts: 2129

Joined: Mon Aug 30, 2010 11:18 am

Location: UK

Post Sun Dec 01, 2013 10:00 am

Re: ServiiGo (Android 3G/4G/Wifi Playback App)

I've uploaded a new beta to Google Play. This has quite a big change in it where by responses form the server (excluding random and online ones) are cached on the device. When browsing the server cached responses will be presented first while the app loads a fresh one over the network. A future version of serviio will hopefully let the app know if anything has changed server side, and if it hasn't then the app won't have to reload the data. Please test it out and tell me what you think. Also after a few days, please go to Settings->Apps->ServiiGo to view the app info, and scroll down to where it shows the size of the app, data and cache and let me know how big the cache is. The cache could get quite big after a while, so I'm tempted to make is Android 4.0+ or at least have an option on old devices which generally have small amounts of built in disk space.

  Code:
==== 3.2 Beta 3 ====
*Added experimental response caching
*Updated Google Analytics to v3 (#74)
Will
Beta Tester Group
ServiiDroid (Android Console) Developer: Download | Home | Support
ServiiGo (Android 3G/4G/WiFi Playback App) Developer: More info

Player: Sony BDP S370 | Server: Debian 6.0 x86
HowTo: Provide supported formats of a device HowTo: Record a new ticket on Bitbucket
HowTo: Provide details of a video file that doesn't play
<<

Xmantium

User avatar

DLNA master

Posts: 1418

Joined: Sat Jul 23, 2011 2:12 pm

Location: Manchester, UK

Post Sun Dec 01, 2013 9:34 pm

Re: ServiiGo (Android 3G/4G/Wifi Playback App)

Hi Will, ive not noticed much difference with load.

BTW, i thought i'll test the Internal Player, im always using BSPlayer as its popup is handy for browsing/txting at the same time while watching a video.
I cant seem to make any online videos work with Profile Standard(mpeg2), Original - Running on Galaxy S4 Android 4.3
Where BSPlayer works fine.
Sony Bravia 2010 52NX803 - Sony PS3 - Xbox 360
Serviio running on QNAP NAS 639 Pro - 1.6 Intel Dual Core - 2GB RAM and QNAP NAS 121 - 2Ghz ARM Marvell - 1GB RAM
Console using ServiiDroid for Android, ServiiMetro and ServiiWP for Windows Phone and WebUI for iOS
<<

will

DLNA master

Posts: 2129

Joined: Mon Aug 30, 2010 11:18 am

Location: UK

Post Sun Dec 01, 2013 9:50 pm

Re: ServiiGo (Android 3G/4G/Wifi Playback App)

The internal player needs the Enhanced profile on most devices, you must have changed the video player option from auto for it to try (and fail).

As for the cache, I wouldn't expect it to help when at home, but it should help when on low quality 3G with high pings.
Will
Beta Tester Group
ServiiDroid (Android Console) Developer: Download | Home | Support
ServiiGo (Android 3G/4G/WiFi Playback App) Developer: More info

Player: Sony BDP S370 | Server: Debian 6.0 x86
HowTo: Provide supported formats of a device HowTo: Record a new ticket on Bitbucket
HowTo: Provide details of a video file that doesn't play
<<

Xmantium

User avatar

DLNA master

Posts: 1418

Joined: Sat Jul 23, 2011 2:12 pm

Location: Manchester, UK

Post Sun Dec 01, 2013 10:58 pm

Re: ServiiGo (Android 3G/4G/Wifi Playback App)

I can't run enhanced on my low powered ARM QNAP that's running Serviio 24/7. My Intel QNAP reserved for the weekend.
Is there going to be more progress on the internal player to support the standard profile for low powered server users? It has come along way from what it was originally.
Sony Bravia 2010 52NX803 - Sony PS3 - Xbox 360
Serviio running on QNAP NAS 639 Pro - 1.6 Intel Dual Core - 2GB RAM and QNAP NAS 121 - 2Ghz ARM Marvell - 1GB RAM
Console using ServiiDroid for Android, ServiiMetro and ServiiWP for Windows Phone and WebUI for iOS
<<

will

DLNA master

Posts: 2129

Joined: Mon Aug 30, 2010 11:18 am

Location: UK

Post Mon Dec 02, 2013 8:10 am

Re: ServiiGo (Android 3G/4G/Wifi Playback App)

No, very few Android devices support mpeg2 which the standard profile uses, whereas most now support h264. The only way to support the standard profile would be to build my own video player around ffmpeg, which I do not have the time to get into.
Will
Beta Tester Group
ServiiDroid (Android Console) Developer: Download | Home | Support
ServiiGo (Android 3G/4G/WiFi Playback App) Developer: More info

Player: Sony BDP S370 | Server: Debian 6.0 x86
HowTo: Provide supported formats of a device HowTo: Record a new ticket on Bitbucket
HowTo: Provide details of a video file that doesn't play
<<

tonovcp

Serviio newbie

Posts: 9

Joined: Sun Dec 15, 2013 11:05 pm

Post Tue Dec 17, 2013 3:50 pm

Re: ServiiGo (Android 3G/4G/Wifi Playback App)

Hi,
I am having problems serving with the enhanced h264 (the other mode works perfect)
My settings are qx9650 quad core 3.6 + 8 gb RAM
- OS: Ubuntu server -- My S4 or Note 8 no receive nothing, but looking at htop the 4 cores are working and it seems it is trying to encode, there are some lines showing ffmepg .. libx264.....
- OS: Windows 8.1 (another partition) -- streaming without problem at 80-90% first minutes and then relax a little bit (but working), and very easy - installed windows, serviio and running in minutes.
So I think it must be something related with x264 or ffmpeg configuration in ubuntu, because same hardware with windows 8.1 is working...
I tryed this two guides for ubuntu:
https://trac.ffmpeg.org/wiki/UbuntuCompilationGuide and http://wiki.serviio.org/doku.php?id=build_ffmpeg_linux
and x264 seems to be installed and ffmpeg tries to use it but doesn't output anything.
Any help would be apreciated
Thank you
<<

will

DLNA master

Posts: 2129

Joined: Mon Aug 30, 2010 11:18 am

Location: UK

Post Tue Dec 17, 2013 5:49 pm

Re: ServiiGo (Android 3G/4G/Wifi Playback App)

Can you turn on detailed logging and then try to run the ffmpeg command manually (making sure to call the correct ffmpeg if you have multiple versions installed). Can you also check that files are being created in the tmp directory.
Will
Beta Tester Group
ServiiDroid (Android Console) Developer: Download | Home | Support
ServiiGo (Android 3G/4G/WiFi Playback App) Developer: More info

Player: Sony BDP S370 | Server: Debian 6.0 x86
HowTo: Provide supported formats of a device HowTo: Record a new ticket on Bitbucket
HowTo: Provide details of a video file that doesn't play
<<

tonovcp

Serviio newbie

Posts: 9

Joined: Sun Dec 15, 2013 11:05 pm

Post Tue Dec 17, 2013 11:39 pm

Re: ServiiGo (Android 3G/4G/Wifi Playback App)

Captura2.PNG
Captura2.PNG (91.01 KiB) Viewed 4594 times
will wrote:Can you turn on detailed logging and then try to run the ffmpeg command manually (making sure to call the correct ffmpeg if you have multiple versions installed). Can you also check that files are being created in the tmp directory.

Ok, I turned log on (but I only see logs aboud scanned files or folders).
I don't know how to manually run the ffmpeg...
In my tmp folder are created segment00001.ts segment00002.ts ... and so on, and also a playlistfile m3u...
Here attached picture of htop: https://www.dropbox.com/s/fpjshx40c966pft/Captura.PNG
It seems it is using as I see the ffmpeg I installed, I added JAVA_OPTS -Dffmpeg.location=/home/username/ffmpeg/ffmpeg to /bin/serviio.sh so it is pointed ok.
Thanks for quick replay


Edit: I looked how to exec ffmpeg and runned for an 9gb 1920x1080p/ac3 mkv movie to -aac/mp4
with preset veryfast - 45-50 fps -- ffmpeg -i 1.mkv -c:v libx264 -preset veryfast -c:a libfaac out.mp4 (picture attached, I manually stopped when fps were stable)
with preset medium 20-30 fps

EDIT2: changed output size to 846x480 - medium and it gets 100 fps !!! Is it possible it has something to do with the .ts segments???
ffmpeg -i 1.mkv -c:v libx264 -preset veryfast -s 846x480 -c:a libfaac out.mp4

EDIT 3: Very weird, with x264 enhanced mode, original format doesn't work either - player gives me error. With the other mode there's no problem..
I hope you can help, the thing I am missing is time search... and cannot do it without the x264 mode..
<<

will

DLNA master

Posts: 2129

Joined: Mon Aug 30, 2010 11:18 am

Location: UK

Post Wed Dec 18, 2013 5:07 pm

Re: ServiiGo (Android 3G/4G/Wifi Playback App)

Both the standard and enhanced profiles do not do any transcoding when playing back using Original quality (for local content, online content is usually re-packaged) so it should just work, which video player are you using for them, have you changed the Video player options as in most cases you will not be able to play back an original quality video in the internal player?

As a seperate test, itt might be worth setting the video player to force external and then testing playback under Medium quality.

By run the ffmpeg command manually, I meant check the logs to see exactly which command ffmpeg was running, and then copy that into a terminal (putting quotes around file paths as needed) and then run that. From the output in the tmp folder it does suggest it is working, but its worth double checking sometimes. Note that the enhanced profile actually uses HTTP Live Steaming (HLS) which splits the video into chunks and controls it using a manifest, so its not quite the same and making an mp4.

Could you post the log of you connecting to the server and starting playback, that will help check for any problems. If the log is fully of library related stuff, you can add the following to your log4j.xml file.

  Code:
<!-- use INFO for library stuff  -->
<category name="org.serviio.library">
      <priority value="INFO"/>
</category>
Will
Beta Tester Group
ServiiDroid (Android Console) Developer: Download | Home | Support
ServiiGo (Android 3G/4G/WiFi Playback App) Developer: More info

Player: Sony BDP S370 | Server: Debian 6.0 x86
HowTo: Provide supported formats of a device HowTo: Record a new ticket on Bitbucket
HowTo: Provide details of a video file that doesn't play
<<

will

DLNA master

Posts: 2129

Joined: Mon Aug 30, 2010 11:18 am

Location: UK

Post Wed Dec 18, 2013 6:09 pm

Re: ServiiGo (Android 3G/4G/Wifi Playback App)

I've uploaded 3.2 to Google Play, for now its just availalble to the beta testers, I'm planning to make it available to all on Friday assuming there aren't any bug reports.

The full changes are

  Code:
==== 3.2 ====
*Added support for Serviio 1.4
*Improved performance by caching responses (#69, #76)
*Improved Music Player
**Reduced delay between tracks
**Added drag and drop re-arranging of the playlist
**Updated Phone UI to match Tablet verion
*Added an option to sort Images by Date or Title (#64)
*Removed view options that don't work properly under Serviio 1.2
**Browse Artists/Album Artists as grids of artwork
**Browse Series as grids of posters
*Jump to a specific position in the Music and Video players (#72)
*Clicking on a movie poster, episode thumbnail, or album artwork displays it full screen
*Improved audio cache cleaning on devices that do not update the last modified time of files
*Various minor bug fixes
*Built against Android 4.4 KitKat
*Updated libraries (#74)


It also includes the following changes since beta 3
  Code:
*Response cache is only updated when a library change occurs (#76) - requires Serviio 1.4 final
*Added support for Video->Ratings browsing category (Serviio 1.4 Beta 2)
*Fixed prefeching of the next track when playing back an already prepared track
*Improved audio cache cleaning on devices that do not update the last modified time of files
*Fixed album grid view for albums with no thumbnails
*Fixed old data being shown when logging out and back in again after viewing search results
*Updated translations
Will
Beta Tester Group
ServiiDroid (Android Console) Developer: Download | Home | Support
ServiiGo (Android 3G/4G/WiFi Playback App) Developer: More info

Player: Sony BDP S370 | Server: Debian 6.0 x86
HowTo: Provide supported formats of a device HowTo: Record a new ticket on Bitbucket
HowTo: Provide details of a video file that doesn't play
<<

tonovcp

Serviio newbie

Posts: 9

Joined: Sun Dec 15, 2013 11:05 pm

Post Thu Dec 19, 2013 4:25 pm

Re: ServiiGo (Android 3G/4G/Wifi Playback App)

will wrote:Both the standard and enhanced profiles do not do any transcoding when playing back using Original quality (for local content, online content is usually re-packaged) so it should just work, which video player are you using for them, have you changed the Video player options as in most cases you will not be able to play back an original quality video in the internal player?

As a seperate test, itt might be worth setting the video player to force external and then testing playback under Medium quality.

By run the ffmpeg command manually, I meant check the logs to see exactly which command ffmpeg was running, and then copy that into a terminal (putting quotes around file paths as needed) and then run that. From the output in the tmp folder it does suggest it is working, but its worth double checking sometimes. Note that the enhanced profile actually uses HTTP Live Steaming (HLS) which splits the video into chunks and controls it using a manifest, so its not quite the same and making an mp4.

Could you post the log of you connecting to the server and starting playback, that will help check for any problems. If the log is fully of library related stuff, you can add the following to your log4j.xml file.

  Code:
<!-- use INFO for library stuff  -->
<category name="org.serviio.library">
      <priority value="INFO"/>
</category>


First of all, original is working, I don't know what happend then, but it is working. I found the log thanks to that code, here is ffmpeg code (28-35fps):

ffmpeg -threads auto -i /home/tono/Peliculas/Dibujos/Aladdin.mkv -y -threads auto -c:v libx264 -profile:v baseline -level 3 -preset veryfast -crf 10 -vf scale=424:240 -r 25 -g 15 -bsf:v h264_mp4toannexb -flags -global_header -c:a aac -strict experimental -b:a 192k -ac 2 -map 0:0 -map 0:1 -sn -f segment -segment_time 10 -segment_format mpegts -segment_list_flags cache -segment_list /home/tono/serviio-1.3.1/tmp/Serviio/transcoding-temp-18384-serviigo_hls-LOW.stf/playlist.m3u8 /home/tono/serviio-1.3.1/tmp/Serviio/transcoding-temp-18384-serviigo_hls-LOW.stf/segment%05d.ts

And an error found in the code (I uploaded part of the log also)

2013-12-19 15:56:39,801 WARN [ServiioStatusService] AuthenticationException occured. Returning error code 401 to the REST layer. Message: No authentication token has been provided for a restricted resource.
2013-12-19 15:56:39,801 DEBUG [ServiioStatusService] Detailed exception:
org.serviio.restlet.AuthenticationException: No authentication token has been provided for a restricted resource.
at org.serviio.upnp.service.contentdirectory.rest.resources.server.LoginServerResource.validateToken(LoginServerResource.java:63)
at org.serviio.upnp.service.contentdirectory.rest.resources.server.AbstractRestrictedCDSServerResource.doConditionalHandle(AbstractRestrictedCDSServerResource.java:44)
at org.restlet.resource.ServerResource.handle(ServerResource.java:846)
at org.restlet.resource.Finder.handle(Finder.java:510)
at org.restlet.routing.Filter.doHandle(Filter.java:156)
at org.restlet.routing.Filter.handle(Filter.java:203)
at org.restlet.routing.Router.doHandle(Router.java:497)
at org.restlet.routing.Router.handle(Router.java:737)
at org.restlet.routing.Filter.doHandle(Filter.java:156)
at org.restlet.routing.Filter.handle(Filter.java:203)
at org.restlet.routing.Filter.doHandle(Filter.java:156)
at org.restlet.routing.Filter.handle(Filter.java:203)
at org.restlet.routing.Filter.doHandle(Filter.java:156)
at org.restlet.engine.application.StatusFilter.doHandle(StatusFilter.java:151)
at org.restlet.routing.Filter.handle(Filter.java:203)
at org.restlet.routing.Filter.doHandle(Filter.java:156)
at org.restlet.routing.Filter.handle(Filter.java:203)
at org.restlet.engine.ChainHelper.handle(ChainHelper.java:111)
at org.restlet.engine.application.ApplicationHelper.handle(ApplicationHelper.java:72)
at org.restlet.Application.handle(Application.java:391)
at org.restlet.routing.Filter.doHandle(Filter.java:156)
at org.restlet.routing.Filter.handle(Filter.java:203)
at org.restlet.routing.Router.doHandle(Router.java:497)
at org.restlet.routing.Router.handle(Router.java:737)
at org.restlet.routing.Filter.doHandle(Filter.java:156)
at org.restlet.routing.Filter.handle(Filter.java:203)
at org.restlet.routing.Router.doHandle(Router.java:497)
at org.restlet.routing.Router.handle(Router.java:737)
at org.restlet.routing.Filter.doHandle(Filter.java:156)
at org.restlet.engine.application.StatusFilter.doHandle(StatusFilter.java:151)
at org.restlet.routing.Filter.handle(Filter.java:203)
at org.restlet.routing.Filter.doHandle(Filter.java:156)
at org.restlet.routing.Filter.handle(Filter.java:203)
at org.restlet.engine.ChainHelper.handle(ChainHelper.java:111)
at org.restlet.Component.handle(Component.java:388)
at org.restlet.Server.handle(Server.java:488)
at org.restlet.engine.http.connector.BaseServerHelper.handle(BaseServerHelper.java:158)
at org.restlet.engine.http.connector.BaseServerHelper.handleInbound(BaseServerHelper.java:167)
at org.restlet.engine.http.connector.BaseHelper.handleNextInbound(BaseHelper.java:418)
at org.restlet.engine.http.connector.Connection.readMessages(Connection.java:696)
at org.restlet.engine.http.connector.Controller$2.run(Controller.java:95)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1146)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
at java.lang.Thread.run(Thread.java:701)
Last edited by tonovcp on Sun Dec 22, 2013 8:35 am, edited 1 time in total.
<<

DannyDMR

Serviio newbie

Posts: 5

Joined: Fri Dec 20, 2013 2:11 am

Post Fri Dec 20, 2013 2:16 am

Re: ServiiGo (Android 3G/4G/Wifi Playback App)

Hiya to all, new coming here :D

I've been using Serviio for a couple of weeks now running just a Movie Server for the Family.

I have been looking for a good DLNA player for ages and other than Archos i dont like anything.

I found ServiiGo last night and it is exactly what i wanted, mainly for the info/description you get with all the movies :D

The only problem i am having is the group access. I have Serviio setup up under 4 folder. Cert PG - Cert 12 - Cert 15 - Cert 18, I have Limited access on Cert PG & Cert 12 for my 3 youngest boys and using Archos it work great but group access doesnt work in ServiiGo so I am unable to use it on the kids Tablets.

Is there anything that can be done? it such a shame, i finally found one that is perfect and it turns out it doesnt support the access groups :(
<<

will

DLNA master

Posts: 2129

Joined: Mon Aug 30, 2010 11:18 am

Location: UK

Post Fri Dec 20, 2013 9:28 am

Re: ServiiGo (Android 3G/4G/Wifi Playback App)

tonovcp wrote:
will wrote:Both the standard and enhanced profiles do not do any transcoding when playing back using Original quality (for local content, online content is usually re-packaged) so it should just work, which video player are you using for them, have you changed the Video player options as in most cases you will not be able to play back an original quality video in the internal player?

As a seperate test, itt might be worth setting the video player to force external and then testing playback under Medium quality.

By run the ffmpeg command manually, I meant check the logs to see exactly which command ffmpeg was running, and then copy that into a terminal (putting quotes around file paths as needed) and then run that. From the output in the tmp folder it does suggest it is working, but its worth double checking sometimes. Note that the enhanced profile actually uses HTTP Live Steaming (HLS) which splits the video into chunks and controls it using a manifest, so its not quite the same and making an mp4.

Could you post the log of you connecting to the server and starting playback, that will help check for any problems. If the log is fully of library related stuff, you can add the following to your log4j.xml file.

  Code:
<!-- use INFO for library stuff  -->
<category name="org.serviio.library">
      <priority value="INFO"/>
</category>


First of all, original is working, I don't know what happend then, but it is working. I found the log thanks to that code, here is ffmpeg code (28-35fps):

ffmpeg -threads auto -i /home/tono/Peliculas/Dibujos/Aladdin.mkv -y -threads auto -c:v libx264 -profile:v baseline -level 3 -preset veryfast -crf 10 -vf scale=424:240 -r 25 -g 15 -bsf:v h264_mp4toannexb -flags -global_header -c:a aac -strict experimental -b:a 192k -ac 2 -map 0:0 -map 0:1 -sn -f segment -segment_time 10 -segment_format mpegts -segment_list_flags cache -segment_list /home/tono/serviio-1.3.1/tmp/Serviio/transcoding-temp-18384-serviigo_hls-LOW.stf/playlist.m3u8 /home/tono/serviio-1.3.1/tmp/Serviio/transcoding-temp-18384-serviigo_hls-LOW.stf/segment%05d.ts

And an error found in the code (I uploaded part of the log also)

2013-12-19 15:56:39,801 WARN [ServiioStatusService] AuthenticationException occured. Returning error code 401 to the REST layer. Message: No authentication token has been provided for a restricted resource.
2013-12-19 15:56:39,801 DEBUG [ServiioStatusService] Detailed exception:
org.serviio.restlet.AuthenticationException: No authentication token has been provided for a restricted resource.
at org.serviio.upnp.service.contentdirectory.rest.resources.server.LoginServerResource.validateToken(LoginServerResource.java:63)
at org.serviio.upnp.service.contentdirectory.rest.resources.server.AbstractRestrictedCDSServerResource.doConditionalHandle(AbstractRestrictedCDSServerResource.java:44)
at org.restlet.resource.ServerResource.handle(ServerResource.java:846)
at org.restlet.resource.Finder.handle(Finder.java:510)
at org.restlet.routing.Filter.doHandle(Filter.java:156)
at org.restlet.routing.Filter.handle(Filter.java:203)
at org.restlet.routing.Router.doHandle(Router.java:497)
at org.restlet.routing.Router.handle(Router.java:737)
at org.restlet.routing.Filter.doHandle(Filter.java:156)
at org.restlet.routing.Filter.handle(Filter.java:203)
at org.restlet.routing.Filter.doHandle(Filter.java:156)
at org.restlet.routing.Filter.handle(Filter.java:203)
at org.restlet.routing.Filter.doHandle(Filter.java:156)
at org.restlet.engine.application.StatusFilter.doHandle(StatusFilter.java:151)
at org.restlet.routing.Filter.handle(Filter.java:203)
at org.restlet.routing.Filter.doHandle(Filter.java:156)
at org.restlet.routing.Filter.handle(Filter.java:203)
at org.restlet.engine.ChainHelper.handle(ChainHelper.java:111)
at org.restlet.engine.application.ApplicationHelper.handle(ApplicationHelper.java:72)
at org.restlet.Application.handle(Application.java:391)
at org.restlet.routing.Filter.doHandle(Filter.java:156)
at org.restlet.routing.Filter.handle(Filter.java:203)
at org.restlet.routing.Router.doHandle(Router.java:497)
at org.restlet.routing.Router.handle(Router.java:737)
at org.restlet.routing.Filter.doHandle(Filter.java:156)
at org.restlet.routing.Filter.handle(Filter.java:203)
at org.restlet.routing.Router.doHandle(Router.java:497)
at org.restlet.routing.Router.handle(Router.java:737)
at org.restlet.routing.Filter.doHandle(Filter.java:156)
at org.restlet.engine.application.StatusFilter.doHandle(StatusFilter.java:151)
at org.restlet.routing.Filter.handle(Filter.java:203)
at org.restlet.routing.Filter.doHandle(Filter.java:156)
at org.restlet.routing.Filter.handle(Filter.java:203)
at org.restlet.engine.ChainHelper.handle(ChainHelper.java:111)
at org.restlet.Component.handle(Component.java:388)
at org.restlet.Server.handle(Server.java:488)
at org.restlet.engine.http.connector.BaseServerHelper.handle(BaseServerHelper.java:158)
at org.restlet.engine.http.connector.BaseServerHelper.handleInbound(BaseServerHelper.java:167)
at org.restlet.engine.http.connector.BaseHelper.handleNextInbound(BaseHelper.java:418)
at org.restlet.engine.http.connector.Connection.readMessages(Connection.java:696)
at org.restlet.engine.http.connector.Controller$2.run(Controller.java:95)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1146)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
at java.lang.Thread.run(Thread.java:701)


I'm visiting family at the moment, but should be able to have a look at the log tonight. Can you try Menu - Settings - Video Settings - Force External, then play the video back in MX Player and go Menu - Tools - Properties and check the url has an authToken param on it.
Will
Beta Tester Group
ServiiDroid (Android Console) Developer: Download | Home | Support
ServiiGo (Android 3G/4G/WiFi Playback App) Developer: More info

Player: Sony BDP S370 | Server: Debian 6.0 x86
HowTo: Provide supported formats of a device HowTo: Record a new ticket on Bitbucket
HowTo: Provide details of a video file that doesn't play
<<

will

DLNA master

Posts: 2129

Joined: Mon Aug 30, 2010 11:18 am

Location: UK

Post Fri Dec 20, 2013 9:36 am

Re: ServiiGo (Android 3G/4G/Wifi Playback App)

DannyDMR wrote:Hiya to all, new coming here :D

I've been using Serviio for a couple of weeks now running just a Movie Server for the Family.

I have been looking for a good DLNA player for ages and other than Archos i dont like anything.

I found ServiiGo last night and it is exactly what i wanted, mainly for the info/description you get with all the movies :D

The only problem i am having is the group access. I have Serviio setup up under 4 folder. Cert PG - Cert 12 - Cert 15 - Cert 18, I have Limited access on Cert PG & Cert 12 for my 3 youngest boys and using Archos it work great but group access doesnt work in ServiiGo so I am unable to use it on the kids Tablets.

Is there anything that can be done? it such a shame, i finally found one that is perfect and it turns out it doesnt support the access groups :(


What tablets do they have, and what Android version. One option could be to make use of restricted profiles option for newer tablets that support multiple accounts, otherwise I would need something to stop the kids changing their access rights. However, all of this world required a change to Serviio to let ServiiGo specify the access group when browsing.

Do they just watch Movies?

Serviio 1.4 will bring MPAA ratings browse category that might help.
Will
Beta Tester Group
ServiiDroid (Android Console) Developer: Download | Home | Support
ServiiGo (Android 3G/4G/WiFi Playback App) Developer: More info

Player: Sony BDP S370 | Server: Debian 6.0 x86
HowTo: Provide supported formats of a device HowTo: Record a new ticket on Bitbucket
HowTo: Provide details of a video file that doesn't play
<<

DannyDMR

Serviio newbie

Posts: 5

Joined: Fri Dec 20, 2013 2:11 am

Post Fri Dec 20, 2013 9:41 am

Re: ServiiGo (Android 3G/4G/Wifi Playback App)

Hiya Will thanks for replying, we have 1 Sony Xperia Tablet Z (Mine) and the kids all have Samsung Tab 3's plus theres 3 PS3's streaming also. I have static ip's on all devices.

The kids only use it for streaming Movies.

As I said in Archos it is working great they can only see the Pg and Cert 12 folders but I can see all 4 folders, 1 of the PS3's can see all folders but the other can only see the PG's and 12's folder.
<<

will

DLNA master

Posts: 2129

Joined: Mon Aug 30, 2010 11:18 am

Location: UK

Post Fri Dec 20, 2013 9:44 am

Re: ServiiGo (Android 3G/4G/Wifi Playback App)

Which versions of Android?
Will
Beta Tester Group
ServiiDroid (Android Console) Developer: Download | Home | Support
ServiiGo (Android 3G/4G/WiFi Playback App) Developer: More info

Player: Sony BDP S370 | Server: Debian 6.0 x86
HowTo: Provide supported formats of a device HowTo: Record a new ticket on Bitbucket
HowTo: Provide details of a video file that doesn't play
<<

DannyDMR

Serviio newbie

Posts: 5

Joined: Fri Dec 20, 2013 2:11 am

Post Fri Dec 20, 2013 9:47 am

Re: ServiiGo (Android 3G/4G/Wifi Playback App)

I cant check the Tab 3's as they are wrapped up for xmas but they are fully updated, my Sony is running 4.2.2
<<

tonovcp

Serviio newbie

Posts: 9

Joined: Sun Dec 15, 2013 11:05 pm

Post Sat Dec 21, 2013 4:43 am

Re: ServiiGo (Android 3G/4G/Wifi Playback App)

Can you try Menu - Settings - Video Settings - Force External, then play the video back in MX Player and go Menu - Tools - Properties and check the url has an authToken param on it.


Ok, MX Player is not giving me nothing, but could get a screenshot of VLC that gives an URL for a couple seconds.
http://to.. .:23424/cds/resources/18384/MEDIA_ITEM/HLS-O/
<<

will

DLNA master

Posts: 2129

Joined: Mon Aug 30, 2010 11:18 am

Location: UK

Post Sat Dec 21, 2013 8:06 am

Re: ServiiGo (Android 3G/4G/Wifi Playback App)

There are supposed to be some parameters at the end of that url, however, VLC might be hiding them.

Just to double check, which version of ServiiGo are you using, and what version of the server. I still haven't had access to a laptop yet but should do tonight so will be able to check the logs and make some suggestions.
Will
Beta Tester Group
ServiiDroid (Android Console) Developer: Download | Home | Support
ServiiGo (Android 3G/4G/WiFi Playback App) Developer: More info

Player: Sony BDP S370 | Server: Debian 6.0 x86
HowTo: Provide supported formats of a device HowTo: Record a new ticket on Bitbucket
HowTo: Provide details of a video file that doesn't play
<<

tonovcp

Serviio newbie

Posts: 9

Joined: Sun Dec 15, 2013 11:05 pm

Post Sat Dec 21, 2013 3:02 pm

Re: ServiiGo (Android 3G/4G/Wifi Playback App)

will wrote:There are supposed to be some parameters at the end of that url, however, VLC might be hiding them.

Just to double check, which version of ServiiGo are you using, and what version of the server. I still haven't had access to a laptop yet but should do tonight so will be able to check the logs and make some suggestions.


Latest, just installed. I found in VLC this.
2013-12-21 15.58.32.png
2013-12-21 15.58.32.png (395.73 KiB) Viewed 4510 times
PreviousNext

Return to Third-party tools integration

Who is online

Users browsing this forum: No registered users and 11 guests

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.