Page 28 of 29

Re: YouTube

PostPosted: Wed Nov 20, 2019 9:09 pm
by Jimbo
Well, youtube is now working. I hope they are finished with their testing.

Re: YouTube

PostPosted: Sat Nov 23, 2019 12:47 am
by Jimbo
Gone again after one day. I give up on them. They're pushing their new streaming service and I suspect that has something to do with the problems.

Re: YouTube

PostPosted: Tue Jan 21, 2020 12:26 pm
by Paul C
Is youtube.groovy plugin currently working under v2 ?

Not sure what I am doing wrong.

Presumably the online source are defined as web resources/video ?

Can someone post a couple of working links for me please.

Re: YouTube

PostPosted: Sat Jan 25, 2020 8:06 pm
by Jimbo
The youtube plugin was working with V2 until youtube made their most recent changes. They added more adverts and a premium streaming service which is a paid service. Serviio has been the only server that I used for years. I haven't used any others. I will check the forum on others to see if they are broke as well.

Re: YouTube

PostPosted: Sun Feb 09, 2020 4:38 pm
by zip
I've uploaded a new version of the plugin.

It doesn't work with all videos (some use encrypted signature which I haven't got to code around yet), but hopefully works for most videos.

Re: YouTube

PostPosted: Mon Feb 10, 2020 8:37 pm
by Jimbo
Thank you Zip! It works with all that I tested so far.

My primary source of on line entertainment is back. I actually use this more than Amazon and Directv.

Re: YouTube

PostPosted: Tue Feb 18, 2020 2:54 pm
by dyuka
Thank you, Petr!
I watch Youtube content only via TV and only in your plugin for Serviio :D Other methods are inconvenient for me.

Re: YouTube

PostPosted: Thu Feb 20, 2020 12:49 am
by Jimbo
Sorry to say that I had an update to windows 10 last week and youtube via servio hasn't worked since. I still works under windows 7.

Re: YouTube

PostPosted: Mon Feb 24, 2020 8:48 pm
by DVD Listing
Thanks ZIP for the plugin update!

Re: YouTube

PostPosted: Tue Mar 10, 2020 8:05 pm
by DVD Listing
Zip,

For me, the plugin is not working again.

Re: YouTube

PostPosted: Tue Mar 10, 2020 10:14 pm
by Jimbo
I don't expect to get a fix for this any time soon. I would personally give youtube some time to make all of their changes/updates to get the platform stable before wasting much time on it.

Re: YouTube

PostPosted: Sat Mar 14, 2020 6:14 am
by triks
Just to clarify, is there currently a way to warch a YouTube video via Serviio? I have spent 2+ hours reading this and other forums but there are no clear instructions on how to set this up in 2020. @zip please provide a download link to the youtube plugin as its impossible to find on this forum.

Re: YouTube

PostPosted: Sun Mar 15, 2020 1:19 am
by Jimbo
Instructions and the latest plugin are in the first post in this thread. The plugin is near the end of the post.

Re: YouTube

PostPosted: Sun Mar 22, 2020 9:02 pm
by DVD Listing
Good Day All.

I hope all are safe from Covid-19.

The last Youtube changes are allowing the latest Serviio Youtube plugin to work again.

:P

Re: YouTube

PostPosted: Wed Mar 25, 2020 6:03 pm
by Jimbo
In answer to a private message that I received. I am posting here for everyone to see. The plugin still isn't fully functional. I run the server on windows 10 and windows 7 systems. The thumbnail for one or two playlists might show up but the contents of the playlists are missing.

Re: YouTube

PostPosted: Sun Mar 29, 2020 1:01 am
by Jimbo
Youtube is working again under windows 7 but not under windows 10. I had this situation once before.

Re: YouTube

PostPosted: Tue Apr 07, 2020 8:31 am
by ErRoR-70
When adding a playlist it only shows the first clip?

https://www.googleapis.com/youtube/v3/p ... 699743BD19

Re: YouTube

PostPosted: Fri Apr 10, 2020 8:40 am
by RaNd
DVD Listing wrote:Zip,

For me, the plugin is not working again.


Same here,

2020-04-08 22:14:18,172 WARN [FeedUpdaterWorker] An error occured while parsing the online resource https://www.googleapis.com/youtube/v3/p ... CG2QkzYr45, waiting for expiry time to try again: Unexpected error while invoking plugin (YouTube): Text must not be null or empty
org.serviio.library.online.metadata.OnlineResourceParseException: Unexpected error while invoking plugin (YouTube): Text must not be null or empty

It was working last week..

Version 2.0, on Debian, with the latest YouTube plugin ( from the first page).

Re: YouTube

PostPosted: Fri Apr 10, 2020 4:31 pm
by Jimbo
Youtube has actually been having problems since the middle of last year. They are making numerous changes to monitize their services. They now have a pay/streaming service and are now inserting adverts at the beginning of and in the middle of videos. I strongly suspect that they are not done with their changes. The plugin might be changed to handle the current conditions only to have youtube break it again.

Re: YouTube

PostPosted: Sun Apr 12, 2020 1:07 am
by mame32
I had the same error on logs:

[FeedUpdaterWorker] An error occured while parsing the online resource 'https://...', will try again soon: Unexpected error while invoking plugin (YouTube): Text must not be null or empty
...

To solve I have added my own APIKEY from my Google Developer Account.
The problem is that the current APIKEY included into the file "Youtube.goovy"

  Code:
final api_key = "AIzaSyCbFQoC....SqGVE243q0"


reaches the limit of 10000 calls per day, because all of us are been using this APIKEY.

Solution:

1. I have had to learn how to create my own APIKEY on Google and activate it.

https://www.slickremix.com/docs/get-api-key-for-youtube/

2. Then I have edited the Youtube.groovy file replacing api_key with mine.

This works form me! :D

Now the Serviio.log file only shows this warning:
[WebResourceParser] Plugin YouTube returned no value for resource item 'null'
on every online resource, but it captures the online source.

Thanks!