FAQ  •  Register  •  Login

Version 1.10 embedded audio option?

<<

kittmaster

Serviio lover

Posts: 55

Joined: Mon Aug 21, 2017 4:34 am

Post Fri Dec 14, 2018 2:46 am

Version 1.10 embedded audio option?

Taking a look at this version for the new "embedded" audio file capture/embedded meta extraction.

First question, where is the option in the console to "enable" that specific feature? All the menus seem the same as 1.9.2.......am I missing something? I see the album art being pulled, album data is there but all the rest of the meta data present in the file is not shown.......should it?

Other thing, on the mp3 tags, my file names are LOOOOONG for reasons not important, be it, the filename itself is not the same as the title of the MP3, yet media browser in the title field is using the file name and not the MP3 title tag.

I "think" this may be a bug??

Anyone else seeing this?
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 17018

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Mon Dec 17, 2018 10:55 pm

Re: Version 1.10 embedded audio option?

the metadata will be used automatically. but to get them you'll need to reindex the affected files. Try to move an audio file to a new folder, is it coming with the metadata?
<<

kittmaster

Serviio lover

Posts: 55

Joined: Mon Aug 21, 2017 4:34 am

Post Mon Dec 17, 2018 11:37 pm

Re: Version 1.10 embedded audio option?

I do see "my" metadata coming across as it is in all CAPS. I wasn't sure because only "some" of the meta data is coming across. I would "assume" that all fields would show up like "album artist" and other fields that are present in the file.

Some people may never have them, but as I'm a DJ and meticulous with my data, I would expect to see all my fields or at least be able to "choose" which fields should be shown???

The BIGGEST issue is that "title" is showing the FILENAME of the file and not the actual title of the audio track, and that is super annoying as my filenames look like this:

{1} - MIXED MEDLEY BY CHRIS--NS7 MIX MEDLEY--BPM(91-117)--BITRATE(320)--YEAR(2011)--12INCH(NO).mp3

Where the title should just be: MIXED MEDLEY BY CHRIS

I can provide some screenshots if needed.

thanks for reviewing this.

Chris
<<

kittmaster

Serviio lover

Posts: 55

Joined: Mon Aug 21, 2017 4:34 am

Post Sat Dec 22, 2018 3:32 am

Re: Version 1.10 embedded audio option?

Any thoughts?...bug or feature?
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 17018

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Thu Jan 03, 2019 7:58 pm

Re: Version 1.10 embedded audio option?

can you provide result of ffmpeg -i <file.mp3>

also, in the Folders category it always shows the file name. You should see the metadata title in the other categories (like Album, Artist, etc)
<<

kittmaster

Serviio lover

Posts: 55

Joined: Mon Aug 21, 2017 4:34 am

Post Fri Jan 04, 2019 1:37 am

Re: Version 1.10 embedded audio option?

Here is a singular example. My 200k+ files are all coded the same way.

  Code:
D:\A11>ffmpeg -i "{5} - CE CE PENISTON--FINALLY--BPM(120)--BITRATE(320)--YEAR(2014)--12INCH(NO).mp3"
ffmpeg version 3.4.4 Copyright (c) 2000-2018 the FFmpeg developers
  built with gcc 8.2.1 (GCC) 20180829
  configuration: --enable-static --disable-shared --disable-ffplay --disable-ffserver --enable-libmp3lame --enable-libass --enable-librtmp --enable-fontconfig --enable-libfreetype --enable-zlib --enable-libx264 --enable-libspeex --extra-libs='-lrtmp -lpolarssl -lws2_32 -lwinmm -lexpat -lfreetype -lfribidi -lz' --arch=x86_32 --enable-runtime-cpudetect --target-os=mingw32 --cross-prefix=i686-w64-mingw32- --enable-gpl --pkg-config=pkg-config --bindir='/jenkins/workspace/FFmpeg - Win32/target'
  libavutil      55. 78.100 / 55. 78.100
  libavcodec     57.107.100 / 57.107.100
  libavformat    57. 83.100 / 57. 83.100
  libavdevice    57. 10.100 / 57. 10.100
  libavfilter     6.107.100 /  6.107.100
  libswscale      4.  8.100 /  4.  8.100
  libswresample   2.  9.100 /  2.  9.100
  libpostproc    54.  7.100 / 54.  7.100
Input #0, mp3, from '{5} - CE CE PENISTON--FINALLY--BPM(120)--BITRATE(320)--YEAR(2014)--12INCH(NO).mp3':
  Metadata:
    album           : 90S ESSENTIALS 17
    artist          : CE CE PENISTON
    album_artist    : CE CE PENISTON
    TBPM            : 120
    comment         : ABP MASTER FILE
    TIT1            : 7
    genre           : Pop
    TKEY            : 10A
    title           : FINALLY
    track           : 5
    KEY             : 10A
    EnergyLevel     : 7
    date            : 2014
  Duration: 00:05:06.21, start: 0.025056, bitrate: 332 kb/s
    Stream #0:0: Audio: mp3, 44100 Hz, stereo, s16p, 320 kb/s
    Metadata:
      encoder         : LAME3.99r
    Side data:
      replaygain: track gain - -4.400000, track peak - unknown, album gain - unknown, album peak - unknown,
    Stream #0:1: Video: mjpeg, yuvj444p(pc, bt470bg/unknown/unknown), 700x700 [SAR 35:35 DAR 1:1], 90k tbr, 90k tbn, 90k tbc
    Metadata:
      comment         : Cover (back)
    Stream #0:2: Video: mjpeg, yuvj444p(pc, bt470bg/unknown/unknown), 700x700 [SAR 35:35 DAR 1:1], 90k tbr, 90k tbn, 90k tbc
    Metadata:
      comment         : Cover (front)
At least one output file must be specified

D:\A11>
<<

gsayer

Serviio newbie

Posts: 4

Joined: Sun Jan 26, 2014 4:42 pm

Post Fri Jan 04, 2019 11:36 am

Re: Version 1.10 embedded audio option?

Looks like 1.10 DLNA functionality is now broken.
<<

kittmaster

Serviio lover

Posts: 55

Joined: Mon Aug 21, 2017 4:34 am

Post Tue Jan 08, 2019 6:35 pm

Re: Version 1.10 embedded audio option?

Is this correct? Do you need any more info?

Thanks,
Chris
<<

kittmaster

Serviio lover

Posts: 55

Joined: Mon Aug 21, 2017 4:34 am

Post Sun Feb 24, 2019 1:40 am

Re: Version 1.10 embedded audio option?

Any further updates on what can be done to fix this?
<<

Paul C

DLNA master

Posts: 166

Joined: Wed Feb 17, 2016 3:46 pm

Location: Essex, UK

Post Fri Mar 08, 2019 12:54 pm

Re: Version 1.10 embedded audio option?

Have you fixed this issue?

I have not encountered any similar issues after migrating to 1.10 then 1.10.1 when they were announced.
I have looked at some of my files including some .mp3 files (most of mine are .flac), using both my BubbleUPnP control app and under Serviio MediaBrowser, and they are displaying the Title correctly not a (different) Filename.

A couple of things to try are:
1. Duplicate a folder and set-up a test by modifying to use short folder names, short filenames, short titles e.g Folder1/File1 and Title1.
These might eliminate filenames with long names or characters that may be causing a problem.

Remember (as I understand it) Serviio is now using a different indexing system using the metadata.

2. Also try putting these files in a short path e.g. C:/Media1/ and adding this to your library in the console.
This would eliminate the issue of a very long path length which can also cause problems.

3. Remove your folders in the console (i.e. no media data), reboot your machine, and then reintroduce the media folders in the console.
This may take a while if you have a large library - so be patient.

4. Remove Serviio, reboot and reinstall Serviio. This may be simple if you you do not have a lot of configuration.

5. Do you have other formats other than .mp3 (e.g. .flac or .wav) and do these exhibit the same issue? My understanding is that Id tags/metadata is stored/held differently on .flac files to that on .mp3, and that .wav is different again. Could this be part of the problem?
Serviio 1.10.1 (Pro), DBpoweramp & Asset UPnP (registered), Acer Aspire One netbook, HP Elitebook, Windows 10 Pro, Denon DNP-730AE, NEET AirstreamPro renderer, Naim NAC72/NAP140 (x2), Celestion Ditton 25 and Spendor A5 speakers, WD TV Media Player (x2), Panasonic Blu-ray DMP-BDT360, Panasonic TV, Amazon Fire 7 HDX, BubbleUPnP app, Mezzmo Android App, Qobuz Studio Hi-Res streaming.

Return to General discussion

Who is online

Users browsing this forum: No registered users and 5 guests

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.