FAQ  •  Register  •  Login

Running with Seviio with VLC Media Player

<<

dcbailey

Serviio newbie

Posts: 2

Joined: Fri Jul 17, 2015 5:48 pm

Post Fri Jul 17, 2015 6:13 pm

Running with Seviio with VLC Media Player

To whom it may concern:

I am attempting serve video to a Video LAN Media Player plug-in using Firefox 39.0

The page is on a Tomcat Server running listening port 8080

When I attempt running the page set in the following manner I get the following error

2015-07-17 12:00:21,100 WARN [ServiioStatusService] ServerUnavailableException occured. Returning error code 503 to the REST layer. Message: Server is not available

  Code:
<html>

<head>
<meta http-equiv="Content-Type" content="text/html; charset=windows-1252">
<title>New Page 1</title>
</head>

<body>

<embed type="application/x-vlc-plugin"
pluginspage="http://www.videolan.org"version="VideoLAN.VLCPlugin.2"  width="1280"       
height="720" id="vlc" loop="yes"autoplay="yes" allowfullscreen="true" target="http://70.113.50.10:23424/resource/cls/90/MEDIA_ITEM/AVC_MP4_MP_HD_720p_AAC-0/ORIGINAL"></embed>

</body>
</html>



If run the page using 8895 it works

  Code:
<html>

<head>
<meta http-equiv="Content-Type" content="text/html; charset=windows-1252">
<title>New Page 1</title>
</head>

<body>

<embed type="application/x-vlc-plugin"
pluginspage="http://www.videolan.org"version="VideoLAN.VLCPlugin.2"  width="1280"       
height="720" id="vlc" loop="yes"autoplay="yes" allowfullscreen="true" target="http://70.113.50.10:8895/resource/89/MEDIA_ITEM/AVC_MP4_MP_HD_720p_AAC-0/ORIGINAL/"></embed>

</body>

</html>


I had similar results from the command line.

Interestingly enough looking at what is printed out by VLC I get the following error messages:

[00007fc8f0000e68] http access error: error: HTTP/1.1 404 Not Found
[00007fc8f0000e68] http access error: error: HTTP/1.1 404 Not Found
[00007fc8f0000e68] access_mms access error: error: HTTP/1.1 404 Not Found
[00007fc8f80009b8] core input error: open of `http://70.113.50.10:23424/cls/resource/90/MEDIA_ITEM/AVC_MP4_MP_HD_720p_AAC-0/ORIGINAL' failed

It looks like there is a timing issue going on some place.

The question that I have has anyone seen this problem before? If this a problem with Video LAN, could some one suggest another plug-in I could use? I will displaying the web pages on a standard monitor.

Thanks for your help

Dave
<<

dcbailey

Serviio newbie

Posts: 2

Joined: Fri Jul 17, 2015 5:48 pm

Post Fri Jul 17, 2015 8:46 pm

Re: Running with Seviio with VLC Media Player

There seems to be a delay issue with VLC LAN Media Player the following is a workaround
  Code:
<html>

<head>
<meta http-equiv="Content-Type" content="text/html; charset=windows-1252">
<title>Play Video</title>
<script>

function Skip()
{
   alert ('Click to Play');
   vlc.playlist.pause();
   vlc.input.time = 12000;
}

function Replay()
{
   vlc.playlist.pause();
   vlc.input.time = 12000;
}

</script>
</head>
<body onload="Skip()">


<embed type="application/x-vlc-plugin"
pluginspage="http://www.videolan.org"version="VideoLAN.VLCPlugin.2"  width="1280"       
height="720" id="vlc" loop="no"autoplay="yes" allowfullscreen="true" target="http://70.113.50.10:8895/resource/71/MEDIA_ITEM/AVC_MP4_MP_HD_1080i_AAC-0/ORIGINAL"></embed>

<br>
<button type="button" onclick="Replay()">Replay</button>
<script>

       
</script>

</body>

<<

zip

User avatar

Serviio developer / Site Admin

Posts: 17039

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Mon Jul 20, 2015 12:53 pm

Re: Running with Seviio with VLC Media Player

try to enable detailed logging

Return to General discussion

Who is online

Users browsing this forum: No registered users and 5 guests

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.