Page 1 of 1

Console non-responsive

PostPosted: Sun May 07, 2017 11:39 pm
by asharp

Serviio installed, netstat -an shows listeners on 23423 and 23424, however using browser - there is never a response from either. Have tried http://<server_ip>:23423/console and http://<server_ip:23424/mediabrowser. Trying a telnet to port 23423 and issuing the "GET /console HTTP/1.1", host: ... reveals that the server never responds.

OpenJDK 8.121.13
Serviio 1.8_2
FreeBSD 11.0p9


(Hoping someone has either run into this or know of a way to enable debugging to help reveal the source of the issue)

Re: Console non-responsive

PostPosted: Mon May 08, 2017 12:58 am
by atc98092
Not sure if a debug log would show anything in reference to that, but the instructions to enable are in my sig line.

Have you tried accessing the browser from the computer using localhost instead of IP address, or is this a headless, non-GUI Linux box? My Linux expertise is old and fuzzy in my brain, but to compare with a Windows box it sounds like a firewall issue. Is Chains still the default Linux firewall?

Re: Console non-responsive

PostPosted: Mon May 08, 2017 2:34 am
by asharp
Thanks for the quick reply.

No firewall involved. Using makes no difference. There's a connect (TCP session established), however the internal/embedded Serviio web server doesn't send any data. The server is FreeBSD (not LInux - although still the UNIX family ;) ...)

Here's a quick capture:

# telnet 23423
Connected to localhost.
Escape character is '^]'.
GET /console HTTP/1.1

HTTP/1.1 307 Temporary Redirect
Content-Length: 0
Date: Mon, 08 May 2017 02:10:48 GMT
Server: Restlet-Framework/2.2
Vary: Accept-Charset, Accept-Encoding, Accept-Language, Accept

HTTP/1.1 404 Not Found
Content-Length: 439
Content-Type: text/html; charset=UTF-8
Date: Mon, 08 May 2017 02:10:50 GMT
Server: Restlet-Framework/2.2
Connection: close

<title>Status page</title>
<body style="font-family: sans-serif;">
<p style="font-size: 1.2em;font-weight: bold;margin: 1em 0px;">Not Found</p>
<p>The server has not found anything matching the request URI</p>
<p>You can get technical details <a href="">here</a>.<br>
Please continue your visit at our <a href="/">home page</a>.
Connection closed by foreign host.

What's particularly odd is that it "sits" either waiting or trying to do something. Then provide a couple carriage returns and the "404 Not Found" message is finally returned. I've checked permissions and I can find nothing that would suggest a permissions problem.

Between original posting and now, ran a "truss" on the process. Happened to notice this from the process during the attempt:
stat("/usr/local/etc/serviio/META-INF/services/javax.xml.parsers.DocumentBuilderFactory",0x7fffdbf925d8) ERR#2 'No such file or directory' <--- oddly enough there's no such structure. Wondering if this is old cruft in Serviio or Windows "needs" or ???

However, more germane to the issue:
kevent(73,{ 125,EVFILT_READ,EV_DELETE,0x0,0x0,0x0 125,EVFILT_WRITE,EV_DELETE,0x0,0x0,0x0 },2,{ 125,EVFILT_WRITE,EV_ERROR,0x0,0x2,0x0 },2,{ 0.000000000 }) = 1 (0x1)
read(125,"GET /console HTTP/1.1\r\n",2048) = 23 (0x17)
gettimeofday({ 1494209698.067407 },0x0) = 0 (0x0)
read(125,0x815ae1000,2048) ERR#35 'Resource temporarily unavailable'
read(125,0x815ae1000,2048) ERR#35 'Resource temporarily unavailable'
read(125,0x815ae1000,2048) ERR#35 'Resource temporarily unavailable'

- Unfortunately, there's nothing that expresses what is "temporarily unavailable".

Also noticed a ton of: _umtx_op(0x8006270f8,UMTX_OP_WAIT_UINT_PRIVATE,0x0,0x18,0x7fffdf5f3d98) ERR#60 'Operation timed out' <-- curious what is timing out. Some time ago there was an issue with Java and thread shutdown on FreeBSD v9.x with JDK 7, but this is FreeBSD 11.x with JDK 8. (Related article: ... -7-freebsd)

Re: Console non-responsive

PostPosted: Mon May 08, 2017 8:28 am
by zip
weird. Can you curl on the URL?

how about

curl http://localhost:23423/rest/application

Re: Console non-responsive

PostPosted: Tue May 09, 2017 3:53 pm
by asharp
I was able to access the URL.

Performed updates (applications/packages) and afterwards it started working. Suspect that something between one of the prior version(s) of a package/library and the latest may have been the culprit. Seemed particularly strange that there were was nothing to coming back when attempting to connect to the console. Generally prefer to try to track down issues before posting, however can't seem to enable/obtain enough debug type of output to determine what/where an issue is. For example: the error message(s) around ffmpeg are difficult. eg: if I knew what the tests were and/or which format(s) were missing - it would make it far easier to "self correct". Absolutely love that once Serviio is running that it's a "zero sum game" - all pleasure and no effort, simply works and runs. Only frustration is when Serviio isn't happy - trying to determine the actual source of the issue as the output often seems vague or cryptic.