FAQ  •  Register  •  Login

New D Series Samsung

<<

jhb50

DLNA master

Posts: 2856

Joined: Thu Jun 30, 2011 9:32 pm

Post Thu Oct 20, 2011 9:57 pm

Re: New D Series Samsung

Try adding this to the 7.- Samsung C/D profile after </Transcoding>
  Code:
<OnlineTranscoding>
    <Video targetContainer="mpegts" targetACodec="ac3" aBitrate="384">
        <Matches container="mp4"/>
    </Video>
    <Audio targetContainer="mp3">
        <Matches container="flv"/>
    </Audio>
</OnlineTranscoding>


this will override the B profile rule which is screwing up the medium file transcoding.
<<

luigui

Serviio newbie

Posts: 13

Joined: Tue Sep 27, 2011 7:42 pm

Post Fri Oct 21, 2011 1:55 pm

Re: New D Series Samsung

jhb50 wrote:Try adding this to the 7.- Samsung C/D profile after </Transcoding>
  Code:
<OnlineTranscoding>
    <Video targetContainer="mpegts" targetACodec="ac3" aBitrate="384">
        <Matches container="mp4"/>
    </Video>
    <Audio targetContainer="mp3">
        <Matches container="flv"/>
    </Audio>
</OnlineTranscoding>


this will override the B profile rule which is screwing up the medium file transcoding.


Yes, I already had that code in my profiles.xml file, and didn't work.
<<

jhb50

DLNA master

Posts: 2856

Joined: Thu Jun 30, 2011 9:32 pm

Post Fri Oct 21, 2011 11:27 pm

Re: New D Series Samsung

OK. Step by Step.

1. Click on link
2. Menu should open showing all the you tube clips
3. Click on Clip
4. Clip should play.

I take it you get to #4 and it says Invalid File format.

Things to do.

1. Stop Serviio,
2. Delete C:\Program Files (x86)\Serviio\log\serviio.log
3. Start serviio and do the above 4 steps.
4. Stop Serviio and post the log as an attached file to your response.

5. OpenC:\Windows\Temp\Serviio\
6. You should see something like "transcoding-temp-4674-MPEG2TS.stf as the latest file.
7. Copy this file to somewhere and rename it to .mpg
8. Play it to ensure it is the YouTube clip.
9. Run ffmpeg -i and Mediainfo against it and post the results in your reply.

This should give us the info needed to identify your problem.
<<

luigui

Serviio newbie

Posts: 13

Joined: Tue Sep 27, 2011 7:42 pm

Post Sat Oct 22, 2011 10:00 am

Re: New D Series Samsung

I attach the serviio.log and profiles.xml files, and I think that the problem is this ("Video xxx does not match any supported DLNA profile"):

  Code:
2011-10-22 11:45:46,331 ERROR [ResourceTransportRequestHandler] Error while processing resource, sending back 500 error. Message: Video http://o-o.preferred.tiws-par1.v17.lscache2.c.youtube.com/videoplayback?sparams=id%2Cexpire%2Cip%2Cipbits%2Citag%2Csource%2Calgorithm%2Cburst%2Cfactor%2Ccp&fexp=907518%2C914055%2C916700%2C912603%2C910206&algorithm=throttle-factor&itag=34&ip=79.0.0.0&burst=40&sver=3&signature=135FB10108107576BCF69FB978CD5E1B8FC007DE.73EF40B1FE080B6A1F2989543457237BF7BC4097&source=youtube&expire=1319299200&key=yt1&ipbits=8&factor=1.25&cp=U0hQTlJUV19FSkNOMF9KTkFDOk9KSHdxX1llVTdB&id=8f9fb22a10ddeb8b [b]does not match any supported DLNA profile[/b]
org.serviio.dlna.UnsupportedDLNAMediaFileFormatException: Video http://o-o.preferred.tiws-par1.v17.lscache2.c.youtube.com/videoplayback?sparams=id%2Cexpire%2Cip%2Cipbits%2Citag%2Csource%2Calgorithm%2Cburst%2Cfactor%2Ccp&fexp=907518%2C914055%2C916700%2C912603%2C910206&algorithm=throttle-factor&itag=34&ip=79.0.0.0&burst=40&sver=3&signature=135FB10108107576BCF69FB978CD5E1B8FC007DE.73EF40B1FE080B6A1F2989543457237BF7BC4097&source=youtube&expire=1319299200&key=yt1&ipbits=8&factor=1.25&cp=U0hQTlJUV19FSkNOMF9KTkFDOk9KSHdxX1llVTdB&id=8f9fb22a10ddeb8b does not match any supported DLNA profile
   at org.serviio.dlna.MediaFormatProfileResolver.resolveVideoFormat(MediaFormatProfileResolver.java:106)
   at org.serviio.dlna.MediaFormatProfileResolver.resolve(MediaFormatProfileResolver.java:48)
   at org.serviio.delivery.resource.VideoDeliveryEngine.retrieveOriginalMediaInfo(VideoDeliveryEngine.java:71)
   at org.serviio.delivery.resource.VideoDeliveryEngine.retrieveOriginalMediaInfo(VideoDeliveryEngine.java:37)
   at org.serviio.delivery.resource.AbstractDeliveryEngine.getMediaInfoForMediaItem(AbstractDeliveryEngine.java:109)
   at org.serviio.delivery.MediaResourceRetrievalStrategy.retrieveResourceInfo(MediaResourceRetrievalStrategy.java:152)
   at org.serviio.upnp.webserver.ResourceTransportRequestHandler.handleRequest(ResourceTransportRequestHandler.java:122)
   at org.serviio.upnp.webserver.AbstractRequestHandler.handle(AbstractRequestHandler.java:54)
   at org.apache.http.protocol.HttpService.doService(HttpService.java:293)
   at org.serviio.upnp.webserver.ServiioHttpService.doService(ServiioHttpService.java:58)
   at org.apache.http.protocol.HttpService.handleRequest(HttpService.java:212)
   at org.serviio.upnp.webserver.WebServer$WorkerThread.run(WebServer.java:187)


Finally, the serviio temp path is empty. Is this normal?

Thanks for your support!!
Attachments
Screenshot.png
Just to show my profiles selection in Serviio console
Screenshot.png (63.41 KiB) Viewed 3353 times
profiles.xml
To check my profiles.xml with OnlineTranscoding modification
(55.18 KiB) Downloaded 310 times
serviio.log
Serviio.log when playing youtube online feeds (INFO level)
(16.16 KiB) Downloaded 161 times
<<

jhb50

DLNA master

Posts: 2856

Joined: Thu Jun 30, 2011 9:32 pm

Post Sat Oct 22, 2011 12:59 pm

Re: New D Series Samsung

It looks like you never even got to the menu of videos .. #2 above.

Also, was http://gdata.youtube.com/feeds/api/standardfeeds/top_rated
the only feed you had setup or are there others? If so what were they?

The url that failed http://o-o.preferred.tiws-par1.v17.lscache2.c.youtube.com/videoplayback?sparams=id%2Cexpire%2Cip%2Cipbits%2Citag%2Csource%2Calgorithm%2Cburst%2Cfactor%2Ccp&fexp=907518%2C914055%2C916700%2C912603%2C910206&algorithm=throttle-factor&itag=34&ip=79.0.0.0&burst=40&sver=3&signature=135FB10108107576BCF69FB978CD5E1B8FC007DE.73EF40B1FE080B6A1F2989543457237BF7BC4097&source=youtube&expire=1319299200&key=yt1&ipbits=8&factor=1.25&cp=U0hQTlJUV19FSkNOMF9KTkFDOk9KSHdxX1llVTdB&id=8f9fb22a10ddeb8b is not part of any of the youtube videos in the top-rated feed so you must have asked for something else. I've never seen "tiws" in a yt link before.


  Code:
2011-10-22 11:44:34,187 INFO  [PluginCompilerThread] Added plugin YouTubeUrlExctractor (Youtube.groovy)
2011-10-22 11:44:41,254 INFO  [Messages] Loaded console message bundle for locale: en
2011-10-22 11:44:41,364 INFO  [UpdateChecker] Checking if a new version is available
2011-10-22 11:44:48,181 INFO  [ContentDirectoryDefinitionParser] Parsing ContentDirectory definition
2011-10-22 11:44:48,555 INFO  [BrowsingCategoriesMessages] Loaded browsing categories message bundle for locale: es
2011-10-22 11:45:00,117 INFO  [FeedUpdaterThread] Started looking for information about online feeds
2011-10-22 11:45:46,331 ERROR [ResourceTransportRequestHandler] Error while processing resource, sending back 500 error. Message: Video http://o-o.preferred.tiws-par1.v17.lscache2.c.youtube.com/videoplayback?sparams=id%2Cexpire%2Cip%2Cipbits%2Citag%2Csource%2Calgorithm%2Cburst%2Cfactor%2Ccp&fexp=907518%2C914055%2C916700%2C912603%2C910206&algorithm=throttle-factor&itag=34&ip=79.0.0.0&burst=40&sver=3&signature=135FB10108107576BCF69FB978CD5E1B8FC007DE.73EF40B1FE080B6A1F2989543457237BF7BC4097&source=youtube&expire=1319299200&key=yt1&ipbits=8&factor=1.25&cp=U0hQTlJUV19FSkNOMF9KTkFDOk9KSHdxX1llVTdB&id=8f9fb22a10ddeb8b does not match any supported DLNA profile
org.serviio.dlna.UnsupportedDLNAMediaFileFormatException: Video http://o-o.preferred.tiws-par1.v17.lscache2.c.youtube.com/videoplayback?sparams=id%2Cexpire%2Cip%2Cipbits%2Citag%2Csource%2Calgorithm%2Cburst%2Cfactor%2Ccp&fexp=907518%2C914055%2C916700%2C912603%2C910206&algorithm=throttle-factor&itag=34&ip=79.0.0.0&burst=40&sver=3&signature=135FB10108107576BCF69FB978CD5E1B8FC007DE.73EF40B1FE080B6A1F2989543457237BF7BC4097&source=youtube&expire=1319299200&key=yt1&ipbits=8&factor=1.25&cp=U0hQTlJUV19FSkNOMF9KTkFDOk9KSHdxX1llVTdB&id=8f9fb22a10ddeb8b does not match any supported DLNA profile
   at org.serviio.dlna.MediaFormatProfileResolver.resolveVideoFormat(MediaFormatProfileResolver.java:106)
<<

luigui

Serviio newbie

Posts: 13

Joined: Tue Sep 27, 2011 7:42 pm

Post Sat Oct 22, 2011 5:28 pm

Re: New D Series Samsung

Yes, I did all the steps, and I only have the youtube top rated feeds to test (on other feeds and no other local files in library). I think that the "tiws" server of youtube it's not the problem, because I have used an sniffer while watching a youtube video in my computer, and that is the internal host used to get the video.

I did the test again, with full debug option in the log, and I watch another important thing... the videos are in the format "AVC_TS_MP_SD_AC3_ISO" ¿?

I copy the line and the full log:

  Code:
2011-10-22 19:20:32,261 DEBUG [VideoDeliveryEngine] Retrieving resource information for item 1000000000050002, format AVC_TS_MP_SD_AC3_ISO and profile Samsung TV / player (C/D-series)



Any ideas?
Attachments
serviio.log
Serviio debug log file
(203.33 KiB) Downloaded 161 times
<<

jhb50

DLNA master

Posts: 2856

Joined: Thu Jun 30, 2011 9:32 pm

Post Sat Oct 22, 2011 7:27 pm

Re: New D Series Samsung

That is a better log and as far as I can see everythng is OK until the TV says it cannot handle that AVC_TS_MP_SD_AC3_ISO format.
That does not make sense since that is a standard format supported by Samsung D series TV's. I can't give you any more help than that. What exactly is your complete model number?
<<

luigui

Serviio newbie

Posts: 13

Joined: Tue Sep 27, 2011 7:42 pm

Post Sun Oct 23, 2011 7:26 am

Re: New D Series Samsung

jhb50 wrote:That is a better log and as far as I can see everythng is OK until the TV says it cannot handle that AVC_TS_MP_SD_AC3_ISO format.
That does not make sense since that is a standard format supported by Samsung D series TV's. I can't give you any more help than that. What exactly is your complete model number?


My complete model number is UE40D8000YSXXC. The weird thing is that the format AVC_TS_MP_SD_AC3_ISO seems to be supported by the TV when I use the UPnP tool. I attach the GetProtocolInfo result.
Attachments
GetProtocolInfo.txt
UPnP formats supported
(16.94 KiB) Downloaded 181 times
<<

jhb50

DLNA master

Posts: 2856

Joined: Thu Jun 30, 2011 9:32 pm

Post Sun Oct 23, 2011 1:47 pm

Re: New D Series Samsung

My model is PN64-D550 and my protocol info is identical to yours, so at least it looks like all the D series are the same.
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 17079

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Mon Oct 24, 2011 9:04 am

Re: New D Series Samsung

This problem is related to the fact the file includes codecs that together don't present a valid DLNA format, even after transcoding. If you can still reproduce it you have to get the URL (rtmp://...) from the log and try running

  Code:
ffmpeg -i "rtmp:/....... svfWfy=1"
<<

jhb50

DLNA master

Posts: 2856

Joined: Thu Jun 30, 2011 9:32 pm

Post Mon Oct 24, 2011 2:30 pm

Re: New D Series Samsung

Hi Zip..help me learn here..

1. how do you know it is an rtmp...swf url. I see nothing in his logs.

2, Secondly this is a standard Youtube link, which your groovy would have scraped. I've not seen any rtmp links for the standard formats. Maybe yt uses them in other regions. I cannot access his video link from here, but I've not seen yt use anything but valid sets of codecs in .flv or .mp4 containers.

3. Lastly, I think his log shows a previous success with that video
  Code:
2011-10-22 19:20:18,291 DEBUG [VideoDeliveryEngine] Retrieving resource information for item 1000000000050002 and profile Samsung TV / player (C/D-series)
2011-10-22 19:20:18,291 DEBUG [VideoDeliveryEngine] Found Format profile for transcoded file http://o-o.preferred.tiws-par1.v21.lscache1.c.youtube.com/videoplayback?sparams=id%2Cexpire%2Cip%2Cipbits%2Citag%2Csource%2Calgorithm%2Cburst%2Cfactor%2Ccp&fexp=903114%2C908525%2C913527%2C910206&algorithm=throttle-factor&itag=34&ip=79.0.0.0&burst=40&sver=3&signature=96AB7BE2C678A3AAADE93AF75699B1072A2DC69E.784ED385636BA09252B2F461B4631B902E65A98F&source=youtube&expire=1319328000&key=yt1&ipbits=8&factor=1.25&cp=U0hQTlNNVl9FSkNOMF9LR1pBOmNIWkRjUXdLZ1JR&id=290eb3afa9023e3f: AVC_TS_MP_SD_AC3_ISO


And then a failure. How can that be?
  Code:
2011-10-22 19:20:32,261 DEBUG [VideoDeliveryEngine] Retrieving resource information for item 1000000000050002, format AVC_TS_MP_SD_AC3_ISO and profile Samsung TV / player (C/D-series)
2011-10-22 19:20:32,263 ERROR [ResourceTransportRequestHandler] Error while processing resource, sending back 500 error. Message: Video http://o-o.preferred.tiws-par1.v21.lscache1.c.youtube.com


Thanks
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 17079

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Mon Oct 24, 2011 2:55 pm

Re: New D Series Samsung

1. how do you know it is an rtmp...swf url. I see nothing in his logs.

Sorry, my mistake, of course this is not rtmp.

3. Lastly, I think his log shows a previous success with that video
  Code:
2011-10-22 19:20:18,291 DEBUG [VideoDeliveryEngine] Retrieving resource information for item 1000000000050002 and profile Samsung TV / player (C/D-series)
2011-10-22 19:20:18,291 DEBUG [VideoDeliveryEngine] Found Format profile for transcoded file http://o-o.preferred.tiws-par1.v21.lscache1.c.youtube.com/videoplayback?sparams=id%2Cexpire%2Cip%2Cipbits%2Citag%2Csource%2Calgorithm%2Cburst%2Cfactor%2Ccp&fexp=903114%2C908525%2C913527%2C910206&algorithm=throttle-factor&itag=34&ip=79.0.0.0&burst=40&sver=3&signature=96AB7BE2C678A3AAADE93AF75699B1072A2DC69E.784ED385636BA09252B2F461B4631B902E65A98F&source=youtube&expire=1319328000&key=yt1&ipbits=8&factor=1.25&cp=U0hQTlNNVl9FSkNOMF9LR1pBOmNIWkRjUXdLZ1JR&id=290eb3afa9023e3f: AVC_TS_MP_SD_AC3_ISO


And then a failure. How can that be?
  Code:
2011-10-22 19:20:32,261 DEBUG [VideoDeliveryEngine] Retrieving resource information for item 1000000000050002, format AVC_TS_MP_SD_AC3_ISO and profile Samsung TV / player (C/D-series)
2011-10-22 19:20:32,263 ERROR [ResourceTransportRequestHandler] Error while processing resource, sending back 500 error. Message: Video http://o-o.preferred.tiws-par1.v21.lscache1.c.youtube.com


I think it's because the feed expired in between these 2 operations:

  Code:
2011-10-22 19:20:18,454 DEBUG [OnlineLibraryManager] Feed http://gdata.youtube.com/feeds/api/standardfeeds/top_rated expired, will reload it


therefore ID 1000000000050002 now represents a different file (URL).

It seems it expires very often though, maybe a bug in the plugin?
  Code:
2011-10-22 19:20:22,849 DEBUG [FeedItemUrlExtractor] YouTubeUrlExctractor: Finished extraction of url: ContentURLContainer [fileType=VIDEO, contentUrl=http://o-o.preferred.tiws-par1.v2.lscache4.c.youtube.com/videoplayback?sparams=id%2Cexpire%2Cip%2Cipbits%2Citag%2Csource%2Calgorithm%2Cburst%2Cfactor%2Ccp&fexp=904542%2C916700&algorithm=throttle-factor&itag=34&ip=79.0.0.0&burst=40&sver=3&signature=B932C7E488A4BBC19C0B773E3B07B9D0908D3FDA.486A1BBF11FA2D0255C17A228EC600C9109B629D&source=youtube&expire=1319328000&key=yt1&ipbits=8&factor=1.25&cp=U0hQTlNNVl9FSkNOMF9LR1pBOndfd2tfa2FUZmVB&id=b781ff66887b1b90, thumbnailUrl=http://i1.ytimg.com/vi/t4H_Zoh7G5A/default.jpg, expiresOn=Sat Oct 22 17:00:00 PDT 2011, expiresImmediately=false]


This runs at 2011-10-22 19:20:22,849 (what time zone?) and it expires at Sat Oct 22 17:00:00 PDT 2011. The latter date must be after the first date, I'm not sure if that's true (the MOD has to confirm which time zone he's in)
<<

jhb50

DLNA master

Posts: 2856

Joined: Thu Jun 30, 2011 9:32 pm

Post Tue Oct 25, 2011 12:03 am

Re: New D Series Samsung

luigui, are you still having problems?
Post another log if you are.
What quality and feed expiry interval is set in your console?
Please also post what timezone you are in.

zip: he started posting on the 20th, so perhaps this expiry problem is different from his original failure, or perhaps he has set a short expiry in the console. I've had no problems with the YT feeds
<<

luigui

Serviio newbie

Posts: 13

Joined: Tue Sep 27, 2011 7:42 pm

Post Tue Oct 25, 2011 7:54 pm

Re: New D Series Samsung

jhb50 wrote:luigui, are you still having problems?
Post another log if you are.
What quality and feed expiry interval is set in your console?
Please also post what timezone you are in.

zip: he started posting on the 20th, so perhaps this expiry problem is different from his original failure, or perhaps he has set a short expiry in the console. I've had no problems with the YT feeds


Now it's working!! Reading your tips about the dates and timezones, I realized that the time of my computer changed frecuently. Today I replaced the battery of the motherboard, and serviio it's working!! Not 100% of the youtube videos, some give me the invalid format error, but most of them play well.

Guys, thank you for your support!! I attach the serviio.log when all goes well.
Attachments
serviioOk.log
(170.39 KiB) Downloaded 166 times
<<

turnig56

Streaming enthusiast

Posts: 22

Joined: Sat Sep 24, 2011 2:17 am

Post Tue Dec 06, 2011 3:57 am

New D Series Samsung

Here is a file that does not work with D:
The.Smurfs.2011.1080p.MKV.x264.AC3.DTS.NL.Subs.EE.Rel.NL
<<

willsenaaa

Serviio newbie

Posts: 2

Joined: Wed Dec 28, 2011 5:44 pm

Post Thu Dec 29, 2011 11:31 pm

Re: New D Series Samsung

I have a new d series Samsung t.v and they did all the steps, and i only have the you tube top rates feed to test. that the server of you tube it's not the problem. because i have used an sniffer while watching a you tube video in my computer, and that is the internal host used t get the video.
Previous

Return to General discussion

Who is online

Users browsing this forum: Susannah, Vida0459 and 6 guests

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.