FAQ  •  Register  •  Login

Inauguration Post!

<<

wiiBox

Serviio newbie

Posts: 11

Joined: Fri Nov 20, 2009 3:56 am

Post Fri Nov 20, 2009 4:49 am

Inauguration Post!

I guess it's up to me to inaugurate this section of the forum. :D

Hello zip, et al!

I'd just like to say how impressed I am with serviio's current state (v0.1.1) and would like to make my WDTV Live and I available as beta testers.

What do you think, zip? :)

Cheers!
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 17014

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Fri Nov 20, 2009 11:00 am

Re: Inauguration Post!

hi,

definitely :-) If you can throw as many formats as possible on it and let us know how it goes it'd be great.
<<

gustavoas

Streaming enthusiast

Posts: 22

Joined: Sat Nov 07, 2009 4:32 pm

Post Fri Nov 20, 2009 2:32 pm

Re: Inauguration Post!

Me too, I'm very impressed. Besides my PS3 and a Samsung A850 TV I have also tested this with my DSM-520 (D-Link Media Client); it has worked well but although it supports subtitles this feature didn't work (although I already expected since it seems to be an unique implementation of serving a .srt file to the client through their media server).
Unfortunatelly I have a mac and the Intel uPnP tool does not work here, in case you know about mac tools to help providing info I would gladly support as a beta tester :-D
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 17014

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Fri Nov 20, 2009 4:19 pm

Re: Inauguration Post!

Thnks guys,

regarding the subtitles: you might find out something by using a packet sniffer (not sure what is available for OSX) and listen on the port of the server where subtitles work. Basically we're interested in packets sent when when you try to play a video (there should be some HEAD and GET http requests, one of them possibly asking if there are any subtitles for the requested video). If you can post here (or into the Experience forum - create a topic for your device) the log maybe I can figure out something.
<<

wiiBox

Serviio newbie

Posts: 11

Joined: Fri Nov 20, 2009 3:56 am

Post Sat Nov 21, 2009 5:17 am

Re: Inauguration Post!

Yes, thanks for the warm reception, zip!

I'm in the process of testing features out, reading all of the forum, etc. I'm also having the missing subs issue, but looking to verify if my players supports it to begin with, or if it's asking for it. Is it the player that's supposed to ask for it?

Also, I notice that when you add new folders to Serviio the whole media library seems to be updated. Probably something you are very much aware of, already.

But, hopefully sooner rather than later, I'll have a somewhat reliable report on interoperability between Serviio and WDTV Live.

TTFN! :)
Testing on WDTV Live FW v1.01.11
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 17014

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Sat Nov 21, 2009 1:51 pm

Re: Inauguration Post!

wiiBox wrote:Also, I notice that when you add new folders to Serviio the whole media library seems to be updated. Probably something you are very much aware of, already.


What do you mean by that? If you add a new folder it should only scan this folder. Do you see different behaviour?
<<

wiiBox

Serviio newbie

Posts: 11

Joined: Fri Nov 20, 2009 3:56 am

Post Sun Nov 22, 2009 10:47 am

Re: Inauguration Post!

Sorry I haven't answered this until now, but I wanted to double check everything.

I think the problem was the intel AV Media Controller. When I use that program to list serviio's content, it lists them almost at random and needs a bit of time to fully list everything... I think I've figured out now that, it's normal for the intel program to behave like that. It was only a coincidence that I was adding new folders and thought serviio was redoing everything. On the WDTVL media player, everything that was there before seems to remain in place while the new media is added slowly.

I hope I haven't held up release of 0.2.0 or anything. :oops:

I have a question, though. How does serviio know which of the two databases to check for a given media? Is it the the episode tag? eg. S01E01? Is it that media without those tags get sent to the movie database and vice versa?

Also... bitbucket is where you keep track of the bugs and requested features, but it's not your development roadmap, is that correct? Is there a development roadmap somewhere on the site?

TIA
Testing on WDTV Live FW v1.01.11
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 17014

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Sun Nov 22, 2009 12:30 pm

Re: Inauguration Post!

wiiBox wrote:I have a question, though. How does serviio know which of the two databases to check for a given media? Is it the the episode tag? eg. S01E01? Is it that media without those tags get sent to the movie database and vice versa?

Yes.
Also... bitbucket is where you keep track of the bugs and requested features, but it's not your development roadmap, is that correct? Is there a development roadmap somewhere on the site?

No roadmap, just bits in my head ;-) I'll be looking for what you guys want in the product and see what can be implemented. Post in the Features forum if you have some cool idea.
<<

wiiBox

Serviio newbie

Posts: 11

Joined: Fri Nov 20, 2009 3:56 am

Post Mon Nov 23, 2009 10:51 am

Re: Inauguration Post!

No roadmap, just bits in my head ;-) I'll be looking for what you guys want in the product and see what can be implemented. Post in the Features forum if you have some cool idea.
:D
Okay, that's absolutely fine. I just didn't want to be redundant with my suggestions nor did I want to impose my design philosophy on you. I mean, I don't know where you would draw the line in terms of suggestions.

But, right now, with the release of v0.2.0, I think I'll start my contribution by creating a profile for my particular player! :)

Cheers!
Testing on WDTV Live FW v1.01.11
<<

fizze

Serviio lover

Posts: 88

Joined: Wed Dec 02, 2009 8:27 am

Location: Austria

Post Fri Dec 04, 2009 2:53 pm

Re: Inauguration Post!

Talking about contributions.... are you planning on releasing the source some day?
There sure are lots of peeps on the interwebs who could lend a hand. :roll: ;) :D
Intel SS4200 - Ubuntu Server 8.04
LG BD - 390

Return to General discussion

Who is online

Users browsing this forum: No registered users and 7 guests

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.