FAQ  •  Register  •  Login

Not working after Windows 11 upgrade

<<

steamroll420

Serviio newbie

Posts: 2

Joined: Sat Mar 26, 2022 5:41 am

Post Sat Mar 26, 2022 5:52 am

Not working after Windows 11 upgrade

Recently updated to Windows 11 and nothing is working. Service wont start, get a "Could not start service Error 1067". I can't even get the console to open(tried running as administrator, nothing happens). Uninstalled, re-installed, tried legacy version, same thing every time. Updated to latest java. Have been getting a Java error when uninstalling (could not start virtual machine I believe).
Would appreciate any advice. Thanks in advance!
<<

atc98092

User avatar

DLNA master

Posts: 4959

Joined: Fri Aug 17, 2012 10:22 pm

Location: Washington (the state)

Post Sun Mar 27, 2022 3:57 am

Re: Not working after Windows 11 upgrade

Would you please upload your Serviio log here? You can find it under C:/Program Files/Serviio/log. Just the Serviio.log file. The Derby file isn't needed.
Dan

LG NANO85 4K TV, Samsung JU7100 4K TV, Sony BDP-S3500, Sharp 4K Roku TV, Insignia Roku TV, Roku Ultra, Premiere and Stick, Nvidia Shield, Yamaha RX-V583 AVR.
Primary server: Intel i5-6400, 8 gig ram, Windows 10 Pro, 22 TB hard drive space | Test server Windows 10 Pro, AMD Phenom II X4 965, 8 gig ram

HOWTO: Enable debug logging HOWTO: Identify media file contents
<<

steamroll420

Serviio newbie

Posts: 2

Joined: Sat Mar 26, 2022 5:41 am

Post Sun Mar 27, 2022 10:54 pm

Re: Not working after Windows 11 upgrade

I went to the log file, and it was empty(nothing hidden). I was able to get rid of the Java error by editing the environmental variables. Still not luck. Tried uninstalling/RE and no luck. Here is the log when I uninstalled;

Sun Mar 27 16:46:51 EDT 2022:
Booting Derby version The Apache Software Foundation - Apache Derby - 10.14.2.0 - (1828579): instance a816c00e-017f-cd21-b0bc-00001ea85e32
on database directory C:\Program Files\Serviio\library\db with class loader jdk.internal.loader.ClassLoaders$AppClassLoader@73d16e93
Loaded from file:/C:/Program%20Files/Serviio/lib/derby.jar
java.vendor=Oracle Corporation
java.runtime.version=17.0.2+8-LTS-86
user.dir=C:\Program Files\Serviio\bin
os.name=Windows 11
os.arch=amd64
os.version=10.0
derby.system.home=C:\Program Files\Serviio\library
derby.stream.error.file=../log/derby.log
Database Class Loader started - derby.database.classpath=''

Still get can not start service on local computer/Error 1067: The process terminated unexpectedly.
After playing around a bit more, I found a few other programs with the same issue;

Plex-Never liked it, but had it on PC for a Backup. Tried un/re-installing, it won't run at all.
Oshare-UPNP server I used with my OPPO bluray player. Simple program that I have used for years with no issue. Program will run, but freeze up and not show up when searching for media players.
Universal Media Player-Works fine(prefer Serviio)

Anything in the event viewer I should look for?
Anyone heard of this issue when upgrading to Windows 11?

Odd situation. I might have to do a clean install. Not the worst, just time consuming.
Thanks in advance!
<<

atc98092

User avatar

DLNA master

Posts: 4959

Joined: Fri Aug 17, 2012 10:22 pm

Location: Washington (the state)

Post Mon Mar 28, 2022 12:02 am

Re: Not working after Windows 11 upgrade

On Windows, Serviio installs its own version of Java, so your Windows global environmental settings shouldn't do anything.

None of my computers are eligible for Windows 11, so I haven't been able to test the new OS. I'm going to have to try it in a VM and see what's going on.

It does sound like Microsoft did something during the upgrade that messed with Serviio. At this point, I'd suggest doing the clean install, but I'd remove Serviio completely first, just to make sure it's completely clean. I've heard of some people needing to do a clean install after a Windows update, so not unheard of. I've heard of the same thing on occasion after a Mac update, so Microsoft doesn't have a corner on the market for messing up applications with an upgrade.
Dan

LG NANO85 4K TV, Samsung JU7100 4K TV, Sony BDP-S3500, Sharp 4K Roku TV, Insignia Roku TV, Roku Ultra, Premiere and Stick, Nvidia Shield, Yamaha RX-V583 AVR.
Primary server: Intel i5-6400, 8 gig ram, Windows 10 Pro, 22 TB hard drive space | Test server Windows 10 Pro, AMD Phenom II X4 965, 8 gig ram

HOWTO: Enable debug logging HOWTO: Identify media file contents
<<

Michalr

Serviio newbie

Posts: 3

Joined: Mon Dec 23, 2013 11:35 am

Post Thu Dec 08, 2022 9:17 pm

Re: Not working after Windows 11 upgrade

Hello, I'm on Win11 and have different issue - latest version of Serviio installed but cannot stream anything to the TV - it always says that the file is in wrong format. The folders and files are visible on the TV, you can connect to the server from the TV itself, but you cannot play any file. On Win10 all files were perfectly working.
<<

dlzc

Streaming enthusiast

Posts: 27

Joined: Tue Nov 13, 2012 11:32 pm

Post Tue Dec 13, 2022 3:56 pm

Re: Not working after Windows 11 upgrade

New install of Win11 on new hardware, and Serviio worked for a week or so, then Windoze breaks it. When it breaks, the Serviio console will not ever fully display... window has title bar but page is blank.

Micro$haft REALLY wants you to use their media player, so they can help spy on you better. I guess.
EDIT:
(KB5020044) broke Serviio
(KB5020880) and / or (KB5021255) fixed Serviio.
... so full updates "eventually" fix whatever Micro$haft breaks.
<<

Michalr

Serviio newbie

Posts: 3

Joined: Mon Dec 23, 2013 11:35 am

Post Thu Dec 29, 2022 9:59 pm

Re: Not working after Windows 11 upgrade

Small update on this - it started to work again on the latest Insider Win 11 compilation.

Wysłane z mojego SM-G770F przy użyciu Tapatalka

Return to Serviio Support & Help

Who is online

Users browsing this forum: No registered users and 23 guests

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.