FAQ  •  Register  •  Login

Serviio not refreshing

<<

spamjam2011

Serviio newbie

Posts: 16

Joined: Thu Dec 27, 2012 6:04 pm

Post Mon Oct 08, 2018 4:04 am

Re: Serviio not refreshing

I've noticed this happening recently. I'm running 1.9 pro and after searching for this issue realized it was resolved with 1.92. I'll check that out. Hopefully it solves the problem.
Pro User since 2011
<<

spamjam2011

Serviio newbie

Posts: 16

Joined: Thu Dec 27, 2012 6:04 pm

Post Mon Oct 29, 2018 1:35 am

Re: Serviio not refreshing

spamjam2011 wrote:I've noticed this happening recently. I'm running 1.9 pro and after searching for this issue realized it was resolved with 1.92. I'll check that out. Hopefully it solves the problem.


Reporting back.. this is still happening. When I open the console, the first thing it does is show a notification regarding an image being added, so it could be something to do with sharing images. Maybe it's hanging up on images which causes the indexing to stall. Whatever the case, it needs to be manually refreshed. A bug for sure.
Pro User since 2011
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 16920

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Mon Oct 29, 2018 1:09 pm

Re: Serviio not refreshing

Try to increase memory of the server by adding / updatind -Xmx property http://serviio.org/index.php?option=com ... e&id=21#q3

to something like (you choose the memory value)

-Xmx 500M
<<

spamjam2011

Serviio newbie

Posts: 16

Joined: Thu Dec 27, 2012 6:04 pm

Post Mon Oct 29, 2018 3:20 pm

Re: Serviio not refreshing

zip wrote:Try to increase memory of the server by adding / updatind -Xmx property http://serviio.org/index.php?option=com ... e&id=21#q3

to something like (you choose the memory value)

-Xmx 500M


Thank you for the response. I've increased the memory to 1024. I tried 2048 but the service could not be started. I have plenty of RAM, so not sure what's causing that unless it's something to do with 32/64 bit. I'll report back after a few weeks of testing.
Pro User since 2011
<<

spamjam2011

Serviio newbie

Posts: 16

Joined: Thu Dec 27, 2012 6:04 pm

Post Wed Oct 31, 2018 1:44 am

Re: Serviio not refreshing

spamjam2011 wrote:
zip wrote:Try to increase memory of the server by adding / updatind -Xmx property http://serviio.org/index.php?option=com ... e&id=21#q3

to something like (you choose the memory value)

-Xmx 500M


Thank you for the response. I've increased the memory to 1024. I tried 2048 but the service could not be started. I have plenty of RAM, so not sure what's causing that unless it's something to do with 32/64 bit. I'll report back after a few weeks of testing.


After making the suggested changes, I added a few videos today and checked tonight on my TV and the server hadn't updated. When I open the app it takes a second to populate the number referencing the amount of videos/images, and then I start seeing notifications for content being added. After doing this, the new content shows when accessing via the TV via DLNA. Not sure what's getting triggered when the app opens, but the Windows service doesn't seem to be doing it on its own.
Pro User since 2011
<<

dymarq

Serviio newbie

Posts: 6

Joined: Wed Jan 30, 2019 3:41 am

Post Thu Feb 07, 2019 3:48 am

Re: Serviio not refreshing

Hello I seem to be having the same problem with version 1.10.1.

I re-installed the software and it seems to work for a while and then the service stops. It manages to index a good portion of the specified library but then the service won't remain started. Not sure what is happening. Clicking Library Refresh stops the service. The only way the service works is when this is unchecked.
Attachments
Main Page.jpg
Main Page.jpg (23.51 KiB) Viewed 69 times
Log End.jpg
Log End.jpg (102.65 KiB) Viewed 69 times
Log Start.jpg
Start of the Service
Log Start.jpg (90.32 KiB) Viewed 69 times
<<

dymarq

Serviio newbie

Posts: 6

Joined: Wed Jan 30, 2019 3:41 am

Post Thu Feb 07, 2019 11:28 pm

Re: Serviio not refreshing

I moved the files to a different location and the service seemed to start again but then it stopped. Any help would be appreciated.
Attachments
Service Stop.jpg
Service Stop.jpg (67.08 KiB) Viewed 61 times
Log End Feb 7th 2019.jpg
Log End Feb 7th 2019.jpg (95.01 KiB) Viewed 61 times
<<

DenyAll

DLNA master

Posts: 2224

Joined: Fri Mar 08, 2013 11:16 pm

Location: Adelaide, Australia

Post Sat Feb 09, 2019 3:12 am

Re: Serviio not refreshing

I have seen instances where one file will cause the indexer to fail.

Enable debug logging, force refresh and then, when it fails, examine the log. See if you can work out if it as always happening with one particular file or folder.

Remove the offending file/folder from the library for now. Try again (there may be more than one). Once you are able to successfully fully index your library we can look at any files that caused issues.
DenyAll
Panasonic Viera FX800A | Panasonic Viera CS610A | Sony PS4 | Sony PS3 | Panasonic DMP-BD79 | Yamaha RX-V500D | iPad | Windows 10 | Serviio 1.10.1 Pro
WinHelper | MediaInfo

Beta Tester, Moderator
Please do not PM me for support as any solution cannot be shared with others.
Previous

Return to Serviio Support & Help

Who is online

Users browsing this forum: Google [Bot] and 11 guests

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.