Page 1 of 1

Serviio with OpenVPN

PostPosted: Mon Mar 16, 2015 11:18 am
by NIckelino
Hello Guys,

first of all serviio is a great solution for media streaming. Yesterday i buyed the pro version.

My System:
I'm using a HP Microserver N54L with AMD Turion 2 Processor and 8 GB RAM.
Installed on the Server is VMWare ESXi 5.5.

For my data i installed a Debain Wheezy virtual Machine with 2GB RAM, wich is sharing data through NFS and Samba.

As Serviio Server i use another VM with 2GB RAM where i installed Ubuntu 14.01 Server amd64 on it.

The Serviio server mounts the NFS shares from the Debain NAS via /etc/fstab.

The files are not getting updated automatically on the NFS shares. I hope that will be fixed.

I configurated on my DD-WRT-router a OpenVPN server.

With this server i can connect to my LAN and it is possible to access the Serviio server through browser (Firefox) and the Android App (ServioGo). Both works great when I'm in my LAN at home.
But when I'm connected through OpenVPN the streams don't start and i don't know why. Is there already any solution? If not, I hope that will be fixed, too.

Before i buyed the Serviio Pro License I used a Limbomedia Server for streaming through OpenVPN. It worked.
But i had one VM more on my ESXi-server.
I really want to work Serviio through OpenVPN so i can delete the Limbomedia-VM.

Hope you can give me some more Informations for my two problems. OpenVPN compatibility and NFS compatibility.

Kind regards


Re: Serviio with OpenVPN

PostPosted: Mon Mar 16, 2015 12:40 pm
by atc98092
The file updating is a known issue, and being worked extensively. I expect Zip to have an update in the near future.

For you VPN connection: are you trying to use MediaBrowser through the VPN, or are you trying to use another form of player through the tunnel?

If you are using MediaBrowser, the VPN isn't really necessary, as you could just forward port 23424 in your router to the Serviio computer and access it directly over the Internet. If you still prefer using the VPN, there shouldn't be any issues connecting to MediaBrowser through the tunnel.

If you are trying to use another type of player, your VPN may not be passing the broadcast packets between the two networks. I am unsure of OpenVPN configuration methods, that is the most likely cause.

Re: Serviio with OpenVPN

PostPosted: Mon Mar 16, 2015 12:55 pm
by NIckelino
I can access the Mediabrwoser through VPN.

I use the TUN mode, where the VPN is sepreated from my LAN. Thats more save than the bridged mode.

UPNP ist not working thrpough two ethernet segments. That's why i want to use the mediabrowser. It is accessable with it's IP-Adress instead of UPNP.

I prefer using my VPN-Connection because i dont want to open more doors to my network.

As i said, i can reach the MediaBrowser via IP-Adress through VPN but if I start s stream, the error message is in the ServiiGO-App (Android) that the data is noch accessable and i have to refresh the library.
On my Windows PC the Browsers (Firefox and IE) say nothing. I click on the stream but it doesn't start. I think the cause is the same on ServiiGo, IE and firefox.

The only difference for my Serviio server between a LAN-Client and an OpenVPN-Client is the IP-Adress and ethernet segment. (LAN: VPN

With LimboMedia, it worked fine. So my Firewall configuration between LAN and VPN is fine.

I think here is the problem, but i don't know how serviio works in this case.

Re: Serviio with OpenVPN

PostPosted: Mon Mar 16, 2015 9:55 pm
by NIckelino
Hi again guys!

I have the solution for my problem: User error!

The problem was that the Serviio server VM didn't mount the NFS-Share of the Debain NAS VM cause of the ESXi-autostart-timer.

The NAS wasn't booted up completely and the Serviio tried to mount the shares but failed.

I configurated the autostart of my ESXi wrong. The VMs started behind one other too fast, so I set the timer higher.


Please close the topic and don't call me an idiot :D

Have anice evening!


Re: Serviio with OpenVPN

PostPosted: Tue Mar 17, 2015 12:27 am
by atc98092
Go job! 8-)

No question is stupid when asked honestly. Every mistake is a learning experience.

Enjoy! :D