FAQ  •  Register  •  Login

Linux installation won't stream online sources

<<

andymoabit

Serviio newbie

Posts: 11

Joined: Fri Oct 30, 2015 9:34 am

Post Fri Oct 30, 2015 10:29 am

Linux installation won't stream online sources

I have Serviio running on my Windows machine, serving web radio streams to my stereo. Works fine.

I also have an Ubuntu Linux media server on the same home network, which serves static media files using miniDLNA. It also works fine, but can't serve web radio streams.

So I thought I would install Serviio on the Linux machine and run only one DLNA server, retiring the miniDLNA.

I followed the instructions here: http://www.wiki.serviio.org/doku.php?id ... all:ubuntu

Unfortunately, Ubuntu doesn't have ffmpeg in its repositories, so I had to compile and install it.

The server runs and serves static files. The problem is that it loads and displays online sources but they don't play on either my stereo or my Samsung Galaxy 5 using MediaHouse. This is a deal-breaker, because the ability to stream the web radio files is the reason I want to replace miniDLNA with Serviio. Otherwise the Serviio installation is just taking up heaps of space (java and ffmpeg are very large) for no gain.

This can't be a network issue, as the Windows and Linux machines are on the same network and workgroup.
Nor can it be a problem with my devices as the Windows Serviio installation correctly streams my online sources to all my devices.
It doesn't seem to be an installation issue, as the Linux Serviio installation appears to work in all other respects.

Set-up details:

Ubuntu 14.04
Serviio v. 1.5.2
Java version 1.8.0_66
ffmpeg 2.8.1

From the log, it seems to be an ffmpeg error. Here is an excerpt from the log which I am guessing is related to the problem:

2015-10-29 14:35:24,618 WARN [ProcessExecutor] Process ffmpeg has a return code of 1! This is a possible error. Detailed output follows.
icy-br : 32
Stream #0:0: Audio: mp3, 0 channels, 128 kb/s
Stream mapping:
Stream #0:0 -> #0:0 (mp3 (native) -> ? (?))
Encoder (codec mp3) not found for output stream #0:0
2015-10-29 14:36:00,653 ERROR [ResourceTransportRequestHandler] Error while processing resource, sending back 500 error. Message: Transcoded stream is empty, FFmpeg execution probably failed or connection has been lost.
java.io.IOException: Transcoded stream is empty, FFmpeg execution probably failed or connection has been lost.
at org.serviio.delivery.resource.transcode.StreamBasedTranscodingDeliveryStrategy.createInputStream(StreamBasedTranscodingDeliveryStrategy.java:68)
at org.serviio.delivery.resource.transcode.AbstractTranscodingDeliveryEngine.retrieveTranscodedResource(AbstractTranscodingDeliveryEngine.java:135)
at org.serviio.delivery.resource.AbstractDeliveryEngine.deliver(AbstractDeliveryEngine.java:110)
at org.serviio.delivery.MediaResourceRetrievalStrategy.retrieveResource(MediaResourceRetrievalStrategy.java:151)
at org.serviio.delivery.GETMethodProcessor.retrieveResource(GETMethodProcessor.java:121)
at org.serviio.delivery.GETMethodProcessor.buildDeliveryContainer(GETMethodProcessor.java:48)
at org.serviio.delivery.AbstractMethodProcessor.handleRequest(AbstractMethodProcessor.java:132)
at org.serviio.delivery.ResourceDeliveryProcessor.deliverContent(ResourceDeliveryProcessor.java:81)
at org.serviio.upnp.webserver.ResourceTransportRequestHandler.handleRequest(ResourceTransportRequestHandler.java:86)
at org.serviio.upnp.webserver.AbstractRequestHandler.handle(AbstractRequestHandler.java:61)
at org.apache.http.protocol.HttpService.doService(HttpService.java:423)
at org.serviio.upnp.webserver.ServiioHttpService.doService(ServiioHttpService.java:78)
at org.apache.http.protocol.HttpService.handleRequest(HttpService.java:341)
at org.serviio.upnp.webserver.WebServer$WorkerThread.run(WebServer.java:204)

At the moment I have reenabled the Serviio server on the Windows machine and the miniDLNA server on the Ubuntu machine.
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 17075

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Fri Oct 30, 2015 11:38 am

Re: Linux installation won't stream online sources

Encoder (codec mp3) not found for output stream #0:0

Looks like you're missing lamemp3lib compiled in your ffmpeg
<<

andymoabit

Serviio newbie

Posts: 11

Joined: Fri Oct 30, 2015 9:34 am

Post Fri Oct 30, 2015 1:20 pm

Re: Linux installation won't stream online sources

OK. I'll chase it up but I might need some help to find it. :D
<<

andymoabit

Serviio newbie

Posts: 11

Joined: Fri Oct 30, 2015 9:34 am

Post Fri Oct 30, 2015 4:58 pm

Re: Linux installation won't stream online sources

Hmm. Checked the source-code, and found:
libmp3lame.c
I assume it was successfully compiled. I can't check as I cleaned out the compiled files after installation.
In any case, the Linux installation successfully served static mp3s, I tested it, only the online sources were a problem. Is this library only used for the online sources?
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 17075

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Sat Oct 31, 2015 11:32 pm

Re: Linux installation won't stream online sources

it';s used to transcode audio to mp3, so by anything that needs this.

type
  Code:
ffmpeg -codecs

to see if you have the mp3 encoder compiled in
<<

andymoabit

Serviio newbie

Posts: 11

Joined: Fri Oct 30, 2015 9:34 am

Post Sun Nov 01, 2015 8:06 am

Re: Linux installation won't stream online sources

Seems to be there:
  Code:
$ ffmpeg -codecs | grep mp3
ffmpeg version 2.8.1 Copyright (c) 2000-2015 the FFmpeg developers
  built with gcc 4.8 (Ubuntu 4.8.4-2ubuntu1~14.04)
  configuration:
  libavutil      54. 31.100 / 54. 31.100
  libavcodec     56. 60.100 / 56. 60.100
  libavformat    56. 40.101 / 56. 40.101
  libavdevice    56.  4.100 / 56.  4.100
  libavfilter     5. 40.101 /  5. 40.101
  libswscale      3.  1.101 /  3.  1.101
  libswresample   1.  2.101 /  1.  2.101
 D.A.L. mp3                  MP3 (MPEG audio layer 3) (decoders: mp3 mp3float )
 D.A.L. mp3adu               ADU (Application Data Unit) MP3 (MPEG audio layer 3) (decoders: mp3adu mp3adufloat )
 D.A.L. mp3on4               MP3onMP4 (decoders: mp3on4 mp3on4float )
<<

jk50

Serviio lover

Posts: 54

Joined: Mon Jan 09, 2012 9:53 am

Post Sun Nov 01, 2015 5:30 pm

Re: Linux installation won't stream online sources

You have mp3 decoders, but you do not have a mp3 encoder.
Your result of ffmpeg -codecs | grep mp3
  Code:
D.A.L. mp3                  MP3 (MPEG audio layer 3) (decoders: mp3 mp3float )

What it should be
  Code:
DEA.L. mp3                  MP3 (MPEG audio layer 3) (decoders: mp3 mp3float ) (encoders: libmp3lame )

As zip suggested you are missing libmp3lame

see here: How to compile ffmpeg http://www.wiki.serviio.org/doku.php?id=build_ffmpeg_linux
<<

andymoabit

Serviio newbie

Posts: 11

Joined: Fri Oct 30, 2015 9:34 am

Post Sun Nov 01, 2015 9:50 pm

Re: Linux installation won't stream online sources

Thanks for being so quick :D . I'll have a good look at the compile instructions.
<<

andymoabit

Serviio newbie

Posts: 11

Joined: Fri Oct 30, 2015 9:34 am

Post Mon Nov 02, 2015 3:55 pm

Re: Linux installation won't stream online sources

Sorry, can't get ffmpeg to compile using those instructions. Perhaps I should try again with the Serviio tarball..... :cry:

Note: I've got the source code in a folder in my ~/Downloads file, not in ~/src and I did not compile x264 and librtmp, leaving them out of the config instruction.
Here is the edited terminal session (My comments preceded by +++):

  Code:
+++Install didn't work entirely

[....]~$ sudo apt-get install build-essential checkinstall git libfaac-dev libjack-jackd2-dev \
>   libmp3lame-dev libopencore-amrnb-dev libopencore-amrwb-dev libsdl1.2-dev libtheora-dev \
>   libva-dev libvdpau-dev libvorbis-dev libx11-dev libxfixes-dev texi2html zlib1g-dev \
>   libssl1.0.0 libssl-dev libxvidcore-dev libxvidcore4 libass-dev
Reading package lists... Done
Building dependency tree       
Reading state information... Done
build-essential is already the newest version.
build-essential set to manually installed.
libx11-dev is already the newest version.
zlib1g-dev is already the newest version.
zlib1g-dev set to manually installed.
libxvidcore4 is already the newest version.
libxvidcore4 set to manually installed.
git is already the newest version.
git set to manually installed.
libssl-dev is already the newest version.
libssl-dev set to manually installed.
libssl1.0.0 is already the newest version.
libxfixes-dev is already the newest version.
libxfixes-dev set to manually installed.
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 unity-control-center : Depends: libcheese-gtk23 (>= 3.4.0) but it is not going to be installed
                        Depends: libcheese7 (>= 3.0.1) but it is not going to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

+++Tried to install the dependencies manually

[....]~$ sudo apt-get install libcheese-gtk23
Reading package lists... Done
Building dependency tree       
Reading state information... Done
libcheese-gtk23 is already the newest version.
libcheese-gtk23 set to manually installed.
The following packages were automatically installed and are no longer required:
  comerr-dev krb5-multidev libdrm-amdgpu1 libdrm-dev libegl1-mesa-dev
  libgcrypt11-dev libgles2-mesa-dev libgnutls-dev libgnutlsxx27
  libgpg-error-dev libgssrpc4 libidn11-dev libkadm5clnt-mit9 libkadm5srv-mit9
  libkdb5-7 libkrb5-dev libldap2-dev libmirclient-dev libmirclient7
  libmirclientplatform-mesa libmirprotobuf-dev libmirprotobuf0 libp11-kit-dev
  libprotobuf-dev libprotobuf-lite8 libpthread-stubs0-dev libssl-dev
  libssl-doc libtasn1-6-dev libwayland-dev libx11-dev libx11-xcb-dev
  libxau-dev libxcb-dri2-0-dev libxcb-dri3-dev libxcb-glx0-dev
  libxcb-present-dev libxcb-randr0-dev libxcb-render0-dev libxcb-shape0-dev
  libxcb-sync-dev libxcb-xfixes0-dev libxcb1-dev libxdamage-dev libxdmcp-dev
  libxext-dev libxfixes-dev libxshmfence-dev libxxf86vm-dev
  linux-headers-3.16.0-49 linux-headers-3.16.0-49-generic
  linux-image-3.16.0-49-generic linux-image-extra-3.16.0-49-generic
  mesa-common-dev mircommon-dev x11proto-core-dev x11proto-damage-dev
  x11proto-dri2-dev x11proto-fixes-dev x11proto-gl-dev x11proto-input-dev
  x11proto-kb-dev x11proto-xext-dev x11proto-xf86vidmode-dev
  xorg-sgml-doctools xtrans-dev zlib1g-dev
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 6 not upgraded.


[....]~$ sudo apt-get install libcheese7
Reading package lists... Done
Building dependency tree       
Reading state information... Done
libcheese7 is already the newest version.
libcheese7 set to manually installed.
The following packages were automatically installed and are no longer required:
  comerr-dev krb5-multidev libdrm-amdgpu1 libdrm-dev libegl1-mesa-dev
  libgcrypt11-dev libgles2-mesa-dev libgnutls-dev libgnutlsxx27
  libgpg-error-dev libgssrpc4 libidn11-dev libkadm5clnt-mit9 libkadm5srv-mit9
  libkdb5-7 libkrb5-dev libldap2-dev libmirclient-dev libmirclient7
  libmirclientplatform-mesa libmirprotobuf-dev libmirprotobuf0 libp11-kit-dev
  libprotobuf-dev libprotobuf-lite8 libpthread-stubs0-dev libssl-dev
  libssl-doc libtasn1-6-dev libwayland-dev libx11-dev libx11-xcb-dev
  libxau-dev libxcb-dri2-0-dev libxcb-dri3-dev libxcb-glx0-dev
  libxcb-present-dev libxcb-randr0-dev libxcb-render0-dev libxcb-shape0-dev
  libxcb-sync-dev libxcb-xfixes0-dev libxcb1-dev libxdamage-dev libxdmcp-dev
  libxext-dev libxfixes-dev libxshmfence-dev libxxf86vm-dev
  linux-headers-3.16.0-49 linux-headers-3.16.0-49-generic
  linux-image-3.16.0-49-generic linux-image-extra-3.16.0-49-generic
  mesa-common-dev mircommon-dev x11proto-core-dev x11proto-damage-dev
  x11proto-dri2-dev x11proto-fixes-dev x11proto-gl-dev x11proto-input-dev
  x11proto-kb-dev x11proto-xext-dev x11proto-xf86vidmode-dev
  xorg-sgml-doctools xtrans-dev zlib1g-dev
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 6 not upgraded.

[....]~$ sudo apt-get install build-essential checkinstall git libfaac-dev libjack-jackd2-dev   libmp3lame-dev libopencore-amrnb-dev libopencore-amrwb-dev libsdl1.2-dev libtheora-dev   libva-dev libvdpau-dev libvorbis-dev libx11-dev libxfixes-dev texi2html zlib1g-dev   libssl1.0.0 libssl-dev libxvidcore-dev libxvidcore4 libass-dev
[...]
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 unity-control-center : Depends: libcheese-gtk23 (>= 3.4.0) but it is not going to be installed
                        Depends: libcheese7 (>= 3.0.1) but it is not going to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

+++Still didn't work. Tried configuration anyway. NOTE I LEFT OUT LIBRTMP AND X264 AS I DONT NEED THEM

[....]/ffmpeg-2.8.1$ ./configure --enable-gpl --enable-libfaac --enable-libmp3lame --enable-libopencore-amrnb \
>     --enable-libopencore-amrwb --enable-libtheora --enable-libvorbis \
>     --enable-nonfree --enable-postproc --enable-version3 --enable-x11grab \
>     --enable-libxvid --enable-libass
ERROR: libass not found using pkg-config

If you think configure made a mistake, make sure you are using the latest
version from Git.  If the latest version fails, report the problem to the
ffmpeg-user@ffmpeg.org mailing list or IRC #ffmpeg on irc.freenode.net.
Include the log file "config.log" produced by configure as this will help
solve the problem.

+++Installed libass individually.

[....]~/Downloads/ffmpeg-2.8.1$ sudo apt-get install libass-dev
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  comerr-dev krb5-multidev libdrm-amdgpu1 libdrm-dev libegl1-mesa-dev
  libgcrypt11-dev libgles2-mesa-dev libgnutls-dev libgnutlsxx27
  libgpg-error-dev libgssrpc4 libidn11-dev libkadm5clnt-mit9 libkadm5srv-mit9
  libkdb5-7 libkrb5-dev libldap2-dev libmirclient-dev libmirclient7
  libmirclientplatform-mesa libmirprotobuf-dev libmirprotobuf0 libp11-kit-dev
  libprotobuf-dev libprotobuf-lite8 libpthread-stubs0-dev libssl-dev
  libssl-doc libtasn1-6-dev libwayland-dev libx11-dev libx11-xcb-dev
  libxau-dev libxcb-dri2-0-dev libxcb-dri3-dev libxcb-glx0-dev
  libxcb-present-dev libxcb-randr0-dev libxcb-render0-dev libxcb-shape0-dev
  libxcb-sync-dev libxcb-xfixes0-dev libxcb1-dev libxdamage-dev libxdmcp-dev
  libxext-dev libxfixes-dev libxshmfence-dev libxxf86vm-dev
  linux-headers-3.16.0-49 linux-headers-3.16.0-49-generic
  linux-image-3.16.0-49-generic linux-image-extra-3.16.0-49-generic
  mesa-common-dev mircommon-dev x11proto-core-dev x11proto-damage-dev
  x11proto-dri2-dev x11proto-fixes-dev x11proto-gl-dev x11proto-input-dev
  x11proto-kb-dev x11proto-xext-dev x11proto-xf86vidmode-dev
  xorg-sgml-doctools xtrans-dev
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  libenca-dev libexpat1-dev libfontconfig1-dev libfreetype6-dev libfribidi-dev
  libpng12-dev
The following NEW packages will be installed:
  libass-dev libenca-dev libexpat1-dev libfontconfig1-dev libfreetype6-dev
  libfribidi-dev libpng12-dev
0 upgraded, 7 newly installed, 0 to remove and 6 not upgraded.
Need to get 1.680 kB of archives.
After this operation, 6.966 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://de.archive.ubuntu.com/ubuntu/ trusty/universe libenca-dev i386 1.15-2 [3.580 B]
Get:2 http://de.archive.ubuntu.com/ubuntu/ trusty-updates/main libexpat1-dev i386 2.1.0-4ubuntu1.1 [112 kB]
Get:3 http://de.archive.ubuntu.com/ubuntu/ trusty/main libpng12-dev i386 1.2.50-1ubuntu2 [204 kB]
Get:4 http://de.archive.ubuntu.com/ubuntu/ trusty-updates/main libfreetype6-dev i386 2.5.2-1ubuntu2.5 [607 kB]
Get:5 http://de.archive.ubuntu.com/ubuntu/ trusty-updates/main libfontconfig1-dev i386 2.11.0-0ubuntu4.1 [661 kB]
Get:6 http://de.archive.ubuntu.com/ubuntu/ trusty/main libfribidi-dev i386 0.19.6-1 [42,6 kB]
Get:7 http://de.archive.ubuntu.com/ubuntu/ trusty/universe libass-dev i386 0.10.1-3ubuntu1 [49,8 kB]
Fetched 1.680 kB in 0s (2.584 kB/s) 
Selecting previously unselected package libenca-dev.
(Reading database ... 351197 files and directories currently installed.)
Preparing to unpack .../libenca-dev_1.15-2_i386.deb ...
Unpacking libenca-dev (1.15-2) ...
Selecting previously unselected package libexpat1-dev:i386.
Preparing to unpack .../libexpat1-dev_2.1.0-4ubuntu1.1_i386.deb ...
Unpacking libexpat1-dev:i386 (2.1.0-4ubuntu1.1) ...
Selecting previously unselected package libpng12-dev.
Preparing to unpack .../libpng12-dev_1.2.50-1ubuntu2_i386.deb ...
Unpacking libpng12-dev (1.2.50-1ubuntu2) ...
Selecting previously unselected package libfreetype6-dev.
Preparing to unpack .../libfreetype6-dev_2.5.2-1ubuntu2.5_i386.deb ...
Unpacking libfreetype6-dev (2.5.2-1ubuntu2.5) ...
Selecting previously unselected package libfontconfig1-dev.
Preparing to unpack .../libfontconfig1-dev_2.11.0-0ubuntu4.1_i386.deb ...
Unpacking libfontconfig1-dev (2.11.0-0ubuntu4.1) ...
Selecting previously unselected package libfribidi-dev.
Preparing to unpack .../libfribidi-dev_0.19.6-1_i386.deb ...
Unpacking libfribidi-dev (0.19.6-1) ...
Selecting previously unselected package libass-dev:i386.
Preparing to unpack .../libass-dev_0.10.1-3ubuntu1_i386.deb ...
Unpacking libass-dev:i386 (0.10.1-3ubuntu1) ...
Processing triggers for doc-base (0.10.5) ...
Processing 3 added doc-base files...
Processing triggers for man-db (2.6.7.1-1ubuntu1) ...
Setting up libenca-dev (1.15-2) ...
Setting up libexpat1-dev:i386 (2.1.0-4ubuntu1.1) ...
Setting up libpng12-dev (1.2.50-1ubuntu2) ...
Setting up libfreetype6-dev (2.5.2-1ubuntu2.5) ...
Setting up libfontconfig1-dev (2.11.0-0ubuntu4.1) ...
Setting up libfribidi-dev (0.19.6-1) ...
Setting up libass-dev:i386 (0.10.1-3ubuntu1) ...

+++Now it can't find something else!

[....]/ffmpeg-2.8.1$ ./configure --enable-gpl --enable-libfaac --enable-libmp3lame --enable-libopencore-amrnb     --enable-libopencore-amrwb --enable-libtheora --enable-libvorbis     --enable-nonfree --enable-postproc --enable-version3 --enable-x11grab     --enable-libxvid --enable-libass
ERROR: libfaac not found

If you think configure made a mistake, make sure you are using the latest
version from Git.  If the latest version fails, report the problem to the
ffmpeg-user@ffmpeg.org mailing list or IRC #ffmpeg on irc.freenode.net.
Include the log file "config.log" produced by configure as this will help
solve the problem.

+++ Retried the install with libfaac at front

[....]/ffmpeg-2.8.1$ sudo apt-get install libfaac-dev libjack-jackd2-dev   libmp3lame-dev libopencore-amrnb-dev libopencore-amrwb-dev libsdl1.2-dev libtheora-dev   libva-dev libvdpau-dev libvorbis-dev libx11-dev libxfixes-dev texi2html zlib1g-dev   libssl1.0.0 libssl-dev libxvidcore-dev libxvidcore4 libass-dev
Reading package lists... Done
Building dependency tree       
Reading state information... Done
libx11-dev is already the newest version.
zlib1g-dev is already the newest version.
zlib1g-dev set to manually installed.
libass-dev is already the newest version.
libxvidcore4 is already the newest version.
libxvidcore4 set to manually installed.
libssl-dev is already the newest version.
libssl-dev set to manually installed.
libssl1.0.0 is already the newest version.
libxfixes-dev is already the newest version.
libxfixes-dev set to manually installed.
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 unity-control-center : Depends: libcheese-gtk23 (>= 3.4.0) but it is not going to be installed
                        Depends: libcheese7 (>= 3.0.1) but it is not going to be installed
           
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

+++ But config still fails

[....]/ffmpeg-2.8.1$ ./configure --enable-gpl --enable-libfaac --enable-libmp3lame --enable-libopencore-amrnb \
>     --enable-libopencore-amrwb --enable-libtheora --enable-libvorbis \
>     --enable-nonfree --enable-postproc --enable-version3 --enable-x11grab \
>     --enable-libxvid --enable-libass
ERROR: libfaac not found

If you think configure made a mistake, make sure you are using the latest
version from Git.  If the latest version fails, report the problem to the
ffmpeg-user@ffmpeg.org mailing list or IRC #ffmpeg on irc.freenode.net.
Include the log file "config.log" produced by configure as this will help
solve the problem.

[....]/ffmpeg-2.8.1$ ./configure --enable-gpl --enable-libmp3lame --enable-libopencore-amrnb \
>     --enable-libopencore-amrwb --enable-libtheora --enable-libvorbis \
>     --enable-nonfree --enable-postproc --enable-version3 --enable-x11grab \
>     --enable-libxvid --enable-libass
ERROR: libmp3lame >= 3.98.3 not found

If you think configure made a mistake, make sure you are using the latest
version from Git.  If the latest version fails, report the problem to the
ffmpeg-user@ffmpeg.org mailing list or IRC #ffmpeg on irc.freenode.net.
Include the log file "config.log" produced by configure as this will help
solve the problem.

+++Bizarre. Anyway, I tried make, just to see what happened and it failed too.

[....]~/Downloads/ffmpeg-2.8.1$ make
Makefile:2: config.mak: No such file or directory
Makefile:62: /common.mak: No such file or directory
Makefile:104: /libavutil/Makefile: No such file or directory
Makefile:104: /library.mak: No such file or directory
Makefile:106: /doc/Makefile: No such file or directory
Makefile:189: /tests/Makefile: No such file or directory
make: *** No rule to make target `/tests/Makefile'.  Stop.
<<

jk50

Serviio lover

Posts: 54

Joined: Mon Jan 09, 2012 9:53 am

Post Mon Nov 02, 2015 8:13 pm

Re: Linux installation won't stream online sources

Your problem is this
  Code:
The following packages have unmet dependencies:
 unity-control-center : Depends: libcheese-gtk23 (>= 3.4.0) but it is not going to be installed
                        Depends: libcheese7 (>= 3.0.1) but it is not going to be installed

libcheese has nothing to do with compiling ffmpeg. It's caused by a bug in ubuntu (trusty). Google ("unity-control-center : Depends: libcheese-gtk23 (>= 3.4.0) but it is not going to be installed" ) for info on the bug.
The bug is causing apt-get to abort before it downloads the ffmpeg dependencies, which is why it won't compile. I don't know how much time you want spend,
but you could try to get the ffmpeg dependencies one at a time. At least then you can isolate which package is triggering the bug and search for a workaround.
Or you could upgrade to a newer version of ubuntu.

NOTE I LEFT OUT LIBRTMP AND X264 AS I DONT NEED THEM

If you manage to get the dependencies you should rethink leaving out x264 and librtmp , you do need them.
<<

andymoabit

Serviio newbie

Posts: 11

Joined: Fri Oct 30, 2015 9:34 am

Post Tue Nov 03, 2015 9:06 am

Re: Linux installation won't stream online sources

Very good. Got the dependencies sorted. Ran the apt-get install with each package individually. For future reference, my system choked on libsdl1.2-dev. The libcheese problem wasn't so bad. I just kept constructing apt-get lists until it had all the dependencies in one command in the right order. Ended up with
  Code:
sudo apt-get install libclutter-1.0-0 libclutter-gtk-1.0-0 libcogl15 libclutter-gst-2.0-0 gstreamer1.0-clutter libcheese-gtk23 libcheese7 libsdl1.2-dev

which wasn't too hard ;)

The really good news is that the streaming web-radio files now work. Yay!

Thanks jk50 and zip.

Q: To add x264 and librtmp I just compile and install them and redo the ffmpeg configure, make and install, is that right?
<<

jk50

Serviio lover

Posts: 54

Joined: Mon Jan 09, 2012 9:53 am

Post Tue Nov 03, 2015 10:07 am

Re: Linux installation won't stream online sources

Q: To add x264 and librtmp I just compile and install them and redo the ffmpeg configure, make and install, is that right?

Yes, that will work
<<

andymoabit

Serviio newbie

Posts: 11

Joined: Fri Oct 30, 2015 9:34 am

Post Tue Nov 03, 2015 2:21 pm

Re: Linux installation won't stream online sources

Sure did. Thanks for the help!
<<

andymoabit

Serviio newbie

Posts: 11

Joined: Fri Oct 30, 2015 9:34 am

Post Thu Nov 05, 2015 12:29 pm

Re: Linux installation won't stream online sources

Oh oh! Now its not working again. No ffmpeg.

Error message from log:
  Code:
2015-11-05 12:13:59,437 ERROR [ProcessExecutor] Fatal error in process starting: Cannot run program "ffmpeg": error=2, No such file or directory
java.io.IOException: Cannot run program "ffmpeg": error=2, No such file or directory
   at java.lang.ProcessBuilder.start(ProcessBuilder.java:1048)
   at org.serviio.external.ProcessExecutor.run(ProcessExecutor.java:135)
Caused by: java.io.IOException: error=2, No such file or directory
   at java.lang.UNIXProcess.forkAndExec(Native Method)
   at java.lang.UNIXProcess.<init>(UNIXProcess.java:248)
   at java.lang.ProcessImpl.start(ProcessImpl.java:134)
   at java.lang.ProcessBuilder.start(ProcessBuilder.java:1029)
   ... 1 more
2015-11-05 12:13:59,439 ERROR [MediaServer] FFMPEG not found. Serviio will not work properly.

Also:
  Code:
[...}~$ ffmpeg
ffmpeg: command not found
[...}~$ ffmpeg -codecs
ffmpeg: command not found

Also:
  Code:
[...}~$ apt-cache policy ffmpeg
ffmpeg:
  Installed: (none)
  Candidate: (none)
  Version table:
[...}~$ whereis ffmpeg
ffmpeg:

Looks like ffmpeg has been uninstalled.
  Code:
[...}~$ sudo dpkg --get-selections | grep ffmpeg
chromium-codecs-ffmpeg-extra         install

I suppose I can redo the install, but I need to know what happened and why.
<<

andymoabit

Serviio newbie

Posts: 11

Joined: Fri Oct 30, 2015 9:34 am

Post Thu Nov 05, 2015 12:37 pm

Re: Linux installation won't stream online sources

It may be relevant that I ran a normal Ubuntu software update this morning. Don't know what it was, though.
<<

andymoabit

Serviio newbie

Posts: 11

Joined: Fri Oct 30, 2015 9:34 am

Post Thu Nov 05, 2015 12:47 pm

Re: Linux installation won't stream online sources

In fact when I reinstalled the ffmpeg package, the server works fine again. I hope this doesn't happen every time I get a software update!

Andy thoughts?

Return to User experiences

Who is online

Users browsing this forum: Google [Bot] and 20 guests

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.