FAQ  •  Register  •  Login

Preferred online content quality question?

<<

fidmas

Serviio lover

Posts: 96

Joined: Thu Dec 17, 2015 8:29 pm

Post Thu Jan 07, 2016 3:15 pm

Preferred online content quality question?

Could someone tell me if I'm imagining things about this setting? I'm using a 2GHz P4 XP Pro with 2GB RAM with a 10MB DSL connection.

I've observed:

When this is set to "Medium", Tune-In and CBS resources normally take from 2 to 10 attempts to get started. Program content will either fail to start or play for less than a second and stop. Once started, they stream nicely forever.

When set to "High", these feeds that require those plugins pretty much don't start at all.

When set to "Low" however, all seem to work almost 100% of the time, but of course the Video quality is poor.

If this observation is correct, might there be a way to demand less bandwidth/CPU-Resources during the first 1 or 2 seconds of the stream?


--------------

Update: Disregard the above. It was only a coincidence. Today, "Low" quality is just as difficult to get started as "Medium". I just wish I knew why!
<<

jhb50

DLNA master

Posts: 2843

Joined: Thu Jun 30, 2011 9:32 pm

Post Thu Jan 07, 2016 8:58 pm

Re: Preferred online content quality question?

First you need to enable the debug log to see what is happening when you fail. Secondly you should start Windows Task Manager and monitor performance tab while you start those streams to see if your system overloads. AFAIC with Tune-in the quality is ignored as there is only one stream for each feed item.
<<

fidmas

Serviio lover

Posts: 96

Joined: Thu Dec 17, 2015 8:29 pm

Post Thu Jan 07, 2016 11:50 pm

Re: Preferred online content quality question?

Thanks. I'll turn the debug log and see if i can make sense of it. If not, may I attach the pertinent section to a reply post? I've been watching the Task Manager network activity and see 0.6% to 0.8% of the 100MB NIC, which is 6% to 8% of the 10MB DSL bandwidth = from 600KB to 800KB per second, be it a successful start or not. So, i would assume it's not bandwidth. CPU usage by ServiioService.exe is more difficult to get a handle on, since I don't have a graph and the TV and Desktop PC are in different rooms. Harder to catch peak usage. While successfully playing a Tune-In station, I see ServiioService.exe using anywhere from 0% to 48% of the CPU, and a fairly constant bandwidth usage of 1% of the 10MB DSL.
<<

jhb50

DLNA master

Posts: 2843

Joined: Thu Jun 30, 2011 9:32 pm

Post Fri Jan 08, 2016 4:17 am

Re: Preferred online content quality question?

It would be worth testing with the media browser in order to rule out the TV. You would also be able to watch the CPU load as the stream is played.
<<

fidmas

Serviio lover

Posts: 96

Joined: Thu Dec 17, 2015 8:29 pm

Post Fri Jan 08, 2016 3:00 pm

Re: Preferred online content quality question?

I wondered why I "Media Browser" didn't ring a bell. I'm using the free version. As much as I like Serviio, the struggle getting things to "Start" and the need to learn how to write and debug my own plugins, doesn't really warrant buying the Pro version at this point. So far streams without Plugins work like a charm, as does Youtube. CBS and TuneIn always require multiple attempts.
<<

fidmas

Serviio lover

Posts: 96

Joined: Thu Dec 17, 2015 8:29 pm

Post Fri Jan 08, 2016 6:20 pm

Re: Preferred online content quality question?

I haven't been able to try debug log yet, but I have ruled out bandwidth an CPU usage. Bandwidth never even gets close to 5%. Using Perfmon to watch ServiioService, I see it idling along most of the time regardless of what's being started, played or failing to start, be it TuneIn audio or CBS Video. Every 60 seconds, ServiioService CPU usage climes to 75% to 90% for around 5 seconds. These peeks seem to have nothing to do with the failures to start a stream.
<<

atc98092

User avatar

DLNA master

Posts: 4118

Joined: Fri Aug 17, 2012 10:22 pm

Location: Washington (the state)

Post Fri Jan 08, 2016 9:36 pm

Re: Preferred online content quality question?

fidmas wrote:I haven't been able to try debug log yet, but I have ruled out bandwidth an CPU usage. Bandwidth never even gets close to 5%. Using Perfmon to watch ServiioService, I see it idling along most of the time regardless of what's being started, played or failing to start, be it TuneIn audio or CBS Video. Every 60 seconds, ServiioService CPU usage climes to 75% to 90% for around 5 seconds. These peeks seem to have nothing to do with the failures to start a stream.


You also have to monitor FFMPEG, in case it is transcoding the files. That's where you get the big CPU usage hit.
Dan

LG NANO85 4K TV, Samsung JU7100 4K TV, Sony BDP-S3500, Sharp 4K Roku TV, Insignia Roku TV, Roku Ultra, Premiere and Stick, Nvidia Shield, Yamaha RX-V583 AVR.
Primary server: Intel i5-6400, 8 gig ram, Windows 10 Pro, 22 TB hard drive space | Test server Windows 10 Pro, AMD Phenom II X4 965, 8 gig ram

HOWTO: Enable debug logging HOWTO: Identify media file contents
<<

fidmas

Serviio lover

Posts: 96

Joined: Thu Dec 17, 2015 8:29 pm

Post Fri Jan 08, 2016 10:01 pm

Re: Preferred online content quality question?

I will monitor ffmpeg soon, although i never saw it near the top of the Task Manager CPU list.

I'm hoping someone can make sense of the attached debug log file because I sure can't.

This time:

The 1st Tunein station started with a slight hesitation, but continued to play..

The 2nd failed to start and got the "File cannot be played".

I tried it again and hesitated but continued to play.

UPDATE:
Had to zip up the partial log file.
Attachments
serviio.zip
(70.43 KiB) Downloaded 127 times
<<

jhb50

DLNA master

Posts: 2843

Joined: Thu Jun 30, 2011 9:32 pm

Post Sat Jan 09, 2016 3:48 am

Re: Preferred online content quality question?

That's less than one minute of log and not the time when those files were played.
<<

fidmas

Serviio lover

Posts: 96

Joined: Thu Dec 17, 2015 8:29 pm

Post Sat Jan 09, 2016 2:31 pm

Re: Preferred online content quality question?

What are you using to unzip and read the file? I just re-downloaded the file and unzipped it again with WinZip and got the original 1.1MB text file from 16:19 to 16:28. The 9 minutes that include 1 success, 1 failure and 1 success.

Should i do this again and zip up a complete debug log from start to end? It could be 5MB+. /-)
<<

jhb50

DLNA master

Posts: 2843

Joined: Thu Jun 30, 2011 9:32 pm

Post Sun Jan 10, 2016 1:53 am

Re: Preferred online content quality question?

Sorry, don't know how that happened. Got it now.
Looking at the log, I can see the requests and the transcodes, and the error while sending the second transcoded stream to the TV.
You probably need a video example as well as the audio one and you need to post your log and error in the Sony forum.
It indicates a software failure, so its probably something specific to the Sony or the profile.
  Code:
2016-01-08 16:23:06,028 DEBUG [WebServer] I/O error: Software caused connection abort: socket write error
2016-01-08 16:23:06,138 DEBUG [PipedOutputStreamMultiplexer] Caught exception: Read end dead
java.io.IOException: Read end dead
   at java.io.PipedInputStream.checkStateForReceive(PipedInputStream.java:262)
   at java.io.PipedInputStream.receive(PipedInputStream.java:226)
   at java.io.PipedOutputStream.write(PipedOutputStream.java:149)
   at org.serviio.external.io.PipedOutputStreamMultiplexer$3.call(PipedOutputStreamMultiplexer.java:87)
   at org.serviio.external.io.PipedOutputStreamMultiplexer$MultiplexCaller.multiplex(PipedOutputStreamMultiplexer.java:119)
   at org.serviio.external.io.PipedOutputStreamMultiplexer.write(PipedOutputStreamMultiplexer.java:89)
   at org.serviio.external.io.PipedOutputBytesReader.processOutput(PipedOutputBytesReader.java:58)
   at org.serviio.external.io.OutputReader.run(OutputReader.java:47)
<<

fidmas

Serviio lover

Posts: 96

Joined: Thu Dec 17, 2015 8:29 pm

Post Sun Jan 10, 2016 2:56 pm

Re: Preferred online content quality question?

Yes. Thanks. I'm was starting to come to the same conclusion since anything that requires a plugin (CBS Video or TunIn Audio) behaves the same way. Almost impossible to get started or play for 0.5 second. All the feeds that don't require a plugin all work beautifully. I'm thinking about running a test with the Generic Profile replacing the Sony (2013/2014) profile. Worth a try??
<<

jhb50

DLNA master

Posts: 2843

Joined: Thu Jun 30, 2011 9:32 pm

Post Sun Jan 10, 2016 7:10 pm

Re: Preferred online content quality question?

I doubt it. The Sony is different and its profiles have all been custom developed by Illico..see the Sony support forum. I would PM him and ask him to take a look.
<<

fidmas

Serviio lover

Posts: 96

Joined: Thu Dec 17, 2015 8:29 pm

Post Sun Jan 10, 2016 8:02 pm

Re: Preferred online content quality question?

jhb50 wrote:I doubt it. The Sony is different and its profiles have all been custom developed by Illico..see the Sony support forum. I would PM him and ask him to take a look.


I have PM'ed him with CBS and Tunein failures in a debug log. I hope he doesn't think a newb is doing an end-around the normal board...........
<<

jhb50

DLNA master

Posts: 2843

Joined: Thu Jun 30, 2011 9:32 pm

Post Mon Jan 11, 2016 5:26 am

Re: Preferred online content quality question?

Post it here too and just refer him to this thread. viewtopic.php?f=6&t=21390
<<

fidmas

Serviio lover

Posts: 96

Joined: Thu Dec 17, 2015 8:29 pm

Post Mon Jan 11, 2016 2:15 pm

Re: Preferred online content quality question?

I sent him this PM yesterday.

Although I've been programming for over 35 years, all this is very new to me and I really don't know where to look. jhb50 suggested I PM you. I have a KDL-48W600B that is behaving very well with Serviio both local and online if the feed does not require a plugin or uses the Youtube.groovy. However, trying to get a CBS ore TuneIn item started normally requires 2 to 10 attempts, if it starts at all.

I've attached a debug log of several CBS failed attempts and several failed attempts at TuneIn stations. These are followed by a successful connection to a Youtube RSS and a "Democracy Now" show.

Can you help?


I'll edit it and direct him here also. Tnx.

Update:
Log file zip file removed on request from Illico.
Last edited by fidmas on Wed Jan 13, 2016 6:49 pm, edited 1 time in total.
<<

Illico

User avatar

DLNA master

Posts: 4646

Joined: Fri Jul 23, 2010 8:08 am

Location: France

Post Tue Jan 12, 2016 7:20 pm

Re: Preferred online content quality question?

Sorry for delay,
Your log is too big for me...but ERROR seems to be due to plugin error or external server url that do not delivered a good rtmp stream format. Its not a BRAVIA problem.
I suggest to cleanup the serviio.log file (remove it or edit with notepad++)
Then try to play your TunIn item with your bravia TV then post the new serviio.log file.
I will have a look if I get time.
I suppose you already post request on specific CBS or TunIn plugins forum thread ?
viewtopic.php?f=20&t=5096
viewtopic.php?f=20&t=5401
<<

jhb50

DLNA master

Posts: 2843

Joined: Thu Jun 30, 2011 9:32 pm

Post Tue Jan 12, 2016 9:10 pm

Re: Preferred online content quality question?

@Illico, these plugins work fine for me and play the streams from these servers correctly, so I cannot agree that is the problem. The serviio.zip a few posts back is smaller and you should be able to load it with notepad+.
<<

fidmas

Serviio lover

Posts: 96

Joined: Thu Dec 17, 2015 8:29 pm

Post Tue Jan 12, 2016 9:12 pm

Re: Preferred online content quality question?

Sorry about the size of the log file, but I was asked to provide a debug log that demonstrated both a Tunein and a CBS error. Debug logs get very big very fast. I'm not confidant I could spot the exact spot of the errors so all I can do is provide you with two logs within the smallest time frame of an error from Tunein and CBS. TuneIn fails to start about 60% of the time, and CBS fails about 90% of the time, but it'll still be difficult to get the exact time of the errors because I'm using two different clocks in two different rooms.

I have posted at viewtopic.php?f=20&t=5096&p=105658#p105632 and jhb50 updated the TuneIn.groovy, but that didn't do anything for the reliability problem.

My viewtopic.php?f=20&t=5401&p=105744#p105744 seems to still be unanswered.

I have no problem editing these large log files with notepad or any other editor, but I'll really try to get you smaller ones by tomorrow.

Thanks again.
<<

fidmas

Serviio lover

Posts: 96

Joined: Thu Dec 17, 2015 8:29 pm

Post Tue Jan 12, 2016 10:43 pm

Re: Preferred online content quality question?

This attempt tried to start the latest episode of NCIS. The TV gave up after about 30 seconds (I guess), and attempted to start the previous episode. That played for about 0.5 seconds, as I recall, and the TV tried to start the next previous episode. That failed with a "File cannot played".

I'll do a Tunein example ASAP.
Attachments
serviio-CBS.zip
(34.11 KiB) Downloaded 106 times
Next

Return to Serviio Support & Help

Who is online

Users browsing this forum: No registered users and 26 guests

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.