Page 1 of 1

Roku Playback Issue

PostPosted: Sat Sep 22, 2018 3:17 pm
by savvy2
hello, just joined, asked on Ruku forum but so many models and restrictions my head explodes.
topic, RUKU3 (4230x1) v4.1 build 1602 works perfectly in the web streaming no issues at all (new ROKU ULTRA 4K in the mail) soon. all software fresh. (versions new or newer)
wired system gagalan snob sure (wifi does sux) real HO servers DL380s, Fast 8 bank RAID SAS. (love it when server farms, purge these jewels I do)

We own roku for only 1 reason, free working apps for the web, after getting that email from 2 top streamers, netflix and hulu (your app protocol will be disabled soon on your 2 TV and 2 bluray players, some only 1 year old) so RUKU is the cure.
But not RMP, RMP fails, for fast forward (but not plex player to plex sever (only ROKU3 to Serviio) transcoding off for sure.
BTW< the dead subtitles now fixed, after years dead, was solved yesterday by force loading FFmpeg.exe nightly build, N91991 (shock, almost fell off couch, raise the flag , happy)
100 mkv some Handbrake , some MAKEMKV, all are H.264 encoded.

the web method works port 23424/mediabrowser, using mouse to FF , jump really not ff like plex with x1,x3 speeds. but that is ok,
As does VLC from anything to any of my MKV vids.
what fails is ROKU RMP. ( question 1, does Serviio have some kind of smart, ROKU plug in? Dreaming I am. sorry)

I have tried many tests now, and FF is dead. codec mpeg4 not 2, h264, ok , found my first clue, just now, made mkv using HB , no sound no subs, h264(as all are) and FF works, so, i will work this to the reason soon.
progress finally, the key is to set the RF quality to 30 for faster builds. then play with sound and subs.
more ... testing HB ver 1.12.

ok 2ch ac3 pass-through fails Fast forward FF.
2ch ac3 auto pass-through works Perfectly for FF.
5.1 test next, ac3, auto pass-through( HB all built by Handbrake mkv to mkv, playing only with audio codec, 16 choices under AC3-5.1 alone. (pending tests)
I really want 1 of the 5.1 modes to work we do have surround here.
BINGO, 5.1 WORKS WITH ac3 + auto pass-through using handbrake v.1.12 Sept, release 2018. ah but the plot thickens.
I add subs back on and boom dead. FF ( what next barometric pressure, LoL)
so i delete all subs and use HB to add my simple srt sub file that works for subs, and FF fails again..... I give up, '
RMP is a very picky app.

i have a super old Purple ROKU 3500 parked (4+ years old that I will test later) "for blast from the past ,effects?)

Re: Compatible devices list

PostPosted: Sat Sep 22, 2018 10:34 pm
by atc98092
And, you've still got me responding to you. :lol:

For other forum users that haven't seen your post on the Roku forum, he connects his player to a Kenwood receiver (I am assuming via HDMI) which connects to an LG TV.

I don't believe I ever mentioned in the other forum about the Serviio profiles. I can't believe I overlooked that. Sorry. :oops:

I suggest trying the Serviio profile labeled "Roku 1080 Media Player (2016+)". By default, Serviio selects the generic Roku profile, which transcodes almost everything. This will allow files with supported audio and video to play without transcoding. Once they aren't transcoded, your FF should work.

But as a reminder, if any of your videos contain MPEG2 (H.262) video, it will require transcoding, since very few Roku players support that codec. Also, all HD audio (Dolby TrueHD or DTS MA) requires transcoding. Multi-channel AAC audio also requires transcoding. And if a file is transcoded, FF will not work.

Re: Compatible devices list

PostPosted: Sun Sep 23, 2018 12:12 am
by atc98092
Are you certain of your AVR brand? When I search for RX V375 all I get back is Yamaha. The only Kenwood with a model number close to that is a car receiver. :D

Look on the Serviio console, and the tab labeled Status. You will find your Roku listed by IP address, and most likely is showing the Roku Media Player as the assigned profile. As I said, that profile transcodes almost everything. Click the Edit tab and then change the profile to the one I suggested. This alone may resolve your issues.

Multi-channel is generally used to indicate more than two audio channels, so 5.1, 7.1 or higher are all considered multi-channel.

To see the list of Roku suggested media codecs, see this page: ... and-photos

Every Roku player should support AC-3 (Dolby Digital) without issue, regardless of channel count. I've never had an issue with 7.1 content, but then most of my players are connected to an AVR which handles all audio.

Re: Compatible devices list

PostPosted: Sun Sep 23, 2018 12:05 pm
by savvy2
hello and greetings: (to ATC98 and all)
sorry Yamaha AVR , typo.
found the Rok3, and MAC addr, and IP and bound (reserv) it up in the router.
set the "Roku 1080 Media Player (2016+)" profile to that IP.
thanks so very much telling me that deep setting in Serviio, and IP specific profile , and set, now. and saved.
support AC-3 (Dolby Digital) without issue, regardless of channel count. (and this is good too, thanks)

ok me back to testing. have great Sunday.!

Re: Compatible devices list

PostPosted: Sun Sep 23, 2018 1:33 pm
by savvy2
Using HB (handbrake -1.12) build the MKV video,
with h.264
AC3, Dolby Surround. default
AC3, stereo
substitles all deleted.

Plays and FF perfectly including my 5.1 speakers all work, in Dolby.

I add subs back , and [b]this kills FF dead RW dead[/b], pause always works as does Resume, but plays perfectly
sub1: VOBSUB english. default. no burn , no forced
Sub2: Foreign audio scan

test 2, same as above, but all subs turned off, inside (orginals)
I have a good SRT file tested externally, so I then load it in the the MKV. (and all the SRT tools to work them, SE and SWXE to work them clean them etc.)
results next........
all tricks to get ff and subs working fail,
I then (omgolly) Google ROKU + subs + VOB subs and see many sites (lets skip blue ray) "DVD VOB SUBS are not supported", nor are multiple, subtitle mkv contained videos/
I then deleted all orig. VOB subs and the videos now FF , so next I add my own SRT file tested externally first then reinstalled it in the MKV (using HB) and shock ! FF still dead. wow. simple RST in UTC8 format , clean.
So i need to work harder and learn the rules for FF and how that is disabled with any class /type of SUBS tried. ( I also trying H/.265)

now my wild guess, even though serviio transcode check box is off, if the Serviio engine sees something it does not like it flips it on , on the fly and rule 2, FF die, on purpose,) how can I see what it does not like, if in fact this is true.
cheers and all help provided "THANKS !"

the PDF above only says, but not the rules of them? formatting etc. SRT imports seems rational but? IDK (sure external SRT works)
"Roku Media Player supports embedded subtitles in .mkv files."

so im running MKcleaver.exe now and converting them all at once to srt or sub. Then make them all srt. (i get to nap while scripts run)

Re: Roku Playback Issue

PostPosted: Sun Sep 23, 2018 7:30 pm
by atc98092
I split this into a new topic, since it didn't really fit the Compatible Devices list. :D

I can't explain why you are having the problem with embedded captions. I have many MKV files that are DVD rips with embedded VOBSUB captions and have never had a problem with FF/rewind, although I'll admit I seldom use trick play. For me, what I more am concerned with is being able to resume play after stopping mid-video. You can't do that with transcoded files either. I'm playing an MP4 right now with H.264 video (a Blu Ray rip). I'm fairly certain that it contains PGS subtitles, and I can FF and rewind with no problem. I just switched to a DVD rip with MPEG2 video and VOBSUB captions. I can play that with FF and rewind as well. (The Ultra can play MPEG2 video).

All I can think of is that there's a setting someone either in Serviio or your Roku that we've overlooked.

Re: Roku Playback Issue

PostPosted: Sun Sep 23, 2018 7:48 pm
by savvy2
thanks so much for that example it helps greatly.

agree if you can do that, I am doing wrong , somewhere...

i have Mkv that has deleted internal subs, plays 5.1 dolby, FF ok , but if copy the file over , stop the server, FF fails.
test odd1:
stop server. (and service)
delete (now just mkv)
start server serviio.
play movie.mkv (ruku3)
plays and fast forwards. (but no subs as the are all gone now, expected)

must not like my srt. i guess.?

Re: Roku Playback Issue

PostPosted: Sun Sep 23, 2018 10:27 pm
by atc98092
I believe that SRT files must be created in a particular encoding. UTF-8 comes to mind. I use Notepad++ as my default text editor, as it is capable of encoding in various formats and also supports so many different languages, such as HTML, XML, Java, and dozens of others.

But that doesn't explain the issue with embedded videos. Perhaps Zip has some ideas.

Re: Roku Playback Issue

PostPosted: Mon Sep 24, 2018 11:14 am
by savvy2
yes, it is encoded perfectly all are UTF-8, for sure.
I export them all (batch mode ,2 clicks ) 100 videos with MKcleaver.ext. (like magic this app. )
then if not srt formatted as some are not, I convert those. from sub/idx to SRT (its graphics to text conversion but im not there yet all mine are srt now)
SRT edits 101:
then with subtitle workshop Xe V6 , do a full cleanup (10 steps list built in) and then OCR it, or what ever suits a fancy, for even colors.
then save it,
all my srt run as external perfectly, but not internal mkv , fails. (fails not for subs but it kills dead FF /RW) there is a relationship from SRT internal to FF ,that leaves me stalled)
FF fails if SRT is inside mkv or outside, in never got FF to work ever , until all subs were deleted, inside and outside.

tests to come. soon. to find true case of this .
later I will test my ROKU Ultra 4K. on different TV.
failing 4k roku box test , I will load serviio fresh to server #2 (roku+plex app to new plex server already tested and works)

also in this SOUP is DNLA, MS (w10) media streaming options, is enabled. so I turned it off just now and the results are .....disabling this , no cure. (only now the w10 media DNLA icons are gone (good)
I'm pretty sure having a plex server on SERVIIO server on 1 PC is no no. (but not tested by me, sounds like nothing but pain if I do )
I will do all these tests. to find the true cause of FF failure, even total fresh reloads of all software if need be.
thanks for helping !!!!

Re: Roku Playback Issue

PostPosted: Mon Sep 24, 2018 1:18 pm
by atc98092
I run Plex and Serviio on both of my media computers without a problem, so no worries there. I can even access both from the Internet, as they use different ports and don't interfere with each other. I'll use Plex sometimes when I'm traveling, as my Roku Stick can access Plex from the hotel network, where it can't access Serviio remotely. That's about all I ever use it for. Never touch Plex from my home network. :D

Re: Roku Playback Issue

PostPosted: Mon Sep 24, 2018 2:52 pm
by savvy2
Thanks for that, ATC.!
I will try that too ....
Yes i see the ports are different. (my only concern was file locks MKV (serviio to plex) running same time)

I will do all the test to prove why FF fails, with only SUBs turned on, (has to be a reason and maybe a cure.... if there is , I will find it.)


frog.jpeg (37.32 KiB) Viewed 4687 times

Re: Roku Playback Issue

PostPosted: Mon Sep 24, 2018 4:53 pm
by savvy2
test 1, today, fails
brand new Ultra, 4k , out of sealed box.
installed fast, no issues. (like it
RMP fail same way, so would guess, its not the RMP end. but bad Serviio setups. or? something.

test 2: fails.
moved Roku3, to Den, LG old TV direct to TV and sure it works, direct. no AVR here,
and fails tool. no FF. subs on , subs remove FF works.

All points to server, and subs.
test 3:
next is plex tests, (before they worked on server 2 HP, will try plex and seviio on sever HP #1 at same time

test 4, is new servio install on server 2 by sel. fresh. (with Profile seat as ROKU 1080p as told to do) and transcoding off, as that kills FF by stated spec pages)
FF/RW fails
never pause, never unpause. (have 3 severs, all HP< one is windows server 2012 R, does this work,, not covered in the wiki spec, what OS (all) it works on, just vague)

Re: Roku Playback Issue

PostPosted: Mon Sep 24, 2018 5:42 pm
by atc98092
I recall someone having issues trying to run Serviio on Windows Server 2012, but can't recall the details. For the Ultra, make sure you're using the 4K player profile, although it shouldn't have an issue with what you're experiencing.

My Serviio console settings as as follows:
Enable Subtitles: checked
Enable extraction of text-based subtitles: checked
Subtitles character encoding: checked, with UTF-8 in the encoding box
Burned in subtitles: NOT checked
Online subtitles: checked

I'm currently experimenting with a new profile specific to the Ultra, since it now supports MPEG2 and I don't want to transcode unnecessarily.

Another question: look at the Serviio console when you are playing a video that will NOT FF. Look on the status tab, to the left of the entry for your Roku. While the video is playing, there is a status indicator (only there during playback). If it's green, then it is not being transcoded, and FF should work. However, if it's red then it is being transcoded. We need to determine why. This will likely require you enabling detailed logging, so we can see the playback command Serviio is using.

Re: Roku Playback Issue

PostPosted: Mon Sep 24, 2018 6:15 pm
by savvy2
ohhh, I didnt know about the green thing,and for sure thanks for helping and and will do all.

Trumpet blare , I owe you case of beer.

BURN IN SUBS (death) fixes this, but makes sense really , the complexity to that for sure with 2d/3d graphic subs .

hero.jpeg (34.98 KiB) Viewed 4679 times

Re: Roku Playback Issue

PostPosted: Mon Sep 24, 2018 7:39 pm
by atc98092
Ah yes. Burning in the subs will force transcoding, regardless of any other settings. Glad that's resolved. :)