FAQ  •  Register  •  Login

Profile Request: Sony-S6700 cannot play AVI files

<<

sully0222

Serviio newbie

Posts: 1

Joined: Sun Aug 15, 2021 3:46 pm

Post Sun Aug 15, 2021 4:34 pm

Profile Request: Sony-S6700 cannot play AVI files

I replaced a Sony blu-rau player that could stream AVI files with a Sony BDP-S6700 play thay is not able to play any AVI files.

Every file which has a .avi suffix results in "The file is corrupt of unsupported".

The profile I started with is Sony BDP-Sx80/SMP-N200 (2011), but every profile I have tried has resulted n the same failure.

I am new at this, and unsure of what I can provide to help someone help me, but I set the log level to debug, and some excerpts follow:

2021-08-15 11:08:08,473 INFO [PlaybackEventsManager] Playback of media item 1713 (S3extras9 [S3extras9.avi]) has started at 0% on Identifier=192.168.1.20, Profile=Sony BDP-Sx70/SMP-N100 (2010) - US, Name=BDP-S6700
2021-08-15 11:08:08,491 DEBUG [VideoDeliveryEngine] Delivering file 'S3extras9.avi' in native format
2021-08-15 11:08:08,491 DEBUG [MediaItemDAOImpl] Getting file of media item 1713
2021-08-15 11:08:08,491 DEBUG [GETMethodProcessor] Stream entity has length: 33280
2021-08-15 11:08:08,491 DEBUG [ResourceTransportRequestHandler] HTTP/1.1 206 Partial Content, headers = [[Content-Length: 33280,Content-Type: video/mpeg,Cache-control: no-cache,Connection: close,Content-Range: bytes 32256-65535/6281216,contentFeatures.dlna.org: DLNA.ORG_PN=MPEG_PS_PAL;DLNA.ORG_OP=01;DLNA.ORG_CI=0;DLNA.ORG_FLAGS=01500000000000000000000000000000,Date: Sun, 15 Aug 2021 16:08:08 GMT,realTimeInfo.dlna.org: DLNA.ORG_TLAG=*,Server: Windows_10 UPnP/1.0 DLNADOC/1.50 Serviio/2.1,transferMode.dlna.org: Streaming]]
2021-08-15 11:08:08,512 DEBUG [ServiioHttpService] Incoming request from /192.168.1.20:38743: GET /resource/1713/MEDIA_ITEM/AVI-0/ORIGINAL HTTP/1.1, headers = [Host: 192.168.1.4:8895,Accept: */*,Range: bytes=65024-98303,X-AV-Physical-Unit-Info: pa="BDP-S6700",X-AV-Client-Info: av=5.0; cn="Sony Corporation"; mn="BDP-S6700"; mv="2.0",getcontentFeatures.dlna.org: 1,Pragma: getIfoFileURI.dlna.org,transferMode.dlna.org: Streaming]]
2021-08-15 11:08:08,513 DEBUG [RendererDAOImpl] Reading a Renderer with ip address 192.168.1.20
2021-08-15 11:08:08,513 DEBUG [RendererService] Rendered 00000000-0000-1010-8000-143fa65681b4 doesn't have a User assigned to it, using Default
2021-08-15 11:08:08,535 DEBUG [VideoDeliveryEngine] Retrieving resource information for item 1713, format AVI and profile Sony BDP-Sx70/SMP-N100 (2010) - US

At this point, the log gets very repetitive, and I'm not seeing anything else that is unique and helpful.

I'm hoping someone else has resolved this issue for streaming AVI files to a Sony BDP-S6700 and can help.

-- Thanks in advance
<<

atc98092

User avatar

DLNA master

Posts: 4651

Joined: Fri Aug 17, 2012 10:22 pm

Location: Washington (the state)

Post Sun Aug 15, 2021 9:28 pm

Re: Profile Request: Sony-S6700 cannot play AVI files

I just looked at the BDP-Sx80/SMP-N200 (2011) profile, as well as the profile that it inherits from, and I don't see a good AVI Matches line. In the parent profile, I see an AVI match, but only if the video is H.264. On the child profile, it too has two extremely narrow Matches lines: one for mpeg4 video and one for msmpeg4 video. I don't know anything specific about that last one.

I don't have any AVI files immediately available, so I can't see what sort of codecs might be inside. As an experiment, try using the "Roku 4K Media Player (2016+)" profile. It simply matches any AVI file, regardless of content, and transcodes it into applehttp/HLS. This is basically the same as if were using the MOV container. Perhaps your BD player doesn't support that either, but it's worth a try.
Dan

LG NANO85 4K TV, Samsung JU7100 4K TV, Sony BDP-S3500, Sharp 4K Roku TV, Insignia Roku TV, Roku Ultra, Premiere and Stick, Nvidia Shield, Yamaha RX-V583 AVR.
Primary server: Intel i5-6400, 8 gig ram, Windows 10 Pro, 22 TB hard drive space | Test server Windows 10 Pro, AMD Phenom II X4 965, 8 gig ram

HOWTO: Enable debug logging HOWTO: Identify media file contents
<<

bkeith4web

Streaming enthusiast

Posts: 22

Joined: Sat Feb 02, 2013 11:48 pm

Post Sun Dec 26, 2021 4:52 pm

Re: Profile Request: Sony-S6700 cannot play AVI files

Re the Sony BDP-S6700, I have one and the best match I've found so far is using the bdp2013/Sx100 profile. The Sony user guide actually lists the codecs it is supposed to support with footnotes about ones that "may" or may not play via DLNA (as opposed to on a USB stick).

One thing to note is that it doesn't support eac3 audio so I've had to create a custom profile that (after checking for everything else like h265 to get a full encode if needed) it will always transcode just the audio if it's eac3. This line is all it takes at the end of the Transcoding section:

<Video targetContainer="mpegts" targetACodec="ac3" aBitrate="320" forceInheritance="true">
<Matches container="*" aCodec="eac3" />

Another option is to use something like the Vizio TV profile that transcodes EVERYTHING to mpeg-ts/mpeg2/ac3 (aac audio should work too):
<Video targetContainer="mpeg" targetVCodec="mpeg2video" maxVBitrate="12000" targetACodec="ac3" aSamplerate="48000">
<Matches container="*" />

As a side note, I have not been able to get online sources to work at all on this player, transcoded or not, and I'm going to replace it with the older Sony BDP-S5100 that is much better at supporting DLNA. I've had one of those for years and I have another on the way that I found for $30 on ebay. My mistake was buying a S-6700 thinking it would be "better" than the S-5100.

Good Luck!
Brian
<<

atc98092

User avatar

DLNA master

Posts: 4651

Joined: Fri Aug 17, 2012 10:22 pm

Location: Washington (the state)

Post Sun Dec 26, 2021 8:37 pm

Re: Profile Request: Sony-S6700 cannot play AVI files

Sony's support of DLNA has deteriorated over the years. I had older players that would bitstream both TrueHD and DTS Master Audio via DLNA, but my last model will only bitstream TrueHD. I gave up on using the apps in a Blu Ray player years ago. Roku provides a better streaming experience, and for my HD/UHD movie rips with lossless audio I use the Nvidia Shield with Kodi as my player. I can't say when the last time I even powered on my Sony BD player, as we never watch the physical disc anymore. Everything we buy is ripped with MakeMKV and stored on my Serviio server.
Dan

LG NANO85 4K TV, Samsung JU7100 4K TV, Sony BDP-S3500, Sharp 4K Roku TV, Insignia Roku TV, Roku Ultra, Premiere and Stick, Nvidia Shield, Yamaha RX-V583 AVR.
Primary server: Intel i5-6400, 8 gig ram, Windows 10 Pro, 22 TB hard drive space | Test server Windows 10 Pro, AMD Phenom II X4 965, 8 gig ram

HOWTO: Enable debug logging HOWTO: Identify media file contents
<<

bkeith4web

Streaming enthusiast

Posts: 22

Joined: Sat Feb 02, 2013 11:48 pm

Post Mon Dec 27, 2021 1:19 am

Re: Profile Request: Sony-S6700 cannot play AVI files

I definitely get that, all my music CDs are long gone but I've got a collection of stuff on DVD that I will "eventually" get around to watching, maybe even before I die. I didn't have enough disk space to rip them all, so I still use the DVD player now and then.

I would have gone with a shield, that would have saved me a lot of time but since I can get another S-5100 for $30 shipped, that's the way I went. I'm trying to strike the correct balance between cheap, lazy and stubborn :lol:

Brian
<<

atc98092

User avatar

DLNA master

Posts: 4651

Joined: Fri Aug 17, 2012 10:22 pm

Location: Washington (the state)

Post Mon Dec 27, 2021 1:35 am

Re: Profile Request: Sony-S6700 cannot play AVI files

Well, you can get an Onn 4K streaming player from Walmart for about $25. It's Android TV based, and while it won't bitstream the lossless audio tracks, it does about everything else my Shield does. I've been tinkering around with one using Kodi and Serviio, and it's almost as good as the Shield for a fraction of the price.
Dan

LG NANO85 4K TV, Samsung JU7100 4K TV, Sony BDP-S3500, Sharp 4K Roku TV, Insignia Roku TV, Roku Ultra, Premiere and Stick, Nvidia Shield, Yamaha RX-V583 AVR.
Primary server: Intel i5-6400, 8 gig ram, Windows 10 Pro, 22 TB hard drive space | Test server Windows 10 Pro, AMD Phenom II X4 965, 8 gig ram

HOWTO: Enable debug logging HOWTO: Identify media file contents

Return to Transcoding

Who is online

Users browsing this forum: No registered users and 8 guests

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.