FAQ  •  Register  •  Login

Sony BDP-S5100 Profile Created and Tested - Sploit

<<

sploit

Serviio newbie

Posts: 9

Joined: Thu Aug 06, 2015 12:38 am

Post Thu Aug 06, 2015 12:55 am

Sony BDP-S5100 Profile Created and Tested - Sploit

Hi guys. I am releasing this Beta Version of the Sony Bluray BDP-S5100 Profile Code. It has been tested on two identical Bluray S5100 3d Players in the house. It plays MKV, AVI, Mp4 and Others with FF AND RW working and tested. I have played all media tv series that I have and Movies from Yify Releases to Garbage Other releases.
The stock Bluray Profiles in Serviio will only play certain Files but not all. So keep me updated if anything doesnt play and example downloads of the videos.and i will try and get then working. I am also working on Roku2 and Roku 3 Profiles for FF and RW. I have FF and RW working on some files but not others. I will update with a Roku thread when i get the majority of files FF and RW working. This is a transcoding issue with Serviio and can be fixed even though Roku created the problem. Anyway... heres the Profile for BDP-S5100.
  Code:
<!-- Sony BDP-S5100 Profile - Sploit Mod -->
   <Profile id="bdp2013sploitmod" name="Sony BDP-S5100 Sploit" extendsProfileId="1">
      <DeviceDescription>
         <!-- act as WMP so that the TV doesn't show root categories -->
         <ModelName>Windows Media Player Sharing</ModelName>
         <ModelNumber>3.0</ModelNumber>
         <Manufacturer>Microsoft Corporation</Manufacturer>
      </DeviceDescription>
      <ContentDirectoryMessageBuilder>org.serviio.upnp.service.contentdirectory.SonyDLNAMessageBuilder</ContentDirectoryMessageBuilder>
      <ContentDirectoryDefinitionFilter>org.serviio.upnp.service.contentdirectory.definition.WMPContentDirectoryDefinitionFilter</ContentDirectoryDefinitionFilter>
      <MediaFormatProfiles>
         <!-- rename native WMA formats to those supported by the tv -->
         <MediaFormatProfile mime-type="audio/x-ms-wma" name="WMABASE">WMA_BASE</MediaFormatProfile>
         <MediaFormatProfile mime-type="audio/x-ms-wma" name="WMAFULL">WMA_FULL</MediaFormatProfile>
         <!-- rename 3gp profiles that can be played as AVC -->
         <MediaFormatProfile mime-type="video/mp4" name="AVC_MP4_MP_SD_AAC_MULT5">AVC_3GPP_BL_QCIF15_AAC</MediaFormatProfile>
      </MediaFormatProfiles>
      <H264LevelCheck>FILE_ATTRIBUTES</H264LevelCheck>
      <Transcoding>
         <!-- For dvr-ms files force mpeg2video transcoding to fix monotone timestamps problems -->
         <Video targetContainer="mpegts" targetACodec="ac3" forceVTranscoding="true" forceInheritance="true">
            <Matches container="asf" vCodec="mpeg2video" />
            <Matches container="asf" vCodec="mpeg1video" />
         </Video>
         <!-- h264 videos with high/main profile level > 4.x will be transcoded to mpegts with mpeg2video and ac3 audio -->
         <Video targetContainer="mpegts" targetVCodec="mpeg2video" maxVBitrate="15000" targetACodec="ac3" aBitrate="320" forceInheritance="true">
             <Matches container="*" vCodec="h265"/>
            <Matches container="*" vCodec="h264" profile="high_10" />
            <Matches container="*" vCodec="h264" profile="high_444" />
            <Matches container="*" vCodec="h264" profile="high_422" />
            <Matches container="*" vCodec="h264" profile="high" levelGreaterThan="4.2" />
            <Matches container="*" vCodec="h264" profile="main" levelGreaterThan="4.2" />
            <Matches container="matroska" vCodec="vp8" />
               <Matches container="matroska" aCodec="dts-hd" />   
               <Matches container="matroska" aCodec="vorbis" />
               <Matches container="matroska" aCodec="truehd" />
                        <Matches container="matroska" aCodec="flac" />
                        <!-- Matches container="mpeg" aCodec="lpcm" / -->
               <Matches container="ogg" vCodec="mpeg4" />
               <Matches container="mp4" aCodec="lpcm" />
         </Video>
         <Video targetContainer="mpegts" forceInheritance="true">
            <Matches container="matroska" />
            <Matches container="flv" vCodec="h264" />
            <!-- Matches container="mp4" vCodec="h264" / -->
            <!--Matches container="mpeg" vCodec="h264" / -->
            <!-- Matches container="avi" vCodec="h264" / -->
         </Video>
         <!-- unsupported codecs will be transcoded to mpegts with mpeg2video and ac3 audio -->
         <Video targetContainer="mpegts" targetVCodec="mpeg2video" maxVBitrate="17000" targetACodec="ac3" aBitrate="320" forceInheritance="true">
            <!-- DivX and AVI Transcode -->
            <Matches container="avi" vCodec="mpeg4" vFourCC="div3,div4,div5,divx,dm4v,dx50" />
            <Matches container="avi" vCodec="msmpeg4" vFourCC="div3,div4,div5,divx,dm4v,dx50" />
            <Matches container="mp4" vCodec="dvvideo" />
            <Matches container="mp4" vCodec="mjpeg" />
            <Matches container="flv" />
            <Matches container="wtv" />
            <Matches container="ogg" />
            <Matches container="rm" />
         </Video>
         <Audio targetContainer="lpcm" forceInheritance="true">
            <!-- To allow "pause" then "resume" functions and album art for TVs that support it - transcode to mp3 instead -->
            <Matches container="ogg" />
            <Matches container="mp2" />
            <Matches container="wavpack" />
            <Matches container="mpc" />
            <Matches container="ape" />
         </Audio>         
      </Transcoding>
      <OnlineTranscoding>
         <Video targetContainer="mpegts">
            <!-- do not transcode to ac3 -->
            <Matches container="mp4" />
            <Matches container="flv" vCodec="h264" />
            <Matches container="applehttp" vCodec="h264" />
         </Video>
         <Video targetContainer="mpeg" targetVCodec="mpeg2video" targetACodec="ac3" aBitrate="320" forceInheritance="true">
            <Matches container="asf" /> <!-- to support mms:// streams -->
            <Matches container="flv" />
         </Video>
      </OnlineTranscoding>
      <HardSubsTranscoding>
         <Video targetContainer="mpegts" targetVCodec="mpeg2video" targetACodec="ac3" maxVBitrate="17000" aBitrate="320" />
      </HardSubsTranscoding>
      <LimitImageResolution>false</LimitImageResolution>
   </Profile>



For those of you who dont know how to edit the profiles.xml then you need to read up on it.
But Here is a Link to a Stock Profiles.xml I uploaded with my code for those of you who dont know how to edit and just need to replace the file.
Attachments
profiles.xml
profiles.xml bdp-s5100 SploitMod
(148.58 KiB) Downloaded 494 times
<<

tstrike

Serviio lover

Posts: 79

Joined: Fri May 10, 2013 5:03 am

Post Wed Sep 02, 2015 6:53 am

Re: Sony BDP-S5100 Profile Created and Tested - Sploit

I am going to try this with my BDP BX58 for giggles
<<

atc98092

User avatar

DLNA master

Posts: 3451

Joined: Fri Aug 17, 2012 10:22 pm

Location: Washington (the state)

Post Wed Sep 02, 2015 12:47 pm

Re: Sony BDP-S5100 Profile Created and Tested - Sploit

I'll give it a shot with the BDP-S3500. Just bought one last night, and using the generic profile it plays almost everything. Did encounter one issue: the player won't bitstream Dolby trueHD, it just throws an incompatible audio error. But it does pass DTS Master Audio with no problems. That's stupid on Sony's part. Bitstream is bitstream, regardless of the codec. :x
Dan

Panasonic ST30 Plasma, Samsung JU7100 4K TV, Sony BDP-S3500, Sharp 4K Roku TV, Insignia Roku TV, Roku 4, Ultra and Stick, Nvidia Shield, Yamaha RX-V583 AVR.
Primary server: Intel i5-6400, 8 gig ram, Windows 10 Pro, 18 TB hard drive space | Test server Windows 10 Pro, AMD Phenom II X4 965, 8 gig ram

HOWTO: Enable debug logging HOWTO: Identify media file contents
<<

sploit

Serviio newbie

Posts: 9

Joined: Thu Aug 06, 2015 12:38 am

Post Sun Sep 06, 2015 10:02 pm

Re: Sony BDP-S5100 Profile Created and Tested - Sploit

Well... Initially I tried all the Default Serviio Sony Bluray Profiles. One would play one thing and not another. Had the most trouble with Avi Files. Im Using a Hp 6000 Pro with 8gb Ram and a Intel q9400 as the processor with 6gbs Sata as Hard Drives and Transcoding is Perfect across Gigabit.

What I had to do was take the pieces from each sony Profile that did work and then piece by piece get each Video file to play. I got Older Avi Transcoding first then Mkv etc... Was Trial and error.but everything Plays and Fast forwards / rewinds. I would like everything that can play native to play native but to Get Everything to always work that way is difficult. So far I havent had any issues with this profile but I have made some adjustments. I will release them later. I have 5 Sony Bluray S5100 operating in the House Now no issues. Im not sure if it will work with the other Sony SXXXX Series or not but with the 5100 its doing well.
<<

tstrike

Serviio lover

Posts: 79

Joined: Fri May 10, 2013 5:03 am

Post Thu Sep 24, 2015 3:29 am

Re: Sony BDP-S5100 Profile Created and Tested - Sploit

sploit wrote:Well... Initially I tried all the Default Serviio Sony Bluray Profiles. One would play one thing and not another. Had the most trouble with Avi Files. Im Using a Hp 6000 Pro with 8gb Ram and a Intel q9400 as the processor with 6gbs Sata as Hard Drives and Transcoding is Perfect across Gigabit.

What I had to do was take the pieces from each sony Profile that did work and then piece by piece get each Video file to play. I got Older Avi Transcoding first then Mkv etc... Was Trial and error.but everything Plays and Fast forwards / rewinds. I would like everything that can play native to play native but to Get Everything to always work that way is difficult. So far I havent had any issues with this profile but I have made some adjustments. I will release them later. I have 5 Sony Bluray S5100 operating in the House Now no issues. Im not sure if it will work with the other Sony SXXXX Series or not but with the 5100 its doing well.



So is the code in the original post a result of your trial and error? By the way great job for putting in the uber hard work.

Dunno why Thumbnails dont work on Sony BDP.

OffTopic: Has anyone ever been able to hack a Sony BDP? It seems to be a mystery.
<<

sploit

Serviio newbie

Posts: 9

Joined: Thu Aug 06, 2015 12:38 am

Post Tue Sep 29, 2015 9:58 pm

Re: Sony BDP-S5100 Profile Created and Tested - Sploit

Yes. The above profile (ongoing) is the result of extreme trial and error and a very patient family member helping test the BDP-S5100. So far that profile data plays everything and allows FF/RW. Every once in awhile certain Utube or Generically encoded videos will freeze shortly on FF/RW but it seems to be the Bitstream Size limitation on the Sony S5100.

Tstrike- As far as your question on hacking the BDP-S5100... Hacking as in Hardwar? What are you thinking? Like removal of certain Sony Copy Protection features? Im curious too? Maybe It can be a project. :)

The real practical sollution :D I have come up with foe future Media Players are installing HP Ultra Slim Computers with HDMI OUT at the TV's instead of the Blurays. Solves any need for transcoding.... But more expensive :)
<<

tstrike

Serviio lover

Posts: 79

Joined: Fri May 10, 2013 5:03 am

Post Thu Oct 01, 2015 4:43 am

Re: Sony BDP-S5100 Profile Created and Tested - Sploit

sploit wrote:
Tstrike- As far as your question on hacking the BDP-S5100... Hacking as in Hardwar? What are you thinking? Like removal of certain Sony Copy Protection features? Im curious too? Maybe It can be a project. :)

)


Yes... My intent is to get in and look at the software packages... Been trying to figure how Sony is able to update the software on those blurays... Given that Sony access the box remotely (more like a pull from the BDP to Sony) I was interested in accessing the BDP myself to update and/or install software... Even solving the mysterious no thumbnails issue that BDPs (and older BDPs like I have) have...

If it is indeed a pull from BDP to Sony, there has to be a config file to alter where the pull is coming from (I bet dollars to donuts that BDP is linux/Unix based). I have Googled everywhere with little or no success.

If my BDP is not warrantied and not supported, I believe it is fair game for a hacking. Heck, might be able to install Serviio on it... :lol: :roll: :lol: ;)
<<

sploit

Serviio newbie

Posts: 9

Joined: Thu Aug 06, 2015 12:38 am

Post Fri Nov 06, 2015 7:48 am

Re: Sony BDP-S5100 Profile Created and Tested - Sploit

https://www.exploitee.rs/index.php/Sony_BDP-S5100


Now what do we do with it for fun :)
:D
<<

tstrike

Serviio lover

Posts: 79

Joined: Fri May 10, 2013 5:03 am

Post Tue Nov 10, 2015 11:58 am

Re: Sony BDP-S5100 Profile Created and Tested - Sploit

sploit wrote:https://www.exploitee.rs/index.php/Sony_BDP-S5100


Now what do we do with it for fun :)
:D

wow nice find!!!!!!
<<

Edja

Serviio newbie

Posts: 1

Joined: Mon Dec 16, 2013 10:05 am

Post Thu Dec 24, 2015 2:44 pm

Re: Sony BDP-S5100 Profile Created and Tested - Sploit

sploit wrote:

Anyway... here's the Profile for BDP-S5100.
I've been using this BDP-S5100 profile since a few days on my new Sony BDP-S6500 and it works just fine. It is a real improvement compared to the BDP-Sx100(2013) profile that is recommended elsewhere on the forum (with a few modifications). I've been using this for the last two weeks but, with and without these modifications, there are still some files that won't play. But they all do play with the BDP-S5100 Sploit profile.

I've compared the 2 profiles in detail and have seen the differences in the transcoding sections. I have some feeling why they have been added but I still have a lot of reading to do before I will understand the details. So I won't ask to many questions until I feel more comfortable with my own level of understanding.

So at this point just one question : Why did you code maxVBrate ="15000" the first time and later in the profile you code maxVBrate ="17000".

Edja
<<

daggerNC

Serviio newbie

Posts: 3

Joined: Tue Mar 26, 2013 1:24 pm

Post Sat Jan 30, 2016 6:07 am

Re: Sony BDP-S5100 Profile Created and Tested - Sploit

sploit - thanks for this! I have an S5100 so will try this out tomorrow. Having FFW and REW working reliably would be a blessing..
<<

daggerNC

Serviio newbie

Posts: 3

Joined: Tue Mar 26, 2013 1:24 pm

Post Sat Jan 30, 2016 6:32 pm

Re: Sony BDP-S5100 Profile Created and Tested - Sploit

I do not know what I'm doing wrong?? I add your code to my profiles.xml file, and then I can't start serviio. I then downloaded your xml file and copied and inserted your code into my valid profiles.xml file, and again same error. I delete the added lines, and then serviio starts up. I'm on v1.6 - is there a code change required to add it to the v1.6 xml file? Is notepad as the xml editing tool mucking something up when I copy and paste a full profile (but I can cut and past a new single line within the xml file with notepad and it takes my changes no issue)???

Return to Transcoding

Who is online

Users browsing this forum: No registered users and 3 guests

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.