FAQ  •  Register  •  Login

Help creating a profile for Sony Google TV NSZ-40GT1

<<

pixelwix

Serviio newbie

Posts: 2

Joined: Sat Apr 02, 2011 6:38 am

Post Sat Apr 02, 2011 6:44 am

Help creating a profile for Sony Google TV NSZ-40GT1

all my media file play fine except for the files that seem to have pcm_bluray audio

C:\Program Files (x86)\Serviio\lib>ffmpeg.exe -i "D:\BlueRay Movies\Harry Potter
7 Part 1.mpg"
FFmpeg version UNKNOWN, Copyright (c) 2000-2011 the FFmpeg developers
built on Jan 10 2011 21:46:22 with gcc 4.4.2
configuration: --enable-static --disable-shared --disable-shared --disable-ffp
lay --disable-ffserver --enable-memalign-hack --enable-libmp3lame --arch=x86 --e
nable-runtime-cpudetect --enable-w32threads --target-os=mingw32 --cross-prefix=i
686-mingw32-
libavutil 50.36. 0 / 50.36. 0
libavcore 0.16. 0 / 0.16. 0
libavcodec 52.108. 0 / 52.108. 0
libavformat 52.92. 0 / 52.92. 0
libavdevice 52. 2. 3 / 52. 2. 3
libavfilter 1.72. 0 / 1.72. 0
libswscale 0.12. 0 / 0.12. 0
[mpegts @ 012fbc10] max_analyze_duration reached

Seems stream 0 codec frame rate differs from container frame rate: 47.95 (200000
00/417083) -> 23.98 (24000/1001)
Input #0, mpegts, from 'D:\BlueRay Movies\Harry Potter 7 Part 1.mpg':
Duration: 02:26:05.30, start: 599.958300, bitrate: 6885 kb/s
Program 1
Stream #0.0[0x1011]: Video: h264, yuv420p, 1280x536 [PAR 1:1 DAR 160:67], 23
.98 fps, 23.98 tbr, 90k tbn, 47.95 tbc
Stream #0.1[0x1100]: Audio: pcm_bluray, 48000 Hz, stereo, s16, 1536 kb/s
At least one output file must be specified

this is the file info.. any help on how i can transcode the audio so it will play with ps3 profile would be most helpful thanks in advance
<<

Cerberus

User avatar

DLNA master

Posts: 4116

Joined: Sun Jan 02, 2011 5:20 pm

Location: Reading, UK

Post Sat Apr 02, 2011 8:32 am

Re: Help creating a profile for Sony Google TV NSZ-40GT1

Please Provide supported formats of a device so that a profile for this device can be made. ( howto link in my signiture ) then test your device using the GENERIC profile and provide details of files that wont play ( howto link in signiture )...
Phil Bennett
Beta Tester Group
Wiki | FAQ

Samsung LE40C750 LCD | Samsung BD-C5900 | Sony PS3 | Windows 7 |
HowTo: Provide supported formats of a device HowTo: Record a new ticket on Bitbucket
HowTo: Provide details of a video file that doesn't play HowTo: Turn on detailed logging
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 16937

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Sat Apr 02, 2011 10:44 am

Re: Help creating a profile for Sony Google TV NSZ-40GT1

I assume you're using the Bravia profile.

Find this in your profiles.xml (in the Bravia profile):

  Code:
<!-- if audio different to ac3, must be transcoded -->


and add this line underneath:

  Code:
<Matches container="mpegts" aCodec="lpcm" />


Save profiles.xml and restart the service.
<<

pixelwix

Serviio newbie

Posts: 2

Joined: Sat Apr 02, 2011 6:38 am

Post Tue Apr 05, 2011 10:19 pm

Re: Help creating a profile for Sony Google TV NSZ-40GT1

i'm using the sony bluray player profile, the bravia profile doesn't play any of the movies. could you give me settings for the bluray profile?
<<

mrecio

Serviio newbie

Posts: 5

Joined: Thu Apr 07, 2011 4:26 pm

Post Thu Apr 07, 2011 4:43 pm

Re: Help creating a profile for Sony Google TV NSZ-40GT1

I also have this TV and would love a specific profile for it.

I am a new user of Serviio (got it two days ago) and think its the best server out of the 5 I tried. The built in Bravia profile works flawlessly with my 32EX308 Bravia TV however it does not work at all with the NSX-40GT1. the supported formats are different. As far as I can tell from the sony website the Google TV supports the following

AAC/MPEG4-AAC
H.264/MPEG-4 AVC
MP3 MPEG-1 Audio Layer

It doesnt mention DLNA support but the built in media player does see the server and plays almost everything fine with the generic profile however I have run into a few movies that do not play audio.

I am new to all this codec stuff but AAC and MP3 are the only supported audio? if so how would I create a profile that transcodes audio but leave video alone and keeps the MPEG4 format?
<<

Cerberus

User avatar

DLNA master

Posts: 4116

Joined: Sun Jan 02, 2011 5:20 pm

Location: Reading, UK

Post Thu Apr 07, 2011 5:05 pm

Re: Help creating a profile for Sony Google TV NSZ-40GT1

mrecio wrote:I also have this TV and would love a specific profile for it.

I am a new user of Serviio (got it two days ago) and think its the best server out of the 5 I tried. The built in Bravia profile works flawlessly with my 32EX308 Bravia TV however it does not work at all with the NSX-40GT1. the supported formats are different. As far as I can tell from the sony website the Google TV supports the following

AAC/MPEG4-AAC
H.264/MPEG-4 AVC
MP3 MPEG-1 Audio Layer

It doesnt mention DLNA support but the built in media player does see the server and plays almost everything fine with the generic profile however I have run into a few movies that do not play audio.

I am new to all this codec stuff but AAC and MP3 are the only supported audio? if so how would I create a profile that transcodes audio but leave video alone and keeps the MPEG4 format?


you need to provide some details on the device and on the files that wont play. (see my signiture for links )
Phil Bennett
Beta Tester Group
Wiki | FAQ

Samsung LE40C750 LCD | Samsung BD-C5900 | Sony PS3 | Windows 7 |
HowTo: Provide supported formats of a device HowTo: Record a new ticket on Bitbucket
HowTo: Provide details of a video file that doesn't play HowTo: Turn on detailed logging
<<

mrecio

Serviio newbie

Posts: 5

Joined: Thu Apr 07, 2011 4:26 pm

Post Thu Apr 07, 2011 5:53 pm

Re: Help creating a profile for Sony Google TV NSZ-40GT1

I will try to provide all the info I can, however I am not at home and am RDPing into my server to get this info. I dont think the UPnP software can scan my TV as the TV is off lol. so the only info I can give you is whats on sony's site, is that not adequate? Ive turned on detailed logging but its not going to log anything until I get home and use the service.

I tried using ffmpeg to get video file info but keep getting a permission issue for some reason? I have full access to the file but FFmpeg is not playing nice.

any suggestions?

Return to Transcoding

Who is online

Users browsing this forum: Google [Bot] and 4 guests

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.