FAQ  •  Register  •  Login

Humax h265/hevc transcoding - changes not instantly visible

<<

ttguy

Serviio lover

Posts: 63

Joined: Sun May 27, 2012 10:52 am

Post Sun Dec 23, 2018 1:08 pm

Humax h265/hevc transcoding - changes not instantly visible

So I ran into some .mkv files that would only play audio and not the video when being delivered via serviio to my Humax hdr3000t PVR
The files in question were reported by ffprobe to have the following properties for the video stream:

Stream #0:0: Video: hevc (Main), yuv420p(tv, bt709), 1912x1076 [SAR 1:1 DAR 478:269], 23.98 fps, 23.98 tbr,

Professor Google told me that hevc is also known as h265. So I set up this profile on the serviio

  Code:
          <Profile id="humax" name="Humax" extendsProfileId="1">
      <Detection>
         <UPnPSearch>
            <ModelName>hdr3000t</ModelName>
            <Manufacturer>Humax</Manufacturer>
         </UPnPSearch>
      </Detection>
      <DeviceDescription>
         <ModelName>Humax HDR-3000T personal video recorder</ModelName>
         <ModelNumber>3000</ModelNumber>
         <Manufacturer>Humax</Manufacturer>
      </DeviceDescription>
      
      <Transcoding>
                    <Video targetContainer="mpegts" targetVCodec="mpeg2video" maxVBitrate="17000" targetACodec="ac3" aBitrate="320" forceInheritance="true">
                    <Matches container="matroska" vCodec="h265" aCodec="aac" />
                 </Video>
      </Transcoding>
       
        </Profile>

I rebooted my serviio and set the PVR to use the Humax profile. And the the file refused to play at all on the Humax PVR
And with this text in the debug
  Code:
DEBUG [VideoDeliveryEngine] Retrieving resource information for item 694, format MATROSKA and profile Humax
DEBUG [AbstractAVTranscodingDeliveryEngine] Getting media info for transcoded version of file The.File1080p.WEB-DL.2CH.x265.HEVC-PSA.mkv
DEBUG [VideoDeliveryEngine] Found Format profile for transcoded file "The.File.1080p.WEB-DL.2CH.x265.HEVC-PSA.mkv": MPEG_TS_SD_EU_ISO
DEBUG [VideoDeliveryEngine] Found Format profile for transcoded file "The.File.1080p.WEB-DL.2CH.x265.HEVC-PSA.mkv": MPEG_TS_SD_NA_ISO
DEBUG [VideoDeliveryEngine] Found Format profile for transcoded file "The.File.1080p.WEB-DL.2CH.x265.HEVC-PSA.mkv": MPEG_TS_SD_KO_ISO
WARN  [ResourceDeliveryProcessor] Invalid request, sending back 500 error
org.serviio.dlna.UnsupportedDLNAMediaFileFormatException: No media description available for required version: MATROSKA


However, several hours later and after another reboot of the serviio machine and restarting the Humax PVR (but no change to the profiles.xml) the file does play.
And the log has all this good news:
  Code:
DEBUG [RendererDAOImpl] Reading a Renderer with ip address 192.168.1.9
DEBUG [ResourceDeliveryProcessor] Resource request accepted. Using client 'Identifier=192.168.1.9, Profile=Humax, Name=PVR'
DEBUG [ResourceDeliveryProcessor] Request for resource 694 and type 'MEDIA_ITEM' received
DEBUG [MediaResourceRetrievalStrategy] Getting information about media item 694 (local)

DEBUG [VideoDeliveryEngine] Retrieving resource information for item 694, format MPEG_TS_SD_EU_ISO and profile Humax
DEBUG [AbstractAVTranscodingDeliveryEngine] Getting media info for transcoded version of file The.File.1080p.WEB-DL.2CH.x265.HEVC-PSA.mkv
DEBUG [VideoDeliveryEngine] Found Format profile for transcoded file "The.File.1080p.WEB-DL.2CH.x265.HEVC-PSA.mkv": MPEG_TS_SD_EU_ISO
DEBUG [VideoDeliveryEngine] Found Format profile for transcoded file "The.File.1080p.WEB-DL.2CH.x265.HEVC-PSA.mkv": MPEG_TS_SD_NA_ISO
DEBUG [VideoDeliveryEngine] Found Format profile for transcoded file "The.File.1080p.WEB-DL.2CH.x265.HEVC-PSA.mkv": MPEG_TS_SD_KO_ISO

DEBUG [MediaResourceRetrievalStrategy] Getting information about media item 694 (local)
DEBUG [VideoDeliveryEngine] Delivering item '694' for client 'Identifier=192.168.1.9, Profile=Humax, Name=PVR'
DEBUG [VideoDeliveryEngine] Delivering file 'The.File.1080p.WEB-DL.2CH.x265.HEVC-PSA.mkv' using transcoding

DEBUG [ImageUtils] Starting image resize, size = 346574 bytes
DEBUG [AbstractAVTranscodingDeliveryEngine] No suitable transcoding job exists yet, start one for client 'Identifier=192.168.1.9, Profile=Humax, Name=PVR'

DEBUG [FFMPEGWrapper] Invoking FFmpeg to transcode video file: /home/god/Videos/Files/The.File.1080p.WEB-DL.2CH.x265.HEVC-PSA/The.File.1080p.WEB-DL.2CH.x265.HEVC-PSA.mkv

DEBUG [ProcessExecutor] Starting ffmpeg -threads 0 -i /home/god/Videos/Files/The.File.1080p.WEB-DL.2CH.x265.HEVC-PSA/The.File.1080p.WEB-DL.2CH.x265.HEVC-PSA.mkv -y -threads 0 -c:v mpeg2video -pix_fmt yuv420p -b:v 17000k -maxrate:v 17000k -bufsize:v 17000k -r 24000/1001 -g 15 -c:a:0 ac3 -b:a:0 320k -ac:a:0 2 -map 0:0 -map 0:1 -sn -f mpegts /tmp/Serviio/transcoding-temp-074dfd5ae644515ff4ae4801588f3ca7.stf


So this post is to share my transcoding profile for humax.

But to also ask - why did I have to wait several hours or do multiple reboots of the serviio or to restart the Humax before my transcoding profile worked? This bugs me because it makes it pretty hard to trouble shoot transcoding issues when you can not be sure that the issue you see is permanent. And that it can take an unknown amount of time for changes to kick in properly.
--
linux/Humax HDR-3000T
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 17051

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Mon Dec 31, 2018 3:05 pm

Re: Humax h265/hevc transcoding - changes not instantly vis

most likely your player used the original cached version of the URL for the non-transcoded video, Serviio complained it's not available anymore. Eventually your player fetched the updated media info from Serviio and is started to work again.
<<

ttguy

Serviio lover

Posts: 63

Joined: Sun May 27, 2012 10:52 am

Post Sun Mar 24, 2019 8:26 am

Re: Humax h265/hevc transcoding - changes not instantly vis

I had to take my serviio down again to take on some OS updates and when it came back up again the files failed to play the video again.

Then the next day they worked. So I guess it could be a caching issue.

The log files suggested that the files did not play the files were identified under Identifier=192.168.1.8,Profile=Generic DLNA profile, Name=Unrecognized device.

And then when it worked
Identifier=192.168.1.8, Profile=Humax, Name=PVR
--
linux/Humax HDR-3000T
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 17051

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Tue Apr 16, 2019 9:49 pm

Re: Humax h265/hevc transcoding - changes not instantly vis

this may happen if there are 2 DLNA clients on the same IP address.

Return to Transcoding

Who is online

Users browsing this forum: No registered users and 8 guests

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.