FAQ  •  Register  •  Login

Serviio 2.1 External and extermal secure ports do NOT work

<<

jemail

Serviio newbie

Posts: 4

Joined: Wed Dec 02, 2020 8:47 pm

Post Wed Dec 02, 2020 9:23 pm

Serviio 2.1 External and extermal secure ports do NOT work

HI,

I have an instance of serviio 2.1 running on a server and I set:

External Port 24424 External Secure Port: 24524

I reboot the server to ensure settings stick. Serviio Console informs me my choices have been made.

However
# sockstat -4 -l
USER COMMAND PID FD PROTO LOCAL ADDRESS FOREIGN ADDRESS
dlna java 86525 120 tcp4 192.168.1.32:23423 *:*
dlna java 86525 130 tcp4 192.168.1.32:23424 *:*
dlna java 86525 152 tcp4 *:8895 *:*
dlna java 86525 156 udp4 *:1900 *:*

You can plainly see serviio is running on the default ports totally ignoring my custom ports.
What am I doing wrong here?
How do I get serviio 2.1 to run on the requested ports?
<<

atc98092

User avatar

DLNA master

Posts: 4361

Joined: Fri Aug 17, 2012 10:22 pm

Location: Washington (the state)

Post Wed Dec 02, 2020 10:19 pm

Re: Serviio 2.1 External and extermal secure ports do NOT wo

How are you setting those properties? I just want to verify the steps you've taken. If you're referring to the advanced settings on the console remote tab, that doesn't change the ports that Serviio uses. That's telling Serviio what external ports you are using through your firewall.

To change the ports Serviio itself uses, you edit the user.vmoptions file in the config folder, following the options listed in this help page: https://www.serviio.org/index.php?optio ... icle&id=43
Dan

LG NANO85 4K TV, Samsung JU7100 4K TV, Sony BDP-S3500, Sharp 4K Roku TV, Insignia Roku TV, Roku Ultra, Premiere and Stick, Nvidia Shield, Yamaha RX-V583 AVR.
Primary server: Intel i5-6400, 8 gig ram, Windows 10 Pro, 22 TB hard drive space | Test server Windows 10 Pro, AMD Phenom II X4 965, 8 gig ram

HOWTO: Enable debug logging HOWTO: Identify media file contents
<<

jemail

Serviio newbie

Posts: 4

Joined: Wed Dec 02, 2020 8:47 pm

Post Thu Dec 03, 2020 4:09 pm

Re: Serviio 2.1 External and extermal secure ports do NOT wo

atc98092 wrote:How are you setting those properties? I just want to verify the steps you've taken. If you're referring to the advanced settings on the console remote tab, that doesn't change the ports that Serviio uses. That's telling Serviio what external ports you are using through your firewall.

To change the ports Serviio itself uses, you edit the user.vmoptions file in the config folder, following the options listed in this help page: https://www.serviio.org/index.php?optio ... icle&id=43


I was using the Advanced Settings on the remote tab.
I am running serviio on FreeBSD 12.2 in a jail. I don't see a user.vmoptions file in /usr/local/etc/serviio.
I guess I edit the rc.conf and pass options there?

Thanks for your help.
<<

atc98092

User avatar

DLNA master

Posts: 4361

Joined: Fri Aug 17, 2012 10:22 pm

Location: Washington (the state)

Post Thu Dec 03, 2020 4:19 pm

Re: Serviio 2.1 External and extermal secure ports do NOT wo

Yes, I believe you have to create the file manually. Serviio created mine because I had a user setting in the main system file, and when the developer added this new function it migrated it for me. Here's the content of my user.vmoptions file:
  Code:
-Xmx512m
-Dserviio.hdThumbnailResolution=1000

There's no format to it, like the XML files require. I use it to increase the resolution of my thumbnail images, which is what the second line does. Based on what you want to do, you need to add the lines:
  Code:
-Dserviio.cdsHttpPort=24424
-Dserviio.cdsHttpsPort=24524


Finally, open the ServiioService.exe.vmoptions file in the Serviio/bin folder and add this line:
  Code:
-include-options ${EXE4J_EXEDIR}\..\config\user.vmoptions


Restart Serviio and you should be using the new ports.
Dan

LG NANO85 4K TV, Samsung JU7100 4K TV, Sony BDP-S3500, Sharp 4K Roku TV, Insignia Roku TV, Roku Ultra, Premiere and Stick, Nvidia Shield, Yamaha RX-V583 AVR.
Primary server: Intel i5-6400, 8 gig ram, Windows 10 Pro, 22 TB hard drive space | Test server Windows 10 Pro, AMD Phenom II X4 965, 8 gig ram

HOWTO: Enable debug logging HOWTO: Identify media file contents

Return to Serviio Support & Help

Who is online

Users browsing this forum: No registered users and 22 guests

cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.