FAQ  •  Register  •  Login

An unexpected error occurred (500). Check the log.

<<

starhu

Serviio newbie

Posts: 2

Joined: Sat Nov 11, 2017 9:22 pm

Post Sat Nov 11, 2017 9:37 pm

An unexpected error occurred (500). Check the log.

Hello,

I love Serviio very much, I think this is the best media server (I use the Windows version).

However it has an annoying bug:
- if I add more then one films to the library, or delete more then one films to the library and then click Save, I get "An unexpected error occurred (500)." message then everything goes back and I need to start it again!
For example I add film A, film B and film C then after the error either only film A will be only in the library or it would be completely empty!

-about every 3rd try I get this error even if I add the films one by one e.g. Add -> Save, Add -> Save . It also deletes everything from the library after the error message.

In the folder of Serviio I couldn't find any log.
A few days ago I downloaded the newest version hoping that this error would stop but it hasn't. I use Windows 7 os.

Thank you for your help!
<<

atc98092

User avatar

DLNA master

Posts: 3451

Joined: Fri Aug 17, 2012 10:22 pm

Location: Washington (the state)

Post Sat Nov 11, 2017 11:12 pm

Re: An unexpected error occurred (500). Check the log.

The log file is located by default at C:\program files\Serviio\Log. It's a simple text file, and if you copy it and upload it here someone can look at it to see what is happening. You might be asked to enable detailed logging for more precise information in the log.
Dan

Panasonic ST30 Plasma, Samsung JU7100 4K TV, Sony BDP-S3500, Sharp 4K Roku TV, Insignia Roku TV, Roku 4, Ultra and Stick, Nvidia Shield, Yamaha RX-V583 AVR.
Primary server: Intel i5-6400, 8 gig ram, Windows 10 Pro, 18 TB hard drive space | Test server Windows 10 Pro, AMD Phenom II X4 965, 8 gig ram

HOWTO: Enable debug logging HOWTO: Identify media file contents
<<

starhu

Serviio newbie

Posts: 2

Joined: Sat Nov 11, 2017 9:22 pm

Post Sun Nov 12, 2017 11:51 am

Re: An unexpected error occurred (500). Check the log.

Hello Dan,

I found the log and I attached it.
There are a lot of these messages:
Caused by: ERROR 23503: DELETE on table 'REPOSITORY' caused a violation of foreign key constraint 'REPOSITORY_FOREIGN_KEY' for key (293). The statement has been rolled back.

So probably it is a database error but I don't understand how it can be. Is the foreign key not set to Cascade?

Thank you.
Attachments
serviio.log
(383.78 KiB) Downloaded 381 times
<<

atc98092

User avatar

DLNA master

Posts: 3451

Joined: Fri Aug 17, 2012 10:22 pm

Location: Washington (the state)

Post Sun Nov 12, 2017 1:17 pm

Re: An unexpected error occurred (500). Check the log.

Zip will now have to answer. Being the developer, he can tell you what it means. But I agree that there might be a DB issue. If you have the time, I would suggest uninstalling Serviio, reboot the computer, then install again. It takes a little time, but might ensure you have a clean DB.
Dan

Panasonic ST30 Plasma, Samsung JU7100 4K TV, Sony BDP-S3500, Sharp 4K Roku TV, Insignia Roku TV, Roku 4, Ultra and Stick, Nvidia Shield, Yamaha RX-V583 AVR.
Primary server: Intel i5-6400, 8 gig ram, Windows 10 Pro, 18 TB hard drive space | Test server Windows 10 Pro, AMD Phenom II X4 965, 8 gig ram

HOWTO: Enable debug logging HOWTO: Identify media file contents
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 17095

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Mon Nov 13, 2017 11:54 am

Re: An unexpected error occurred (500). Check the log.

By saying 'add a film' do you mean adding a shared folder? I will look at that.

But in any case, you should really be adding your i:\Ideig as a shared folder, not one folder per movie.
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 17095

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Mon Nov 13, 2017 10:26 pm

Re: An unexpected error occurred (500). Check the log.

No worries, reproduced and fixed for 1.9.1
<<

user12345678

Streaming enthusiast

Posts: 35

Joined: Sun May 14, 2017 3:25 am

Post Sat Mar 24, 2018 6:56 pm

Re: An unexpected error occurred (500). Check the log.

Ok so i had 1.9 on my Linux Debian
I updated it to 1.9.1 to see if i can get my fast foward and rewind feature back
Now when i add the hdd i get the 500 error
I checked all my group per
It said to look in log file but there is not a log file in the folder, its empty
I did everything this user did in this thread http://forum.serviio.org/viewtopic.php?f=5&t=18257
<<

user12345678

Streaming enthusiast

Posts: 35

Joined: Sun May 14, 2017 3:25 am

Post Sat Mar 24, 2018 7:03 pm

Re: An unexpected error occurred (500). Check the log.

opps forgot to post this too how i installed it http://wiki.serviio.org/doku.php?id=how ... all:debian
I just changed filenames like i did on my 2nd server which works like a champ

sudo -H bash
useradd -r -s /bin/false serviio
mkdir -p /opt
cd /opt
wget http://download.serviio.org/releases/se ... nux.tar.gz
tar zxvf serviio-1.9.1-linux.tar.gz
rm serviio-1.9.1-linux.tar.gz
ln -s serviio-1.9.1 serviio
chown -R root:root serviio-1.9.1
cd serviio-1.9.1
mkdir log
chown -R serviio:serviio library log
<<

user12345678

Streaming enthusiast

Posts: 35

Joined: Sun May 14, 2017 3:25 am

Post Sat Mar 24, 2018 7:34 pm

Re: An unexpected error occurred (500). Check the log.

ok cool beans lets see if i can fast foward my files
how i fixed it was installed gnome disk utility
looked at the mount i did and noticed the defaults was missing something
defaults 0 3
i mounted using terminal edited fstab like so
UUID=28A0884AA0882104 /home/houdini/Videos/Drives/Videos ntfs defaults 0 3 <----0 3 was missing i added that in gnome and bam were good to go

Return to Serviio Support & Help

Who is online

Users browsing this forum: Google [Bot] and 27 guests

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.