Post Thu Feb 06, 2020 12:46 pm

(LN40C630K1FXZA) C series EAC3/Cue MKV issue (solved)

Our Samsung TV is a little bit older model: LN40C630K1FXZA 40". I too was experiencing issues while playing only *some* files using the EAC3 audio codec, using the Samsung B/C series profile of Serviio. Most MKV's, using EAC3, will play just fine, but I have a few 'newer', troublesome ones that cause the Samsung TV to say "Loading" for over a minute and that then cause the TV to power down and restart...

After tinkering with and comparing the various examples of files that would play and not play, I finally found a fix that has worked with every problem file I have tried so far.
I remux the MKV's in MKVToolNix v43.0.0 using these 3 flags:
--engage no_chapters_in_meta_seek --engage no_cue_duration --engage no_cue_relative_position

(Thanks to the MKVToolNix FAQ for the hints.) You can add these in the Output tab / Miscellaneous section / Additional options item. Click the box to the right of the text field and then place check-marks next to all three of these if you don't feel like typing.

In the end, I don't think I am experiencing an EAC3 problem, but rather a "cue" formatting issue in some recent MKV's that just happen to also contain EAC3. I don't know of a way to examine a particular MKV, ahead of time, to know whether or not it will work for me. But, for whatever reason, the above does fix this problem for me. So, give it a try if you're having similar issues.