FAQ  •  Register  •  Login

Samsung B Series - Accelerated frame rate problem

<<

GDarkow

Serviio newbie

Posts: 3

Joined: Sun Aug 21, 2011 2:12 pm

Post Sun Aug 21, 2011 2:35 pm

Samsung B Series - Accelerated frame rate problem

Hello, everyone.

First off, I want to say that I absolutely LOVE Serviio. I've been on nearly a two year quest to find a fast and descriptive media server and, finally, Serviio seems to be the answer.

I have a bit of a problem, however. I own a Samsung B-Series Plasma (PN58B860) and am experiencing an accelerated frame rate on certain MKV files—though I haven't fully tested yet, I believe it is those that are of a DTS audio nature. The files play and there is sound, but both audio and video are both running at about 2-times the speed they should.

In the past, I've used other media servers and have experienced similar issues. Without any transcoding, the TV will play fluid video at the proper frame rate, but to due to the TV's inability to accept DTS audio, there is no audio and a message of "Not Supported Audio Codec" is displayed. On other occasions, after converting files from MKV to mpeg2, the TV will play the file, but again the frame rate and audio are accelerated as well.

There has to be some sort of fix for this beyond simply transcoding EVERYTHING. It seems like an issue with the container the file takes when the audio is converted from DTS to AC3, but I'm at a loss as to how to change the container. While the video is perfectly fluid without any audio transcoding, it seems like there must be a way to simply get the DTS audio to AC3 and send it to the TV in whatever container resembles the file's native container.

I hope this makes sense, and I hope someone can help. Like I said, I love Serviio and if I can just get these DTS files to play properly I'll have a solution I've been searching for for years.
<<

GDarkow

Serviio newbie

Posts: 3

Joined: Sun Aug 21, 2011 2:12 pm

Post Sun Aug 21, 2011 3:54 pm

Re: Samsung B Series - Accelerated frame rate problem

Here's an update:

I've tinkered with the "aBitrate" setting, and I've now managed to get the movies to play normally but only in 2-3 intervals. Basically, the movie begins fine for 2-3 seconds, accelerates for a second, then it's fine for another 2-3 seconds, then it accelerates, etc. etc. etc.

I've tried setting the aBitrate to everything from 192-640.

It seems I'm close now, but still not there... Any ideas?
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 17053

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Mon Aug 22, 2011 10:43 am

Re: Samsung B Series - Accelerated frame rate problem

are you running the latest TV firmware?
<<

GDarkow

Serviio newbie

Posts: 3

Joined: Sun Aug 21, 2011 2:12 pm

Post Mon Aug 22, 2011 6:18 pm

Re: Samsung B Series - Accelerated frame rate problem

Yes, sir. It's a PN58B860 with the latest firmware. I've even tried the older "alternative" firmware and the problem persists. It's quite strange. I used to use PS3 Media Server and serve MKVs that were remuxed in MKV2VOB. Those files played great on the PS3, but when I'd use the TV as a client, I got the same result-everything was accelerated. It seems like it has something to do with the mpeg2ts container. The strange thing is that by upping the bitrate, the problem lessens. It's still not watchable, but the acceleration only happens every three or four seconds.

I believe the firmware I'm on is version *****18. Sorry, not at home to get an exact, but I know I've attempted an update and the TV has stated that I have the latest.

Return to Samsung

Who is online

Users browsing this forum: No registered users and 9 guests

cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.