FAQ  •  Register  •  Login

Samsung D Series - TV displays Sub - BluRay Combo does not.

<<

jhb50

DLNA master

Posts: 2856

Joined: Thu Jun 30, 2011 9:32 pm

Post Wed Aug 31, 2011 5:08 am

Samsung D Series - TV displays Sub - BluRay Combo does not.

I have a Samsung D series TV with DLNA which is recognized by Serviio and set to Samsung C/D Profile and a Samsung D series Combo BluRay/Amp HT-D5300 with DLNA support which is not recognized by Serviio and is manually set to Samsung C/D Profile.

I am also hearing impaired so all my videos have matching .srt files

When I play the videos with other servers (for example TVMobili) the subtitles display when played using the TV DLNA and the Combo DLNA. However when I play with Serviio the subtitles display correctly when played using the TV DLNA but they do not display when played using the Combo DLNA.

I've attached the log where I first played a movie thru the TV and the subs displayed and I then switched to the Combo and played the same movie and subs did not display.

Is this a bug or have I done something wrong?

This problem is regardless of the video type .avi, .mkv, .mp4

The profile is the standard Samsung C/D as follows. My transcoding is turned off.

<Profile id="7" name="Samsung TV / player (C/D-series)" extendsProfileId="2">
<Detection>
<UPnPSearch>
<FriendlyName>(^TV-\d{2}C\d{3}.*)|(^\[TV\][A-Z]{2}\d{2}D\d{3}.*)</FriendlyName>
<ModelNumber>(1\.0)|(AllShare1\.0)</ModelNumber>
</UPnPSearch>
<HttpHeaders>
<!-- for BD players -->
<User-Agent>(.*SEC_HHP_BD-[CD].*)|(.*SEC_HHP_\[HT\][CD].*)</User-Agent>
</HttpHeaders>
</Detection>
<DeviceDescription>
<ExtraElements>
&lt;sec:ProductCap&gt;smi,DCM10,getMediaInfo.sec,getCaptionInfo.sec&lt;/sec:ProductCap&gt;
&lt;sec:X_ProductCap&gt;smi,DCM10,getMediaInfo.sec,getCaptionInfo.sec&lt;/sec:X_ProductCap&gt;
</ExtraElements>
</DeviceDescription>
<ContentDirectoryDefinitionFilter>org.serviio.upnp.service.contentdirectory.definition.SamsungContentDirectoryDefinitionFilter</ContentDirectoryDefinitionFilter>
Attachments
serviio.zip
(245.91 KiB) Downloaded 95 times
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 17053

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Wed Aug 31, 2011 8:26 am

Re: Samsung D Series - TV displays Sub - BluRay Combo does n

I can only see request for a MKV file from 192.168.1.65, no other IP. In this case the srt file is found, requested and sent to the device.
<<

jhb50

DLNA master

Posts: 2856

Joined: Thu Jun 30, 2011 9:32 pm

Post Wed Aug 31, 2011 11:36 am

Re: Samsung D Series - TV displays Sub - BluRay Combo does n

OK. Got rid of the library stuff. Heres the log with just the combo result with no subs.
Attachments
serviio.log
(96.53 KiB) Downloaded 168 times
<<

jhb50

DLNA master

Posts: 2856

Joined: Thu Jun 30, 2011 9:32 pm

Post Wed Aug 31, 2011 11:45 am

Re: Samsung D Series - TV displays Sub - BluRay Combo does n

And heres the clean TV log which displayed the subs
Attachments
TV.txt
(111.99 KiB) Downloaded 186 times
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 17053

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Wed Aug 31, 2011 11:54 am

Re: Samsung D Series - TV displays Sub - BluRay Combo does n

It's because the HT does not use Samsung profile, but a generic one. I'll update the profile for automatic detection, but before 0.6 you have to assign the profile for your HT's IP address in the console (and make the IP static on your router)
<<

jhb50

DLNA master

Posts: 2856

Joined: Thu Jun 30, 2011 9:32 pm

Post Wed Aug 31, 2011 9:43 pm

Re: Samsung D Series - TV displays Sub - BluRay Combo does n

OK. I got it working but this is really weird. Serviio is detecting 2 devices for the combo, 64 which is the correct one but is displayed as unrecognized device and 69 which displays as Samsung TV/player C/D but does not exist either in DeviceSpy or Windows Network Device list!

I had assumed that the detected 69 which points at the Samsung C/D profile was correct, so I did not provide a profile for 64 and so the generic profile was used with no subs. Once I gave 64 the correct profile the subs display correctly.

But the question is how did serviio detect a non existant 69? I've attached a pic of the console and Device Spy. The only thing I have set manually is the profile for 64. The 69 line was generated by serviio using the profile above which we developed earlier ..see viewtopic.php?f=5&t=2712 Based on that the 64 line should have generated the results shown in the 69 line. Perhaps this is a bug?
Attachments
Console.jpg
Console.jpg (181.43 KiB) Viewed 3116 times
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 17053

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Wed Aug 31, 2011 9:56 pm

Re: Samsung D Series - TV displays Sub - BluRay Combo does n

the RCR device is not the Renderer device but Remote Control Receiver device. Not sure why it's on a different IP but it's not the player itself. The Samsung BD players don't show in DeviceSpy. Make sure you have the device on static IP and set the right profile to the IP. 0.6 will have updated detection for your device.
<<

jhb50

DLNA master

Posts: 2856

Joined: Thu Jun 30, 2011 9:32 pm

Post Wed Aug 31, 2011 10:25 pm

Re: Samsung D Series - TV displays Sub - BluRay Combo does n

But subs only display if I set the Samsung Profile on the RCR 64. This doesn't jibe with what you just said.
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 17053

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Wed Aug 31, 2011 10:41 pm

Re: Samsung D Series - TV displays Sub - BluRay Combo does n

do you have static IP setup?

in the log, it only gets requests from .64, no mention of .69
<<

jhb50

DLNA master

Posts: 2856

Joined: Thu Jun 30, 2011 9:32 pm

Post Thu Sep 01, 2011 12:54 pm

Re: Samsung D Series - TV displays Sub - BluRay Combo does n

No, I did not give my RCR 64 device a static IP because everything works fine if I assign the Samsung Profile to that 64 device.

It seems that you have said above that Serviio would not use the 64 RCR device "the RCR device is not the Renderer device but Remote Control Receiver device. .. The Samsung BD players don't show in DeviceSpy" which inicates to me that you expect it to use the 69 device that it detected, but as you point out only the 64 device was used in the log.

So it seems to me that Serviio should have displayed its 69 device with its Samsung Profile in the console as the 64 device and I would not have had to assign a profile to it.

Sorry if this does not make sense but I am confused as to how a non existant 69 device was displayed as a Renderer and then not used.
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 17053

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Thu Sep 01, 2011 1:39 pm

Re: Samsung D Series - TV displays Sub - BluRay Combo does n

is there something running on .60 at the moment? If not, it might be a remnant of the TV's previous IP.

YOu could start again by removing all your renderers in the console and restarting Serviio service. Then post what's there and also detailed log.
<<

jhb50

DLNA master

Posts: 2856

Joined: Thu Jun 30, 2011 9:32 pm

Post Thu Sep 01, 2011 9:00 pm

Re: Samsung D Series - TV displays Sub - BluRay Combo does n

I had done that and started clean before I created this thread reporting the 64 and 69 and no subs problem. However I have done it again as you requested and everything works as I thought it should have the first time.
The combo is recognized on 64 as a renderer per the modified profile entry <User-Agent>(.*SEC_HHP_BD-[CD].*)|(.*SEC_HHP_\[HT\][CD].*)</User-Agent> and it is automatically assigned the Samsung C/D profile and the subs work fine on it.

Attached is the new console snap and the log using both the TV and the Combo to play the file. I guess we will never know where the 69 came from.

PS: This is all with the latest firmware update on the Combo which I installed about a month ago.

So looks like Serviio is working correctly. Sorry to have raised a red herring again!

I have now shut down my other servers and am using Serviio exclusively to play all my files. Thanks for all your efforts. Any chance of me getting a beta of .6?

Thanks.
Attachments
console.jpg
console.jpg (113.97 KiB) Viewed 2578 times
serviio.log
(145.93 KiB) Downloaded 152 times

Return to Samsung

Who is online

Users browsing this forum: No registered users and 14 guests

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.