FAQ  •  Register  •  Login

[SOLVED] Samsung C/D Series - Subtitle issue (0.6.2)

<<

pilothaz

Streaming enthusiast

Posts: 28

Joined: Thu Jun 02, 2011 6:47 pm

Post Thu Feb 09, 2012 1:28 am

[SOLVED] Samsung C/D Series - Subtitle issue (0.6.2)

Hi Zip,

I am having an issue right now with the subtitle fix that you have brought into the 0.6.2 . For starters subtitles never really seemed to work for my C series tv, but was very excited once I saw your notes saying it was setup for this one. I have files the same way that you have stated in your notes:
Subtitles support
For Serviio to recognize the subtitle file it must be named with the same name as the video file, except the extension, e.g.:

my_movie.avi
my_movie.srt

Though I have not tried to convert it it doesn't seem that srt subtitles are within the profile for C series...

Seeing it here:
  Code:
<Profile id="7" name="Samsung TV / player (C/D-series)" extendsProfileId="1">
      <ContentDirectoryMessageBuilder>org.serviio.upnp.service.contentdirectory.SamsungDLNAMessageBuilder</ContentDirectoryMessageBuilder>
        <ResourceTransportProtocolHandler>org.serviio.upnp.protocol.http.transport.SamsungWiseLinkProtocolHandler</ResourceTransportProtocolHandler>
        <Detection>
         <UPnPSearch>
            <FriendlyName>(^TV-\d{2}C\d{3}.*)|(^\[TV\][A-Z]{2}\d{2}D\d{3}.*)</FriendlyName>            
            <ModelNumber>(1\.0)|(AllShare1\.0)</ModelNumber>
         </UPnPSearch>   
         <HttpHeaders>
            <!-- for BD players -->
            <User-Agent>(.*SEC_HHP_BD-[CD].*)|(.*SEC_HHP_\[(HT|BD)\][CD].*)</User-Agent>
         </HttpHeaders>
      </Detection>
      <DeviceDescription>
           <ExtraElements>
              &lt;sec:ProductCap&gt;smi,DCM10,getMediaInfo.sec,getCaptionInfo.sec&lt;/sec:ProductCap&gt;
            &lt;sec:X_ProductCap&gt;smi,DCM10,getMediaInfo.sec,getCaptionInfo.sec&lt;/sec:X_ProductCap&gt;
           </ExtraElements>
        </DeviceDescription>
        <MediaFormatProfiles>
            <MediaFormatProfile mime-type="video/x-mkv">MATROSKA</MediaFormatProfile>
            <MediaFormatProfile mime-type="video/x-msvideo" name="">AVI</MediaFormatProfile>
        </MediaFormatProfiles>
      <ContentDirectoryDefinitionFilter>org.serviio.upnp.service.contentdirectory.definition.SamsungContentDirectoryDefinitionFilter</ContentDirectoryDefinitionFilter>   
      <Transcoding>
         <!-- Transcode all h264 video with HIGH/MAIN > Level 4.1 on MPEG-TS stream with MPEG2VIDEO and ac3 audio transcoding -->
         <Video targetContainer="mpegts" targetVCodec="mpeg2video" targetACodec="ac3" aBitrate="192" maxVBitrate="20000">
            <Matches container="avi" vCodec="h264" profile="high" levelGreaterThan="4.2" />
            <Matches container="avi" vCodec="h264" profile="main" levelGreaterThan="4.2" />
            <Matches container="matroska" vCodec="h264" profile="high" levelGreaterThan="4.2" />
            <Matches container="matroska" vCodec="h264" profile="main" levelGreaterThan="4.2" />
            <Matches container="mp4" vCodec="h264" profile="high" levelGreaterThan="4.2" />
            <Matches container="mp4" vCodec="h264" profile="main" levelGreaterThan="4.2" />
            <Matches container="mpegts" vCodec="h264" profile="high" levelGreaterThan="4.2" />
               <Matches container="mpegts" vCodec="h264" profile="main" levelGreaterThan="4.2" />
                <Matches container="mp4" vCodec="mpeg4" aCodec="lpcm" />
         </Video>
         <!-- transcode H264 MP4 files with LPCM audio -->
         <Video targetContainer="mpegts" targetACodec="ac3">
            <Matches container="mpegts" aCodec="mp2" />
            <Matches container="mp4" aCodec="lpcm" />
            <Matches container="flv" vCodec="h264" /> <!-- looks like some (D?) devices play FLV@H264 natively so this could be removed -->
            <Matches container="matroska" vCodec="h264" aCodec="flac" />
            <Matches container="matroska" vCodec="h264" aCodec="vorbis" />
            <Matches container="matroska" vCodec="h264" aCodec="truehd" />
            <Matches container="matroska" vCodec="vc1" />
            <Matches container="ogg" vCodec="mpeg4" />
            <Matches container="3gp" aCodec="amrnb" /> 
         </Video>   
         <!-- transcode MKV with MPEG2 video, remux into mpeg2ts -->
         <!-- transcode AVI with AVC video -->
         <Video targetContainer="mpegts" targetACodec="ac3" targetVCodec="mpeg2video" maxVBitrate="20000">
            <Matches container="matroska" vCodec="mpeg2video" />
            <Matches container="matroska" vCodec="vp8" />
            <Matches container="avi" vCodec="h264" />
            <Matches container="avi" vCodec="mjpeg" />
            <Matches container="avi" vCodec="dvvideo" />
            <Matches container="flv" />
            <Matches container="ogg" />
         </Video>
         <!-- For dvr-ms files force mpeg2video transcoding to fix monotone timestamps problems-->
         <Video targetContainer="mpegts" targetACodec="ac3" forceVTranscoding="true" maxVBitrate="20000">
            <Matches container="asf" vCodec="mpeg2video" />
         </Video>
         <Video targetContainer="mpegts">
            <Matches container="wtv" />
         </Video>
         <!-- transcode audio only for wmv with wmapro -->
         <Video targetContainer="asf" targetACodec="ac3" aBitrate="256">
            <Matches container="asf" aCodec="wmapro" />
         </Video>
         <Audio targetContainer="lpcm">
            <Matches container="mp4" />
            <Matches container="flac" />
            <Matches container="ogg" />
            <Matches container="adts" />
         </Audio>
      </Transcoding>
      <OnlineTranscoding>
         <Video targetContainer="mpegts" targetACodec="ac3" aBitrate="384">
            <Matches container="mp4" vCodec="h264" />      
             <Matches container="applehttp" vCodec="h264"/>
         </Video>      
         <Video targetContainer="mpegts" targetVCodec="mpeg2video" targetACodec="ac3" aBitrate="384" maxVBitrate="20000">
            <Matches container="mp4" />
            <Matches container="asf" /> <!-- mms -->
         </Video>
      </OnlineTranscoding>
      <AutomaticImageRotation>true</AutomaticImageRotation>
        <LimitImageResolution>false</LimitImageResolution>
        <SubtitlesMimeType>smi/caption</SubtitlesMimeType>
   </Profile>


I was trying to place in this line which is suppose to be there I thought to make sure that srt will work for the C series. I tried to append this under the smi/caption
  Code:
<SubtitlesMimeType>text/srt</SubtitlesMimeType>


But when doing this it gave me an issue within my log, so I took it out. Here is the log issue:
2012-02-09 01:20:26,033 ERROR [XmlUtils] XML Profiles.xsd didn't pass validation, reason: cvc-complex-type.2.4.a: Invalid content was found starting with element 'SubtitlesMimeType'. One of '{ProtocolInfo}' is expected.
2012-02-09 01:20:26,034 ERROR [MediaServer] An unexpected error occured. Ending the application. Message: org.serviio.profile.ProfilesDefinitionException: Profiles XML file is not valid (according to the schema). Check the log.
java.lang.RuntimeException: org.serviio.profile.ProfilesDefinitionException: Profiles XML file is not valid (according to the schema). Check the log.
at org.serviio.profile.ProfileManager.loadProfiles(ProfileManager.java:158)
at org.serviio.MediaServer.main(MediaServer.java:105)
Caused by: org.serviio.profile.ProfilesDefinitionException: Profiles XML file is not valid (according to the schema). Check the log.
at org.serviio.profile.ProfilesDefinitionParser.validateXML(ProfilesDefinitionParser.java:763)
at org.serviio.profile.ProfilesDefinitionParser.parseDefinition(ProfilesDefinitionParser.java:129)
at org.serviio.profile.ProfileManager.loadProfiles(ProfileManager.java:156)
... 1 more


Zip can you please help me with this? I love the application :)
<<

Cerberus

User avatar

DLNA master

Posts: 4116

Joined: Sun Jan 02, 2011 5:20 pm

Location: Reading, UK

Post Thu Feb 09, 2012 1:40 am

Re: Samsung C/D Series - Subtitle issue (0.6.2)

samsung devices are done slightly different to the rest as it has some extra intergration settings in the profile that make special samsung specific functions work and subtitkes are part of that, once i get home today i will test this for you and see if subs still work for me if they do we can look at your files and see whats wrong if they dont then i will look at intergration and try and work out why they dont work.
Phil Bennett
Beta Tester Group
Wiki | FAQ

Samsung LE40C750 LCD | Samsung BD-C5900 | Sony PS3 | Windows 7 |
HowTo: Provide supported formats of a device HowTo: Record a new ticket on Bitbucket
HowTo: Provide details of a video file that doesn't play HowTo: Turn on detailed logging
<<

pilothaz

Streaming enthusiast

Posts: 28

Joined: Thu Jun 02, 2011 6:47 pm

Post Thu Feb 09, 2012 1:47 am

Re: Samsung C/D Series - Subtitle issue (0.6.2)

Appreciate it.

I have tired it now for about 10 different movies with subtitle.srt files with the exact same filename as the movie. Unfortunately it keeps saying on the tv, Not Available.
<<

Saphroxx

Serviio newbie

Posts: 6

Joined: Fri Jan 06, 2012 2:49 am

Post Sat Feb 11, 2012 3:00 pm

Re: Samsung C/D Series - Subtitle issue (0.6.2)

Subtitles do work for me on my Samsung UE40D6500.
<<

pilothaz

Streaming enthusiast

Posts: 28

Joined: Thu Jun 02, 2011 6:47 pm

Post Sat Feb 11, 2012 4:00 pm

Re: Samsung C/D Series - Subtitle issue (0.6.2)

Cerberus: were you able to get it working or test it on your machines?

None are showing on mine still.
On my UN55C5000
<<

Citronel

Streaming enthusiast

Posts: 28

Joined: Fri Feb 03, 2012 10:28 pm

Post Sat Feb 11, 2012 4:17 pm

Re: Samsung C/D Series - Subtitle issue (0.6.2)

On Samsung 32D5000 subtitle are ok, be sure you use use only srt file.
<<

pilothaz

Streaming enthusiast

Posts: 28

Joined: Thu Jun 02, 2011 6:47 pm

Post Sat Feb 11, 2012 4:29 pm

Re: Samsung C/D Series - Subtitle issue (0.6.2)

I am using only srt. Couchpotato will grab them, rename them exactly the same filename as the video and placed in the same folder.
<<

Cerberus

User avatar

DLNA master

Posts: 4116

Joined: Sun Jan 02, 2011 5:20 pm

Location: Reading, UK

Post Sat Feb 11, 2012 6:57 pm

Re: Samsung C/D Series - Subtitle issue (0.6.2)

pilothaz wrote:I am using only srt. Couchpotato will grab them, rename them exactly the same filename as the video and placed in the same folder.

maybe thats your issue does couchpotatoe corrupt them somehow so that then serviio can not reda them, try getting the srt from another source and see if that helps.
Phil Bennett
Beta Tester Group
Wiki | FAQ

Samsung LE40C750 LCD | Samsung BD-C5900 | Sony PS3 | Windows 7 |
HowTo: Provide supported formats of a device HowTo: Record a new ticket on Bitbucket
HowTo: Provide details of a video file that doesn't play HowTo: Turn on detailed logging
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 17037

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Sun Feb 12, 2012 11:33 pm

Re: Samsung C/D Series - Subtitle issue (0.6.2)

there is a srt fix tool somewhere on this forum, you might want to run it through it.
<<

pilothaz

Streaming enthusiast

Posts: 28

Joined: Thu Jun 02, 2011 6:47 pm

Post Sun Feb 12, 2012 11:37 pm

Re: Samsung C/D Series - Subtitle issue (0.6.2)

There is one, which is only for windows. All that were downloaded are from CouchPotato as stated before which looks at the file name of the movie and correctly finds the corresponding one for that timing etc.

They should not be corrupt in any way in my mind. They also do not show up in my WDTV Live Plus when trying to select srt subs..
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 17037

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Tue Feb 14, 2012 1:24 pm

Re: Samsung C/D Series - Subtitle issue (0.6.2)

you can check the detailed log if the srt file is downloaded by the TV.
<<

pilothaz

Streaming enthusiast

Posts: 28

Joined: Thu Jun 02, 2011 6:47 pm

Post Tue Feb 14, 2012 1:46 pm

Re: Samsung C/D Series - Subtitle issue (0.6.2)

2012-02-14 13:42:29,911 DEBUG [SubtitlesService] Found subtitle file: /mnt/flicks/12 Monkeys (1995)/12 Monkeys.srt
2012-02-14 13:42:29,912 DEBUG [ResourceTransportRequestHandler] Sending HEAD response back
2012-02-14 13:42:29,912 DEBUG [ResourceTransportRequestHandler] HTTP/1.1 200 OK, headers = [[Content-Type: video/x-msvideo,Content-Length: 1022776168,Date: Tue, 14 Feb 2012 13:42:29 GMT,Server: FreeBSD, UPnP/1.0 DLNADOC/1.50, Serviio/0.6.2,Cache-control: no-cache,transferMode.dlna.org: Streaming,CaptionInfo.sec: http://192.168.2.10:8895/resource/241/S ... s.dlna.org: DLNA.ORG_OP=01;DLNA.ORG_CI=0;DLNA.ORG_FLAGS=01500000000000000000000000000000]]
2012-02-14 13:42:29,914 DEBUG [WebServer] Incoming connection from /192.168.2.12:49719
2012-02-14 13:42:29,915 DEBUG [ResourceTransportRequestHandler] GET /resource/241/SUBTITLE.srt HTTP/1.0, headers = [HOST: 192.168.2.10:8895,ACCEPT-LANGUAGE: en-us,getcontentFeatures.dlna.org: 1,transferMode.dlna.org: Background]]
2012-02-14 13:42:29,915 DEBUG [RendererDAOImpl] Reading a Renderer with ip address 192.168.2.12
2012-02-14 13:42:29,916 DEBUG [ResourceTransportRequestHandler] Resource request accepted. Using client 'IPAddress=/192.168.2.12, Profile=Samsung TV / player (C/D-series)'
2012-02-14 13:42:29,917 DEBUG [ResourceTransportRequestHandler] Request for resource 241 and type 'SUBTITLE' received
2012-02-14 13:42:29,919 DEBUG [MediaItemDAOImpl] Reading a MediaItem (id = 241)
2012-02-14 13:42:29,920 DEBUG [MediaItemDAOImpl] Getting file of media item 241
2012-02-14 13:42:29,922 DEBUG [SubtitlesService] Found subtitle file: /mnt/flicks/12 Monkeys (1995)/12 Monkeys.srt
2012-02-14 13:42:29,923 DEBUG [SubtitlesRetrievalStrategy] Retrieving Subtitles for media item with id 241
2012-02-14 13:42:29,924 DEBUG [ResourceTransportRequestHandler] Creating stream entity with length: 67310
2012-02-14 13:42:29,924 DEBUG [ResourceTransportRequestHandler] Sending file back
2012-02-14 13:42:29,924 DEBUG [ResourceTransportRequestHandler] HTTP/1.1 200 OK, headers = [[Content-Type: smi/caption,Content-Length: 67310,Date: Tue, 14 Feb 2012 13:42:29 GMT,Server: FreeBSD, UPnP/1.0 DLNADOC/1.50, Serviio/0.6.2,Cache-control: no-cache,transferMode.dlna.org: Background]]
2012-02-14 13:42:42,485 DEBUG [FeedUpdaterThread] Checking for new and expired online resources
2012-02-14 13:42:42,853 DEBUG [OnlineRepositoryDAOImpl] Reading all OnlineRepositories


Tried with another one.

2012-02-14 13:45:03,273 DEBUG [ResourceTransportRequestHandler] HEAD /resource/258/MEDIA_ITEM/AVI*0 HTTP/1.0, headers = [getCaptionInfo.sec: 1]]
2012-02-14 13:45:03,273 DEBUG [RendererDAOImpl] Reading a Renderer with ip address 192.168.2.12
2012-02-14 13:45:03,274 DEBUG [ResourceTransportRequestHandler] Resource request accepted. Using client 'IPAddress=/192.168.2.12, Profile=Samsung TV / player (C/D-series)'
2012-02-14 13:45:03,275 DEBUG [ResourceTransportRequestHandler] Request for resource 258 and type 'MEDIA_ITEM' received
2012-02-14 13:45:03,275 DEBUG [MediaResourceRetrievalStrategy] Getting information about media item 258 (local)
2012-02-14 13:45:03,275 DEBUG [MediaItemDAOImpl] Reading a MediaItem (id = 258)
2012-02-14 13:45:03,277 DEBUG [VideoDAOImpl] Reading a Video (id = 258)
2012-02-14 13:45:03,278 DEBUG [VideoDeliveryEngine] Retrieving resource information for item 258, format AVI and profile Samsung TV / player (C/D-series)
2012-02-14 13:45:03,279 DEBUG [MediaItemDAOImpl] Reading a MediaItem (id = 258)
2012-02-14 13:45:03,280 DEBUG [MediaItemDAOImpl] Getting file of media item 258
2012-02-14 13:45:03,282 DEBUG [SubtitlesService] Found subtitle file: /mnt/flicks/50-50 (2011)/50-50.srt
2012-02-14 13:45:03,282 DEBUG [ResourceTransportRequestHandler] Sending HEAD response back
2012-02-14 13:45:03,283 DEBUG [ResourceTransportRequestHandler] HTTP/1.1 200 OK, headers = [[Content-Type: video/x-msvideo,Content-Length: 1618765824,Date: Tue, 14 Feb 2012 13:45:03 GMT,Server: FreeBSD, UPnP/1.0 DLNADOC/1.50, Serviio/0.6.2,Cache-control: no-cache,transferMode.dlna.org: Streaming,CaptionInfo.sec: http://192.168.2.10:8895/resource/258/S ... s.dlna.org: DLNA.ORG_OP=01;DLNA.ORG_CI=0;DLNA.ORG_FLAGS=01500000000000000000000000000000]]
2012-02-14 13:45:03,285 DEBUG [WebServer] Incoming connection from /192.168.2.12:49740
2012-02-14 13:45:03,285 DEBUG [ResourceTransportRequestHandler] GET /resource/258/SUBTITLE.srt HTTP/1.0, headers = [HOST: 192.168.2.10:8895,ACCEPT-LANGUAGE: en-us,getcontentFeatures.dlna.org: 1,transferMode.dlna.org: Background]]
2012-02-14 13:45:03,286 DEBUG [RendererDAOImpl] Reading a Renderer with ip address 192.168.2.12
2012-02-14 13:45:03,287 DEBUG [ResourceTransportRequestHandler] Resource request accepted. Using client 'IPAddress=/192.168.2.12, Profile=Samsung TV / player (C/D-series)'
2012-02-14 13:45:03,288 DEBUG [ResourceTransportRequestHandler] Request for resource 258 and type 'SUBTITLE' received
2012-02-14 13:45:03,288 DEBUG [MediaItemDAOImpl] Reading a MediaItem (id = 258)
2012-02-14 13:45:03,289 DEBUG [MediaItemDAOImpl] Getting file of media item 258
2012-02-14 13:45:03,291 DEBUG [SubtitlesService] Found subtitle file: /mnt/flicks/50-50 (2011)/50-50.srt
2012-02-14 13:45:03,292 DEBUG [SubtitlesRetrievalStrategy] Retrieving Subtitles for media item with id 258
2012-02-14 13:45:03,303 DEBUG [ResourceTransportRequestHandler] Creating stream entity with length: 119144
2012-02-14 13:45:03,304 DEBUG [ResourceTransportRequestHandler] Sending file back
2012-02-14 13:45:03,304 DEBUG [ResourceTransportRequestHandler] HTTP/1.1 200 OK, headers = [[Content-Type: smi/caption,Content-Length: 119144,Date: Tue, 14 Feb 2012 13:45:03 GMT,Server: FreeBSD, UPnP/1.0 DLNADOC/1.50, Serviio/0.6.2,Cache-control: no-cache,transferMode.dlna.org: Background]]


Still showing Not Available on the screen.
<<

pilothaz

Streaming enthusiast

Posts: 28

Joined: Thu Jun 02, 2011 6:47 pm

Post Tue Feb 14, 2012 3:16 pm

Re: Samsung C/D Series - Subtitle issue (0.6.2)

I think i found my issue. I was trying to use the 'CC' button on the remote, which doesn't seem to be for when in the Media menu. When in a video that had Subtitles, I hit the Tools button and then saw a subtitles information in the menu.


So issue was error on my stupidity. Thinking the CC button was for Subtitles.... what a thought.

Sorry for the issue.

Zip: Can you please close this thread?

Return to Samsung

Who is online

Users browsing this forum: No registered users and 10 guests

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.