FAQ  •  Register  •  Login

serviio stops device disconnected

<<

twhite81

Serviio newbie

Posts: 3

Joined: Tue May 15, 2012 12:05 am

Post Sat May 19, 2012 3:18 am

serviio stops device disconnected

after about 10-20 mins the video stops and i get a message "device disconnected device:serviio" when i check the computer serviio is stopped. I have samsung d series led and d6400 blu ray player and it does it on both. any help would be great thanks! :D
<<

moltra

DLNA master

Posts: 1871

Joined: Thu Mar 24, 2011 11:00 pm

Location: Ohio USA

Post Sat May 19, 2012 5:37 am

Re: serviio stops device disconnected

Can you attach your serviio.log file.
Mark
Beta Tester Group
http://www.serviidb.com Online media resource repository

Netgear EVA2000 | Samsung BD-D5300 | XBOX 360 | Windows 7 | Mint Debian 12 | Raxz Maxx
HowTo: Provide supported formats of a device HowTo: Record a new ticket on Bitbucket
HowTo: Provide details of a video file that doesn't play HowTo: Turn on detailed logging
<<

spedkey

Serviio newbie

Posts: 3

Joined: Sun Apr 01, 2012 3:13 am

Post Sat Jun 02, 2012 9:29 pm

Re: serviio stops device disconnected

Hi, I have a similar "problem".

I use serviio on a Samsung LCD D550 and after playing a few seconds a random file, mkv/avi/etc, it gets disconnected.
But in my PC the servioservice is still running (and the server status at serviio console it's green) and all seems right.
I can only fix it by rebooting my PC (re initializing serviio service doesn't solve it, sadly).

I'd appreciate any help, thanks!
Attachments
serviio.log
(424.51 KiB) Downloaded 412 times
<<

Palandrusk

Serviio newbie

Posts: 1

Joined: Fri Jun 08, 2012 2:53 pm

Post Fri Jun 08, 2012 4:10 pm

Re: serviio stops device disconnected

Similar issue here.

I'm streaming to a D5700 bluray player and it has a real issue connecting and maintaining a connection with Serviio loaded on my desktop through wireless connection. Once it does find the server, can watch a minute or so of video before disconnection.

Server status still shows as running. Log file attached.

No internet connection issues, that hasn't been a problem.
Attachments
serviio.log
(31.48 KiB) Downloaded 391 times
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 17127

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Mon Jun 11, 2012 3:52 pm

Re: serviio stops device disconnected

Internet connection and constant byte stream needed for video is a different beast. Check the quality of your wifi connection (you might share the wifi channel with a lot of neighbours, for example). You could try to run a cable from your laptop to the router to see if it improves things.
<<

TBoulter

Serviio newbie

Posts: 4

Joined: Sat May 19, 2012 2:18 am

Post Wed Jun 27, 2012 7:34 am

Re: serviio stops device disconnected

Adding to the discussion: similar problem...random disconnects on a Samsung BD-C5500. From the log file:

2012-06-27 02:44:37,967 DEBUG [WebServer] I/O error: Connection reset by peer: socket write error

Sometimes will play only a few minutes, other times will play for hours and multiple files before suddenly disconnecting.
Problem seems to be worse lately than it used to be: happening a lot more. I do not currently use Serviio for transcoding - these are all native avi files. (for transcoding I use an older system - AvelLinkplayer2 and software because the config works well and
Ive never taken the time to fool with transcoding via Serviio yet).

Even on same file - will play through (does not fail on same file/location) so it does not seem to be problems with the avi files themselves.

System:

Windows 2008-64 bit server on amd chipset, Rhine II ethernet, Dell 2724 Gig switch (jumpered to a Netgear Gig switch in the living room for AV devices - previously a Linksys 10/100 that was replaced as part of the testing last night with no change to random disconnects and I have also tried taking out the living room AV switch and direct connecting to the main Dell switch), Samsung BD-C5500 using C/D series Serviio profile, latest patches and java on all units including Samsung. Storage is a Raid-5 (Hardware) Venus T-5 Sata-connected box. Have played with duplex settings, speed settings, and frame settings on all network equipment (server, switches, etc) to no avail.

No indications on server/logs/ etc of any failure, no bad packet issues, disabled all other DNLA devices/servers including Directv system at different times...still no change - random disconnects. Serviio server/service never seems to be stopped or restarting - if I give it a sec and reattach the Samsung to the Serviio server I can start playing again. Serviio service does disappear from the samsung unit at time of device disconnect, have to reattach to it but then will reappear in list about 10 seconds later and I can reattach.

This has been an ongoing problem - like I said seems worse lately but has been a problem ever since initial setup about a year ago. Youtube/Netflix/Hulu all work fine from the Samsung, so it also doesn't seem to be a problem with the network adapter in the samsung player.
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 17127

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Mon Jul 02, 2012 7:03 pm

Re: serviio stops device disconnected

TBoulter wrote:2012-06-27 02:44:37,967 DEBUG [WebServer] I/O error: Connection reset by peer: socket write error

This means the player closed the connection. I assume either some dodgy bytes in the stream or similar... Do you have the latest firmware on your device?
<<

fredricz

User avatar

Streaming enthusiast

Posts: 30

Joined: Mon Mar 26, 2012 7:58 pm

Post Thu Jul 05, 2012 6:34 pm

Re: serviio stops device disconnected

I've got the same problem... Got dlink dir-655, samsung tv . Updated to the latest firmware, on both.

So, my test;

On ethernet cable: stops working after around 5 min. "Serviio server was disconnected", after around 10 min I can see the serviio server again on the TV.

On wireless: the same as wired.

On another TV (samsung): the same problem.

I need to add that I can still see windows own homegroup sharing on the screen. So its only serviio thats gone. If you got any questions, ask. :) thanks for reading and the help.
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 17127

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Mon Jul 09, 2012 12:42 pm

Re: serviio stops device disconnected

I'll try to do some changes for 1.0 to tackle this. Not sure if it'll help, but will try :-)
<<

fredricz

User avatar

Streaming enthusiast

Posts: 30

Joined: Mon Mar 26, 2012 7:58 pm

Post Mon Jul 09, 2012 7:40 pm

Re: serviio stops device disconnected

zip wrote:I'll try to do some changes for 1.0 to tackle this. Not sure if it'll help, but will try :-)


Great, cuz I losing my mind here. Is there any info about 1.0?

Btw, Have you ever thought about updating your website? :lol:
<<

handsome

Serviio newbie

Posts: 10

Joined: Sat Jul 14, 2012 6:00 pm

Post Fri Jul 20, 2012 9:48 am

Re: serviio stops device disconnected

i am also having the same problem and it is also becoming more frequent but i have noticed something lately please see below:

My setup is Windows 7 32bit running Serviio 0.62 using transcoding with samsung B/C profile connected via CAT5 to an Asus RT-N66U router then wifi to a samsung LA32D550 tv. Logitech Media Server is also running on the PC.

I also have a samsung galaxy s2 cellphone connected to the wifi network to access the ineternet.

Whenever the disconnect occurs my samsung galaxy s2 gives me a "need to logon to a wireless network" message - that is a wireless icon with a question mark in it (the cellphone connects automatically whenever i am within range). In other words the cellphone also seems to lose the wifi connection. My logon particulars are already stored on the cellphone so i just tap the message which launches the android browser and then the network reconnects - so i just close the browser.

I then load up the serviio android app on the cellphone and my TV reconnects within a minute or so. The server appears to be running whenever this happens - the lights are 'green' in the android app.

Does this perhaps shed any light on the problem?
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 17127

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Sat Jul 21, 2012 4:19 pm

Re: serviio stops device disconnected

might be the router stops the connection? not sure, I never had a disconnection so far. The fact that it started to happen more frequently recently seems to point at your infrastructure, rather than Serviio. Maybe your WiFi is on a busy channel?
<<

handsome

Serviio newbie

Posts: 10

Joined: Sat Jul 14, 2012 6:00 pm

Post Sat Jul 21, 2012 6:05 pm

Re: serviio stops device disconnected

will check that out thank you.
<<

furiannn

Serviio newbie

Posts: 5

Joined: Mon Jul 23, 2012 9:05 pm

Post Mon Jul 23, 2012 9:42 pm

Re: serviio stops device disconnected

Hi, I have recently been experiencing the same exact issue, when before (maybe 2 months ago) it was working perfectly.

My setup: Serviio on WHS2011 box. Asus RT-N66U (Have also tried and experienced same issue on N56U). WDTVLive. Transcoding off.

I too am getting a lot of "2012-07-23 22:18:48,953 DEBUG [WebServer] I/O error: Connection reset by peer: socket write error" type entries in the log file, when the video just stops playing.
<<

mostsleek

Serviio newbie

Posts: 10

Joined: Wed Oct 19, 2011 3:22 am

Post Thu Aug 02, 2012 10:30 pm

Re: serviio stops device disconnected

I recently too have been having random disconnects. The first time it happened I did not think too mush of it since it was an HD video. However, since then it has been "normal" stuff. This is on a Samung Blu-Ray E-5900. The DLNA profile is set correctly.

Here is my error:


Caused by: java.sql.SQLNonTransientConnectionException: Connection closed by unknown interrupt.
at org.apache.derby.impl.jdbc.SQLExceptionFactory40.getSQLException(Unknown Source)
at org.apache.derby.impl.jdbc.Util.generateCsSQLException(Unknown Source)
at org.apache.derby.impl.jdbc.TransactionResourceImpl.wrapInSQLException(Unknown Source)
at org.apache.derby.impl.jdbc.TransactionResourceImpl.handleException(Unknown Source)
at org.apache.derby.impl.jdbc.EmbedConnection.handleException(Unknown Source)
at org.apache.derby.impl.jdbc.ConnectionChild.handleException(Unknown Source)
at org.apache.derby.impl.jdbc.EmbedStatement.executeStatement(Unknown Source)
at org.apache.derby.impl.jdbc.EmbedPreparedStatement.executeStatement(Unknown Source)
at org.apache.derby.impl.jdbc.EmbedPreparedStatement.executeUpdate(Unknown Source)
at org.serviio.library.dao.RepositoryDAOImpl.markRepositoryAsScanned(RepositoryDAOImpl.java:171)
... 2 more
Caused by: java.sql.SQLException: Connection closed by unknown interrupt.
at org.apache.derby.impl.jdbc.SQLExceptionFactory.getSQLException(Unknown Source)
at org.apache.derby.impl.jdbc.SQLExceptionFactory40.wrapArgsForTransportAcrossDRDA(Unknown Source)
... 12 more
Caused by: ERROR 08000: Connection closed by unknown interrupt.
at org.apache.derby.iapi.error.StandardException.newException(Unknown Source)
at org.apache.derby.iapi.util.InterruptStatus.setInterrupted(Unknown Source)
at org.apache.derby.iapi.util.InterruptStatus.throwIf(Unknown Source)
at org.apache.derby.impl.sql.execute.BasicNoPutResultSetImpl.checkCancellationFlag(Unknown Source)
at org.apache.derby.impl.sql.execute.TableScanResultSet.getNextRowCore(Unknown Source)
at org.apache.derby.impl.sql.execute.IndexRowToBaseRowResultSet.getNextRowCore(Unknown Source)
at org.apache.derby.impl.sql.execute.ProjectRestrictResultSet.getNextRowCore(Unknown Source)
at org.apache.derby.impl.sql.execute.NormalizeResultSet.getNextRowCore(Unknown Source)
at org.apache.derby.impl.sql.execute.DMLWriteResultSet.getNextRowCore(Unknown Source)
at org.apache.derby.impl.sql.execute.UpdateResultSet.collectAffectedRows(Unknown Source)
at org.apache.derby.impl.sql.execute.UpdateResultSet.open(Unknown Source)
at org.apache.derby.impl.sql.GenericPreparedStatement.executeStmt(Unknown Source)
at org.apache.derby.impl.sql.GenericPreparedStatement.execute(Unknown Source)
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 17127

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Thu Aug 02, 2012 10:33 pm

Re: serviio stops device disconnected

this error is not related to disconections. check the quality of your network
<<

mostsleek

Serviio newbie

Posts: 10

Joined: Wed Oct 19, 2011 3:22 am

Post Fri Aug 03, 2012 1:52 am

Re: serviio stops device disconnected

Network is fine. However, I did update my old JAVA from 6 something to the latest version, Java 7 Update 5. It has been working fine now for the past few hours and multiple files.
<<

iplem

Streaming enthusiast

Posts: 35

Joined: Wed Apr 25, 2012 10:05 am

Post Mon Aug 06, 2012 5:45 pm

Re: serviio stops device disconnected

Hi,

I want to add that I am also suffering from it recently, specially after installing the version 1.0. The network is wired and what I noticed, it happens only with online streaming and not with files in the computer. I too have a samsung (d550) and their latest firmware. I do believe that it is related to bad streaming time-out but not the 20 secs as stated in the log

2012-08-06 07:20:07,558 DEBUG [WebServer] I/O error: Connection reset by peer: socket write error
2012-08-06 07:20:07,558 DEBUG [NonClosingPipedInputStream] Scheduling stream stop to happen in 20 seconds if there is no traffic

Iplem
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 17127

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Mon Aug 06, 2012 11:11 pm

Re: serviio stops device disconnected

the TV is probably sensitive to the incoming data stream - so if the online stream is not sufficient quality it might choke
<<

iplem

Streaming enthusiast

Posts: 35

Joined: Wed Apr 25, 2012 10:05 am

Post Tue Aug 07, 2012 7:39 pm

Re: serviio stops device disconnected

I do think also that it might be something related to TV, but I also believe we might overcome it by some switch in ffmpeg which might keep the TV waiting for more streams instead of EOF
Next

Return to Samsung

Who is online

Users browsing this forum: No registered users and 7 guests

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.