FAQ  •  Register  •  Login

2.0 Can't play .ts files that I record from cable TV.

<<

Ravenik

Serviio newbie

Posts: 4

Joined: Sat Oct 12, 2019 2:20 pm

Post Sat Oct 12, 2019 2:37 pm

2.0 Can't play .ts files that I record from cable TV.

Hello,

I test Serviio on my new NAS and it is working better then other DLNA servers that I tried (on Qnap TS-453B-4G).
It plays the majority of my video files on Sony TV.

However I have a problem with video files recorded by my TV decoder (.ts conteiner). I just record from cable TV on standalone TV decoder (Octagon SF4008). The decoder can then play this recordings ok. However my TV NOT (tested from USB).
These video files are not encrypted and are playable on Windows using for example Media Player Classis and other software players.

Unfortunately all videos that I record are not playable using Serviio as dlna server and my Sony TV as player/renderer. The TV just shows it starts playing and then its display remains black and nothing is being played.

Before I try to understand profiles.xml, I kindly ask for help.

NAS: Qnap TS-453B-4G (x86 64)
Serviio_2.0_x86_64.
TV: Sony KDL-32HX751 (it is the same model as KDL-32HX750, the only difference in 3d glasses provided)
Profile set: Sony Bravia TV 2012
Example video file was recorded from Eurosport 2 HD by decoder. The decoder plays it Ok. Serviio+Sony TV not.
I am interested in playback with the first audio stream.

FFMPEG -I:
-----------
  Code:
ffmpeg version 3.4.4 Copyright (c) 2000-2018 the FFmpeg developers
  built with gcc 4.9.2 (toolchain config: [gcc-4.9.2 binutils-2.25 glibc-2.21])
  configuration: --enable-gpl --enable-static --disable-shared --disable-ffplay --disable-ffserver --enable-libmp3lame --enable-libass --enable-librtmp --enable-fontconfig --enable-libfreetype --enable-zlib --enable-libx264 --enable-libspeex --enable-pthreads --extra-libs='-lrtmp -lpolarssl -lexpat -lfreetype -lfribidi -lz' --prefix=/cross/qnap-intel-64/CT/x86_64-QNAP-linux-gnu/cross-tools/x86_64-QNAP-linux-gnu/usr --enable-cross-compile --arch=x86_64 --target-os=linux --cross-prefix=x86_64-QNAP-linux-gnu- --pkg-config=pkg-config --bindir='/jenkins/workspace/FFmpeg - Qnap - Intel - 64/target'
  libavutil      55. 78.100 / 55. 78.100
  libavcodec     57.107.100 / 57.107.100
  libavformat    57. 83.100 / 57. 83.100
  libavdevice    57. 10.100 / 57. 10.100
  libavfilter     6.107.100 /  6.107.100
  libswscale      4.  8.100 /  4.  8.100
  libswresample   2.  9.100 /  2.  9.100
  libpostproc    54.  7.100 / 54.  7.100
[h264 @ 0x3bf7260] SPS unavailable in decode_picture_timing
[h264 @ 0x3bf7260] non-existing PPS 0 referenced
[h264 @ 0x3bf7260] SPS unavailable in decode_picture_timing
[h264 @ 0x3bf7260] non-existing PPS 0 referenced
[h264 @ 0x3bf7260] decode_slice_header error
[h264 @ 0x3bf7260] no frame!
[h264 @ 0x3bf7260] SPS unavailable in decode_picture_timing
[h264 @ 0x3bf7260] non-existing PPS 0 referenced
[h264 @ 0x3bf7260] SPS unavailable in decode_picture_timing
[h264 @ 0x3bf7260] non-existing PPS 0 referenced
[h264 @ 0x3bf7260] decode_slice_header error
[h264 @ 0x3bf7260] no frame!
[h264 @ 0x3bf7260] SPS unavailable in decode_picture_timing
[h264 @ 0x3bf7260] non-existing PPS 0 referenced
[h264 @ 0x3bf7260] SPS unavailable in decode_picture_timing
[h264 @ 0x3bf7260] non-existing PPS 0 referenced
[h264 @ 0x3bf7260] decode_slice_header error
[h264 @ 0x3bf7260] no frame!
[h264 @ 0x3bf7260] SPS unavailable in decode_picture_timing
[h264 @ 0x3bf7260] non-existing PPS 0 referenced
[h264 @ 0x3bf7260] SPS unavailable in decode_picture_timing
[h264 @ 0x3bf7260] non-existing PPS 0 referenced
[h264 @ 0x3bf7260] decode_slice_header error
[h264 @ 0x3bf7260] no frame!
[mpegts @ 0x3bd1240] PES packet size mismatch
    Last message repeated 1 times
Input #0, mpegts, from 'Eurosport-1.ts':
  Duration: 00:10:48.02, start: 53169.529211, bitrate: 9374 kb/s
  Program 2501
  Program 2502
  Program 2503
  Program 2504
    Stream #0:0[0x191]: Video: h264 (High) ([27][0][0][0] / 0x001B), yuv420p(tv, bt709, top first), 1920x1080 [SAR 1:1 DAR 16:9], Closed Captions, 25 fps, 50 tbr, 90k tbn, 50 tbc
    Stream #0:1[0x192](pol): Audio: mp2 ([4][0][0][0] / 0x0004), 48000 Hz, stereo, s16p, 192 kb/s
    Stream #0:2[0x193](eng): Audio: mp2 ([4][0][0][0] / 0x0004), 48000 Hz, stereo, s16p, 192 kb/s
  Program 2505
  Program 2506
  Program 2507
At least one output file must be specified



MEDIAINFO:
-----------
  Code:
General
ID                          : 25 (0x19)
Complete name               : C:\Users\Marek\Desktop\Serviio\Eurosport-1.ts
Format                      : MPEG-TS
File size                   : 724 MiB
Duration                    : 10 min 47 s
Overall bit rate mode       : Variable
Overall bit rate            : 9 387 kb/s

Video
ID                          : 401 (0x191)
Menu ID                     : 2504 (0x9C8)
Format                      : AVC
Format/Info                 : Advanced Video Codec
Format profile              : High@L4
Format settings             : CABAC / 4 Ref Frames
Format settings, CABAC      : Yes
Format settings, Reference  : 4 frames
Codec ID                    : 27
Duration                    : 10 min 46 s
Bit rate                    : 8 535 kb/s
Width                       : 1 920 pixels
Height                      : 1 080 pixels
Display aspect ratio        : 16:9
Frame rate                  : 25.000 FPS
Standard                    : Component
Color space                 : YUV
Chroma subsampling          : 4:2:0
Bit depth                   : 8 bits
Scan type                   : MBAFF
Scan type, store method     : Separated fields
Scan order                  : Top Field First
Bits/(Pixel*Frame)          : 0.165
Stream size                 : 658 MiB (91%)
Color range                 : Limited
Color primaries             : BT.709
Transfer characteristics    : BT.709
Matrix coefficients         : BT.709

Audio #1
ID                          : 402 (0x192)
Menu ID                     : 2504 (0x9C8)
Format                      : MPEG Audio
Format version              : Version 1
Format profile              : Layer 2
Codec ID                    : 4
Duration                    : 10 min 46 s
Bit rate mode               : Constant
Bit rate                    : 192 kb/s
Channel(s)                  : 2 channels
Sampling rate               : 48.0 kHz
Frame rate                  : 41.667 FPS (1152 SPF)
Compression mode            : Lossy
Delay relative to video     : -1 s 164 ms
Stream size                 : 14.8 MiB (2%)
Language                    : Polish

Audio #2
ID                          : 403 (0x193)
Menu ID                     : 2504 (0x9C8)
Format                      : MPEG Audio
Format version              : Version 1
Format profile              : Layer 2
Codec ID                    : 4
Duration                    : 10 min 46 s
Bit rate mode               : Constant
Bit rate                    : 192 kb/s
Channel(s)                  : 2 channels
Sampling rate               : 48.0 kHz
Frame rate                  : 41.667 FPS (1152 SPF)
Compression mode            : Lossy
Delay relative to video     : -1 s 204 ms
Stream size                 : 14.8 MiB (2%)
Language                    : English

Menu
ID                          : 400 (0x190)
Menu ID                     : 2504 (0x9C8)
Duration                    : 10 min 47 s
List                        : 401 (0x191) (AVC) / 402 (0x192) (MPEG Audio, Polish) / 403 (0x193) (MPEG Audio, English)
Language                    :  / Polish / English
<<

Ravenik

Serviio newbie

Posts: 4

Joined: Sat Oct 12, 2019 2:20 pm

Post Sat Oct 12, 2019 6:53 pm

Re: 2.0 Can't play .ts files that I record from cable TV.

Below I attach serviio.log in "DEBUG" mode.
Before logging, I made log 0-length.
During log I connected from Sony TV to serviio, selected "Eurosport-1.ts" video file and ran play.
serviio.log
Debug log
(297.17 KiB) Downloaded 12 times

The TV's profile is "Sony Bravia TV (2012)":
2019-10-12 20:24:29,112 DEBUG [ConnectionManager] Sending protocol info using profile 'Sony Bravia TV (2012)'
(...)

If I understand this log, the Serviio tries to send the video in native format - without transcoding:
2019-10-12 20:25:18,191 DEBUG [VideoDeliveryEngine] Delivering file 'Eurosport-1.ts' in native format

I think that this video should be rather transcoded, as it doesn't play natively on my TV even from USB-stick (it just shows black screen on tv without any info).

However I don't know how to force transcoding on this video :?: I suppose it should be done by some modification of profile (I need support here).

The TV correctly displays from Serviio most .m2ts, mkv, mp4 Full Hd content that I have :D Main problem with files from the TV decoder .

Unfortunately the profile is quite complicated for me at first sight:

  Code:
<Profile id="sony2012" name="Sony Bravia TV (2012)" extendsProfileId="1">
  <!-- 2012 models
    - Still images: JPEG, MPO
    - Music: MP3, linear PCM, WMA, MP4
    - Video: AVCHD, MPEG2, MPEG1, MP4 (AVC), MP4 (MPEG4), DivX, WMV -->
  <Detection>
    <UPnPSearch>
      <FriendlyName>BRAVIA KDL-\d{2}[A-Z]X\d5(\d|G).*</FriendlyName>
    </UPnPSearch>
  </Detection>
  <DeviceDescription>
    <!-- act as WMP so that the TV doesn't show root categories -->
    <ModelName>Windows Media Player Sharing</ModelName>
    <ModelNumber>3.0</ModelNumber>
    <Manufacturer>Microsoft Corporation</Manufacturer>
  </DeviceDescription>
  <ContentDirectoryMessageBuilder>org.serviio.upnp.service.contentdirectory.SonyDLNAMessageBuilder</ContentDirectoryMessageBuilder>
  <ContentDirectoryDefinitionFilter>org.serviio.upnp.service.contentdirectory.definition.WMPContentDirectoryDefinitionFilter</ContentDirectoryDefinitionFilter>
  <MediaFormatProfiles>
    <!-- rename 3gp profiles that can be played as AVC -->
    <MediaFormatProfile mime-type="video/mp4" name="AVC_MP4_MP_SD_AAC_MULT5">AVC_3GPP_BL_QCIF15_AAC</MediaFormatProfile>
    <!-- Rename native avi formats to those supported by the tv -->
    <MediaFormatProfile mime-type="video/avi" name="">AVI</MediaFormatProfile>
    <!-- Rename native mpeg2ts with h264+ac3/aac formats to those supported by the tv (aac support is not advertised by the renderer but it works) -->
    <MediaFormatProfile mime-type="video/vnd.dlna.mpeg-tts" name="AVC_TS_HD_24_AC3,AVC_TS_HD_50_AC3,AVC_TS_HD_60_AC3,AVC_TS_HD_EU">AVC_TS_MP_HD_AC3</MediaFormatProfile>
    <MediaFormatProfile mime-type="video/vnd.dlna.mpeg-tts" name="AVC_TS_HD_24_AC3,AVC_TS_HD_50_AC3,AVC_TS_HD_60_AC3,AVC_TS_HD_EU">AVC_TS_MP_SD_AC3</MediaFormatProfile>
    <MediaFormatProfile mime-type="video/vnd.dlna.mpeg-tts" name="AVC_TS_HD_24_AC3,AVC_TS_HD_50_AC3,AVC_TS_HD_60_AC3,AVC_TS_HD_EU">AVC_TS_MP_HD_AAC_MULT5</MediaFormatProfile>
    <MediaFormatProfile mime-type="video/vnd.dlna.mpeg-tts" name="AVC_TS_HD_24_AC3,AVC_TS_HD_50_AC3,AVC_TS_HD_60_AC3,AVC_TS_HD_EU">AVC_TS_MP_SD_AAC_MULT5</MediaFormatProfile>
    <MediaFormatProfile mime-type="video/vnd.dlna.mpeg-tts" name="AVC_TS_HD_24_AC3_T,AVC_TS_HD_50_AC3_T,AVC_TS_HD_60_AC3_T,AVC_TS_HD_EU_T">AVC_TS_MP_HD_AC3_T</MediaFormatProfile>
    <MediaFormatProfile mime-type="video/vnd.dlna.mpeg-tts" name="AVC_TS_HD_24_AC3_T,AVC_TS_HD_50_AC3_T,AVC_TS_HD_60_AC3_T,AVC_TS_HD_EU_T">AVC_TS_MP_SD_AC3_T</MediaFormatProfile>
    <MediaFormatProfile mime-type="video/vnd.dlna.mpeg-tts" name="AVC_TS_HD_24_AC3_T,AVC_TS_HD_50_AC3_T,AVC_TS_HD_60_AC3_T,AVC_TS_HD_EU_T">AVC_TS_HP_HD_MPEG1_L2_T</MediaFormatProfile>
    <MediaFormatProfile mime-type="video/vnd.dlna.mpeg-tts" name="AVC_TS_HD_24_AC3_T,AVC_TS_HD_50_AC3_T,AVC_TS_HD_60_AC3_T,AVC_TS_HD_EU_T">AVC_TS_HP_SD_MPEG1_L2_T</MediaFormatProfile>
    <MediaFormatProfile mime-type="video/vnd.dlna.mpeg-tts" name="AVC_TS_HD_24_AC3_T,AVC_TS_HD_50_AC3_T,AVC_TS_HD_60_AC3_T,AVC_TS_HD_EU_T">AVC_TS_MP_HD_AAC_MULT5_T</MediaFormatProfile>
    <MediaFormatProfile mime-type="video/vnd.dlna.mpeg-tts" name="AVC_TS_HD_24_AC3_T,AVC_TS_HD_50_AC3_T,AVC_TS_HD_60_AC3_T,AVC_TS_HD_EU_T">AVC_TS_MP_SD_AAC_MULT5_T</MediaFormatProfile>
    <MediaFormatProfile mime-type="video/vnd.dlna.mpeg-tts" name="AVC_TS_HD_24_AC3_T,AVC_TS_HD_50_AC3_T,AVC_TS_HD_60_AC3_T,AVC_TS_HD_EU_T">AVC_TS_MP_SD_MPEG1_L3</MediaFormatProfile>
    <MediaFormatProfile mime-type="video/vnd.dlna.mpeg-tts" name="AVC_TS_HD_24_AC3_T,AVC_TS_HD_50_AC3_T,AVC_TS_HD_60_AC3_T,AVC_TS_HD_EU_T">AVC_TS_MP_SD_MPEG1_L3_T</MediaFormatProfile>         
    <!-- Rename transcoded mpeg2ts with h264 to one of the TV's supported profiles -->
    <MediaFormatProfile mime-type="video/mpeg" name="AVC_TS_HD_24_AC3_ISO,AVC_TS_HD_50_AC3_ISO,AVC_TS_HD_60_AC3_ISO,AVC_TS_HD_EU_ISO">AVC_TS_MP_HD_AC3_ISO</MediaFormatProfile>
    <MediaFormatProfile mime-type="video/mpeg" name="AVC_TS_HD_24_AC3_ISO,AVC_TS_HD_50_AC3_ISO,AVC_TS_HD_60_AC3_ISO,AVC_TS_HD_EU_ISO">AVC_TS_MP_SD_AC3_ISO</MediaFormatProfile>
    <MediaFormatProfile mime-type="video/mpeg" name="AVC_TS_HD_24_AC3_ISO,AVC_TS_HD_50_AC3_ISO,AVC_TS_HD_60_AC3_ISO,AVC_TS_HD_EU_ISO">AVC_TS_HP_HD_MPEG1_L2_ISO</MediaFormatProfile>
    <MediaFormatProfile mime-type="video/mpeg" name="AVC_TS_HD_24_AC3_ISO,AVC_TS_HD_50_AC3_ISO,AVC_TS_HD_60_AC3_ISO,AVC_TS_HD_EU_ISO">AVC_TS_HP_SD_MPEG1_L2_ISO</MediaFormatProfile>
    <MediaFormatProfile mime-type="video/mpeg" name="AVC_TS_HD_24_AC3_ISO,AVC_TS_HD_50_AC3_ISO,AVC_TS_HD_60_AC3_ISO,AVC_TS_HD_EU_ISO">AVC_TS_MP_HD_AAC_MULT5_ISO</MediaFormatProfile>
    <MediaFormatProfile mime-type="video/mpeg" name="AVC_TS_HD_24_AC3_ISO,AVC_TS_HD_50_AC3_ISO,AVC_TS_HD_60_AC3_ISO,AVC_TS_HD_EU_ISO">AVC_TS_MP_SD_AAC_MULT5_ISO</MediaFormatProfile>
    <MediaFormatProfile mime-type="video/mpeg" name="AVC_TS_HD_24_AC3_ISO,AVC_TS_HD_50_AC3_ISO,AVC_TS_HD_60_AC3_ISO,AVC_TS_HD_EU_ISO">AVC_TS_MP_SD_MPEG1_L3_ISO</MediaFormatProfile>
  </MediaFormatProfiles>
  <Transcoding>
    <!-- Transcode all h264 video with HIGH/MAIN > Level 4.1 on MPEG-TS stream with MPEG2VIDEO and ac3 audio transcoding -->
    <!-- expected profile MPEG_TS_SD_EU/MPEG_TS_SD_NA/MPEG_TS_SD_KO -->
    <Video targetContainer="mpegts" targetVCodec="mpeg2video" maxVBitrate="17000" targetACodec="ac3" aBitrate="384" DAR="16:9" forceInheritance="true" maxWidth="1920" maxHeight="1080">
      <Matches container="*" vCodec="h265"/>
      <Matches container="*" vCodec="h264" profile="high_10" />
      <Matches container="*" vCodec="h264" profile="high_422" />
      <Matches container="*" vCodec="h264" profile="high_444" />
      <Matches container="*" vCodec="h264" profile="high" levelGreaterThan="4.1" />
      <Matches container="*" vCodec="h264" profile="main" levelGreaterThan="4.1" />
      <Matches container="*" widthGreaterThan="1920" />
    </Video>
    <!-- Remux containers with h264 video + AC3 audio to MPEG-TS stream without transcoding -->
    <Video targetContainer="mpegts" forceInheritance="true">
      <Matches container="avi" vCodec="h264" aCodec="ac3" />
      <Matches container="matroska" vCodec="h264" aCodec="ac3" />
      <Matches container="flv" vCodec="h264" aCodec="ac3" />
      <Matches container="wtv" vCodec="h264" aCodec="ac3" />
       <Matches container="avi" vCodec="h264" aCodec="eac3" />
      <Matches container="matroska" vCodec="h264" aCodec="eac3" />
      <Matches container="flv" vCodec="h264" aCodec="eac3" />
      <Matches container="wtv" vCodec="h264" aCodec="eac3" />
    </Video>
    <!-- Remux all other h264 video to MPEG-TS stream with ac3 audio transcoding -->
    <!-- expected profile AVC_TS_MP_HD_AC3_ISO -->
    <Video targetContainer="mpegts" targetACodec="ac3" aBitrate="384" forceInheritance="true">
      <Matches container="avi" vCodec="h264" />
      <Matches container="matroska" vCodec="h264" />
      <Matches container="flv" vCodec="h264" />
      <Matches container="wtv" vCodec="h264" />
      <Matches container="mp4" vCodec="h264" aCodec="mp3" />
      <Matches container="mp4" vCodec="h264" aCodec="dca" />
      <Matches container="mp4" vCodec="h264" aCodec="dts-hd" />   
      <Matches container="mp4" vCodec="h264" aCodec="lpcm" />
      <!-- if audio different to ac3, it must be transcoded -->
      <Matches container="mpegts" aCodec="truehd" />
      <Matches container="mpegts" aCodec="mp3" />
      <Matches container="mpegts" aCodec="dca" />
      <Matches container="mpegts" aCodec="dts-hd" />   
      <Matches container="mpegts" aCodec="lpcm" />
      <Matches container="mpeg" aCodec="dca" />
      <Matches container="mpeg" aCodec="dts-hd" />   
    </Video>
    <!-- VC1_ASF_AP_L3_WMA not supported : TODO find a match -->
    <!-- <Video targetContainer="asf" targetACodec="wmav2" forceStereo="true"> -->
    <!-- <Matches container="asf" vCodec="vc1" maxHeight="720"/> -->
    <!-- </Video> -->
    <!-- DVR-MS -->
    <!-- force mpeg2video transcoding to fix monotone timestamps problems -->
    <Video targetContainer="mpegts" targetACodec="ac3" forceVTranscoding="true" DAR="16:9" forceInheritance="true">
      <Matches container="asf" vCodec="mpeg2video" />
    </Video>
    <!-- All Others video/audio codec will be transcoded into mpeg2ts, mpeg2video and ac3 audio -->
    <!-- expected profile MPEG_TS_SD_EU/MPEG_TS_SD_NA/MPEG_TS_SD_KO -->
    <Video targetContainer="mpegts" targetVCodec="mpeg2video" maxVBitrate="17000" targetACodec="ac3" aBitrate="384" DAR="16:9" forceInheritance="true">
      <Matches container="mpegts" vCodec="vc1" />
      <Matches container="matroska" />
      <Matches container="flv" />
      <Matches container="wtv" />
      <Matches container="ogg" />
      <Matches container="rm" />
      <Matches container="3gp" vCodec="mpeg4" />
      <Matches container="3gp" vCodec="h263" />
      <!-- digital camera video formats -->
         <Matches container="avi" vCodec="mjpeg" />
         <Matches container="mp4" vCodec="mjpeg" />
         <Matches container="asf" vCodec="vc1" aCodec="wmapro" />
         <Matches container="avi" vCodec="dvvideo" />
         <Matches container="mp4" vCodec="dvvideo" />
    </Video>
    <Audio targetContainer="lpcm" forceInheritance="true">
      <!-- To allow "pause" then "resume" functions and album art for TVs that support it - transcode to mp3 instead -->
      <Matches container="flac" />
      <Matches container="ogg" />
      <Matches container="adts" /> 
      <Matches container="mp3" codec="mp2" />
      <Matches container="wv" />
      <Matches container="mpc" />
      <Matches container="ape" />
      <Matches container="dsf" />
      <Matches container="wav" />
      <Matches container="mp4" codec="alac" />
    </Audio>
    <Image forceInheritance="true">
      <Matches container="jpeg" subsampling="YUV444" />
    </Image>
  </Transcoding>
  <OnlineTranscoding>
    <Video targetContainer="mpegts" targetACodec="ac3" aBitrate="384" forceInheritance="true">
      <Matches container="mp4" vCodec="h264" />
      <Matches container="flv" vCodec="h264" />
      <Matches container="applehttp" vCodec="h264" />
    </Video>
    <!-- Add DAR option for Sony Bravia -->
    <Video targetContainer="mpegts" targetVCodec="mpeg2video" DAR="16:9" targetACodec="ac3" aBitrate="384" forceInheritance="true">
      <Matches container="asf"/>
      <Matches container="flv"/>
      <Matches container="rtp"/>
      <Matches container="rtsp"/>
      <Matches container="applehttp"/>
    </Video>
  </OnlineTranscoding>
  <AudioTrackRemux>
    <Video targetContainer="mpegts" targetACodec="ac3" aBitrate="384">
      <Matches container="*" vCodec="h264" />
      <Matches container="*" vCodec="mpeg2video" />
      <Matches container="*" vCodec="mpeg1video" />
      <Matches container="*" vCodec="mpeg4" />
      <Matches container="*" vCodec="msmpeg4" />
    </Video>
  </AudioTrackRemux>
  <GenericTranscoding>
    <Video targetContainer="mpegts" targetVCodec="mpeg2video" maxVBitrate="17000" targetACodec="ac3" aBitrate="384" DAR="16:9" />
  </GenericTranscoding>
  <LimitImageResolution>false</LimitImageResolution>
</Profile>
<<

Ravenik

Serviio newbie

Posts: 4

Joined: Sat Oct 12, 2019 2:20 pm

Post Sun Oct 13, 2019 12:26 am

Re: 2.0 Can't play .ts files that I record from cable TV.

I finally got it working. Two modifications were needed in profiles.xml, in the profile id="sony2012":

1. In the section <MediaFormatProfiles> I found a line with "AVC_TS_HP_HD_MPEG1_L2_ISO" and moved "AVC_TS_HD_50_AC3_ISO" to the first position in "name=", so that the line is now:
  Code:
<MediaFormatProfile mime-type="video/mpeg" name="AVC_TS_HD_50_AC3_ISO,AVC_TS_HD_24_AC3_ISO,AVC_TS_HD_60_AC3_ISO,AVC_TS_HD_EU_ISO">AVC_TS_HP_HD_MPEG1_L2_ISO</MediaFormatProfile>


2. in the third <Video...>...</Video> section I added the following line after all the lines being like "<Matches container="mpegts" ... />:
  Code:
<Matches container="mpegts" aCodec="mp2" />


If I understand, now only audio is recoded for the mentioned video file. Observing Serviio "tmp" folder also indicates so.
<<

Emileroure

User avatar

Serviio newbie

Posts: 4

Joined: Thu Oct 03, 2019 4:52 pm

Location: Burkina Faso

Post Wed Oct 16, 2019 9:40 pm

2 0 Cant play ts files that I record from cable TV

If the clip opens in Quicktime, can you just export from Quicktime? You might need to have Quicktime Pro for this.

What about Compressor? Have you tried that?
<<

atc98092

User avatar

DLNA master

Posts: 3423

Joined: Fri Aug 17, 2012 10:22 pm

Location: Washington (the state)

Post Thu Oct 17, 2019 12:23 am

Re: 2.0 Can't play .ts files that I record from cable TV.

Ravenik wrote:I finally got it working. Two modifications were needed in profiles.xml, in the profile id="sony2012":

2. in the third <Video...>...</Video> section I added the following line after all the lines being like "<Matches container="mpegts" ... />:
  Code:
<Matches container="mpegts" aCodec="mp2" />


If I understand, now only audio is recoded for the mentioned video file. Observing Serviio "tmp" folder also indicates so.


I'd have to see the complete <Video> section to say for sure what is happening with that Matches line. It's matching the MP2 audio in any TS container, but depending on the first line of the <Video> section it may be transcoding the video along with the audio.
Dan

Panasonic ST30 Plasma, Samsung JU7100 4K TV, Sony BDP-S3500, Sharp 4K Roku TV, Insignia Roku TV, Roku 4, Ultra and Stick, Nvidia Shield, Yamaha RX-V583 AVR.
Primary server: Intel i5-6400, 8 gig ram, Windows 10 Pro, 18 TB hard drive space | Test server Windows 10 Pro, AMD Phenom II X4 965, 8 gig ram

HOWTO: Enable debug logging HOWTO: Identify media file contents
<<

Ravenik

Serviio newbie

Posts: 4

Joined: Sat Oct 12, 2019 2:20 pm

Post Thu Oct 17, 2019 12:38 am

Re: 2.0 Can't play .ts files that I record from cable TV.

atc98092 wrote:I'd have to see the complete <Video> section to say for sure what is happening with that Matches line. It's matching the MP2 audio in any TS container, but depending on the first line of the <Video> section it may be transcoding the video along with the audio.


Thanks for the reply. Below I include <Transcoding> with <Video...> sections. My modification goes after "<!-- add mpegts with mp2 audio, so that some enigma2 videos will match: -->"

It would be helpful indeed if you could say if only audio is transcoded in this "case" but also how can you know from <video> section code if only audio is transoced or video also?

  Code:
<Transcoding>
         <!-- Transcode all h264 video with HIGH/MAIN > Level 4.1 on MPEG-TS stream with MPEG2VIDEO and ac3 audio transcoding -->
         <!-- expected profile MPEG_TS_SD_EU/MPEG_TS_SD_NA/MPEG_TS_SD_KO -->
         <Video targetContainer="mpegts" targetVCodec="mpeg2video" maxVBitrate="17000" targetACodec="ac3" aBitrate="384" DAR="16:9" forceInheritance="true" maxWidth="1920" maxHeight="1080">
            <Matches container="*" vCodec="h265"/>
            <Matches container="*" vCodec="h264" profile="high_10" />
            <Matches container="*" vCodec="h264" profile="high_422" />
         <Matches container="*" vCodec="h264" profile="high_444" />
            <Matches container="*" vCodec="h264" profile="high" levelGreaterThan="4.1" />
            <Matches container="*" vCodec="h264" profile="main" levelGreaterThan="4.1" />
            <Matches container="*" widthGreaterThan="1920" />
         </Video>
         <!-- Remux containers with h264 video + AC3 audio to MPEG-TS stream without transcoding -->
         <Video targetContainer="mpegts" forceInheritance="true">
            <Matches container="avi" vCodec="h264" aCodec="ac3" />
            <Matches container="matroska" vCodec="h264" aCodec="ac3" />
            <Matches container="flv" vCodec="h264" aCodec="ac3" />
            <Matches container="wtv" vCodec="h264" aCodec="ac3" />
          <Matches container="avi" vCodec="h264" aCodec="eac3" />
            <Matches container="matroska" vCodec="h264" aCodec="eac3" />
            <Matches container="flv" vCodec="h264" aCodec="eac3" />
            <Matches container="wtv" vCodec="h264" aCodec="eac3" />
         </Video>
         <!-- Remux all other h264 video to MPEG-TS stream with ac3 audio transcoding -->
         <!-- expected profile AVC_TS_MP_HD_AC3_ISO -->
         <Video targetContainer="mpegts" targetACodec="ac3" aBitrate="384" forceInheritance="true">
            <Matches container="avi" vCodec="h264" />
            <Matches container="matroska" vCodec="h264" />
            <Matches container="flv" vCodec="h264" />
            <Matches container="wtv" vCodec="h264" />
            <Matches container="mp4" vCodec="h264" aCodec="mp3" />
            <Matches container="mp4" vCodec="h264" aCodec="dca" />
            <Matches container="mp4" vCodec="h264" aCodec="dts-hd" />   
            <Matches container="mp4" vCodec="h264" aCodec="lpcm" />
            <!-- if audio different to ac3, it must be transcoded -->
            <Matches container="mpegts" aCodec="truehd" />
            <Matches container="mpegts" aCodec="mp3" />
            <Matches container="mpegts" aCodec="dca" />
            <Matches container="mpegts" aCodec="dts-hd" />   
            <Matches container="mpegts" aCodec="lpcm" />
            <!-- add mpegts with mp2 audio, so that some enigma2 videos will match: -->
            <Matches container="mpegts" aCodec="mp2" />         
            <Matches container="mpeg" aCodec="dca" />
            <Matches container="mpeg" aCodec="dts-hd" />   
         </Video>
         <!-- VC1_ASF_AP_L3_WMA not supported : TODO find a match -->
         <!-- <Video targetContainer="asf" targetACodec="wmav2" forceStereo="true"> -->
         <!-- <Matches container="asf" vCodec="vc1" maxHeight="720"/> -->
         <!-- </Video> -->
         <!-- DVR-MS -->
         <!-- force mpeg2video transcoding to fix monotone timestamps problems -->
         <Video targetContainer="mpegts" targetACodec="ac3" forceVTranscoding="true" DAR="16:9" forceInheritance="true">
            <Matches container="asf" vCodec="mpeg2video" />
         </Video>
         <!-- All Others video/audio codec will be transcoded into mpeg2ts, mpeg2video and ac3 audio -->
         <!-- expected profile MPEG_TS_SD_EU/MPEG_TS_SD_NA/MPEG_TS_SD_KO -->
         <Video targetContainer="mpegts" targetVCodec="mpeg2video" maxVBitrate="17000" targetACodec="ac3" aBitrate="384" DAR="16:9" forceInheritance="true">
            <Matches container="mpegts" vCodec="vc1" />
            <Matches container="matroska" />
            <Matches container="flv" />
            <Matches container="wtv" />
            <Matches container="ogg" />
            <Matches container="rm" />
            <Matches container="3gp" vCodec="mpeg4" />
            <Matches container="3gp" vCodec="h263" />
            <!-- digital camera video formats -->
               <Matches container="avi" vCodec="mjpeg" />
               <Matches container="mp4" vCodec="mjpeg" />
               <Matches container="asf" vCodec="vc1" aCodec="wmapro" />
               <Matches container="avi" vCodec="dvvideo" />
               <Matches container="mp4" vCodec="dvvideo" />
         </Video>
         <Audio targetContainer="lpcm" forceInheritance="true">
            <!-- To allow "pause" then "resume" functions and album art for TVs that support it - transcode to mp3 instead -->
            <Matches container="flac" />
            <Matches container="ogg" />
            <Matches container="adts" /> 
            <Matches container="mp3" codec="mp2" />
            <Matches container="wv" />
            <Matches container="mpc" />
            <Matches container="ape" />
            <Matches container="dsf" />
            <Matches container="wav" />
            <Matches container="mp4" codec="alac" />
         </Audio>
         <Image forceInheritance="true">
            <Matches container="jpeg" subsampling="YUV444" />
         </Image>
      </Transcoding>
Last edited by Ravenik on Thu Oct 17, 2019 4:37 pm, edited 1 time in total.
<<

atc98092

User avatar

DLNA master

Posts: 3423

Joined: Fri Aug 17, 2012 10:22 pm

Location: Washington (the state)

Post Thu Oct 17, 2019 3:16 am

Re: 2.0 Can't play .ts files that I record from cable TV.

OK, looking through it I see where you added the line. This is the complete section that is being applied:
  Code:
 <Video targetContainer="mpegts" targetACodec="ac3" aBitrate="384" forceInheritance="true">
            <Matches container="avi" vCodec="h264" />
            <Matches container="matroska" vCodec="h264" />
            <Matches container="flv" vCodec="h264" />
            <Matches container="wtv" vCodec="h264" />
            <Matches container="mp4" vCodec="h264" aCodec="mp3" />
            <Matches container="mp4" vCodec="h264" aCodec="dca" />
            <Matches container="mp4" vCodec="h264" aCodec="dts-hd" />   
            <Matches container="mp4" vCodec="h264" aCodec="lpcm" />
            <!-- if audio different to ac3, it must be transcoded -->
            <Matches container="mpegts" aCodec="truehd" />
            <Matches container="mpegts" aCodec="mp3" />
            <Matches container="mpegts" aCodec="dca" />
            <Matches container="mpegts" aCodec="dts-hd" />   
            <Matches container="mpegts" aCodec="lpcm" />
            <!-- add mpegts with mp2 audio, so that some enigma2 videos will match: -->
            <Matches container="mpegts" aCodec="mp2" />         
            <Matches container="mpeg" aCodec="dca" />
            <Matches container="mpeg" aCodec="dts-hd" />   
         </Video>


If you look at the first line, you see a TargetACodec, but no TargetVCodec. That means you are transcoding the audio to AC3, but the video is being transmuxed, which leaves the video as is and simply adds it to the container along with the transcoded audio. So, no the video is not being transcoded. You can confirm that by starting Task Manager (in Windows) and watch the CPU utilization. If it's not near 100%, then there's no video transcoding going on.
Dan

Panasonic ST30 Plasma, Samsung JU7100 4K TV, Sony BDP-S3500, Sharp 4K Roku TV, Insignia Roku TV, Roku 4, Ultra and Stick, Nvidia Shield, Yamaha RX-V583 AVR.
Primary server: Intel i5-6400, 8 gig ram, Windows 10 Pro, 18 TB hard drive space | Test server Windows 10 Pro, AMD Phenom II X4 965, 8 gig ram

HOWTO: Enable debug logging HOWTO: Identify media file contents

Return to Sony

Who is online

Users browsing this forum: No registered users and 2 guests

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.