FAQ  •  Register  •  Login

Mpeg4/AAC file not playing on PS3

<<

cliff_sch

Serviio newbie

Posts: 5

Joined: Wed Oct 05, 2011 3:50 am

Post Wed Oct 05, 2011 3:59 am

Mpeg4/AAC file not playing on PS3

Hi, I have a file that seems like it should play on a PS3 but doesn't. Strangely, the file streams/plays on the PS3 just fine using the built-in media server on my Synology NAS but won't play when served from Serviio. The file streams fine from Serviio to another player (WD TV Live Plus) so it just seems to be the PS3 that has trouble with the file from Serviio.

I'm hoping it's a simple mod to the PS3 profile but in trying to edit the profile I haven't been able to make any progress.


MediaInfo profile for the file -
General
Complete name : V:\Exercise\One on One with Tony Horton\v01d02 Road Warrior.mp4
Format : MPEG-4
Format profile : Base Media
Codec ID : isom
File size : 354 MiB
Duration : 55mn 57s
Overall bit rate : 884 Kbps
Encoded date : UTC 2009-09-01 00:01:20
Tagged date : UTC 2009-09-01 00:01:20

Video
ID : 1
Format : MPEG-4 Visual
Format profile : Simple@L1
Format settings, BVOP : No
Format settings, QPel : No
Format settings, GMC : No warppoints
Format settings, Matrix : Default (H.263)
Codec ID : 20
Duration : 55mn 57s
Bit rate mode : Variable
Bit rate : 800 Kbps
Width : 480 pixels
Height : 320 pixels
Display aspect ratio : 3:2
Frame rate mode : Constant
Frame rate : 29.970 fps
Color space : YUV
Chroma subsampling : 4:2:0
Bit depth : 8 bits
Scan type : Progressive
Bits/(Pixel*Frame) : 0.174
Stream size : 320 MiB (90%)
Writing library : Lavc51.40.4
Encoded date : UTC 2009-09-01 00:01:20
Tagged date : UTC 2009-09-01 00:01:20

Audio
ID : 2
Format : AAC
Format/Info : Advanced Audio Codec
Format version : Version 4
Format profile : LC
Format settings, SBR : No
Codec ID : 40
Duration : 55mn 57s
Bit rate mode : Variable
Bit rate : 79.7 Kbps
Channel(s) : 2 channels
Channel positions : Front: L R
Sampling rate : 48.0 KHz
Stream size : 31.9 MiB (9%)
Encoded date : UTC 2009-09-01 00:01:20
Tagged date : UTC 2009-09-01 00:01:20
<<

Cerberus

User avatar

DLNA master

Posts: 4116

Joined: Sun Jan 02, 2011 5:20 pm

Location: Reading, UK

Post Wed Oct 05, 2011 4:15 am

Re: Mpeg4/AAC file not playing on PS3

in the ps3 profile

find

  Code:
<Matches container="3gp" aCodec="amrnb" />


and add this after

  Code:
<Matches container="mp4" aCodec="aac" />
Phil Bennett
Beta Tester Group
Wiki | FAQ

Samsung LE40C750 LCD | Samsung BD-C5900 | Sony PS3 | Windows 7 |
HowTo: Provide supported formats of a device HowTo: Record a new ticket on Bitbucket
HowTo: Provide details of a video file that doesn't play HowTo: Turn on detailed logging
<<

cliff_sch

Serviio newbie

Posts: 5

Joined: Wed Oct 05, 2011 3:50 am

Post Wed Oct 05, 2011 5:11 am

Re: Mpeg4/AAC file not playing on PS3

I made the change and restarted the Serviio service and get "The data type is not supported" on the PS3 when I try to play the file.

If it helps, I turned on debugging and pulled this snippet from the serviio log:

2011-10-04 22:06:04,889 DEBUG [WebServer] Incoming connection from /192.168.43.138:57273
2011-10-04 22:06:04,889 DEBUG [ResourceTransportRequestHandler] GET /resource/15923/MEDIA_ITEM/MPEG4_P2_TS_ASP_AC3_ISO$0 HTTP/1.1, headers = [Host: 192.168.43.10:8895,User-Agent: PLAYSTATION 3,Connection: Keep-Alive,Accept-Encoding: identity,transferMode.dlna.org: Streaming,TimeSeekRange.dlna.org: npt=0.000-]]
2011-10-04 22:06:04,889 DEBUG [RendererDAOImpl] Reading a Renderer with ip address 192.168.43.138
2011-10-04 22:06:04,905 DEBUG [ResourceTransportRequestHandler] Resource request accepted. Using client 'IPAddress=/192.168.43.138, Profile=Playstation 3'
2011-10-04 22:06:04,905 DEBUG [ResourceTransportRequestHandler] Request for resource 15923 and type 'MEDIA_ITEM' received
2011-10-04 22:06:04,905 DEBUG [MediaResourceRetrievalStrategy] Getting information about media item 15923 (local)
2011-10-04 22:06:04,905 DEBUG [VideoDeliveryEngine] Delivering item '15923' for client 'IPAddress=/192.168.43.138, Profile=Playstation 3'
2011-10-04 22:06:04,905 DEBUG [VideoDeliveryEngine] Delivering file 'v01d02 Road Warrior.mp4' using transcoding
2011-10-04 22:06:04,905 DEBUG [AbstractTranscodingDeliveryEngine] No suitable transcoding job exists yet, start one for client 'IPAddress=/192.168.43.138, Profile=Playstation 3'
2011-10-04 22:06:04,905 DEBUG [FFMPEGWrapper] Invoking FFmpeg to transcode video file: \\home\video\Exercise\One on One with Tony Horton\v01d02 Road Warrior.mp4
2011-10-04 22:06:04,920 DEBUG [ProcessExecutor] Starting C:\Program Files\Serviio\bin\\..\lib/ffmpeg.exe -i \\home\video\Exercise\One on One with Tony Horton\v01d02 Road Warrior.mp4 -y -vcodec copy -copyts -acodec ac3 -ab 384k -ac 2 -map 0:0 -map 0:1 -sn -f mpegts C:\Windows\TEMP\Serviio\transcoding-temp-15923-MPEG2TS.stf
2011-10-04 22:06:05,435 DEBUG [VideoDeliveryEngine] Found Format profile for transcoded file v01d02 Road Warrior.mp4: MPEG4_P2_TS_ASP_AC3_ISO
2011-10-04 22:06:05,451 DEBUG [AbstractTranscodingDeliveryEngine] Sending transcoding stream
2011-10-04 22:06:05,997 DEBUG [LocalContentCacheDecorator] Cleared cache (local_resetafterplay)
2011-10-04 22:06:06,012 DEBUG [ResourceTransportRequestHandler] Creating stream entity with length: 50000000000
2011-10-04 22:06:06,012 DEBUG [ResourceTransportRequestHandler] Creating entity with chunked transfer
2011-10-04 22:06:06,012 DEBUG [ResourceTransportRequestHandler] Sending file back
2011-10-04 22:06:06,012 DEBUG [ResourceTransportRequestHandler] HTTP/1.1 200 OK, headers = [[Content-Type: video/mpeg,TimeSeekRange.dlna.org: npt=0.0-3357.0/3357,Date: Wed, 05 Oct 2011 05:06:06 GMT,Server: Windows 7, UPnP/1.0 DLNADOC/1.50, Serviio/0.6.0.1,Cache-control: no-cache,transferMode.dlna.org: Streaming]]
2011-10-04 22:06:06,153 DEBUG [WebServer] I/O error: Connection reset by peer: socket write error
<<

Cerberus

User avatar

DLNA master

Posts: 4116

Joined: Sun Jan 02, 2011 5:20 pm

Location: Reading, UK

Post Wed Oct 05, 2011 5:13 am

Re: Mpeg4/AAC file not playing on PS3

ah damn ok move that line up in teh profile so its under this line

  Code:
<Matches container="avi" vCodec="dvvideo" />
Phil Bennett
Beta Tester Group
Wiki | FAQ

Samsung LE40C750 LCD | Samsung BD-C5900 | Sony PS3 | Windows 7 |
HowTo: Provide supported formats of a device HowTo: Record a new ticket on Bitbucket
HowTo: Provide details of a video file that doesn't play HowTo: Turn on detailed logging
<<

cliff_sch

Serviio newbie

Posts: 5

Joined: Wed Oct 05, 2011 3:50 am

Post Wed Oct 05, 2011 5:19 am

Re: Mpeg4/AAC file not playing on PS3

Okay, so technically it works now, but it's transcoding the video stream now, right? I have Serviio running on a test PC but want to get it running on my Synology NAS which would rule out transcoding video streams.

What I don't understand is why the video streams/plays from the stock media server on the Synology NAS? Clearly it doesn't transcode the video stream and the file plays just fine.

Any other thoughts on how to get this to work without video transcoding?

Thanks for the quick responses!
<<

Cerberus

User avatar

DLNA master

Posts: 4116

Joined: Sun Jan 02, 2011 5:20 pm

Location: Reading, UK

Post Wed Oct 05, 2011 5:24 am

Re: Mpeg4/AAC file not playing on PS3

cliff_sch wrote:Okay, so technically it works now, but it's transcoding the video stream now, right? I have Serviio running on a test PC but want to get it running on my Synology NAS which would rule out transcoding video streams.

What I don't understand is why the video streams/plays from the stock media server on the Synology NAS? Clearly it doesn't transcode the video stream and the file plays just fine.

Any other thoughts on how to get this to work without video transcoding?

Thanks for the quick responses!


nope file has to be transcoded as we tried the other option first and NAS wont have an issue with transcoding, it will cope just fine.
Phil Bennett
Beta Tester Group
Wiki | FAQ

Samsung LE40C750 LCD | Samsung BD-C5900 | Sony PS3 | Windows 7 |
HowTo: Provide supported formats of a device HowTo: Record a new ticket on Bitbucket
HowTo: Provide details of a video file that doesn't play HowTo: Turn on detailed logging
<<

cliff_sch

Serviio newbie

Posts: 5

Joined: Wed Oct 05, 2011 3:50 am

Post Wed Oct 05, 2011 5:32 am

Re: Mpeg4/AAC file not playing on PS3

...though transcoding is still necessary in this case.

Can you help me understand how the native NAS media server can send this file to the PS3 as MP4/AAC video with no transcoding but Serviio can't seem to do it without transcoding to MPEG2/AC3?

It does take a pretty big hit on the CPU of the test Serviio box right now which is an Intel Atom CPU.

It's nice to have a transcoding option *when needed* but I'm at a loss as to why this file needs transcoding under Serviio. I have quite a few videos with this format so it would be nice to find a non-transcoding solution.

Thanks
<<

Cerberus

User avatar

DLNA master

Posts: 4116

Joined: Sun Jan 02, 2011 5:20 pm

Location: Reading, UK

Post Wed Oct 05, 2011 5:42 am

Re: Mpeg4/AAC file not playing on PS3

Couldnt tell you i have never used it, your only other option is to remux the file manualy then it wont need to be transcoded.
Phil Bennett
Beta Tester Group
Wiki | FAQ

Samsung LE40C750 LCD | Samsung BD-C5900 | Sony PS3 | Windows 7 |
HowTo: Provide supported formats of a device HowTo: Record a new ticket on Bitbucket
HowTo: Provide details of a video file that doesn't play HowTo: Turn on detailed logging
<<

cliff_sch

Serviio newbie

Posts: 5

Joined: Wed Oct 05, 2011 3:50 am

Post Wed Oct 05, 2011 5:55 am

Re: Mpeg4/AAC file not playing on PS3

Yeah, I get it. Same old problem as ever there was. {sigh}

I could certainly transcode EVERYTHING I have to a single format to know that it will work - and it's hard to fault Serviio when the on-the-fly transcoding does work well... but still - the PS3 supports MP4/AAC videos both locally and streamed from another non-transcoding media server without issue. I wish I knew what was tripping up Serviio on these files.

Pegging the CPU on my NAS unit is a bit of a showstopper for me. It already gets taxed with enough duties between software RAID, backups, and downloading.

My first choice would be to run Serviio and solve the problem of streaming these particular MP4/AAC files (assuming there's more in my future that would be in that format) without transcoding. I would still get MKV support with audio-only transcoding and I'd be very happy.

Thanks for trying, at least.
<<

Illico

User avatar

DLNA master

Posts: 4645

Joined: Fri Jul 23, 2010 8:08 am

Location: France

Post Wed Oct 05, 2011 6:56 am

Re: Mpeg4/AAC file not playing on PS3

cliff_sch wrote:MediaInfo profile for the file -
...
Format : MPEG-4 Visual
Format profile : Simple@L1
Format settings, BVOP : No
Format settings, QPel : No
Format settings, GMC : No warppoints
Format settings, Matrix : Default (H.263)
Codec ID : 20

Its probably due to codec used that is not supported by PS3 or format settings...
Don't know what is "Codec Id : 20", should be XVID or something else.
But Serviio could not distinguish codecs, only "Video: mpeg4" matched.
Sorry no more ideas, search on forum and compare.
Illico
Sony 2010 KDL-46EX501 | BDP-S373 | SMP-N100 | Windows 8-i7 | Network DD HD-CE1.5TLU2 | Livebox2-UHD86 | ServiiDroid | ServiiGo | BubbleUPnP
Serviio beta tester - Moderator
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 17056

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Sun Oct 09, 2011 5:07 pm

Re: Mpeg4/AAC file not playing on PS3

can you provide protocol info of the file how it's served by the stock server? You'll need to install intel tools, run AV Media Controller, find the file and go to the properties, then select the video resource.

It might be as simple as a mime type.
<<

hygeian

Serviio newbie

Posts: 1

Joined: Fri Nov 18, 2011 2:56 am

Post Fri Aug 24, 2012 2:33 am

Re: Mpeg4/AAC file not playing on PS3

PS3 cannot play any knids of MP4 files. PS3 can play MP4 video files with extension of .mp4 with video codec of MPEG-4 AVC H.264 /Xvid/DivX and audio codec of AAC. There are still some other MP4 video files are unsupported like MPEG-4 ASP.

As MPEG-4 AVC H.264 codec, support is limited to the following specifications:

AVC Profile: Baseline, Main or High Profiles
Maximum bitrate: None specified. However, if bitrate is above 20Mbps, stuttering will occur when playback
AVC Level: 4.2
No B-Pyramid and P4x4 support
4GB limit for streaming H.264 files

To successful play MP4 files that PS3 failed to see/recognize, transfer, playback or not normally playback, a better solution is to convert MP4 to PS3 supported MPEG-4 AVC codec or MPEG-2 video

Here is the detailed guide on how to successfully play various kinds of MP4 on PS3:
http://videoconverter-software.blogspot.com/2012/04/play-mp4-on-ps3-convert-mp4-to-ps3.html
<<

Asuccessful

Serviio newbie

Posts: 1

Joined: Thu Jun 13, 2013 8:57 am

Post Thu Jun 13, 2013 9:04 am

Re: Mpeg4/AAC file not playing on PS3

PS3 does not support M4A file format. To play and transfer M4A files to PS3, it will be better to change M4A to MP3 or WAV. You can get one solution in Google or Bing. Or you can find one way here: http://www.bigasoft.com/articles/m4a-to-wav-converter-convert-m4a-to-wav-on-mac-and-windows.html
<<

smallcated

Serviio newbie

Posts: 1

Joined: Fri Mar 25, 2016 10:43 am

Post Fri Mar 25, 2016 10:45 am

Re: Mpeg4/AAC file not playing on PS3

Have you tried Avdshare Video Converter which can Convert all PS3  unsupported MP4 to PS3 supported video formats with the highest converting speed.

Return to Sony

Who is online

Users browsing this forum: No registered users and 7 guests

cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.