FAQ  •  Register  •  Login

Audio glitches when transcoding DTS on some files

<<

dreamlayers

Serviio newbie

Posts: 15

Joined: Tue Apr 10, 2012 6:12 pm

Location: Ontario, Canada

Post Sat Oct 27, 2012 9:06 pm

Audio glitches when transcoding DTS on some files

I'm using Serviio 1.0.1 and I was encountering problems with some files when transcoding DTS. I just examined the problem a bit.

I ran Serviio in Ubuntu 12.10 using ffmpeg from Jon Severinsson's PPA (because normal Ubuntu ffmpeg is too old). When playing via VLC and transcoding DTS to AC3 or MP2, I heard clipping and audio was noticeably louder than when playing DTS. The same thing could be heard if playing the transcoded temporary file using ffplay. Setting "Audio channels" to "Keep original" instead of "Downmix to stereo" avoided the volume increase and clipping. Audio played properly on the LG 47LW5600 TV.

When running Serviio in Windows 7, this configuration change did not fix the problem. With "Keep original" I was still hearing audio interruptions with clicks. It did not sound like clipping. The same thing played properly from C:\Windows\Temp using mplayer. Replacing ffmpeg.exe with the one from Serviio 0.6.2 fixed the problem. The ffmpeg.exe from 1.0 had the same problem.

I hope Serviio 1.0.1 will work properly with ffmpeg.exe from 0.6.2. If there are any problems with this, I will downgrade Serviio to 0.6.2.
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 17076

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Mon Nov 05, 2012 11:25 pm

Re: Audio glitches when transcoding DTS on some files

I will not work with the old FFmpeg version.

Return to LG

Who is online

Users browsing this forum: No registered users and 4 guests

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.