FAQ  •  Register  •  Login

Subtitles work on LG TV but not on HT

<<

pkeuter

Serviio newbie

Posts: 2

Joined: Wed Nov 28, 2012 2:59 pm

Post Wed Dec 12, 2012 9:51 am

Subtitles work on LG TV but not on HT

So I got this 42LM3450 TV which works pretty nice except for the DTS decoding, which is fine because I can play the same stuff with DTS on my HX352 (home theather). The problem is though, when I play files on my TV, I've got the external subtitles whereas they don't work on my home theater. So I checked the manual which says that it supports subrip (.srt) files and (I've translated this from Dutch): "To play a movie-file, the filename of the subtitles and the movie should be identical". Which to me implies that the system works with external subtitles (i have the names identical of course).

Now, to check my assumption, I've tried playing the same stuff with Nero Mediahome 4 and it works just fine. So I suppose it's a Serviio-problem. I tried converting the file to UTF-8 because it was ISO-8859-1 but it doesn't matter. SRTWiz doesn't change a bit in the file so that doesn't fix the problem either.

I put the debug log on pastebin: http://www.pastebin.ca/2291746
This is the mediainfo of the file: http://www.pastebin.ca/2291747
I'm running Ubuntu 12.04.

Hope someone can figure out what's wrong!
<<

Illico

User avatar

DLNA master

Posts: 4649

Joined: Fri Jul 23, 2010 8:08 am

Location: France

Post Wed Dec 12, 2012 10:01 am

Re: Subtitles work on LG TV but not on HT

pkeuter wrote:...42LM3450 TV which works pretty nice... HX352 (home theather).

What are profiles selected on serviio console for each devices ?
You can try to use the same "LG profile" for your HT.
Illico
Sony 2010 KDL-46EX501 | BDP-S373 | SMP-N100 | Windows 8-i7 | Network DD HD-CE1.5TLU2 | Livebox2-UHD86 | ServiiDroid | ServiiGo | BubbleUPnP
Serviio beta tester - Moderator
<<

pkeuter

Serviio newbie

Posts: 2

Joined: Wed Nov 28, 2012 2:59 pm

Post Wed Dec 12, 2012 10:04 am

Re: Subtitles work on LG TV but not on HT

Illico wrote:
pkeuter wrote:...42LM3450 TV which works pretty nice... HX352 (home theather).

What are profiles selected on serviio console for each devices ?
You can try to use the same "LG profile" for your HT.


Sorry, I forgot to mention (you can see it in the log though) that the HT is using the "LG TV / player"-profile, the same profile as the television.
<<

Illico

User avatar

DLNA master

Posts: 4649

Joined: Fri Jul 23, 2010 8:08 am

Location: France

Post Wed Dec 12, 2012 11:11 am

Re: Subtitles work on LG TV but not on HT

All resources are presented in same way (res1=VIDEO, res2=SUBTILES,etc...).
Your TV saw these resources and requested for both of them, but your HT did not request for the SUBITLE request. Don't know why.
Something with the subtitle mime-type ?? (text/srt)
With Wireshark tool, you can make an advanced analysis of what other DLNA server delivered. Then check and compare DLNA messages. (I know it's quite difficult)
Illico
Sony 2010 KDL-46EX501 | BDP-S373 | SMP-N100 | Windows 8-i7 | Network DD HD-CE1.5TLU2 | Livebox2-UHD86 | ServiiDroid | ServiiGo | BubbleUPnP
Serviio beta tester - Moderator

Return to LG

Who is online

Users browsing this forum: No registered users and 4 guests

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.