FAQ  •  Register  •  Login

LG Blu-ray sees serviio but all folders empty

<<

haptrail

Serviio newbie

Posts: 5

Joined: Tue Jan 08, 2013 3:04 am

Post Tue Jan 08, 2013 3:23 am

LG Blu-ray sees serviio but all folders empty

Hello, I'm new to this so please go easy on me. I'm using a Mac with OS X10.6 (Snow Leopard) and the renderer is an LG BP620 blu-ray dvd player. The dvd player shows up in the console under renderer profiles, and the dvd player sees serviio, the server is running, and the dvd player is on, but all of the folders, playlists, itunes, etc. appear as "empty". So I figure I must have the paths wrong but I don't know. I tried to provide the log, and I found the log4j.xml file but I do not know how to edit it to create the detailed log. Please tell me how to edit the .xml file or otherwise point me in the right direction. Thanks.
<<

slyguy42o

DLNA master

Posts: 480

Joined: Wed Oct 24, 2012 5:29 am

Post Tue Jan 08, 2013 5:45 am

Re: LG Blu-ray sees serviio but all folders empty

under the status tab of the console, what profile do you have selected for your player?

logging info

viewtopic.php?f=5&t=7
<<

haptrail

Serviio newbie

Posts: 5

Joined: Tue Jan 08, 2013 3:04 am

Post Wed Jan 09, 2013 1:03 am

Re: LG Blu-ray sees serviio but all folders empty

Thanks for your response. The profile for the player is "Generic DLNA Profile", although to my knowledge, I didn't select the profile, it just appeared there with the DVD player. I don't see an option to change or select its profile.

Thanks also for the link to the logging details - that's actually where I read about editing the log4j.xml file. I just don't know how to edit this file to change the code as directed in the instructions. How do you edit the file? I need to look at the log because now when I click on "refresh" on the Status Page, I get an unexpected 500 error telling me to check the log. And since then, my DVD player no longer even finds serviio. I'm going backwards! :(

Thanks, haptrail.

slyguy42o wrote:under the status tab of the console, what profile do you have selected for your player?

logging info

viewtopic.php?f=5&t=7
<<

haptrail

Serviio newbie

Posts: 5

Joined: Tue Jan 08, 2013 3:04 am

Post Wed Jan 09, 2013 1:25 am

Re: LG Blu-ray sees serviio but all folders empty

OK, I'm updating my response. I found I could edit the log4j.xml file with text edit (see, I know little) and produced the detailed serviio log which shows a bunch of errors like this:

2013-01-07 22:37:56,405 WARN [LibraryAdditionsCheckerThread] Cannot add file 10 I Like To Live The Love.m4a because of an unexpected error. Message: Cannot read a list of Extractor configuration for type AUDIO
Caused by: ERROR XSCH1: Container 1456 not found.

Any advice? Thanks.
=============================
haptrail wrote:Thanks for your response. The profile for the player is "Generic DLNA Profile", although to my knowledge, I didn't select the profile, it just appeared there with the DVD player. I don't see an option to change or select its profile.

Thanks also for the link to the logging details - that's actually where I read about editing the log4j.xml file. I just don't know how to edit this file to change the code as directed in the instructions. How do you edit the file? I need to look at the log because now when I click on "refresh" on the Status Page, I get an unexpected 500 error telling me to check the log. And since then, my DVD player no longer even finds serviio. I'm going backwards! :(

Thanks, haptrail.

slyguy42o wrote:under the status tab of the console, what profile do you have selected for your player?

logging info

viewtopic.php?f=5&t=7
<<

haptrail

Serviio newbie

Posts: 5

Joined: Tue Jan 08, 2013 3:04 am

Post Wed Jan 09, 2013 2:52 am

Re: LG Blu-ray sees serviio but all folders empty

Another update: I see now that if I click on the profile I get the drop-down box, which I changed from generic to LG TV/Player. Now I can refresh and don't get that 500 error, AND, the DVD player now sees the serviio again, AND, I can stream my files. So I'm making progress here. One thing missing is that I don't yet see how to access my Itunes playlists (I can get the songs and artists, etc.) and may have to work on my paths to get to where I can stream the Iphoto events and albums. Plus, photos are created which show closeups of faces - that could be an LG issue. But anyone reading this who can advise me on how to get to the Itunes playlists and Iphoto albums, I'd appreciate it. In the meantime, I'll poke around the site and see if I can find something on it. Thanks.
========================
haptrail wrote:OK, I'm updating my response. I found I could edit the log4j.xml file with text edit (see, I know little) and produced the detailed serviio log which shows a bunch of errors like this:

2013-01-07 22:37:56,405 WARN [LibraryAdditionsCheckerThread] Cannot add file 10 I Like To Live The Love.m4a because of an unexpected error. Message: Cannot read a list of Extractor configuration for type AUDIO
Caused by: ERROR XSCH1: Container 1456 not found.

Any advice? Thanks.
=============================
haptrail wrote:Thanks for your response. The profile for the player is "Generic DLNA Profile", although to my knowledge, I didn't select the profile, it just appeared there with the DVD player. I don't see an option to change or select its profile.

Thanks also for the link to the logging details - that's actually where I read about editing the log4j.xml file. I just don't know how to edit this file to change the code as directed in the instructions. How do you edit the file? I need to look at the log because now when I click on "refresh" on the Status Page, I get an unexpected 500 error telling me to check the log. And since then, my DVD player no longer even finds serviio. I'm going backwards! :(

Thanks, haptrail.

slyguy42o wrote:under the status tab of the console, what profile do you have selected for your player?

logging info

viewtopic.php?f=5&t=7
<<

slyguy42o

DLNA master

Posts: 480

Joined: Wed Oct 24, 2012 5:29 am

Post Thu Jan 10, 2013 8:19 pm

Re: LG Blu-ray sees serviio but all folders empty

I am not sure if iTunes playlists are supported, I haven't works with those before.
<<

haptrail

Serviio newbie

Posts: 5

Joined: Tue Jan 08, 2013 3:04 am

Post Fri Jan 11, 2013 3:05 am

Re: LG Blu-ray sees serviio but all folders empty

OK, thanks, I really appreciate your help - at least I can access the songs now.

slyguy42o wrote:I am not sure if iTunes playlists are supported, I haven't works with those before.

Return to LG

Who is online

Users browsing this forum: No registered users and 4 guests

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.