FAQ  •  Register  •  Login

Serviio server on WD My Book Live

<<

lnng

Serviio newbie

Posts: 1

Joined: Sun Aug 07, 2011 8:09 am

Post Sun Aug 07, 2011 8:20 am

Serviio server on WD My Book Live

Hi
Someone tried successfully to install serviio on Western Digital My Book Live?
If so, can you make a step by step guide for a newbie in Linux?
Thanx
<<

Cerberus

User avatar

DLNA master

Posts: 4114

Joined: Sun Jan 02, 2011 5:20 pm

Location: Reading, UK

Post Sun Aug 07, 2011 10:34 pm

Re: Serviio server on WD My Book Live

Phil Bennett
Beta Tester Group
Wiki | FAQ

Samsung LE40C750 LCD | Samsung BD-C5900 | Sony PS3 | Windows 7 |
HowTo: Provide supported formats of a device HowTo: Record a new ticket on Bitbucket
HowTo: Provide details of a video file that doesn't play HowTo: Turn on detailed logging
<<

tozevv

Serviio newbie

Posts: 1

Joined: Mon Oct 03, 2011 9:17 pm

Post Mon Oct 03, 2011 9:58 pm

Re: Serviio server on WD My Book Live

After several attempts I was able to make serviio run with MyBook Live:

1. Enable my book live root shell and log in as root / welc0me
2. Install optware. Just follow the instructions on http://mybookworld.wikidot.com/optware
3. Install the core-utils package from optware
4. Add a symbolic link for dirname to the core-utils package:

  Code:
 # ln -s /opt/bin/coreutils-dirname /usr/bin/dirname


5. Install ibm java - it's a 1.6 version. Grab the 32bit IBM POWER Install anywere J2SE version from http://www.ibm.com/developerworks/java/jdk/linux/download.html

6. Install serviio tgz package
7. Run Serviio.sh. Make sure JAVA_PATH points to you newly installed IBM JRE
8. Configure serviio console with -Dserviio.remoteHost=<hostname> (check the forum)
9. Set up a init.d script for serviio start / stop with NAS boots. Check this site for instructions http://www.debian-administration.org/articles/28

So far looks great. The box is fast enough to run it smoothly with subtitles, skip/ff and resume - all tested and working fine.

Keep up the good work with serviio :)
Last edited by tozevv on Mon Oct 03, 2011 10:17 pm, edited 2 times in total.
<<

Cerberus

User avatar

DLNA master

Posts: 4114

Joined: Sun Jan 02, 2011 5:20 pm

Location: Reading, UK

Post Mon Oct 03, 2011 10:03 pm

Re: Serviio server on WD My Book Live

nice can you do one thing though and make it a full howto rather than giving links ( as they can die ) then we can stickie it for other users? or would you like me to do that from information you have provide and then get you to look over it to make sure i havent made any mistakes?
Phil Bennett
Beta Tester Group
Wiki | FAQ

Samsung LE40C750 LCD | Samsung BD-C5900 | Sony PS3 | Windows 7 |
HowTo: Provide supported formats of a device HowTo: Record a new ticket on Bitbucket
HowTo: Provide details of a video file that doesn't play HowTo: Turn on detailed logging
<<

joaorsfonseca

Streaming enthusiast

Posts: 23

Joined: Sat Apr 30, 2011 3:53 pm

Post Tue Nov 22, 2011 12:27 pm

Re: Serviio server on WD My Book Live

Does anyone install serviio on MBL using tozevv guide?

MBL comes with TwonkyManager v5 (too old) and for upgrade it i must have to buy a new license for version 6.

As i have Serviio installed on my home pc, and i like it a lot, i want to try it on my MBL.
<<

Cerberus

User avatar

DLNA master

Posts: 4114

Joined: Sun Jan 02, 2011 5:20 pm

Location: Reading, UK

Post Tue Nov 22, 2011 7:40 pm

Re: Serviio server on WD My Book Live

try it according to Tozevv it works, and he has given a great guide. i will however try and make a full guide this week and add it to the wiki.
Phil Bennett
Beta Tester Group
Wiki | FAQ

Samsung LE40C750 LCD | Samsung BD-C5900 | Sony PS3 | Windows 7 |
HowTo: Provide supported formats of a device HowTo: Record a new ticket on Bitbucket
HowTo: Provide details of a video file that doesn't play HowTo: Turn on detailed logging
<<

joaorsfonseca

Streaming enthusiast

Posts: 23

Joined: Sat Apr 30, 2011 3:53 pm

Post Tue Nov 22, 2011 11:15 pm

Re: Serviio server on WD My Book Live

I am affraid to try it because i've never tryed any linux commands. And if anything goes wrong, waranty will be avoided :(
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 17154

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Wed Nov 23, 2011 9:58 am

Re: Serviio server on WD My Book Live

joaorsfonseca wrote:I am affraid to try it because i've never tryed any linux commands. And if anything goes wrong, waranty will be avoided :(

So I'm not sure what you're asking for..
<<

joaorsfonseca

Streaming enthusiast

Posts: 23

Joined: Sat Apr 30, 2011 3:53 pm

Post Wed Nov 23, 2011 10:35 pm

Re: Serviio server on WD My Book Live

zip wrote:
joaorsfonseca wrote:I am affraid to try it because i've never tryed any linux commands. And if anything goes wrong, waranty will be avoided :(

So I'm not sure what you're asking for..


Just ake if anyone have installed serviio using tozevv guide.
<<

Dan_M

Serviio newbie

Posts: 4

Joined: Tue Dec 13, 2011 2:01 pm

Post Tue Dec 13, 2011 2:14 pm

Re: Serviio server on WD My Book Live

tozevv wrote:After several attempts I was able to make serviio run with MyBook Live:

5. Install ibm java - it's a 1.6 version. Grab the 32bit IBM POWER Install anywere J2SE version from http://www.ibm.com/developerworks/java/jdk/linux/download.html

6. Install serviio tgz package
7. Run Serviio.sh. Make sure JAVA_PATH points to you newly installed IBM JRE
8. Configure serviio console with -Dserviio.remoteHost=<hostname> (check the forum)
9. Set up a init.d script for serviio start / stop with NAS boots. Check this site for instructions http://www.debian-administration.org/articles/28

So far looks great. The box is fast enough to run it smoothly with subtitles, skip/ff and resume - all tested and working fine.

:)


I am stuck at step 5, been trolling the net for days now with no luck. Can anyone help with step by step? Does it have to be ibm? would sun do?

~ Dan.
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 17154

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Wed Dec 14, 2011 9:57 am

Re: Serviio server on WD My Book Live

Sun Java is preferred
<<

jc_slig

Serviio newbie

Posts: 9

Joined: Mon Dec 26, 2011 1:27 am

Post Mon Dec 26, 2011 1:31 am

Re: Serviio server on WD My Book Live

Hi Guys,

I am stuck trying to get Java 6 installed on the WD My Book Live, the prerequisite for Serviio.
The link supplied no longer works, have tried looking for a similar download but had no luck.

I am relatively new to debian so any help would be appreciated.
I have tried openjdk and sun through the aptitude/apt-get mechanism it will not work due to missing dependencies which i cannot install either!

Thanks!
<<

Cerberus

User avatar

DLNA master

Posts: 4114

Joined: Sun Jan 02, 2011 5:20 pm

Location: Reading, UK

Post Mon Dec 26, 2011 11:26 pm

Re: Serviio server on WD My Book Live

run

  Code:
apt-get install sun-java6-jdk


then run

  Code:
update-java-alternatives -s java-6-sun


sudo maybe require at start of command. see below

  Code:
sudo apt-get install sun-java6-jdk


then run

  Code:
sudo update-java-alternatives -s java-6-sun
Phil Bennett
Beta Tester Group
Wiki | FAQ

Samsung LE40C750 LCD | Samsung BD-C5900 | Sony PS3 | Windows 7 |
HowTo: Provide supported formats of a device HowTo: Record a new ticket on Bitbucket
HowTo: Provide details of a video file that doesn't play HowTo: Turn on detailed logging
<<

jc_slig

Serviio newbie

Posts: 9

Joined: Mon Dec 26, 2011 1:27 am

Post Wed Dec 28, 2011 2:44 pm

Re: Serviio server on WD My Book Live

Thanks Cerberus.

I could not reach the distribution links in /etc/apt/sources.list, I added these to /etc/hosts and was able to install open-jdk.

I have been able to get Serviio up and running on the MBL.
Access and Play works ok from my iPad but playing from Sony Bravia TV throws up the following error:

Error while processing resource, sending back 500 error. Message: Transcoded file '/tmp/Serviio/transcoding-temp-125-MPEG2TS.stf' cannot be found, FFmpeg execution probably failed
java.io.IOException: Transcoded file '/tmp/Serviio/transcoding-temp-125-MPEG2TS.stf' cannot be found, FFmpeg execution probably failed
at org.serviio.delivery.resource.AbstractTranscodingDeliveryEngine.retrieveTranscodedResource(AbstractTranscodingDeliveryEngine.java:115)


I have looked around the forum and found that a possible cause is executing serviio as root, which I am doing.

I tried creating a user and running Serviio under this, it now fails with a java ClassDef not found.

My question is, is there a preferred serviio user setup, is this documented anywhere? I could not see explicit instructions on the forum.
If I change the user do I need to perform any additional actions or reinstall Serviio?

Thanks in Advance!
<<

Cerberus

User avatar

DLNA master

Posts: 4114

Joined: Sun Jan 02, 2011 5:20 pm

Location: Reading, UK

Post Wed Dec 28, 2011 6:17 pm

Re: Serviio server on WD My Book Live

once you change user make sure that new user has premissions to access java installation directory or u will get that issue. :)
Phil Bennett
Beta Tester Group
Wiki | FAQ

Samsung LE40C750 LCD | Samsung BD-C5900 | Sony PS3 | Windows 7 |
HowTo: Provide supported formats of a device HowTo: Record a new ticket on Bitbucket
HowTo: Provide details of a video file that doesn't play HowTo: Turn on detailed logging
<<

jc_slig

Serviio newbie

Posts: 9

Joined: Mon Dec 26, 2011 1:27 am

Post Wed Dec 28, 2011 8:23 pm

Re: Serviio server on WD My Book Live

Thanks Cerberus,

I got the Serviio server running as a daemon at startup (as shown in forum how to) under a different user which has secondary group root so should be ok for Java.
All seems to be ok, iPad access works fine but the Bravia TV still fails to play the videos.

This points the server running ok and no issues with Java?
I have lost my serviio.log file but would appear to be still around transcoding.

Anything obvious I should be looking at? I have the latest ffmpeg and doing an ffmpeg -i <file> looks ok.
<<

moltra

DLNA master

Posts: 1871

Joined: Thu Mar 24, 2011 11:00 pm

Location: Ohio USA

Post Wed Dec 28, 2011 8:52 pm

Re: Serviio server on WD My Book Live

Have you got the console working? If so under the transcoding tab, you can disable trancoding and see if the Ipad still works properly and everything will play. This will check and see if the transcoding is working or not.
Mark
Beta Tester Group
http://www.serviidb.com Online media resource repository

Netgear EVA2000 | Samsung BD-D5300 | XBOX 360 | Windows 7 | Mint Debian 12 | Raxz Maxx
HowTo: Provide supported formats of a device HowTo: Record a new ticket on Bitbucket
HowTo: Provide details of a video file that doesn't play HowTo: Turn on detailed logging
<<

Cerberus

User avatar

DLNA master

Posts: 4114

Joined: Sun Jan 02, 2011 5:20 pm

Location: Reading, UK

Post Wed Dec 28, 2011 8:57 pm

Re: Serviio server on WD My Book Live

jc_slig wrote:Thanks Cerberus,

I got the Serviio server running as a daemon at startup (as shown in forum how to) under a different user which has secondary group root so should be ok for Java.
All seems to be ok, iPad access works fine but the Bravia TV still fails to play the videos.

This points the server running ok and no issues with Java?
I have lost my serviio.log file but would appear to be still around transcoding.

Anything obvious I should be looking at? I have the latest ffmpeg and doing an ffmpeg -i <file> looks ok.


no not java but it looks asif ffmpeg is the issue as ipad doesnt use transcoding but sony does so either its access issue or wd my book cant cope with transcoding, from what i can tell.
Phil Bennett
Beta Tester Group
Wiki | FAQ

Samsung LE40C750 LCD | Samsung BD-C5900 | Sony PS3 | Windows 7 |
HowTo: Provide supported formats of a device HowTo: Record a new ticket on Bitbucket
HowTo: Provide details of a video file that doesn't play HowTo: Turn on detailed logging
<<

jc_slig

Serviio newbie

Posts: 9

Joined: Mon Dec 26, 2011 1:27 am

Post Wed Dec 28, 2011 9:09 pm

Re: Serviio server on WD My Book Live

Yes it appears to be related to FFMpeg, however would the previous issue be a symptom of the below error? Not sure how FFMpeg works.
See below for output I got from FFMpeg command prior to "/tmp/Serviio not found" error in serviio.log.

Is there any limitation of filename length or should it be space free?


ffmpeg -i "/shares/Public/Shared Videos/TV Shows/TV Show/file.avi" -y -threads 1 -vcodec mpeg2video -b 17000k -maxrate 17000k -bufsize 5097k -r 24000/1001 -g 15 -copyts -acodec ac3 -ab 192k -ac 2 -map 0:0 -map 0:1 -sn -f mpegts /tmp/Serviio/transcoding-temp-125-MPEG2TS.stf
FFmpeg version SVN-r0.5.4-4:0.5.4-1, Copyright (c) 2000-2009 Fabrice Bellard, et al.
configuration: --extra-version=4:0.5.4-1 --prefix=/usr --enable-avfilter --enable-avfilter-lavf --enable-vdpau --enable-bzlib --enable-libdirac --enable-libgsm --enable-libopenjpeg --enable-libschroedinger --enable-libspeex --enable-libtheora --enable-libvorbis --enable-pthreads --enable-zlib --disable-stripping --disable-vhook --enable-runtime-cpudetect --enable-gpl --enable-postproc --enable-swscale --enable-x11grab --enable-libfaad --enable-libdc1394 --disable-altivec --enable-shared --disable-static
libavutil 49.15. 0 / 49.15. 0
libavcodec 52.20. 1 / 52.20. 1
libavformat 52.31. 0 / 52.31. 0
libavdevice 52. 1. 0 / 52. 1. 0
libavfilter 0. 4. 0 / 0. 4. 0
libswscale 0. 7. 1 / 0. 7. 1
libpostproc 51. 2. 0 / 51. 2. 0
built on Mar 27 2011 04:50:25, gcc: 4.4.5
Input #0, avi, from '/shares/Public/Shared Videos/TV Shows/TV Show/file.avi':
Duration: 00:53:15.74, start: 0.000000, bitrate: 1442 kb/s
Stream #0.0: Video: mpeg4, yuv420p, 624x352 [PAR 1:1 DAR 39:22], 23.98 tbr, 23.98 tbn, 23.98 tbc
Stream #0.1: Audio: mp3, 48000 Hz, stereo, s16, 128 kb/s
Unknown encoder 'mpeg2video'
<<

Cerberus

User avatar

DLNA master

Posts: 4114

Joined: Sun Jan 02, 2011 5:20 pm

Location: Reading, UK

Post Wed Dec 28, 2011 9:12 pm

Re: Serviio server on WD My Book Live

ah i see your ffmpeg is very very old that might be cause of these issue, you will need to update it.

http://wiki.serviio.org/doku.php?id=build_ffmpeg_linux
Phil Bennett
Beta Tester Group
Wiki | FAQ

Samsung LE40C750 LCD | Samsung BD-C5900 | Sony PS3 | Windows 7 |
HowTo: Provide supported formats of a device HowTo: Record a new ticket on Bitbucket
HowTo: Provide details of a video file that doesn't play HowTo: Turn on detailed logging
Next

Return to NAS installation

Who is online

Users browsing this forum: No registered users and 5 guests

cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.