FAQ  •  Register  •  Login

Tv3Play (Sweden)

<<

FlamingLizard

Streaming enthusiast

Posts: 36

Joined: Sat Sep 24, 2011 8:19 pm

Location: Gothenburg, Sweden

Post Thu Sep 29, 2011 8:27 pm

Tv3Play (Sweden)

Here's a plugin for Tv3Play, it seems it works for Tv6Play as well, but I have not confirmed that yet.

http://www.tv3play.se/rss/recent
http://www.tv3play.se/rss/mostviewed
http://www.tv3play.se/rss/highestrated

Updated 2011-10-01: New version with thumbnails and some optimizations.
Updated 2011-10-18: New version, finally got it working using swfVfy and managed to solve the parsing for the AdamLive show.
Attachments
Tv3Play.groovy
New version, finally got it working using swfVfy and managed to solve the parsing for the AdamLive show.
(3.17 KiB) Downloaded 1267 times
Last edited by FlamingLizard on Tue Oct 18, 2011 12:27 pm, edited 3 times in total.
Tomas
Samsung LE46B650
Serviio 0.6 on Win7x64 ultimate
<<

sulfobus

Serviio newbie

Posts: 4

Joined: Mon Sep 26, 2011 9:04 pm

Post Fri Sep 30, 2011 9:13 am

Re: Tv3Play (Sweden)

Great, you're on a roll :)
<<

FlamingLizard

Streaming enthusiast

Posts: 36

Joined: Sat Sep 24, 2011 8:19 pm

Location: Gothenburg, Sweden

Post Fri Sep 30, 2011 10:53 am

Re: Tv3Play (Sweden)

sulfobus wrote:Great, you're on a roll :)


Well, the tricky part was learning groovy and to get the basics of this streaming stuff as I haven't done anything with either earlier :P
Tomas
Samsung LE46B650
Serviio 0.6 on Win7x64 ultimate
<<

Gimbal

Serviio newbie

Posts: 14

Joined: Sun Sep 25, 2011 7:31 pm

Post Fri Sep 30, 2011 6:05 pm

Re: Tv3Play (Sweden)

Thanks, seems to be working. Keep 'em coming!
<<

FlamingLizard

Streaming enthusiast

Posts: 36

Joined: Sat Sep 24, 2011 8:19 pm

Location: Gothenburg, Sweden

Post Sat Oct 01, 2011 9:48 am

Re: Tv3Play (Sweden)

See updated first post for new version.
Tomas
Samsung LE46B650
Serviio 0.6 on Win7x64 ultimate
<<

dualc

Streaming enthusiast

Posts: 49

Joined: Tue Oct 04, 2011 6:54 pm

Location: Rimbo (Sweden)

Post Thu Oct 06, 2011 9:20 am

Re: Tv3Play (Sweden)

Hi ...

my log is full of this...

[FeedUpdaterThread] Failed to retrieve feed item information for rtmp://cp90686.edgefcs.net/ondemand/fla ... /Efterlys$
java.io.IOException: org.serviio.library.local.metadata.extractor.InvalidMediaFormatException: Unknown video file type.
at org.serviio.library.online.metadata.FeedUpdaterThread.updateLazyLoadedProperties(FeedUpdaterThread.java:188)
at org.serviio.library.online.metadata.FeedUpdaterThread.run(FeedUpdaterThread.java:93)
Caused by: org.serviio.library.local.metadata.extractor.InvalidMediaFormatException: Unknown video file type.
at org.serviio.library.metadata.FFmpegMetadataRetriever.validateCodecsFound(FFmpegMetadataRetriever.java:318)
at org.serviio.library.metadata.FFmpegMetadataRetriever.retrieveMetadata(FFmpegMetadataRetriever.java:68)
at org.serviio.library.online.metadata.FeedUpdaterThread.updateLazyLoadedProperties(FeedUpdaterThread.java:169)
... 1 more

I have compile the ffmpeg with rtp support but serviio tels me at upstart hes not use it..
/M
BlurayPlayer: Samsung BD-C5500
TV: Samsung LE40B535
<<

Janne

Serviio newbie

Posts: 7

Joined: Wed Sep 28, 2011 8:30 pm

Post Thu Oct 06, 2011 7:54 pm

Re: Tv3Play (Sweden)

Well, same here...

I can't get the TV3 or TV6 plugin to work, I get empty folder on the TV and the log is full this, even when I'm down to one single TV3 feed:

  Code:
2011-10-06 21:46:16,088 WARN  [FeedUpdaterThread] Failed to retrieve feed item information for rtmp://mtgfs.fplive.net/mtg/mp4:flash/sweden/tv3/AdamLive/Season1/Program/adamlive_122_111004.mp4. It might not play.
java.io.IOException: org.serviio.library.local.metadata.extractor.InvalidMediaFormatException: Unknown video file type.
   at org.serviio.library.online.metadata.FeedUpdaterThread.updateLazyLoadedProperties(FeedUpdaterThread.java:188)
   at org.serviio.library.online.metadata.FeedUpdaterThread.run(FeedUpdaterThread.java:93)
Caused by: org.serviio.library.local.metadata.extractor.InvalidMediaFormatException: Unknown video file type.
   at org.serviio.library.metadata.FFmpegMetadataRetriever.validateCodecsFound(FFmpegMetadataRetriever.java:318)
   at org.serviio.library.metadata.FFmpegMetadataRetriever.retrieveMetadata(FFmpegMetadataRetriever.java:68)
   at org.serviio.library.online.metadata.FeedUpdaterThread.updateLazyLoadedProperties(FeedUpdaterThread.java:169)
   ... 1 more


Making 5 full log files per hour... :?

Any ideas?

(BTW. big thanks for the SVT plugin, works wonderfully and I use it almost every day! :D)
<<

dualc

Streaming enthusiast

Posts: 49

Joined: Tue Oct 04, 2011 6:54 pm

Location: Rimbo (Sweden)

Post Fri Oct 07, 2011 6:16 am

Re: Tv3Play (Sweden)

Janne wrote:Well, same here...

I can't get the TV3 or TV6 plugin to work, I get empty folder on the TV and the log is full this, even when I'm down to one single TV3 feed:

  Code:
2011-10-06 21:46:16,088 WARN  [FeedUpdaterThread] Failed to retrieve feed item information for rtmp://mtgfs.fplive.net/mtg/mp4:flash/sweden/tv3/AdamLive/Season1/Program/adamlive_122_111004.mp4. It might not play.
java.io.IOException: org.serviio.library.local.metadata.extractor.InvalidMediaFormatException: Unknown video file type.
   at org.serviio.library.online.metadata.FeedUpdaterThread.updateLazyLoadedProperties(FeedUpdaterThread.java:188)
   at org.serviio.library.online.metadata.FeedUpdaterThread.run(FeedUpdaterThread.java:93)
Caused by: org.serviio.library.local.metadata.extractor.InvalidMediaFormatException: Unknown video file type.
   at org.serviio.library.metadata.FFmpegMetadataRetriever.validateCodecsFound(FFmpegMetadataRetriever.java:318)
   at org.serviio.library.metadata.FFmpegMetadataRetriever.retrieveMetadata(FFmpegMetadataRetriever.java:68)
   at org.serviio.library.online.metadata.FeedUpdaterThread.updateLazyLoadedProperties(FeedUpdaterThread.java:169)
   ... 1 more


Making 5 full log files per hour... :?

Any ideas?

(BTW. big thanks for the SVT plugin, works wonderfully and I use it almost every day! :D)


Cool u have a working SVT plugin, .. i dont. :) cant see anything.. :/
BlurayPlayer: Samsung BD-C5500
TV: Samsung LE40B535
<<

FlamingLizard

Streaming enthusiast

Posts: 36

Joined: Sat Sep 24, 2011 8:19 pm

Location: Gothenburg, Sweden

Post Fri Oct 07, 2011 12:19 pm

Re: Tv3Play (Sweden)

dualc wrote:Hi ...

my log is full of this...

[FeedUpdaterThread] Failed to retrieve feed item information for rtmp://cp90686.edgefcs.net/ondemand/fla ... /Efterlys$
java.io.IOException: org.serviio.library.local.metadata.extractor.InvalidMediaFormatException: Unknown video file type.
at org.serviio.library.online.metadata.FeedUpdaterThread.updateLazyLoadedProperties(FeedUpdaterThread.java:188)
at org.serviio.library.online.metadata.FeedUpdaterThread.run(FeedUpdaterThread.java:93)
Caused by: org.serviio.library.local.metadata.extractor.InvalidMediaFormatException: Unknown video file type.
at org.serviio.library.metadata.FFmpegMetadataRetriever.validateCodecsFound(FFmpegMetadataRetriever.java:318)
at org.serviio.library.metadata.FFmpegMetadataRetriever.retrieveMetadata(FFmpegMetadataRetriever.java:68)
at org.serviio.library.online.metadata.FeedUpdaterThread.updateLazyLoadedProperties(FeedUpdaterThread.java:169)
... 1 more

I have compile the ffmpeg with rtp support but serviio tels me at upstart hes not use it..
/M


Hm, I don't know... Could it possibly be an issue with dlna-profile? Anyone else got any idea?
Tomas
Samsung LE46B650
Serviio 0.6 on Win7x64 ultimate
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 17095

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Sun Oct 09, 2011 2:48 pm

Re: Tv3Play (Sweden)

run ffmpeg -i for the rtmp url, like

  Code:
ffmpeg -i "rtmp://............"


and post the result
<<

Janne

Serviio newbie

Posts: 7

Joined: Wed Sep 28, 2011 8:30 pm

Post Sun Oct 09, 2011 3:16 pm

Re: Tv3Play (Sweden)

Ok, tried that but it didn't seem to work:

  Code:
ffmpeg version 0.8.git, Copyright (c) 2000-2011 the FFmpeg developers
  built on Aug 14 2011 22:07:26 with gcc 4.0.1 (Apple Inc. build 5493)
  configuration: --enable-static --disable-shared --bindir=/tmp/ffmpeg --disable-ffplay --disable-ffserver --enable-libmp3lame --enable-librtmp --enable-pthreads --disable-mmx --extra-ldflags=-L/tmp/static/lib --extra-cflags=-I/tmp/static/include --extra-libs=-lpolarssl
  libavutil    51. 11. 0 / 51. 11. 0
  libavcodec   53.  8. 0 / 53.  8. 0
  libavformat  53.  6. 0 / 53.  6. 0
  libavdevice  53.  2. 0 / 53.  2. 0
  libavfilter   2. 25. 0 /  2. 25. 0
  libswscale    2.  0. 0 /  2.  0. 0
HandShake: client signature does not match!
HandleCtrl: Ignoring SWFVerification request, use --swfVfy!
rtmp server sent error
rtmp server requested close
rtmp://mtgfs.fplive.net/mtg/mp4:flash/sweden/tv3/AdamLive/Season1/Program/adamlive_122_111004.mp4: Operation not permitted

Some type of authorisation is needed to get to the stream...

If that's the problem, how can some people have it working?
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 17095

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Sun Oct 09, 2011 3:24 pm

Re: Tv3Play (Sweden)

not sure, is it possible that some streams use rtmp and some http URLs for the files?
<<

FlamingLizard

Streaming enthusiast

Posts: 36

Joined: Sat Sep 24, 2011 8:19 pm

Location: Gothenburg, Sweden

Post Mon Oct 10, 2011 6:59 am

Re: Tv3Play (Sweden)

zip wrote:not sure, is it possible that some streams use rtmp and some http URLs for the files?


All I have come across use rtmp, but it may be that some require verification, I haven't had any time to dig deeper into this yet.
Tomas
Samsung LE46B650
Serviio 0.6 on Win7x64 ultimate
<<

muszaj

Streaming enthusiast

Posts: 35

Joined: Thu Oct 13, 2011 7:07 pm

Location: Hungary

Post Thu Oct 13, 2011 7:16 pm

Re: Tv3Play (Sweden)

Hej! Thanks for this plugin.

I have an issue unfortunately:
The programs load fine, play fine, but every TV3 play program stops after 1 minute. :(
Please help me with this, I may be doing something wrong.
I use Panasonic Viera with Samsung C/D profile (B produces the same, Panasonic profile doesn't play the files at all)
Thanks in advance!

(TV6 has the same issue )
<<

ortner

Serviio newbie

Posts: 9

Joined: Sun Oct 16, 2011 8:26 pm

Post Sun Oct 16, 2011 9:13 pm

Re: Tv3Play (Sweden)

Hi,

I have a problem playing the content. I can see the thumbnails and all but when I try to play it I get a "Format not supported" on my samsung D series TV.


When I start to play it i get this in my serviio log:
  Code:
2011-10-16 23:02:18,967 DEBUG [WebServer] I/O error: Broken pipe
2011-10-16 23:02:19,080 DEBUG [WebServer] Incoming connection from /192.168.0.12:37242
2011-10-16 23:02:19,080 DEBUG [ResourceTransportRequestHandler] HEAD /resource/1000000000030002/MEDIA_ITEM/MPEG_TS_SD_KO_ISO$0 HTTP/1.0, headers = [getCaptionInfo.sec: 1]]
2011-10-16 23:02:19,080 DEBUG [RendererDAOImpl] Reading a Renderer with ip address 192.168.0.12
2011-10-16 23:02:19,081 DEBUG [ResourceTransportRequestHandler] Resource request accepted. Using client 'IPAddress=/192.168.0.12, Profile=Samsung TV / player (C/D-series)'
2011-10-16 23:02:19,081 DEBUG [ResourceTransportRequestHandler] Request for resource 1000000000030002 and type 'MEDIA_ITEM' received
2011-10-16 23:02:19,081 DEBUG [MediaResourceRetrievalStrategy] Getting information about media item 1000000000030002 (online)
2011-10-16 23:02:19,081 DEBUG [OnlineRepositoryDAOImpl] Reading an OnlineRepository (id = 3)
2011-10-16 23:02:19,082 DEBUG [FeedCacheDecorator] Found entry in the cache (online_feeds), returning it
2011-10-16 23:02:19,082 DEBUG [VideoDeliveryEngine] Retrieving resource information for item 1000000000030002, format MPEG_TS_SD_KO_ISO and profile Samsung TV / player (C/D-series)
2011-10-16 23:02:19,082 DEBUG [AbstractTranscodingDeliveryEngine] Getting media info for transcoded version of file rtmp://cp90686.edgefcs.net/ondemand/flash/sweden/tv3/Extra/Season7/Program/extraextra_703
2011-10-16 23:02:19,082 DEBUG [VideoDeliveryEngine] Found Format profile for transcoded file rtmp://cp90686.edgefcs.net/ondemand/flash/sweden/tv3/Extra/Season7/Program/extraextra_703: MPEG_TS_SD_EU_ISO
2011-10-16 23:02:19,082 DEBUG [VideoDeliveryEngine] Found Format profile for transcoded file rtmp://cp90686.edgefcs.net/ondemand/flash/sweden/tv3/Extra/Season7/Program/extraextra_703: MPEG_TS_SD_NA_ISO
2011-10-16 23:02:19,083 DEBUG [VideoDeliveryEngine] Found Format profile for transcoded file rtmp://cp90686.edgefcs.net/ondemand/flash/sweden/tv3/Extra/Season7/Program/extraextra_703: MPEG_TS_SD_KO_ISO
2011-10-16 23:02:19,083 DEBUG [ResourceTransportRequestHandler] Sending HEAD response back
2011-10-16 23:02:19,083 DEBUG [ResourceTransportRequestHandler] HTTP/1.1 200 OK, headers = [[Content-Type: video/mpeg,Content-Length: 50000000000,Date: Sun, 16 Oct 2011 21:02:19 GMT,Server: Mac OS X, UPnP/1.0 DLNADOC/1.50, Serviio/0.6.0.1,Cache-control: no-cache,transferMode.dlna.org: Streaming]]


and if I do a "ffmpeg -i" I get this:
  Code:
./ffmpeg -i rtmp://cp90686.edgefcs.net/ondemand/flash/sweden/tv3/Extra/Season7/Program/extraextra_703.mp4
ffmpeg version 0.8.git, Copyright (c) 2000-2011 the FFmpeg developers
  built on Aug 14 2011 22:07:26 with gcc 4.0.1 (Apple Inc. build 5493)
  configuration: --enable-static --disable-shared --bindir=/tmp/ffmpeg --disable-ffplay --disable-ffserver --enable-libmp3lame --enable-librtmp --enable-pthreads --disable-mmx --extra-ldflags=-L/tmp/static/lib --extra-cflags=-I/tmp/static/include --extra-libs=-lpolarssl
  libavutil    51. 11. 0 / 51. 11. 0
  libavcodec   53.  8. 0 / 53.  8. 0
  libavformat  53.  6. 0 / 53.  6. 0
  libavdevice  53.  2. 0 / 53.  2. 0
  libavfilter   2. 25. 0 /  2. 25. 0
  libswscale    2.  0. 0 /  2.  0. 0
HandleCtrl: Ignoring SWFVerification request, use --swfVfy!
Closing connection: NetStream.Play.StreamNotFound
rtmp://cp90686.edgefcs.net/ondemand/flash/sweden/tv3/Extra/Season7/Program/extraextra_703.mp4: Operation not permitted
 



I don't know if this is related to this https://bitbucket.org/xnejp03/serviio/issue/425/samsung-d-series-tv-will-not-play-online#comment-710251. But I have tried to add that bit of code to the C/D profile with no succes.





*EDIT*

Partially solved, it was a profile problem. I followed jhb50's profile, found here. Now I can see the first minute, then it changes to the next episode in the feed.

Any ideas?
<<

FlamingLizard

Streaming enthusiast

Posts: 36

Joined: Sat Sep 24, 2011 8:19 pm

Location: Gothenburg, Sweden

Post Tue Oct 18, 2011 12:33 pm

Re: Tv3Play (Sweden)

Ok, so I've finally made a new version which uses swfVfy.
This might help with the skips to next show after 1 minute.
The new version should solve the issues with the AdamLive-show cluttering the log with error messages. For some reason they were using different formats for some(only found AdamLive so far, but might be others) shows...

Newest version can be found here:
viewtopic.php?p=22717#p22717
Tomas
Samsung LE46B650
Serviio 0.6 on Win7x64 ultimate
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 17095

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Tue Oct 18, 2011 12:37 pm

Re: Tv3Play (Sweden)

well done, mate.
<<

ortner

Serviio newbie

Posts: 9

Joined: Sun Oct 16, 2011 8:26 pm

Post Tue Oct 18, 2011 1:09 pm

Re: Tv3Play (Sweden)

Awesome, will try it when I get home!

Sent from my GT-I9100 using Tapatalk
<<

ortner

Serviio newbie

Posts: 9

Joined: Sun Oct 16, 2011 8:26 pm

Post Tue Oct 18, 2011 4:39 pm

Re: Tv3Play (Sweden)

I can confirm that the new plugin works with my Samsung D series TV.


Tusen tack FlamingLizard!
<<

muszaj

Streaming enthusiast

Posts: 35

Joined: Thu Oct 13, 2011 7:07 pm

Location: Hungary

Post Tue Oct 18, 2011 6:35 pm

Re: Tv3Play (Sweden)

Bravo bravo! 1 minute issue solved! :)
Panasonic Viera D25
Next

Return to Available plugins

Who is online

Users browsing this forum: No registered users and 1 guest

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.