FAQ  •  Register  •  Login

Library Not Automatically updating

<<

AndrewW

Serviio lover

Posts: 81

Joined: Sat Mar 19, 2011 8:15 am

Post Thu Nov 12, 2015 5:48 am

Library Not Automatically updating

Just moved from windows to Ubuntu 14 lts
Serviio Pro is running ok except the "Keep library automatically updated" files added to the storage location are never picked up unless serviio is restarted or the "Keep library automatically updated" check box is unticked and reticked again in the console.

The files are accessed via a cifs share
Any Idea, looking at the forums there seems to have been similar comments about remotely stored files.
If there is no fix is there a command which can be run to force the library update function WITHOUT restarting serviio
Thanks
<<

AndrewW

Serviio lover

Posts: 81

Joined: Sat Mar 19, 2011 8:15 am

Post Thu Nov 12, 2015 9:13 am

Re: Library Not Automatically updating

Just been reading some more on the forums, and there is an old post about calling a REST API. Does that mean the update is triggered by the console which is not running on my headless linux box

The console is remote from a windows client ?
<<

DenyAll

DLNA master

Posts: 2248

Joined: Fri Mar 08, 2013 11:16 pm

Location: Adelaide, Australia

Post Thu Nov 12, 2015 10:02 am

Re: Library Not Automatically updating

This problem has been noted for CIFS shares. See: http://wiki.serviio.org/doku.php?id=lib ... _mechanism (Forcing POLLER scanner) which will give you the means to overcome this (by forcing Serviio to poll your shared folders rather than use the automatic (iNotify based) polling).

ps. the REST API (http://www.serviio.org/component/conten ... sed/66-api) is a means to communicate to the Serviio server, and yes, you could use it to trigger a refresh... but the Polling Method should do the same thing.
pps. The console plays no part in the library update mechanism (other than to set your preferences).
DenyAll
Panasonic Viera FX800A | Panasonic Viera CS610A | Sony PS4 | Sony PS3 | Panasonic DMP-BD79 | Yamaha RX-V500D | iPad | Windows 10 | Serviio 1.10.1 Pro
WinHelper | MediaInfo

Beta Tester, Moderator
Please do not PM me for support as any solution cannot be shared with others.

Return to General discussion

Who is online

Users browsing this forum: No registered users and 11 guests

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.