FAQ  •  Register  •  Login

Windows 10 Integration

<<

Meat Juice

Serviio newbie

Posts: 8

Joined: Sat Nov 16, 2013 2:53 am

Post Tue Sep 22, 2015 4:14 pm

Windows 10 Integration

I've used Serviio Pro for around 4-5 years. Found it works very well with Windows 7 x64 Pro. However not so reliable in Windows 10 x64 Pro and have had to uninstall it due to it's lack of reliability when paired with a WDTV Live box. Accordingly I went through about 10 servers in one day trying to replicate the feature set of Serviio and have had to settle with less. I am hoping Serviio is working on a version with Windows 10 support. I would happily pay for another license to have Serviio back. What I miss the most is how Serviio allowed me to create a folder structure arranged by HDD.
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 17076

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Tue Sep 22, 2015 10:46 pm

Re: Windows 10 Integration

I'm not planning any specific Windows 10 fix, I'm not aware of any issues.
<<

Meat Juice

Serviio newbie

Posts: 8

Joined: Sat Nov 16, 2013 2:53 am

Post Tue Sep 22, 2015 11:06 pm

Re: Windows 10 Integration

On my next set of days off I'll spend some time to reproduce the problems, create some log files and provide specific information.
<<

atc98092

User avatar

DLNA master

Posts: 3391

Joined: Fri Aug 17, 2012 10:22 pm

Location: Washington (the state)

Post Wed Sep 23, 2015 12:43 am

Re: Windows 10 Integration

I'm running Windows 10 Pro on my primary server with no issues. The only thing I've changed is to use the latest 64 bit version of FFMPEG. At least the latest for when I installed it, which was Aug 28. Everything else is default.
Dan

Panasonic ST30 Plasma, Samsung JU7100 4K TV, Sony BDP-S3500, Sharp 4K Roku TV, Insignia Roku TV, Roku 4, Ultra and Stick, Nvidia Shield, Yamaha RX-V583 AVR.
Primary server: Intel i5-6400, 8 gig ram, Windows 10 Pro, 18 TB hard drive space | Test server Windows 10 Pro, AMD Phenom II X4 965, 8 gig ram

HOWTO: Enable debug logging HOWTO: Identify media file contents
<<

adielk

Streaming enthusiast

Posts: 42

Joined: Fri Sep 05, 2014 5:02 pm

Post Wed Sep 23, 2015 2:23 am

Re: Windows 10 Integration

Running serviio on whs 2011 server and 2 Win 10 64 Pro desktops. All fine with serviiodroid on android tablets.
<<

Morden2004

Streaming enthusiast

Posts: 30

Joined: Sun Mar 16, 2014 1:29 pm

Location: Morden, Nova Scotia Canada

Post Sun Oct 25, 2015 2:47 pm

Re: Windows 10 Integration

I've had some weird issues running Serviio Pro under Windows 10 with a WDMyCloud 2TB DLNA drive. Fortunately, I think I've solved them all - or Windows 10 self-healed the problems - read on.

Here is my main issue and one you need to understand when running Serviio under Windows 10 with network attached libraries.

At first, Serviio would not build a library from my WDMyCloud network server. It took me several tries (3 reinstalls; and 2 days each time to see results) to get that solved and still I'm not sure what worked. It was suggested that I needed to have the Serviio service log in as my own Windows account and not the local service account on the theory that the local account did not have sufficient rights to access the WDMyCloud. Changing that to my own account did eventually work, but I've since discovered that switching it back to the service account works too!?! Again, Windows 10 seems to have a mind of it's own regarding network attached storage since it took it 2 days before it would actually display the directories without a 5 minutes (!) delay.

I next reloaded part of my library on a local hard drive and BINGO! the Serviio had no difficulty building the library! Strange? So back to the WDMyCloud I went. After numerous tries I finally discovered that if I waited about 2 days the damn thing finally access the WDMyCloud without delay and it worked. My best SWAG is that Windows 10 builds an index for speed of access and network attached devices are slower to respond PLUS the tens of thousands of entries I have on the device makes for a long build. I have not been able to confirm this.

As of today it all work stunningly well!

Anybody else having slow network issues with Windows 10?

Paul
<<

atc98092

User avatar

DLNA master

Posts: 3391

Joined: Fri Aug 17, 2012 10:22 pm

Location: Washington (the state)

Post Mon Oct 26, 2015 12:27 pm

Re: Windows 10 Integration

I haven't tried using network sources, so unknown if this is normal for me. With my local drives, it of course works just fine.

When you are dealing with networked files, there are a couple of possibilities. The first of course is network speed and other traffic. I would not attempt to use networked files unless you are using Gigabit Ethernet, and certainly not wireless. Your thoughts about Windows 10 maintaining an index is possible, although I believe such indexing is not enabled by default and must be turned on. The delay in displaying the directories may be something related to network access permissions.

You are correct that the Local Service (which Serviio uses by default) seldom has access rights to network assets. This is why changing the user account to your personal one will allow access. Why switching back still worked is a puzzle, but it sounds like you may have changed permissions on the NAS without realizing it.

Now that it appears to be working OK, I say don't mess with it :lol: . You may just muck something up. :P
Dan

Panasonic ST30 Plasma, Samsung JU7100 4K TV, Sony BDP-S3500, Sharp 4K Roku TV, Insignia Roku TV, Roku 4, Ultra and Stick, Nvidia Shield, Yamaha RX-V583 AVR.
Primary server: Intel i5-6400, 8 gig ram, Windows 10 Pro, 18 TB hard drive space | Test server Windows 10 Pro, AMD Phenom II X4 965, 8 gig ram

HOWTO: Enable debug logging HOWTO: Identify media file contents
<<

newby

Streaming enthusiast

Posts: 24

Joined: Sat Dec 05, 2015 6:24 pm

Location: Weiden/Germany

Post Sat Dec 05, 2015 6:36 pm

Re: Windows 10 Integration

Sorry for my bad english, i am a german user.

I have problems with windows 10 too.

I am a user since many years. after installation windows 10, serviio has a problem to send informations to samsung tv, and any other devices . i use android, apple, ps3 and samsung tv.

My configuration is: Windows 10 64bit Pro, GBit Lan, 3 Samsung TV, 2 x PS3, 4 Android Tablets, 1 Apple, Firewall and Virus Bitdefender Internet Security, 3 Showcenter, 2 Samsung Handys
all this devices are connect to serviio. i dont have any problems before.
my server has stored 100000 mp3 songs, and more as 8000 movies and round about 20000 photos.

the problem is, if i select movie by the name. in (A) i have 1000 movies. samsung bring me an error (cant reach server and so on)
if i select a name with 8 Movies, samsung tv show me the movies on screen.

in web-server (firefox) the section with (A), the screen fills very slow with the pictures (of movies).

Before i usw windows 10 it goes fast....

i have reinstall the serviio, virus scanner, firewall, and then i have reinstall windows 10. it was not better!!

at last, i have test plex.... it works okay. (butt it is no programm for me, only testing)

do anyone other have same problems? can it be... the firewall close any ports????
<<

atc98092

User avatar

DLNA master

Posts: 3391

Joined: Fri Aug 17, 2012 10:22 pm

Location: Washington (the state)

Post Sun Dec 06, 2015 11:04 pm

Re: Windows 10 Integration

You have double-posted this, and I answered in your other post. However, I can't remember if you mentioned your anti-virus in the other post. No matter.

If you are seeing Serviio from a player, there's likely no issues with your firewall settings. See my other responses in the other post.
Dan

Panasonic ST30 Plasma, Samsung JU7100 4K TV, Sony BDP-S3500, Sharp 4K Roku TV, Insignia Roku TV, Roku 4, Ultra and Stick, Nvidia Shield, Yamaha RX-V583 AVR.
Primary server: Intel i5-6400, 8 gig ram, Windows 10 Pro, 18 TB hard drive space | Test server Windows 10 Pro, AMD Phenom II X4 965, 8 gig ram

HOWTO: Enable debug logging HOWTO: Identify media file contents

Return to User experiences

Who is online

Users browsing this forum: No registered users and 10 guests

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.