FAQ  •  Register  •  Login

Synology NAS Serviio docker problem



Serviio newbie

Posts: 5

Joined: Sun Feb 25, 2018 5:38 pm

Post Fri Mar 08, 2019 5:21 pm

Synology NAS Serviio docker problem

Hello. I have a strange problem. My docker was working fine but I thought that I should make a new image with updated alpine version and FFMPEG version. Problem is that after image successful creation and starting the container I have a warning and the container is not starting. I tried to use a someone else serviio image, I have restored my docker backup, I have uninstalled docker etc. but image is restarting every time after a clean start and I have the same error. I don`t understand what could have happened. Any help please? Here is the log:

2019-03-08 17:07:38 stdout log4j:WARN See http://logging.apache.org/log4j/1.2/faq.html#noconfig for more info.
2019-03-08 17:07:38 stdout log4j:WARN Please initialize the log4j system properly.
2019-03-08 17:07:38 stdout log4j:WARN No appenders could be found for logger (org.serviio.ApplicationInstanceManager).
2019-03-08 17:07:36 stdout tail: no files
2019-03-08 17:07:36 stdout tail: can't open '/opt/serviio/log/serviio.log': No such file or directory

edit: more info: I was using https://hub.docker.com/r/riftbit/serviio edited docker by me but not even original one is not working anymore.


User avatar

DLNA master

Posts: 325

Joined: Thu Mar 27, 2014 2:05 pm

Location: Endor

Post Thu Mar 14, 2019 3:38 pm

Re: Synology NAS Serviio docker problem

seems like a permissions file problem on the synology os.

From the docker source:

- /srv/docker/serviio/library:/opt/serviio/library
- /srv/docker/serviio/plugins:/opt/serviio/plugins
- /srv/docker/serviio/log:/opt/serviio/log

I would check permissions on these folders and see if whatever linux user needs to write has permission.

Return to User experiences

Who is online

Users browsing this forum: No registered users and 4 guests

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.