FAQ  •  Register  •  Login

DLNA Not playing certain formats



Serviio newbie

Posts: 3

Joined: Wed Jul 29, 2015 2:28 am

Post Fri Jan 27, 2017 3:39 pm

DLNA Not playing certain formats

I have a VIZIO smart tv and use DLNA to stream from my home server to my VIZIO Smart TV --> I have the profile in Serviio set to be Vizio TV and under Delivery --> Transcoding, I have checked Enable Transcoding
Transcoding Location: C:\WINDOWS\TEMP\
Number of CPU cores to use: 8
Produce the best video quality: checked
Audio Channels: Keep Original

However, when I attempt to stream specific .mp4 files - I get an onscreen error that says Audio not supported Video not supported. I thought my on-the-fly encoding would be able to handle this, but it is not. What must I change in order for these type files to be played appropriately?

Running Windows 10 - enabled DEBUG and this is log as it is 36,733

This looks like the pertinent line in my log
2017-01-27 12:13:57,457 DEBUG [MediaItemDAOImpl] Getting file of media item 20539
2017-01-27 12:13:57,458 WARN  [ResourceDeliveryProcessor] Error while processing resource, sending back 404 error. Message: E:\TV Shows\Westworld.1973.1080p.BluRay.x264-[YTS.AG].mp4 (The system cannot find the file specified)
2017-01-27 12:14:15,205 DEBUG [SearchManager] Committing search index

I also tried to rename the file to Westworld.1973.mp4 to see if the hyphen was the issue, and it is not, same error thrown. I think it is an issue with the profile I selected, as I ran this command through terminal
"C:\Program Files\Serviio\lib\ffmpeg.exe" -threads auto -i "E:\TV Shows\Westworld.1973.1080p.BluRay.x264.mp4" -y -threads auto -c:v mpeg2video -pix_fmt yuv420p -qscale:v 1 -r 25 -g 15 -c:a ac3 -b:a 128k -ac 2 -map 0:0 -map 0:1 -sn -f vob "E:\TV Shows\Westworld.1973.1080p.BluRay.x264.mpg"

And serviio can play the .mp4 file that was generated no problem!


User avatar

DLNA master

Posts: 3061

Joined: Fri Aug 17, 2012 10:22 pm

Location: Washington (the state)

Post Fri Jan 27, 2017 6:25 pm

Re: DLNA Not playing certain formats

I have recently encountered problems when transcoding videos containing HD audio. Since you appear to be using a Blu Ray rip, I am assuming you have either TrueHD or DTS Master Audio in the file. Not sure why you are getting the video error. The Vizio profile seems to transcode almost everything.

Panasonic ST30 Plasma, Samsung JU7100 4K TV, Sony BDP-S3500, Sharp 4K Roku TV, Insignia Roku TV, Roku 4, Ultra and Stick, Yamaha RX-V583 AVR.
Primary server: Intel i5-6400, 8 gig ram, Windows 10 Pro, 18 TB hard drive space | Test server Windows 7 Home Premium, AMD Phenom II X4 965, 8 gig ram

HOWTO: Enable debug logging HOWTO: Identify media file contents


DLNA master

Posts: 2227

Joined: Fri Mar 08, 2013 11:16 pm

Location: Adelaide, Australia

Post Fri Jan 27, 2017 11:11 pm

Re: DLNA Not playing certain formats

Post MediaInfo details for one of the files that doesn't play. What are your settings under Transcoding (include all audio tracks in particular).
Could Bea library issue. Have you recently upgraded Serviio and if so, has the library fully updated? Try making a copy of the file and check that it's added to the library properly (in the log) and then see if it plays.
Panasonic Viera FX800A | Panasonic Viera CS610A | Sony PS4 | Sony PS3 | Panasonic DMP-BD79 | Yamaha RX-V500D | iPad | Windows 10 | Serviio 1.10.1 Pro
WinHelper | MediaInfo

Beta Tester, Moderator
Please do not PM me for support as any solution cannot be shared with others.

Return to Transcoding

Who is online

Users browsing this forum: No registered users and 3 guests

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.