FAQ  •  Register  •  Login

Creating a Profile for a Sony UBP-X700

<<

Fork

Serviio newbie

Posts: 1

Joined: Mon Aug 19, 2019 7:40 pm

Post Mon Aug 19, 2019 7:45 pm

Creating a Profile for a Sony UBP-X700

Hi,

I'm trying to create a custom profile for this device because I've found it can't stream E_AC3. Instead I'm using AviDemux to convert to AC3 (Aften) at 448Kbps.

I've looked through the documentation and I'm trying to create a custom profile but it's not quite as simple as I thought :-)

Does anyone either;

1. Have a Sony UBP-X700 where they've already created the custom profile which they could send to me?
2. Be interested in a custom profile if I persist with this and finally create one myself?

Thanks,

Fork.
<<

daggerNC

Serviio newbie

Posts: 6

Joined: Tue Mar 26, 2013 1:24 pm

Post Fri Dec 27, 2019 12:15 am

Re: Creating a Profile for a Sony UBP-X700

I have the UBP-X700 and also need a custom profile for it. So bumping this thread. Thanks in advance for anybody's help with this.
<<

atc98092

User avatar

DLNA master

Posts: 3959

Joined: Fri Aug 17, 2012 10:22 pm

Location: Washington (the state)

Post Fri Dec 27, 2019 3:19 am

Re: Creating a Profile for a Sony UBP-X700

It's not too difficult to create a profile, but the syntax of the text is critical. I'm rather surprised that a Sony UHD player doesn't support E-AC3. Does it have a Netflix app within it? Because Netflix uses E-AC3, as do many online streaming sources.

Here's how a users-profile.xml file would be formatted. But what actually goes within the profile itself is wholly dependent on what you are attempting to do. I made an attempt to capture only E-AC3 audio, regardless of container. But chances are it might need more fine tuning, as this is only going to transcode the audio and pass the video through. If for some reason your video codec isn't supported, then it needs to be tweaked to capture just that particular video codec as well. save this text into a new file in the Serviio/config folder and name it user-profiles.xml. Then restart the Serviio process in the Serviio console to load the new file. Finally, select the new profile (named Sony UHD Player) for your player and give it a go. I haven't tested this code, so in case Serviio won't work after adding the file, remove it and let me know and I'll check it closer.

  Code:
<?xml version="1.0" encoding="UTF-8"?>
<Profiles version="1.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:noNamespaceSchemaLocation="http://www.serviio.org/xsd/profiles/v/1.10/Profiles.xsd">
<Profile id="Sony_UHD" name="Sony UHD Player" extendsProfileId="bdp2013">
      
      <Transcoding>
         <!-- transcode HD video unsupported by device, transcode audio regardless of codec -->
         
         <!-- Remux H.264 video stream, transcode audio only -->
         <Video targetContainer="mpegts" targetACodec="ac3" >
             <Matches container="*" aCodec="eac3" />
            
         </Video>
      </Transcoding>
      <OnlineTranscoding>
         <Video targetContainer="applehttp"> <!-- dont transcode to ac3 -->
            <Matches container="mp4" />
            <Matches container="flv" vCodec="h264" />
         </Video>
      </OnlineTranscoding>
      <GenericTranscoding>
         <Video targetContainer="applehttp" targetVCodec="h264" targetACodec="aac" />
      </GenericTranscoding>
   </Profile>

</Profiles>
Dan

Samsung NU7100 4K TV, Samsung JU7100 4K TV, Sony BDP-S3500, Sharp 4K Roku TV, Insignia Roku TV, Roku Ultra, Premiere and Stick, Nvidia Shield, Yamaha RX-V583 AVR.
Primary server: Intel i5-6400, 8 gig ram, Windows 10 Pro, 22 TB hard drive space | Test server Windows 10 Pro, AMD Phenom II X4 965, 8 gig ram

HOWTO: Enable debug logging HOWTO: Identify media file contents
<<

daggerNC

Serviio newbie

Posts: 6

Joined: Tue Mar 26, 2013 1:24 pm

Post Fri Dec 27, 2019 4:00 am

Re: Creating a Profile for a Sony UBP-X700

Dan - that was quick - Thank you!! I will give it a try and let you know.

Cheers,
David
<<

daggerNC

Serviio newbie

Posts: 6

Joined: Tue Mar 26, 2013 1:24 pm

Post Sat Dec 28, 2019 4:00 am

Re: Creating a Profile for a Sony UBP-X700

It's a no-go. Launched a .mkv movie tonight with the new profile and it hung the screen with the spinning arrow, and had to power cycle the Blueray player.

Bummer,
David
<<

atc98092

User avatar

DLNA master

Posts: 3959

Joined: Fri Aug 17, 2012 10:22 pm

Location: Washington (the state)

Post Sat Dec 28, 2019 5:32 am

Re: Creating a Profile for a Sony UBP-X700

Weird. Unfortunately, it's extremely difficult to troubleshoot without having the device. About the only thing I can think of is to enable detailed logging, attempt to play the movie, then upload that log here to see if there's something amiss in the transcoding line that I've overlooked.
Dan

Samsung NU7100 4K TV, Samsung JU7100 4K TV, Sony BDP-S3500, Sharp 4K Roku TV, Insignia Roku TV, Roku Ultra, Premiere and Stick, Nvidia Shield, Yamaha RX-V583 AVR.
Primary server: Intel i5-6400, 8 gig ram, Windows 10 Pro, 22 TB hard drive space | Test server Windows 10 Pro, AMD Phenom II X4 965, 8 gig ram

HOWTO: Enable debug logging HOWTO: Identify media file contents

Return to Transcoding

Who is online

Users browsing this forum: No registered users and 3 guests

cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.