FAQ  •  Register  •  Login

Newbie: No transcoding at all

<<

transfererror

Serviio newbie

Posts: 4

Joined: Thu Sep 17, 2020 3:58 pm

Post Thu Sep 17, 2020 4:40 pm

Newbie: No transcoding at all

Hello,

I'm using serviio ver. 2.1 (fresh installation; tried on 2 different Windows-computers)
I've several TV-recordings in ts-format and three different Samsung TVs from different series (E, J, M).
Some of the files play with serviio, some don't.
The device profiles are set correctly and I also tried it alternatively with the DirectTV-profile (which is said to transcode all files).
Transcoding is activated.
When starting a non-working file on TV, I do not see any temporary files in the temporary folder.
In the log-file I get a new entry: "[PlaybackEventsManager] Playback of media item 2... has started at 0%"

I guess transcoding doesn't work.

Any ideas?

Information on a file that doesn't work:

Allgemein
ID : 10009 (0x2719)
Complete name : C:\Star Trek - Raumschiff Voyager 05\20200804 1715 - TELE 5 HD - S05E25 Geheimnisvolle Intelligenz Star Trek - Raumschiff Voyager.ts
Format : MPEG-TS
File size : 2,74 GiB
Duration : 1 h 0 min
Start time : UTC 2020-08-04 15:15:05
End time : UTC 2020-08-04 16:16:01
Overall bit rate mode : variabel
Overall bit rate : 6 439 kb/s
Country : DEU
Timezone : +02:00:00

Video
ID : 6701 (0x1A2D)
Menu ID : 50043 (0xC37B)
Format : AVC
Format/Info : Advanced Video Codec
Format profile : High@L4
Format settings : CABAC / 4 Ref Frames
Format settings, CABAC : Ja
Format settings, Reference frames : 4 frames
Format settings, GOP : M=4, N=32
Codec ID : 27
Duration : 1 h 0 min
Bit rate : 5 732 kb/s
Width : 1 440 Pixel
Height : 1 080 Pixel
Display aspect ratio : 16:9
Frame rate : 25,000 FPS
Standard : Component
Color space : YUV
Chroma subsampling : 4:2:0
Bit depth : 8 bits
Scan type : Interlaced
Scan type, store method : Separated fields
Scan order : oberes Feld zuerst
Bits/(Pixel*Frame) : 0.147
Stream size : 2,44 GiB (89%)
Color range : Limited
Color primaries : BT.709
Transfer characteristics : BT.709
Matrix coefficients : BT.709

Audio
ID : 6702 (0x1A2E)
Menu ID : 50043 (0xC37B)
Format : AC-3
Format/Info : Audio Coding 3
Commercial name : Dolby Digital
Codec ID : 6
Duration : 1 h 0 min
Bit rate mode : konstant
Bit rate : 384 kb/s
Channel(s) : 2 Kanäle
Channel layout : L R
Sampling rate : 48,0 kHz
Frame rate : 31,250 FPS (1536 SPF)
Compression mode : Lossy
Delay relative to video : -851 ms
Stream size : 167 MiB (6%)
Language : Deutsch
Service kind : Complete Main

Andere
ID : 6704 (0x1A30)-100
Menu ID : 50043 (0xC37B)
Format : Teletext
Language : Deutsch

Menü
ID : 101 (0x65)
Menu ID : 50043 (0xC37B)
Duration : 1 h 0 min
List : 6701 (0x1A2D) (AVC) / 6702 (0x1A2E) (AC-3, Deutsch) / 6704 (0x1A30)-100 (Teletext, de)
Language : / Deutsch / Deutsch
<<

atc98092

User avatar

DLNA master

Posts: 4150

Joined: Fri Aug 17, 2012 10:22 pm

Location: Washington (the state)

Post Thu Sep 17, 2020 6:11 pm

Re: Newbie: No transcoding at all

I too thought that the DirecTV profile transcoded everything. But I'm looking at it and I see that TS containers are only captured if the image size exceeds 1920x1080, which yours does not. Since the TS container is supported by virtually everything, I don't think any profile will match your file.

The question is: why is that file not playing on your TV? I'm in the US, and based on your video you are somewhere in Europe. I can't say if there's a difference, but any US TV should play that video fine. Is it an issue with the AC3 audio? Do your TVs support Dolby Digital? I have no idea what your TV might support, but I can't see anything in your video that would cause it not to play.
Dan

LG NANO85 4K TV, Samsung JU7100 4K TV, Sony BDP-S3500, Sharp 4K Roku TV, Insignia Roku TV, Roku Ultra, Premiere and Stick, Nvidia Shield, Yamaha RX-V583 AVR.
Primary server: Intel i5-6400, 8 gig ram, Windows 10 Pro, 22 TB hard drive space | Test server Windows 10 Pro, AMD Phenom II X4 965, 8 gig ram

HOWTO: Enable debug logging HOWTO: Identify media file contents
<<

transfererror

Serviio newbie

Posts: 4

Joined: Thu Sep 17, 2020 3:58 pm

Post Thu Sep 17, 2020 8:37 pm

Re: Newbie: No transcoding at all

Thanks for the reply.

It seems that your direction is correct: It's a problem of my Samsung TVs with these files, and not a serviio problem.
Though it's a problem that serviio probably can solve (with transcoding).

But one by one:
I made some further tests with a slim dlna server coming with my TV-receiver (VU+ Uno 4k se).
Here again I get the "unexpected error"-message when starting the mentioned file (see above).
This error message means:"the file is supported, but something is wrong."
With unsupported media files, I get a different error message, namely "unsupported file"

My problem is, that I get this "unexpected error" with about 30% of my TV-recordings (though they are fine, when playing them with my receiver or with vlc).
Since I do not expect any support from Samsung, I would like to tell serviio to transcode all files instead.
Is it possible?
<<

atc98092

User avatar

DLNA master

Posts: 4150

Joined: Fri Aug 17, 2012 10:22 pm

Location: Washington (the state)

Post Thu Sep 17, 2020 8:53 pm

Re: Newbie: No transcoding at all

Possible? Certainly. We'd just need to create a custom profile for you. But before you do that, let's see if you can resolve the issue of the media not playing on the TV in the first place.

There is a program called tsMuxeR (https://www.videohelp.com/software/tsMuxeR). It takes your media in the TS container and remuxes it into either a new TS container or the M2TS container. It doesn't recode anything, simply takes the content and repackages it. Sometimes there's an error in the container, but there's nothing wrong with the media itself. Since there's no transcoding, it's pretty fast. It also allows you to change the order of the audio tracks if you want a different one as default. Give it a try on a few of your non-playable media.

If it doesn't work, we'll build a profile for you that will transcode your TS files. But we can try just changing the audio first, since that's far less intensive for the computer to transcode. If the audio isn't the issue, then we change the video as well.
Dan

LG NANO85 4K TV, Samsung JU7100 4K TV, Sony BDP-S3500, Sharp 4K Roku TV, Insignia Roku TV, Roku Ultra, Premiere and Stick, Nvidia Shield, Yamaha RX-V583 AVR.
Primary server: Intel i5-6400, 8 gig ram, Windows 10 Pro, 22 TB hard drive space | Test server Windows 10 Pro, AMD Phenom II X4 965, 8 gig ram

HOWTO: Enable debug logging HOWTO: Identify media file contents
<<

transfererror

Serviio newbie

Posts: 4

Joined: Thu Sep 17, 2020 3:58 pm

Post Thu Sep 17, 2020 9:35 pm

Re: Newbie: No transcoding at all

Yes, thank you very very much.
Remuxing the file content to a new ts container did the job!

When opening the original file with tsmuxer I got an error "unsupported format - some tracks not recognized..."
But this error is not necessarily connected with my original problem, since this error also occurs with files that I can play on my TVs.

OK, now there is a solution.
But is there a way to automatically apply it?

Because my situation is as follows:
I typically record 2-3 TV broadcasts per day.
In the next days I watch and delete most of them.
Most of them I watch with my recorder (without dlna). Some of the via dlna on other TVs (in bed for example).
Especially when I'm in bed my motivatability to go to the pc and run tsmuxer is quiet low ;)
<<

atc98092

User avatar

DLNA master

Posts: 4150

Joined: Fri Aug 17, 2012 10:22 pm

Location: Washington (the state)

Post Thu Sep 17, 2020 10:19 pm

Re: Newbie: No transcoding at all

tsMuxeR can be run from the command line, so it would be possible to create a script to do it automatically. Here's what I fond for command line format:

Command Line
Alternatively you can use tsMuxer via the command-line.

Examples:

tsMuxeR <media file name>
tsMuxeR <meta file name> <out file/dir name>
tsMuxeR can be run in track detection mode or muxing mode. If tsMuxeR is run with only one argument, then the program displays track information required to construct a meta file. When running with two arguments, tsMuxeR starts the muxing or demuxing process.

The output of the program is encoded in UTF-8, which means that non-ASCII characters will not show up properly in the Windows console by default. If you want to see the output properly, run chcp 65001 before running tsMuxeR.


This is where I found that: https://github.com/justdan96/tsMuxer

I haven't created a script to run something like that in a long time, so I'd have to research it some. But you can use variables for the input and output file name. Just don't have that off the top of my head any longer... :D
Dan

LG NANO85 4K TV, Samsung JU7100 4K TV, Sony BDP-S3500, Sharp 4K Roku TV, Insignia Roku TV, Roku Ultra, Premiere and Stick, Nvidia Shield, Yamaha RX-V583 AVR.
Primary server: Intel i5-6400, 8 gig ram, Windows 10 Pro, 22 TB hard drive space | Test server Windows 10 Pro, AMD Phenom II X4 965, 8 gig ram

HOWTO: Enable debug logging HOWTO: Identify media file contents
<<

transfererror

Serviio newbie

Posts: 4

Joined: Thu Sep 17, 2020 3:58 pm

Post Fri Sep 18, 2020 10:29 am

Re: Newbie: No transcoding at all

Thank you again.

Since my problem obviously results from corrupted ts-containers, I think it is not a serviio problem.
I will think about your tsmuxer-script-idea.
In general I think it would be a good idea to have a "transcode-all-files"-profile, at least for debugging purposes.
What do you think about it?
<<

atc98092

User avatar

DLNA master

Posts: 4150

Joined: Fri Aug 17, 2012 10:22 pm

Location: Washington (the state)

Post Fri Sep 18, 2020 2:34 pm

Re: Newbie: No transcoding at all

Well, that would be easy enough to create. :)
Dan

LG NANO85 4K TV, Samsung JU7100 4K TV, Sony BDP-S3500, Sharp 4K Roku TV, Insignia Roku TV, Roku Ultra, Premiere and Stick, Nvidia Shield, Yamaha RX-V583 AVR.
Primary server: Intel i5-6400, 8 gig ram, Windows 10 Pro, 22 TB hard drive space | Test server Windows 10 Pro, AMD Phenom II X4 965, 8 gig ram

HOWTO: Enable debug logging HOWTO: Identify media file contents

Return to Transcoding

Who is online

Users browsing this forum: No registered users and 5 guests

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.