FAQ  •  Register  •  Login

General questions and folder not showing up.

<<

g12345567

Serviio newbie

Posts: 3

Joined: Fri Jul 29, 2011 3:46 am

Post Fri Jul 29, 2011 3:59 am

General questions and folder not showing up.

I am running serviio to stream media via wired DLNA to my Sony BDP-S370 (Australian Version with latest firmware).

1) Is the S370 able to display subtitles and access chapter points embedded in x264 MKV video files? I see it can access multiple audio streams no problem. When playing media over DLNA?

2) Serviio is not displaying all the shared folders containing videos. I have a couple of folders containing MKV videos that are not showing up. All the new files and filders I have added since, show up.
<<

Cerberus

User avatar

DLNA master

Posts: 4116

Joined: Sun Jan 02, 2011 5:20 pm

Location: Reading, UK

Post Fri Jul 29, 2011 10:33 am

Re: General questions and folder not showing up.

g12345567 wrote:I am running serviio to stream media via wired DLNA to my Sony BDP-S370 (Australian Version with latest firmware).


1) Is the S370 able to display subtitles and access chapter points embedded in x264 MKV video files? I see it can access multiple audio streams no problem. When playing media over DLNA?


Chapter selection is not support over DLNA, and external subtitles are limited to only certain file types (embedded subtitles will not work).

2) Serviio is not displaying all the shared folders containing videos. I have a couple of folders containing MKV videos that are not showing up. All the new files and filders I have added since, show up.


please provide " FFmpeg -i " details on the files that wont play ( see signiture for howto )
Phil Bennett
Beta Tester Group
Wiki | FAQ

Samsung LE40C750 LCD | Samsung BD-C5900 | Sony PS3 | Windows 7 |
HowTo: Provide supported formats of a device HowTo: Record a new ticket on Bitbucket
HowTo: Provide details of a video file that doesn't play HowTo: Turn on detailed logging
<<

g12345567

Serviio newbie

Posts: 3

Joined: Fri Jul 29, 2011 3:46 am

Post Fri Jul 29, 2011 12:35 pm

Re: General questions and folder not showing up [SOLVED]

2) Serviio is not displaying all the shared folders containing videos. I have a couple of folders containing MKV videos that are not showing up. All the new files and filders I have added since, show up.


please provide " FFmpeg -i " details on the files that wont play ( see signiture for howto )


There is 1 folder containing 2 MKV file that does not show up when I access the shared folders on the Sony blu-ray player.

The original mkv file is 10gb. with 1 audio track and 19 subtitles.

I worked out the file was not loading/showing up because it contained too many subtitles. I used MKVTOOLS to strip out all the unwanted subtitles and just leave english. Now the MKV file shows up on the S370, but is recognised as DIVX with a * (star symbol) next to it. So I used another utility called "MKV WD Fix" to fix the corrupt header in the MKV. File now recognised as MT2S and plays fine.

The reason for the file to loading: Too many Subtitles
Reason for file not being recognised correctly: Corrupt Header
Last edited by g12345567 on Fri Jul 29, 2011 1:21 pm, edited 4 times in total.
<<

Cerberus

User avatar

DLNA master

Posts: 4116

Joined: Sun Jan 02, 2011 5:20 pm

Location: Reading, UK

Post Fri Jul 29, 2011 12:37 pm

Re: General questions and folder not showing up.

g12345567 wrote:
There is 1 folder containing 2 MKV file that does not show up when I access the shared folders on the Sony blu-ray player.

The original mkv file is 10gb. with 1 audio track and 19 subtitles.
I worked out the file was not loading/showing up because it contained too many subtitles. I used MKVTOOLS to strip out all the unwanted subtitles and just leave english. Now the MKV file shows up on the S370, but is recognised as DIVX with a * (star symbol) next to it. And will not play.

All my other MKV files show up as M2TS in serviio on the S370.


ok that was not what i asked for, please follow teh below quote.

please provide " FFmpeg -i " details on the files that wont play ( see signiture for howto )
Phil Bennett
Beta Tester Group
Wiki | FAQ

Samsung LE40C750 LCD | Samsung BD-C5900 | Sony PS3 | Windows 7 |
HowTo: Provide supported formats of a device HowTo: Record a new ticket on Bitbucket
HowTo: Provide details of a video file that doesn't play HowTo: Turn on detailed logging
<<

Illico

User avatar

DLNA master

Posts: 4645

Joined: Fri Jul 23, 2010 8:08 am

Location: France

Post Fri Jul 29, 2011 2:27 pm

Re: General questions and folder not showing up [SOLVED]

g12345567 wrote:I used MKVTOOLS to strip out all the unwanted subtitles and just leave english. Now the MKV file shows up on the S370, but is recognised as DIVX with a * (star symbol) next to it. So I used another utility called "MKV WD Fix" to fix the corrupt header in the MKV. File now recognised as MT2S and plays fine.

Very interesting fix.
I'll have a look at these "MKV WD Fix" Tool.
Thanks
Illico
Sony 2010 KDL-46EX501 | BDP-S373 | SMP-N100 | Windows 8-i7 | Network DD HD-CE1.5TLU2 | Livebox2-UHD86 | ServiiDroid | ServiiGo | BubbleUPnP
Serviio beta tester - Moderator
<<

g12345567

Serviio newbie

Posts: 3

Joined: Fri Jul 29, 2011 3:46 am

Post Fri Jul 29, 2011 11:45 pm

Re: General questions and folder not showing up.

MKV header removal compression
http://www.bunkus.org/videotools/mkvtoolnix/faq.html#header_removal_compression

The MKV WD FIX tool v0.1.2 can be used to fix header compression in MKV files.

http://www.chumpusrex.com/junk/MKVFix.exe (requires MKVtoolnix 4.3.0)
http://www.bunkus.org/videotools/mkvtoolnix/win32/ (all windows versions)

or MKVtoolnix utility
http://wdtvforum.com/main/index.php?topic=6897.30
<<

hasenfuss

Serviio newbie

Posts: 2

Joined: Mon Dec 30, 2013 2:48 pm

Post Wed Aug 24, 2016 3:06 pm

Re: General questions and folder not showing up.

Hello all,
I have a similar problem.
Since a long time, I had no problem with files with the type "mkv".
Suddenly it does not work any more.
Not all mkv-files but a lot.
It is a file recordet at TV.

I got the error-message:
2016-08-21 17:25:24,442 WARN [MetadataExtractionCoordinator] Skipping processing metadata for an unsupported file (C:\linkdir\Serien\Satire\Extra 3\2016 08-17 22-40-01 NDR FS HH HD (AC3,deu) extra 3 extra 3 Satiresendung.mkv). Message: Unknown video file type.

The output of the ffmpeg - command is:
C:\linkdir\Serien\Satire\Extra 3>
C:\linkdir\Serien\Satire\Extra 3>"C:\Program Files\Serviio\lib\ffmpeg.exe" -i "2016 08-17 22-40-01 NDR FS HH HD (AC3,deu) extra 3 extra 3 Satiresendung.mkv"
ffmpeg version 2.4.git Copyright (c) 2000-2014 the FFmpeg developers
built on Nov 19 2014 22:12:09 with gcc 4.7.2 (GCC)
configuration: --enable-static --disable-shared --disable-ffplay --disable-ffserver --enable-memalign-hack --enable-libmp3lame --enable-libass --enable-librtmp --enable-fontconfig --enable-libfreetype --enable-zlib --enable-libx264 --enable-libspeex --extra-libs='-lrtmp -lpolarssl -lws2_32 -lwinmm -lexpat -lfreetype -lfribidi -lz' --arch=x86 --enable-runtime-cpudetect --enable-pthreads --target-os=mingw32 --cross-prefix=i686-w64-mingw32- --enable-gpl --pkg-config=pkg-config
libavutil 54. 14.100 / 54. 14.100
libavcodec 56. 12.101 / 56. 12.101
libavformat 56. 14.100 / 56. 14.100
libavdevice 56. 3.100 / 56. 3.100
libavfilter 5. 2.103 / 5. 2.103
libswscale 3. 1.101 / 3. 1.101
libswresample 1. 1.100 / 1. 1.100
libpostproc 53. 3.100 / 53. 3.100
Input #0, matroska,webm, from '2016 08-17 22-40-01 NDR FS HH HD (AC3,deu) extra 3 extra 3 Satiresendung.mkv':
Metadata:
encoder : Haali DirectShow Matroska Muxer 1.13.138.14
creation_time : 2016-08-21 10:20:22
Duration: 00:28:55.46, start: 0.000000, bitrate: 7955 kb/s
Stream #0:0: Video: h264 (High), yuv420p, 1280x720 [SAR 1:1 DAR 16:9], 50 fps, 50 tbr, 1k tbn, 100 tbc
Metadata:
title : PID 5221 Video
Stream #0:1(deu): Audio: ac3, 48000 Hz, stereo, fltp, 448 kb/s (default)
Metadata:
title : AC3
At least one output file must be specified


Could you help?

Regards

Hasenfuss
Serviio on Windows 8.1 pro
Intel Dualcore-Processor

Return to Sony

Who is online

Users browsing this forum: No registered users and 2 guests

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.