FAQ  •  Register  •  Login

mkv files not appearing on BD-J5900 player

<<

ronnyvedal

Streaming enthusiast

Posts: 28

Joined: Fri Dec 20, 2013 4:06 pm

Post Wed Apr 06, 2016 6:45 pm

Re: mkv files not appearing on BD-J5900 player

Yep, in the Folders directory. I dont use anything else than that. It must have something to do with the profile. I can use the E/F profile, but like 95% of the mkv/mp4 files are gone. If i turn on the J profile, 100% are gone...just xvid left.

Do you have a J series player available somewhere, so you can test?
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 17095

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Wed Apr 06, 2016 9:16 pm

Re: mkv files not appearing on BD-J5900 player

Normally it's be this block in the profile

  Code:
<MediaFormatProfiles>
            <MediaFormatProfile mime-type="video/x-matroska">MATROSKA</MediaFormatProfile>
            <MediaFormatProfile mime-type="audio/x-flac">FLAC</MediaFormatProfile>           
        </MediaFormatProfiles>


The MimeType of video/x-matroska is what Samsungs normally require. You could try to change it to something else, like viseo/x-mkv or video/avi
<<

Infernity

Serviio newbie

Posts: 1

Joined: Thu Apr 07, 2016 8:04 am

Post Thu Apr 07, 2016 8:09 am

Re: mkv files not appearing on BD-J5900 player

I have exactly the same issue as OP. I own BD-J7500 which plays and sees everything perfect with J-Series profile selected and BD-J5900 which can not see anything but avi container files using the J-Series profile.
So there must be something slightly different in BD-J5900 which does not work correctly with the J-Series proifile. When I tried to use H-Series Profile, I could see only few files, like 90% of files invisible which are other than .avi files.

Edit: Using the pro edition.
<<

ronnyvedal

Streaming enthusiast

Posts: 28

Joined: Fri Dec 20, 2013 4:06 pm

Post Thu Apr 07, 2016 2:24 pm

Re: mkv files not appearing on BD-J5900 player

This is annoying as hell. Try to switch over to the E/F profile on the J-5900 player and you should see "some" files. I dont remember if it was any different with H profile.

This is something that should be checked out. With plex it works fine, thats the most annoying part...
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 17095

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Thu Apr 07, 2016 7:30 pm

Re: mkv files not appearing on BD-J5900 player

Does this work with the player?

viewtopic.php?f=5&t=19

I think it's most likely the mime type. You might try to change it as my previous post to avi or mpeg. I don't have the device so cannot really help.
<<

ronnyvedal

Streaming enthusiast

Posts: 28

Joined: Fri Dec 20, 2013 4:06 pm

Post Thu Apr 07, 2016 8:37 pm

Re: mkv files not appearing on BD-J5900 player

Device spy doesnt show this player at all.. it shows my smart tv and serviio. The J5900 is online and can connect to serviio but still doesnt show up in device spy...

All of my other players shows up.. wtf?
<<

ronnyvedal

Streaming enthusiast

Posts: 28

Joined: Fri Dec 20, 2013 4:06 pm

Post Thu Apr 07, 2016 8:55 pm

Re: mkv files not appearing on BD-J5900 player

<MediaFormatProfile mime-type="video/x-mkv">MATROSKA</MediaFormatProfile>
<MediaFormatProfile mime-type="video/x-avi">MATROSKA</MediaFormatProfile>

(under the J profile)

Same result
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 17095

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Thu Apr 07, 2016 8:58 pm

Re: mkv files not appearing on BD-J5900 player

ronnyvedal wrote:Device spy doesnt show this player at all.. it shows my smart tv and serviio. The J5900 is online and can connect to serviio but still doesnt show up in device spy...

All of my other players shows up.. wtf?

Yeah, some don't.
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 17095

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Thu Apr 07, 2016 8:59 pm

Re: mkv files not appearing on BD-J5900 player

When you use Plex, does it show as mpeg file? I have a feeling that Plex maybe transcodes everything.
<<

ronnyvedal

Streaming enthusiast

Posts: 28

Joined: Fri Dec 20, 2013 4:06 pm

Post Thu Apr 07, 2016 9:09 pm

Re: mkv files not appearing on BD-J5900 player

I play a file that doesnt show on serviio, with plex.. and press tools -> information on the remote

Videocodec: H264
Audiocodec: Dolby digital
<<

ronnyvedal

Streaming enthusiast

Posts: 28

Joined: Fri Dec 20, 2013 4:06 pm

Post Thu Apr 07, 2016 9:24 pm

Re: mkv files not appearing on BD-J5900 player

samsung profile.xml in plex directory (theres two files, samsung.xml and samsung smart tv.xml)

I'm not sure if plex even recognizes this player as samsung, since i cant find a list of clients in plex.

In serviio, this player automatically shows up as unrecognized and gets generic profile, while my other samsungs automatically gets detected. Very strange

Heres the files as attachment
Attachments
Samsung.xml
(2.03 KiB) Downloaded 185 times
Samsung SmartTV.xml
(3.35 KiB) Downloaded 167 times
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 17095

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Thu Apr 07, 2016 10:45 pm

Re: mkv files not appearing on BD-J5900 player

What if you replace the MATROSKA profile line with this (don't forget to restart the service / PC)

  Code:
<MediaFormatProfile mime-type="video/x-mkv" name="">MATROSKA</MediaFormatProfile>
<<

ronnyvedal

Streaming enthusiast

Posts: 28

Joined: Fri Dec 20, 2013 4:06 pm

Post Fri Apr 08, 2016 5:14 pm

Re: mkv files not appearing on BD-J5900 player

now every file is visualbe with the j profile, but i cant play h264, only mpeg4

playable:

Input #0, avi, from 'test2.avi':
Duration: 00:20:00.16, start: 0.000000, bitrate: 1703 kb/s
Stream #0:0: Video: mpeg4 (Advanced Simple Profile) (XVID / 0x44495658), yuv420p, 1280x720 [SAR 1:1 DAR 16:9], 1504 kb/s, 25 fps, 25 tbr, 25 tbn, 25 tbc
Stream #0:1: Audio: mp3 (U[0][0][0] / 0x0055), 44100 Hz, stereo, s16p, 192 kb/s
At least one output file must be specified


not playable (not supported):

Input #0, avi, from 'test.avi':
Duration: 00:22:25.82, start: 0.000000, bitrate: 1161 kb/s
Stream #0:0: Video: h264 (High) (H264 / 0x34363248), yuv420p, 1280x720 [SAR 1:1 DAR 16:9], 1016 kb/s, 50 fps, 50 tbr, 50 tbn, 100 tbc
Stream #0:1: Audio: mp3 (U[0][0][0] / 0x0055), 44100 Hz, stereo, s16p, 128 kb/s
At least one output file must be specified
<<

ronnyvedal

Streaming enthusiast

Posts: 28

Joined: Fri Dec 20, 2013 4:06 pm

Post Fri Apr 08, 2016 6:15 pm

Re: mkv files not appearing on BD-J5900 player

playable: (please explain the difference between this one, and the non-playable h264 i posted in the last post. to me, both looks like h264 but only one is playable?)
The last one has AVI container, not matroska. I cant find any AVI or MP4 in the J profile.. perhaps missing?
Also, mp4 files still aint showing with the J profile, but with E/F it shows.


ffmpeg version 2.4.git Copyright (c) 2000-2014 the FFmpeg developers
built on Nov 19 2014 22:12:09 with gcc 4.7.2 (GCC)
configuration: --enable-static --disable-shared --disable-ffplay --disable-ffserver --enable-memalign-hack --enable-libmp3lame --enable-libass --enable-librtmp --enable-fontconfig --enable-libfreetype --enable-zlib --enable-libx264 --enable-libspeex --extra-libs='-lrtmp -lpolarssl -lws2_32 -lwinmm -lexpat -lfreetype -lfribidi -lz' --arch=x86 --enable-runtime-cpudetect --enable-pthreads --target-os=mingw32 --cross-prefix=i686-w64-mingw32- --enable-gpl --pkg-config=pkg-config
libavutil 54. 14.100 / 54. 14.100
libavcodec 56. 12.101 / 56. 12.101
libavformat 56. 14.100 / 56. 14.100
libavdevice 56. 3.100 / 56. 3.100
libavfilter 5. 2.103 / 5. 2.103
libswscale 3. 1.101 / 3. 1.101
libswresample 1. 1.100 / 1. 1.100
libpostproc 53. 3.100 / 53. 3.100
Input #0, matroska,webm, from 'Criminal.Minds.S11E19.Tribute.720p.WEB-DL.DD5.1.H.264-NTb.mkv':
Metadata:
encoder : libebml v1.3.3 + libmatroska v1.4.4
creation_time : 2016-03-31 12:59:18
Duration: 00:42:52.70, start: 0.000000, bitrate: 4426 kb/s
Stream #0:0(eng): Subtitle: subrip
Metadata:
BPS : 85
BPS-eng : 85
DURATION : 00:42:01.584000000
DURATION-eng : 00:42:01.584000000
NUMBER_OF_FRAMES: 834
NUMBER_OF_FRAMES-eng: 834
NUMBER_OF_BYTES : 26996
NUMBER_OF_BYTES-eng: 26996
_STATISTICS_WRITING_APP: mkvmerge v8.5.2 ('Crosses') 64bit
_STATISTICS_WRITING_APP-eng: mkvmerge v8.5.2 ('Crosses') 64bit
_STATISTICS_WRITING_DATE_UTC: 2016-03-31 12:59:18
_STATISTICS_WRITING_DATE_UTC-eng: 2016-03-31 12:59:18
_STATISTICS_TAGS: BPS DURATION NUMBER_OF_FRAMES NUMBER_OF_BYTES
_STATISTICS_TAGS-eng: BPS DURATION NUMBER_OF_FRAMES NUMBER_OF_BYTES
Stream #0:1(eng): Video: h264 (High), yuv420p(tv, bt709), 1280x720 [SAR 1:1 DAR 16:9], 23.98 fps, 23.98 tbr, 1k tbn, 2k tbc (default)
Metadata:
BPS : 4040692
BPS-eng : 4040692
DURATION : 00:42:52.695000000
DURATION-eng : 00:42:52.695000000
NUMBER_OF_FRAMES: 61683
NUMBER_OF_FRAMES-eng: 61683
NUMBER_OF_BYTES : 1299433519
NUMBER_OF_BYTES-eng: 1299433519
_STATISTICS_WRITING_APP: mkvmerge v8.5.2 ('Crosses') 64bit
_STATISTICS_WRITING_APP-eng: mkvmerge v8.5.2 ('Crosses') 64bit
_STATISTICS_WRITING_DATE_UTC: 2016-03-31 12:59:18
_STATISTICS_WRITING_DATE_UTC-eng: 2016-03-31 12:59:18
_STATISTICS_TAGS: BPS DURATION NUMBER_OF_FRAMES NUMBER_OF_BYTES
_STATISTICS_TAGS-eng: BPS DURATION NUMBER_OF_FRAMES NUMBER_OF_BYTES
Stream #0:2(eng): Audio: ac3, 48000 Hz, 5.1(side), fltp, 384 kb/s (default)
Metadata:
BPS : 384000
BPS-eng : 384000
DURATION : 00:42:52.672000000
DURATION-eng : 00:42:52.672000000
NUMBER_OF_FRAMES: 80396
NUMBER_OF_FRAMES-eng: 80396
NUMBER_OF_BYTES : 123488256
NUMBER_OF_BYTES-eng: 123488256
_STATISTICS_WRITING_APP: mkvmerge v8.5.2 ('Crosses') 64bit
_STATISTICS_WRITING_APP-eng: mkvmerge v8.5.2 ('Crosses') 64bit
_STATISTICS_WRITING_DATE_UTC: 2016-03-31 12:59:18
_STATISTICS_WRITING_DATE_UTC-eng: 2016-03-31 12:59:18
_STATISTICS_TAGS: BPS DURATION NUMBER_OF_FRAMES NUMBER_OF_BYTES
_STATISTICS_TAGS-eng: BPS DURATION NUMBER_OF_FRAMES NUMBER_OF_BYTES
At least one output file must be specified
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 17095

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Sat Apr 09, 2016 5:06 pm

Re: mkv files not appearing on BD-J5900 player

Might be the high profile combined with too high level. Which is normally transcoded
<<

ronnyvedal

Streaming enthusiast

Posts: 28

Joined: Fri Dec 20, 2013 4:06 pm

Post Sun Apr 10, 2016 5:50 pm

Re: mkv files not appearing on BD-J5900 player

But, what do we do from here? Theres obviously something that can be done with the profile...
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 17095

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Sun Apr 10, 2016 7:25 pm

Re: mkv files not appearing on BD-J5900 player

Post the profile you're using now here. And do you have Transcoding on or off?
<<

ronnyvedal

Streaming enthusiast

Posts: 28

Joined: Fri Dec 20, 2013 4:06 pm

Post Mon Apr 11, 2016 4:16 am

Re: mkv files not appearing on BD-J5900 player

Transcoding is on.



<Profile id="sam_j" name="Samsung TV / player (J-series)" extendsProfileId="1">
<ContentDirectoryMessageBuilder>org.serviio.upnp.service.contentdirectory.SamsungTizenDLNAMessageBuilder</ContentDirectoryMessageBuilder>
<ResourceTransportProtocolHandler>org.serviio.upnp.protocol.http.transport.SamsungWiseLinkProtocolHandler</ResourceTransportProtocolHandler>
<Detection>
<UPnPSearch>
<ModelName>(^[A-Z]{2}\d{2}J[A-Z]?\d{3,4}.*)</ModelName>
<ModelNumber>(1\.0)|(AllShare1\.0)</ModelNumber>
</UPnPSearch>
<HttpHeaders>
<!-- some models only support headers -->
<User-Agent>(.*SEC_HHP_\[TV\] [A-Z]{2}\d{2}J[A-Z]?\d{3,4}.*)</User-Agent>
</HttpHeaders>
</Detection>
<MediaFormatProfiles>
<MediaFormatProfile mime-type="video/x-mkv" name="">MATROSKA</MediaFormatProfile>
<MediaFormatProfile mime-type="audio/x-flac">FLAC</MediaFormatProfile>
</MediaFormatProfiles>
<ContentDirectoryDefinitionFilter>org.serviio.upnp.service.contentdirectory.definition.SamsungContentDirectoryDefinitionFilter</ContentDirectoryDefinitionFilter>
<H264LevelCheck>FILE_ATTRIBUTES</H264LevelCheck>
<Transcoding>
<!-- Transcode all h264 video with HIGH/MAIN > Level 4.1 on MPEG-TS stream with MPEG2VIDEO and ac3 audio transcoding -->
<Video targetContainer="mpegts" targetVCodec="mpeg2video" targetACodec="ac3" aBitrate="192" maxVBitrate="15360" forceInheritance="true">
<Matches container="*" vCodec="h264" profile="high_10" />
<Matches container="mp4" vCodec="mpeg4" aCodec="lpcm" />
<Matches container="*" vCodec="dvvideo" />
<Matches container="mp4" vCodec="mjpeg" />
<Matches container="matroska" vCodec="vp9" />
</Video>
<Video targetContainer="mpegts" targetACodec="ac3" forceInheritance="true">
<Matches container="wtv" vCodec="h264"/>
</Video>
<Video targetContainer="mpegts" forceInheritance="true">
<Matches container="wtv" />
</Video>
<Audio targetContainer="mp3" forceInheritance="true">
<Matches container="mp4" />
<Matches container="ogg" />
<Matches container="adts" />
<Matches container="mp2" />
<Matches container="wavpack" />
<Matches container="mpc" />
<Matches container="ape" />
<Matches container="asf" />
<Matches container="dsf" />
</Audio>
</Transcoding>
<OnlineTranscoding>
<Video targetContainer="mpegts" targetACodec="ac3" aBitrate="384">
<Matches container="applehttp" vCodec="h264"/>
</Video>
<Video targetContainer="mpegts" targetVCodec="mpeg2video" targetACodec="ac3" aBitrate="384">
<Matches container="asf" /> <!-- mms -->
<Matches container="flv" /> <!-- transcoding all flv streams, even h264, to avoild premature disconnects, to avoid this, use Samsung C/D profile -->
</Video>
</OnlineTranscoding>
<GenericTranscoding>
<Video targetContainer="mpegts" targetVCodec="mpeg2video" targetACodec="ac3" aBitrate="192"/>
</GenericTranscoding>
<AutomaticImageRotation>true</AutomaticImageRotation>
<LimitImageResolution>false</LimitImageResolution>
<Subtitles>
<SoftSubs mime-type="smi/caption" />
<HardSubs>
<TextBased supported="false" />
</HardSubs>
</Subtitles>
<AllowChunkedTransfer forced="true">true</AllowChunkedTransfer>
</Profile>
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 17095

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Mon Apr 11, 2016 6:50 pm

Re: mkv files not appearing on BD-J5900 player

What is you turn transcoding off.
<<

ronnyvedal

Streaming enthusiast

Posts: 28

Joined: Fri Dec 20, 2013 4:06 pm

Post Thu Apr 28, 2016 5:38 am

Re: mkv files not appearing on BD-J5900 player

Same result. Sorry for the late answer.
Previous

Return to Samsung

Who is online

Users browsing this forum: No registered users and 6 guests

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.