FAQ  •  Register  •  Login

Audio won't play.

<<

m0h0y0y0

Serviio newbie

Posts: 2

Joined: Sun Apr 21, 2019 10:50 am

Post Sun Apr 21, 2019 10:58 am

Audio won't play.

Hi.

I am having a Samsung M series Tv connected to a home theater system( only audio ) with optic cable. I am streaming from PC with Serviio App to to TV. When i set the sound (at TV's menu) from the TV's soundbar to the home theater system, the audio wont play.
When i watch regular tv shows from T-home the sound is able to play on Both settings. The system is set to "digital in" and it sees the TV but the signal wont come. Otherwise i am able to use the system with my mobile phone ETC.

How and what to set to be able to get the audio because that's why i am having home theater.

Thanks for your answers,
<<

atc98092

User avatar

DLNA master

Posts: 3466

Joined: Fri Aug 17, 2012 10:22 pm

Location: Washington (the state)

Post Sun Apr 21, 2019 5:43 pm

Re: Audio won't play.

Exactly what player are you using? Is it the built in TV DLNA player connected to Serviio, or do you have something streaming Serviio connected to the TV via HDMI? I ask because some TVs won't send certain audio codecs out via the optical connection from external devices. If it's the internal Samsung player, it's possible the audio codec in your media files aren't supported by the TV. My Samsung is an older model, and the DLNA player is terrible. I stopped using it a long time ago, and instead used a Roku player and now an Nvidia Shield. But the Samsung only supports Dolby Digital or PCM audio. If you have lossless audio (TrueHD or DTS MA for example) the TV won't play them. In that case, Serviio has to transcode the audio to DD. I haven't looked at the Samsung profiles in some time, so I can't say what they are set to do.

What profile are you using? If you're on the Generic profile, that would explain why there's no audio if your media has unsupported codecs.
Dan

Panasonic ST30 Plasma, Samsung JU7100 4K TV, Sony BDP-S3500, Sharp 4K Roku TV, Insignia Roku TV, Roku 4, Ultra and Stick, Nvidia Shield, Yamaha RX-V583 AVR.
Primary server: Intel i5-6400, 8 gig ram, Windows 10 Pro, 18 TB hard drive space | Test server Windows 10 Pro, AMD Phenom II X4 965, 8 gig ram

HOWTO: Enable debug logging HOWTO: Identify media file contents
<<

m0h0y0y0

Serviio newbie

Posts: 2

Joined: Sun Apr 21, 2019 10:50 am

Post Sun Apr 21, 2019 6:57 pm

Re: Audio won't play.

I have already set Serviio to Samsung TV / Player ( M series ) Should i change the profile to what u said ? i cant see nvidia shield in the list
<<

atc98092

User avatar

DLNA master

Posts: 3466

Joined: Fri Aug 17, 2012 10:22 pm

Location: Washington (the state)

Post Sun Apr 21, 2019 11:08 pm

Re: Audio won't play.

Sorry, I may have confused you. The Shield isn't a profile, it's an external player that is plugged into my AVR, which sends the video to the TV. I haven't used the built-in Samsung media player for years because it's so poor.

I'm looking at the M profile, and all it does is force an M series TV to use the J profile. Looking at the J profile, I see no transcoding lines that match any audio codec except for LPCM in an MP4 container. So if you have Dolby Digital Plus, or DTS or one of the other audio codecs your TV doesn't support, you won't get any audio, because none of those are being sent out the optical port. So we need to know what codecs are within your media files to determine what is happening.

I don't know if your TV supports 4K, but you might try the two Roku TV profiles to see if that gives you audio. Use the Roku 4K TV if you TV supports it, otherwise try the other Roku TV profile.
Dan

Panasonic ST30 Plasma, Samsung JU7100 4K TV, Sony BDP-S3500, Sharp 4K Roku TV, Insignia Roku TV, Roku 4, Ultra and Stick, Nvidia Shield, Yamaha RX-V583 AVR.
Primary server: Intel i5-6400, 8 gig ram, Windows 10 Pro, 18 TB hard drive space | Test server Windows 10 Pro, AMD Phenom II X4 965, 8 gig ram

HOWTO: Enable debug logging HOWTO: Identify media file contents

Return to Samsung

Who is online

Users browsing this forum: No registered users and 5 guests

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.