FAQ  •  Register  •  Login

[Solved] Samsung TV can't see Serviio

<<

paulchen933

Serviio newbie

Posts: 5

Joined: Sat Dec 15, 2012 7:18 am

Post Tue Dec 18, 2012 12:11 pm

[Solved] Samsung TV can't see Serviio

Hi

Unfortunately I have not yet succeeded in making my Samsung TV see Serviio.

The TV is a Samsung UE40ES8000S which has DLNA capability.
Using the Samsung utility AllShare I have successfully been able to stream an mpg file from the PC to the TV.

Now with Serviio so far I have :

- installed Serviio 1.0.1, the server runs and is visible in the Windows system tray
- stopped the Samsung Allshare server
- assigned a shared folder in the Serviio console with one video available for sharing in the folder
- in OS Win 7 (64 bit) allowed access to the shared video folder
- in the console observed that the TV is listed in the status window
- inserted the local IP of the TV in the field called "Bound IP address".
- under profile told Serviio that it's a Samsung TV (C/D/E series)
- removed the Window Media player from the status list
- in the Windows Firewall opened up TCP8895 and UDP1900 ports for incoming and outgoing traffic
- in TPLink Router Firewall opened up TCP8895 and UDP1900 ports for incoming and outgoing traffic

As far as I understand I should now be able to press the source button at the top of the Samsung remote control and see the Serviio icon on the list underneath the items TV and EXT.

Thanks if anybody has a tip.

Paul
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 17147

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Tue Dec 18, 2012 12:36 pm

Re: Samsung TV can't see Serviio

- inserted the local IP of the TV in the field called "Bound IP address".

You either leave the field empty or insert the IP of the PC running Serviio, not the TV
<<

paulchen933

Serviio newbie

Posts: 5

Joined: Sat Dec 15, 2012 7:18 am

Post Tue Dec 18, 2012 1:17 pm

Re: Samsung TV can't see Serviio

Thanks for your reply.

I tried the IP of the PC and I also tried leaving the "Bound IP address" field empty.
The TV still cannot see Serviio.
The Samsung TV is listed in the status window with a green icon.

I wonder if there is something else I have missed.

Paul
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 17147

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Tue Dec 18, 2012 4:43 pm

Re: Samsung TV can't see Serviio

post the detailed log (see my signature for link)
<<

paulchen933

Serviio newbie

Posts: 5

Joined: Sat Dec 15, 2012 7:18 am

Post Fri Dec 21, 2012 10:48 am

Re: Samsung TV can't see Serviio

I sent the log file in but so far no feedback.

Well ... it's a pity but it seems I won't be able to work with Serviio if the TV can't see the server.

Does anybody else out there have a Samsung UE40ES8000S TV or comparable Samsung TV and maanged to make it work ?

I'd be grateful if anyone else has a tip.

Regards
Pauö
<<

Meelis

User avatar

Serviio lover

Posts: 92

Joined: Mon Aug 13, 2012 6:00 pm

Location: Estonia

Post Sun Dec 23, 2012 7:34 pm

Re: Samsung TV can't see Serviio

paulchen933 wrote:I sent the log file in but so far no feedback.

Well ... it's a pity but it seems I won't be able to work with Serviio if the TV can't see the server.

Does anybody else out there have a Samsung UE40ES8000S TV or comparable Samsung TV and maanged to make it work ?

I'd be grateful if anyone else has a tip.

Regards
Pauö



Hi,


I have 7000 series. Works fine! Runn the serviio service, runn / open serviio console. Open Serviio console first tab, refresh and then klick on your tv ip aadress. (See pictures how to find a TV IP aadress under the Network Connection) After that be sure that it is a not Generic DLNA profile. You must select a samsung profile for it. If that will not help you then try to disable antivirus program and firewall. For wirst check antivirus firewall. I just had issue when antivirus was blocked a connection. From tv select source and look for AllShare Serviio with serviio logo. Thats all :) I hope that will help you.
Attachments
Samsung 7000.png
Samsung 7000.png (82.29 KiB) Viewed 63468 times
Samsung IP.png
Samsung IP.png (32.43 KiB) Viewed 63468 times
Samsung propertis.png
Samsung propertis.png (20.14 KiB) Viewed 63468 times
<<

NX3

DLNA master

Posts: 578

Joined: Fri Jan 28, 2011 12:39 pm

Post Mon Dec 24, 2012 3:31 pm

Re: Samsung TV can't see Serviio

paulchen933 wrote:I sent the log file in but so far no feedback.


I can't see the log in the forum, where did you post it ? You should post to this thread if you want a reply
<<

paulchen933

Serviio newbie

Posts: 5

Joined: Sat Dec 15, 2012 7:18 am

Post Wed Dec 26, 2012 8:24 am

Re: Samsung TV can't see Serviio

OK here's the log.

Regards
Paul
Attachments
serviio.log
(17.65 KiB) Downloaded 703 times
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 17147

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Wed Dec 26, 2012 11:01 am

Re: Samsung TV can't see Serviio

Log looks ok. Do you have a firewall or antivirus that might be blocking the ports? Try to turn those off.
<<

dmitche3

Serviio newbie

Posts: 13

Joined: Wed Dec 05, 2012 1:29 am

Post Sun Jan 13, 2013 4:08 pm

Re: Samsung TV can't see Serviio

I had a similar problem. As I'm obsessive about security I had secured my firewall in the past when I had no desire to share my PC with any other device.
I'm running Windows 7, being unable or unwilling to spend the time to figure out all of my tweaks to my Windows 7 firewall, I used the option to reset the firewall back to the 'basics'. Warning. That wiped out all program settings but I knew that it would. It wasn't very painful but I then uninstalled and reinstalled several packages (serviio) being one and things were back to normal.

One symptom that I noticed on my Samsung ES6500 and EH5300 TVs were that I was having firewall issues was that the color of the Serviio Logo on my TVs were YELLOW when things were good,while it was WHITE when some of the ports were being blocked. I haven't a clue as to what that means, just an observation that might help others.
<<

kiwiman2000

Streaming enthusiast

Posts: 27

Joined: Mon Jan 14, 2013 4:03 am

Post Mon Jan 14, 2013 4:13 am

Re: Samsung TV can't see Serviio

We also just bought a Samsung 32inch Smart TV not sure on model but it just works with everything videos and media servers only a few avis wont play
without transcoding

tool a couple of minutes to setup and the wifi dongel on the usb port scanned and found
aps and then the coloured button on remote to select playallmedia pops up the
media servers on NAS, PCS and routers around the house

i suspect like above has said its a FIREWALL issues or router setup issue where your
blocking ports .. disable all security and see if works then work out which ports
to open TCP and UDP
<<

Big Al

Serviio newbie

Posts: 1

Joined: Thu Jan 17, 2013 9:30 pm

Post Thu Jan 17, 2013 10:00 pm

Re: Samsung TV can't see Serviio

Hi Everyone,
I have just installed Serviio today and it works like a dream, so far...
Was getting absolutely nowhere with AllShare Play on the PC side, a heap of rubbish in my opinion. I had just purchased a Samsung UE40ES7000 and wanted to stream media from a Verbatim 1Tb Save & Go HDD which is resident as an external drive on an ethernet wired PC, the Samsung is WiFi connected to the network. Have 600gb of movies and music which streams perfectly, something that Samsung said was not possible when I couldn't get it to work with AllShare Play. So far only one movie wont play but I have so far not looked at the Serviio features and functionality, not even at the differences between the free and pro version or the cost...
It was a very straightforward and simple installation but I am happy to assist if I can... Looking forward to learning more about Serviio and will probably spend a bit of time here. Regards
<<

kiwiman2000

Streaming enthusiast

Posts: 27

Joined: Mon Jan 14, 2013 4:03 am

Post Tue Jan 22, 2013 11:29 am

Re: Samsung TV can't see Serviio

big all. try a different profile.. did you change it to samsung profile from generic? if not try panasonic veria 2010 it will transcode before sending to tv tha solve some not playing i think but it take more
processor and slight delay to stream to tv

to change this go to serviio console and find the tvs ip..in list hit refresh.. now I told my router to always assign the
same ip from the dhcp service like 192.168.1.64 so the profile sticks to it.
else you run in the problem of some things wont play cos it switched back to generic

you could if not able to change on router the ip fixing.. go into adv setup of the tv and
tell it manual network setup and you can enter a fixed ip there I recall.
<<

paulchen933

Serviio newbie

Posts: 5

Joined: Sat Dec 15, 2012 7:18 am

Post Sun Jan 27, 2013 9:03 am

Re: Samsung TV can't see Serviio

Hi

I changed my router.
The local Ip address management now works as it should.
Now I can see all the network media servers on my Samsung TV including Serviio.

This means my original question in this thread is now solved.
Thank you for the help.

Regards
Paul
<<

cartucho

Serviio newbie

Posts: 6

Joined: Tue May 01, 2012 1:49 am

Post Thu May 08, 2014 5:58 am

Re: [Solved] Samsung TV can't see Serviio

Only to help, I has this problem too and was the router's fault.
I have a D-Link wireless router and my TV could not see serviio.
The solution was check Enable Multicast Streams option in Advanced Network in the router Config.
<<

nikkifury

Serviio newbie

Posts: 1

Joined: Sat Apr 18, 2015 4:25 pm

Post Sat Apr 18, 2015 4:33 pm

Re: [Solved] Samsung TV can't see Serviio

Hi Guys!

I know it’s an old topic but I found this while trying to fix my problem. The posts didn’t actually answer my Q but it did inspire me to the answer to my situation so I thought I’d share it as it was amazingly minor!

I have a Dreytek router/firewall and this week, to try and make GTAV online a bit stable I was experimenting with firewall setups. Fragments, packet size etc. In doing so Serviio was not accessible to my TV, WD but obviously the share will still ok.

To cut a long story short and many hours changing firewall rules, it appears, at least from the dreytek perspective, you must allow the router to accept large incoming fragmented UDP packets. Soon as I re enabled that everything was visible again!
<<

BMH

Serviio newbie

Posts: 1

Joined: Tue Dec 03, 2019 5:39 pm

Post Tue Dec 03, 2019 5:50 pm

Re: [Solved] Samsung TV can't see Serviio

In my case I had to enable the ARP Binding under IP & MAC Binding settings of my TP-Link Wireless Router TL-WR841N for my Samsung TV UE48J5570. Then the Serviio Server appeared in the source list after pressing the Source button as well as in Own Contents after pressing the SMART HUB button of my remote TV control.

Return to User experiences

Who is online

Users browsing this forum: No registered users and 4 guests

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.