FAQ  •  Register  •  Login

embedded subtitles not working



Serviio newbie

Posts: 6

Joined: Tue Mar 26, 2019 5:38 pm

Post Tue Mar 26, 2019 10:27 pm

embedded subtitles not working

First off, love the software and it is working well with some minor issues. I have searched here for my question and I think this is just an issue that may not have an answer but I'll try anyway.

I have tons of MKV videos that have subtitles included/embeded in them; not hardcoded, not a separate subtitle like an SRT, but part of the original file. The subtitles just wont play on my samsung C630 TV. Prior to having serviio, I used WD TV Live and I could select the subs. now if I run serviio or even if I run WD TV LIVE through the serviio server, I cannot get any subs. for the few files I have that do have an SRT, those seem to work.

I have every box checked under the Serviio subtitles section except the hardcoding/transcending box.

Any thoughts?


DLNA master

Posts: 2257

Joined: Fri Mar 08, 2013 11:16 pm

Location: Adelaide, Australia

Post Sun Mar 31, 2019 12:35 am

Re: embedded subtitles not working

Firstly which problem are you trying to solve - for the Samsung TV or the WD TV Live box?

For the Samsung TV, it appears from the info you've provided it doesnt support subtitles (have you tried the Generic profile), so you will need to burn them in - you will need to enable "Enable extraction of text-based subtitles embedded in video files" and "Enable burned-in subtitles" in the Delivery, Subtitles areas of Serviio Console. Press Save.

The above may also fix the issue for the WD Live. It shouldn't however be needed - to see what's going on post MediaInfo details of one of the offending files.
Panasonic Viera FX800A | Panasonic Viera CS610A | Sony PS4 | Sony PS3 | Panasonic DMP-BD79 | Yamaha RX-V500D | iPad | Windows 10 | Serviio 1.10.1 Pro
WinHelper | MediaInfo

Beta Tester, Moderator
Please do not PM me for support as any solution cannot be shared with others.


Serviio newbie

Posts: 6

Joined: Thu Oct 18, 2018 1:25 pm

Post Mon Nov 30, 2020 7:04 pm

Re: embedded subtitles not working

I had the same problem with no Subtitles on my movie “Amelie” (which is a French movie, and one of my favorites). I solved the issue in stages. First, make sure “Subtitles” are turned ON in Serviio, which is under the Delivery section; and check every box. But this was not the real problem in my case. The problem was that my Samsung TV (series 6) did not have “captions” turned on. Now, Captions and Subtitles are technically different; but in the Samsung TV, it is considered the same setting. This is found under the “Accessibility” section in Samsung Settings in their Smart Hub. Simply click on the “Captions” to turn it on. The setting which worked for me was “Default.” Then turn off your TV, wait 30 seconds, and turn it back on so that the Samsung TV (or whatever TV or device you use) loads to the new configuration. It worked immediately. :D

Return to Samsung

Who is online

Users browsing this forum: No registered users and 6 guests

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.