FAQ  •  Register  •  Login

Why can not see it after I add YouTube online resources?

<<

colemanlee

User avatar

Streaming enthusiast

Posts: 23

Joined: Mon Oct 07, 2019 10:57 am

Post Wed Oct 09, 2019 4:12 pm

Why can not see it after I add YouTube online resources?

Hi,
I have added the Youtube.groovy to D:\Program Files\Serviio\plugins, and follow the steps in this page https://forum.serviio.org/viewtopic.php?f=20&t=3276, but I still can not see any Item in MediaBrowser webpage.
What's wrong with my steps?
Origin playlist URL:
  Code:
https://www.youtube.com/playlist?list=PLLW-qoCMKQsxxXRmzxEJQhUrdX0kekHhV

transfer to playlist Resource URL:
  Code:
https://www.googleapis.com/youtube/v3/playlistItems?playlistId=PLLW-qoCMKQsxxXRmzxEJQhUrdX0kekHhV

--
Origin video URL:
  Code:
https://www.youtube.com/watch?v=mb4hN0TghAw&list=PLLW-qoCMKQsxxXRmzxEJQhUrdX0kekHhV

transfer to video Resource URL:
  Code:
https://www.googleapis.com/youtube/v3/videos?id=mb4hN0TghAw&list=PLLW-qoCMKQsxxXRmzxEJQhUrdX0kekHhV

Youtube.groovy file infomation:
  Code:
File Name: Youtube.groovy
File Size: 11.3 KB (11,641 Bytes)
MD5: A5383086C36E44781564991D2F4313B6
CRC32: 1CC8C60A


But this serviio://video:feed?url=http%3A%2F%2Ffeeds.hd-trailers.net%2Fhd-trailers&name=feeds works well.
Jeff
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 17095

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Wed Oct 09, 2019 7:34 pm

Re: Why can not see it after I add YouTube online resources?

I tried your playlist and it should work. Are you sure you enable the web resource for your users (if you're using Pro)?

Can you post your log?
<<

colemanlee

User avatar

Streaming enthusiast

Posts: 23

Joined: Mon Oct 07, 2019 10:57 am

Post Thu Oct 10, 2019 1:21 am

Re: Why can not see it after I add YouTube online resources?

zip wrote:I tried your playlist and it should work. Are you sure you enable the web resource for your users (if you're using Pro)?
Can you post your log?

Hi,
Here is the relevant log:
  Code:
2019-10-10 09:02:53,952 WARN  [FeedUpdaterWorker] An error occured while parsing the online resource https://www.googleapis.com/youtube/v3/playlistItems?playlistId=PLLW-qoCMKQsxxXRmzxEJQhUrdX0kekHhV, will try again soon: Error during feed reading. Message: connect timed out
org.serviio.library.online.metadata.OnlineResourceParseException: Error during feed reading. Message: connect timed out
   at org.serviio.library.online.feed.FeedParser.parse(FeedParser.java:109)
   at org.serviio.library.online.OnlineLibraryManager.findResource(OnlineLibraryManager.java:185)
   at org.serviio.library.online.OnlineLibraryManager.findResourceInCacheOrParse(OnlineLibraryManager.java:207)
   at org.serviio.library.online.metadata.FeedUpdaterWorker.getOnlineItems(FeedUpdaterWorker.java:194)
   at org.serviio.library.online.metadata.FeedUpdaterWorker.run(FeedUpdaterWorker.java:100)
   at java.lang.Thread.run(Thread.java:748)
Caused by: java.net.SocketTimeoutException: connect timed out
   at java.net.TwoStacksPlainSocketImpl.socketConnect(Native Method)
   at java.net.AbstractPlainSocketImpl.doConnect(AbstractPlainSocketImpl.java:350)
   at java.net.AbstractPlainSocketImpl.connectToAddress(AbstractPlainSocketImpl.java:206)
   at java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:188)
   at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:172)
   at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392)
   at java.net.Socket.connect(Socket.java:589)
   at sun.security.ssl.SSLSocketImpl.connect(SSLSocketImpl.java:666)
   at sun.net.NetworkClient.doConnect(NetworkClient.java:175)
   at sun.net.www.http.HttpClient.openServer(HttpClient.java:463)
   at sun.net.www.http.HttpClient.openServer(HttpClient.java:558)
   at sun.net.www.protocol.https.HttpsClient.<init>(HttpsClient.java:264)
   at sun.net.www.protocol.https.HttpsClient.New(HttpsClient.java:367)
   at sun.net.www.protocol.https.AbstractDelegateHttpsURLConnection.getNewHttpClient(AbstractDelegateHttpsURLConnection.java:191)
   at sun.net.www.protocol.http.HttpURLConnection.plainConnect0(HttpURLConnection.java:1156)
   at sun.net.www.protocol.http.HttpURLConnection.plainConnect(HttpURLConnection.java:1050)
   at sun.net.www.protocol.https.AbstractDelegateHttpsURLConnection.connect(AbstractDelegateHttpsURLConnection.java:177)
   at sun.net.www.protocol.http.HttpURLConnection.getInputStream0(HttpURLConnection.java:1564)
   at sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1492)
   at java.net.HttpURLConnection.getResponseCode(HttpURLConnection.java:480)
   at sun.net.www.protocol.https.HttpsURLConnectionImpl.getResponseCode(HttpsURLConnectionImpl.java:347)
   at org.serviio.util.HttpClient.retrieveStreamFromConnection(HttpClient.java:200)
   at org.serviio.util.HttpClient.retrieveBinaryFileFromURL(HttpClient.java:89)
   at org.serviio.util.HttpClient.retrieveBinaryFileFromURL(HttpClient.java:105)
   at org.serviio.library.online.feed.FeedParser.parseFeedStream(FeedParser.java:120)
   at org.serviio.library.online.feed.FeedParser.parse(FeedParser.java:89)
   ... 5 more
Jeff
<<

Jimbo

Serviio newbie

Posts: 10

Joined: Mon Feb 02, 2015 6:08 pm

Post Sun Nov 10, 2019 5:07 am

Re: Why can not see it after I add YouTube online resources?

YouTube has been flaky for a couple of months. At first, it would go down for a few hours each day. It went away completely a couple of weeks ago on the windows 10 system. It came back about 3 days ago and worked properly for a couple of days then went away again and is still gone.

I installed Serviio on a windows 7 system when youtube first started acting up. It worked fine on windows 7 from the beginning and didn't fail until yesterday. Now youtube is flaky on win 10 and win 7 systems.

Other non-youtube plugins continue to work fine.

All other methods that I use to access youtube work fine. The problem is only with the serviio plugin so far.

I just figured that youtube was testing potential changes when it would go down for a gew hours then return.

This is one of my web resources that I use

https://www.googleapis.com/youtube/v3/c ... iatedPress
<<

Jimbo

Serviio newbie

Posts: 10

Joined: Mon Feb 02, 2015 6:08 pm

Post Wed Nov 20, 2019 9:07 pm

Re: Why can not see it after I add YouTube online resources?

Well, youtube is now working. I hope they are finished with their testing.

Return to General discussion

Who is online

Users browsing this forum: Google [Bot] and 1 guest

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.